aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBoris Samorodov <bsam@FreeBSD.org>2013-05-20 15:06:17 +0000
committerBoris Samorodov <bsam@FreeBSD.org>2013-05-20 15:06:17 +0000
commit7423c7fd5fa393dce18d272fb3f5724201b70c6c (patch)
treebb4fad5e3cf632ddf45837a49d7cfc4cbb24d17f
parent8194533c4bff974d98632589cd9a9a79ecf9fe96 (diff)
downloadports-7423c7fd5fa393dce18d272fb3f5724201b70c6c.tar.gz
ports-7423c7fd5fa393dce18d272fb3f5724201b70c6c.zip
This port installs the prerequisites for Mathworks (r) Matlab R2012a for Linux
and an installer script matlab-2012a-installer, which automates the somewhat tricky process of installing Linux Matlab. It requires installation media and a license file from Mathworks, Inc. PR: ports/177724 Submitted by: Jason Bacon
Notes
Notes: svn path=/head/; revision=318605
-rw-r--r--math/Makefile1
-rw-r--r--math/matlab-R2012a-installer/Makefile31
-rw-r--r--math/matlab-R2012a-installer/distinfo2
-rw-r--r--math/matlab-R2012a-installer/files/pkg-message.in20
-rw-r--r--math/matlab-R2012a-installer/pkg-descr5
5 files changed, 59 insertions, 0 deletions
diff --git a/math/Makefile b/math/Makefile
index aea6088ecda9..61e8a323995c 100644
--- a/math/Makefile
+++ b/math/Makefile
@@ -244,6 +244,7 @@
SUBDIR += matharray
SUBDIR += mathomatic
SUBDIR += matio
+ SUBDIR += matlab-R2012a-installer
SUBDIR += matrices
SUBDIR += matrix
SUBDIR += maxima
diff --git a/math/matlab-R2012a-installer/Makefile b/math/matlab-R2012a-installer/Makefile
new file mode 100644
index 000000000000..67873ecc8a02
--- /dev/null
+++ b/math/matlab-R2012a-installer/Makefile
@@ -0,0 +1,31 @@
+# Created by: Jason Bacon
+# $FreeBSD$
+
+PORTNAME= matlab-R2012a-installer
+PORTVERSION= 0.1
+CATEGORIES= math science java
+MASTER_SITES= http://acadix.biz/Ports/distfiles/ \
+ http://personalpages.tds.net/~jwbacon/Ports/distfiles/
+
+MAINTAINER= jwbacon@tds.net
+COMMENT= Mathworks(r) Matlab installation tool
+
+USE_LINUX= yes
+USE_LINUX_APPS= ncurses-base
+USE_JAVA= yes
+JAVA_VERSION= 1.6+
+JAVA_OS= linux
+JAVA_RUN= yes
+
+NO_BUILD= yes
+SUB_FILES= pkg-message
+PLIST_FILES= bin/${PORTNAME}
+
+do-install:
+ ${MKDIR} ${PREFIX}/bin
+ ${INSTALL_SCRIPT} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
+
+post-install:
+ @${CAT} ${WRKDIR}/pkg-message
+
+.include <bsd.port.mk>
diff --git a/math/matlab-R2012a-installer/distinfo b/math/matlab-R2012a-installer/distinfo
new file mode 100644
index 000000000000..394d80bf21fb
--- /dev/null
+++ b/math/matlab-R2012a-installer/distinfo
@@ -0,0 +1,2 @@
+SHA256 (matlab-R2012a-installer-0.1.tar.gz) = 047888d53f5d2cce32598e45072693aa225cb1472b9196e521f541a3b73ba749
+SIZE (matlab-R2012a-installer-0.1.tar.gz) = 4706
diff --git a/math/matlab-R2012a-installer/files/pkg-message.in b/math/matlab-R2012a-installer/files/pkg-message.in
new file mode 100644
index 000000000000..84d08525aee0
--- /dev/null
+++ b/math/matlab-R2012a-installer/files/pkg-message.in
@@ -0,0 +1,20 @@
+====================================================================
+If you did not allow the Matlab installer to create symbolic links
+to the Matlab binaries, users will need %%PREFIX%%/matlab/bin
+in their PATH to run matlab.
+
+If you want to run matlab without the graphical desktop, you will need
+a terminfo database installed in
+
+ /compat/linux/usr/share/terminfo
+
+To install Matlab (r), have your license.dat file and installation
+media ready, and run
+
+ matlab-R2012a-installer
+
+as root.
+
+NOTE: The root user must have the ability to run X11 applications,
+as Matlab R2012a does not have a text-based installer.
+====================================================================
diff --git a/math/matlab-R2012a-installer/pkg-descr b/math/matlab-R2012a-installer/pkg-descr
new file mode 100644
index 000000000000..d0a4c37dfa2f
--- /dev/null
+++ b/math/matlab-R2012a-installer/pkg-descr
@@ -0,0 +1,5 @@
+This port installs the prerequisites for Mathworks (r) Matlab R2012a for Linux
+and an installer script matlab-2012a-installer, which automates the somewhat
+tricky process of installing Linux Matlab.
+
+It requires installation media and a license file from Mathworks, Inc.