aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJosh Paetzel <jpaetzel@FreeBSD.org>2010-07-16 16:37:42 +0000
committerJosh Paetzel <jpaetzel@FreeBSD.org>2010-07-16 16:37:42 +0000
commit8704ece7c56f5bc020013f4bb47e5b2e8e4568e6 (patch)
treeb3ddf292621f5d0daf31adfb4ef887c64265b1a4
parent2658f3012cf102c58285f1fe896b769b10e3e6c9 (diff)
downloadports-8704ece7c56f5bc020013f4bb47e5b2e8e4568e6.tar.gz
ports-8704ece7c56f5bc020013f4bb47e5b2e8e4568e6.zip
Notes
-rw-r--r--net/Sockets/Makefile44
-rw-r--r--net/Sockets/distinfo6
-rw-r--r--net/Sockets/files/Makefile.Defines.freebsd14
-rw-r--r--net/Sockets/files/patch-Makefile49
-rw-r--r--net/Sockets/pkg-descr9
-rw-r--r--net/Sockets/pkg-plist37
6 files changed, 96 insertions, 63 deletions
diff --git a/net/Sockets/Makefile b/net/Sockets/Makefile
index 5087106797b1..d6b9d8a37093 100644
--- a/net/Sockets/Makefile
+++ b/net/Sockets/Makefile
@@ -1,44 +1,40 @@
# New ports collection makefile for: C++ Sockets
-# Date created: Sat Jan 15 16:17:20 UTC 2005
-# Whom: Mario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>
+# Date created: Tue Jun 29 16:00:00 UTC 2010
+# Whom: Andrea Venturoli <ml@netfence.it>
#
# $FreeBSD$
#
PORTNAME= Sockets
-PORTVERSION= 2.1.4
-CATEGORIES= net ipv6
-MASTER_SITES= http://www.alhem.net/Sockets/
+PORTVERSION= 2.3.9.2
+CATEGORIES= net
+MASTER_SITES= http://www.alhem.net/Sockets/ \
+ http://www.netfence.it/Sockets/
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= ml@netfence.it
COMMENT= A C++ wrapper for BSD-style sockets
-LIB_DEPENDS= execinfo.1:${PORTSDIR}/devel/libexecinfo
+#execinfo is optional and currently not configured (would need to patch source's #ifdef LINUX)
+#LIB_DEPENDS= execinfo.1:${PORTSDIR}/devel/libexecinfo
-CFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib
-CONFIGURE_ARGS+= CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS} ${PTHREAD_LIBS}"
+#Not needed without execinfo or xml
+#CFLAGS+= -I${LOCALBASE}/include
+#LDFLAGS+= -L${LOCALBASE}/lib
+
+MAKE_JOBS_SAFE=yes
USE_GMAKE= yes
USE_OPENSSL= yes
-WITH_OPENSSL_BASE= yes
+USE_LDCONFIG= yes
+
+ALL_TARGET= all shared
+INSTALL_TARGET= install_shared
post-patch:
# PREFIX safeness
-# CXX safeness
-# CXXFLAGS safeness
+ @${CP} ${PATCHDIR}/Makefile.Defines.freebsd ${WRKSRC}
@${REINPLACE_CMD} -E \
- -e 's|-O2||' \
+ -e 's|linux-x86-32|freebsd|' \
-e 's|^PREFIX.+$$|PREFIX=${PREFIX}|' \
- -e 's|^INCLUDE.+$$|INCLUDE=-I. -I${OPENSSLINC}|' \
- -e 's|g\+\+|${CXX}|' \
${BUILD_WRKSRC}/${MAKEFILE}
-# fix StdLog.h location
- @${FIND} ${WRKSRC} -type f | \
- ${XARGS} -n 5 -x \
- ${REINPLACE_CMD} -E \
- -e 's|"StdLog.h"|<StdLog.h>|'
-
- @${REINPLACE_CMD} -e 's#pthread#(unsigned long)pthread#g' \
- ${WRKSRC}/Utility.cpp
.include <bsd.port.mk>
diff --git a/net/Sockets/distinfo b/net/Sockets/distinfo
index c5bd39a56620..c602467c6f1f 100644
--- a/net/Sockets/distinfo
+++ b/net/Sockets/distinfo
@@ -1,3 +1,3 @@
-MD5 (Sockets-2.1.4.tar.gz) = b58dbe074eeacf2a885914141c9f73a5
-SHA256 (Sockets-2.1.4.tar.gz) = a90d4e1a735f315ad3adde70bf64c67a01ff44687be2b32836dfef51504bb630
-SIZE (Sockets-2.1.4.tar.gz) = 123138
+MD5 (Sockets-2.3.9.2.tar.gz) = 669c4c093aa446c9c831a142a22571a4
+SHA256 (Sockets-2.3.9.2.tar.gz) = 810ab9b6a7316bfa7994c0d5e9bd8c556e9edcb8da35a1778ea11bd16471fba8
+SIZE (Sockets-2.3.9.2.tar.gz) = 191131
diff --git a/net/Sockets/files/Makefile.Defines.freebsd b/net/Sockets/files/Makefile.Defines.freebsd
new file mode 100644
index 000000000000..9d69e80c463a
--- /dev/null
+++ b/net/Sockets/files/Makefile.Defines.freebsd
@@ -0,0 +1,14 @@
+CXX?= g++
+
+CFLAGS += -Wall $(INCLUDE) -MD -D_VERSION='"$(VERSION)"'
+
+CFLAGS += -O2
+
+
+CFLAGS += -fPIC
+
+OBJS += Semaphore.o
+
+LDFLAGSSO = -shared \
+ -Wl,-lssl \
+ -Wl,-h$(SONAME)
diff --git a/net/Sockets/files/patch-Makefile b/net/Sockets/files/patch-Makefile
index 63e1a7ab321e..f0d93cd6fa6d 100644
--- a/net/Sockets/files/patch-Makefile
+++ b/net/Sockets/files/patch-Makefile
@@ -1,25 +1,30 @@
---- Makefile.orig 2010-01-12 15:22:03.000000000 +0800
-+++ Makefile 2010-01-12 15:24:19.000000000 +0800
-@@ -70,18 +70,17 @@
+--- /Makefile.orig 2010-06-29 21:16:10.000000000 +0200
++++ Makefile 2010-06-29 21:17:45.000000000 +0200
+@@ -90,9 +90,9 @@
install: all
- @mkdir -p $(PREFIX)/lib
-- cp libSockets.a $(PREFIX)/lib
-- cp libSocketsEx.a $(PREFIX)/lib
-+ @${BSD_INSTALL_DATA} libSockets.a $(PREFIX)/lib
-+ @${BSD_INSTALL_DATA} libSocketsEx.a $(PREFIX)/lib
- @mkdir -p $(PREFIX)/include/Sockets
-- cp -a *.h $(PREFIX)/include/Sockets
-+ @${BSD_INSTALL_DATA} *.h $(PREFIX)/include/Sockets
- @rm -f $(PREFIX)/include/Sockets/SSLSocket.*
- @rm -f $(PREFIX)/include/Sockets/HttpsGetSocket.*
- @rm -f $(PREFIX)/include/Sockets/HttpsSocket.*
- @rm -f $(PREFIX)/include/Sockets/EventSocket.*
- @rm -f $(PREFIX)/include/Sockets/PoolSocket.*
- @rm -f $(PREFIX)/include/Sockets/SocketThread.*
-- @mkdir -p $(PREFIX)/bin
-- install Sockets-config $(PREFIX)/bin
-+ @${BSD_INSTALL_DATA} Sockets-config $(PREFIX)/bin
+ @mkdir -p $(DESTDIR)/$(PREFIX)/lib
+- cp $(LIBNAME) $(DESTDIR)/$(PREFIX)/lib
++ @${BSD_INSTALL_DATA} $(LIBNAME) $(DESTDIR)/$(PREFIX)/lib
+ @mkdir -p $(DESTDIR)/$(PREFIX)/include/$(NAME)
+- cp -a *.h $(DESTDIR)/$(PREFIX)/include/$(NAME)
++ @${BSD_INSTALL_DATA} *.h $(DESTDIR)/$(PREFIX)/include/$(NAME)
+ @rm -f $(DESTDIR)/$(PREFIX)/include/$(NAME)/SSLSocket.*
+ @rm -f $(DESTDIR)/$(PREFIX)/include/$(NAME)/HttpsGetSocket.*
+ @rm -f $(DESTDIR)/$(PREFIX)/include/$(NAME)/HttpsSocket.*
+@@ -106,12 +106,12 @@
+ @rm -f $(DESTDIR)/$(PREFIX)/include/$(NAME)/Min*Handler.h
+ @rm -f $(DESTDIR)/$(PREFIX)/include/$(NAME)/Uid.h
+ @mkdir -p $(DESTDIR)/$(PREFIX)/bin
+- install $(CONFNAME) $(DESTDIR)/$(PREFIX)/bin
++ @${BSD_INSTALL_PROGRAM} $(CONFNAME) $(DESTDIR)/$(PREFIX)/bin
- # no binary files, zip will translate lf to cr lf
- FILES = *.h *.cpp Makefile Makefile.* Project/*.ds* \
+ install_shared: install shared
+ @mkdir -p $(DESTDIR)/$(PREFIX)/lib/pkgconfig
+- cp $(SHAREDLIBNAME) $(DESTDIR)/$(PREFIX)/lib
+- cp -a pkgconfig/*pc $(DESTDIR)/$(PREFIX)/lib/pkgconfig
++ @${BSD_INSTALL_DATA} $(SHAREDLIBNAME) $(DESTDIR)/$(PREFIX)/lib
++ @${BSD_INSTALL_DATA} pkgconfig/*pc $(DESTDIR)/$(PREFIX)/libdata/pkgconfig
+ rm -f $(DESTDIR)/$(PREFIX)/lib/lib$(NAME).so
+ rm -f $(DESTDIR)/$(PREFIX)/lib/lib$(NAME).so.$(MAJOR)
+ ln -s $(DESTDIR)/$(PREFIX)/lib/lib$(NAME).so.$(MAJOR).$(MINOR) $(DESTDIR)/$(PREFIX)/lib/lib$(NAME).so
diff --git a/net/Sockets/pkg-descr b/net/Sockets/pkg-descr
index 2f716765c87a..8d1270c8e876 100644
--- a/net/Sockets/pkg-descr
+++ b/net/Sockets/pkg-descr
@@ -1,10 +1,11 @@
[ excerpt from developer's web site ]
-This is a GPL licensed C++ class library wrapping the berkeley
+This is C++ class library wrapping the berkeley
sockets C API, and therefore works on most unixes and also win32.
Features include, but are not limited to, SSL support, IPv6 support,
tcp and udp sockets, encrypted tcp, http protocol, highly customizable
-error handling. Testing has been done on Linux and Windows 2000,
-and to some part on Solaris and Mac OS X.
+error handling.
+The source code is released under the terms of the GNU GPL, but is
+also available under an alternative license.
-WWW: http://www.alhem.net/Sockets/index.html
+WWW: http://www.alhem.net/Sockets/
diff --git a/net/Sockets/pkg-plist b/net/Sockets/pkg-plist
index e0d2362c8ad9..acefb2d85595 100644
--- a/net/Sockets/pkg-plist
+++ b/net/Sockets/pkg-plist
@@ -1,37 +1,42 @@
bin/Sockets-config
+include/Sockets/Ajp13Socket.h
+include/Sockets/AjpBaseSocket.h
include/Sockets/Base64.h
-include/Sockets/CTcpSocket.h
-include/Sockets/CircularBuffer.h
include/Sockets/Debug.h
include/Sockets/Event.h
include/Sockets/EventHandler.h
include/Sockets/EventTime.h
+include/Sockets/Exception.h
include/Sockets/File.h
+include/Sockets/FileStream.h
include/Sockets/HTTPSocket.h
+include/Sockets/HttpBaseSocket.h
include/Sockets/HttpClientSocket.h
include/Sockets/HttpDebugSocket.h
include/Sockets/HttpGetSocket.h
include/Sockets/HttpPostSocket.h
include/Sockets/HttpPutSocket.h
+include/Sockets/HttpRequest.h
+include/Sockets/HttpResponse.h
+include/Sockets/HttpTransaction.h
include/Sockets/HttpdCookies.h
include/Sockets/HttpdForm.h
include/Sockets/HttpdSocket.h
-include/Sockets/ICrypt.h
+include/Sockets/IBase.h
include/Sockets/IEventHandler.h
include/Sockets/IEventOwner.h
include/Sockets/IFile.h
+include/Sockets/IFileUpload.h
+include/Sockets/IHttpServer.h
+include/Sockets/IMutex.h
include/Sockets/ISocketHandler.h
+include/Sockets/IStream.h
include/Sockets/Ipv4Address.h
include/Sockets/Ipv6Address.h
include/Sockets/ListenSocket.h
include/Sockets/Lock.h
include/Sockets/MemFile.h
-include/Sockets/MinderSocket.h
-include/Sockets/MinderHandler.h
-include/Sockets/MinionSocket.h
include/Sockets/Mutex.h
-include/Sockets/NullCrypt.h
-include/Sockets/RandomNumber.h
include/Sockets/Parse.h
include/Sockets/ResolvServer.h
include/Sockets/ResolvSocket.h
@@ -42,15 +47,27 @@ include/Sockets/SmtpdSocket.h
include/Sockets/Socket.h
include/Sockets/SocketAddress.h
include/Sockets/SocketHandler.h
+include/Sockets/SocketHandlerEp.h
+include/Sockets/SocketStream.h
include/Sockets/StdLog.h
include/Sockets/StdoutLog.h
+include/Sockets/StreamSocket.h
+include/Sockets/StreamWriter.h
include/Sockets/TcpSocket.h
include/Sockets/Thread.h
include/Sockets/UdpSocket.h
-include/Sockets/Uid.h
include/Sockets/Utility.h
+include/Sockets/XmlDocument.h
+include/Sockets/XmlException.h
+include/Sockets/XmlNode.h
+include/Sockets/ajp13.h
include/Sockets/socket_include.h
include/Sockets/sockets-config.h
+libdata/pkgconfig/libSockets.pc
+libdata/pkgconfig/libsockets2.pc
lib/libSockets.a
-lib/libSocketsEx.a
+lib/libSockets.so
+lib/libSockets.so.2
+lib/libSockets.so.2.3.9.2
@dirrm include/Sockets
+@dirrmtry lib/pkgconfig