aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWen Heping <wen@FreeBSD.org>2009-12-23 13:43:00 +0000
committerWen Heping <wen@FreeBSD.org>2009-12-23 13:43:00 +0000
commit8735375fbf32b1d304e89fcee42709708caf480a (patch)
tree62dbcd57ebfc55ec16061955564682b28d1ef328
parentdbf1345f02c3794337b5dcc7ce6a69d1f316f837 (diff)
downloadports-8735375fbf32b1d304e89fcee42709708caf480a.tar.gz
ports-8735375fbf32b1d304e89fcee42709708caf480a.zip
Notes
-rw-r--r--audio/Makefile1
-rw-r--r--audio/p5-MusicBrainz-DiscID/Makefile26
-rw-r--r--audio/p5-MusicBrainz-DiscID/distinfo3
-rw-r--r--audio/p5-MusicBrainz-DiscID/pkg-descr6
-rw-r--r--audio/p5-MusicBrainz-DiscID/pkg-plist6
5 files changed, 42 insertions, 0 deletions
diff --git a/audio/Makefile b/audio/Makefile
index 5ab900098700..39e2d90de15a 100644
--- a/audio/Makefile
+++ b/audio/Makefile
@@ -534,6 +534,7 @@
SUBDIR += p5-Music-Audioscrobbler-MPD
SUBDIR += p5-Music-Audioscrobbler-Submit
SUBDIR += p5-MusicBrainz-Client
+ SUBDIR += p5-MusicBrainz-DiscID
SUBDIR += p5-MusicBrainz-Queries
SUBDIR += p5-MusicBrainz-TRM
SUBDIR += p5-Net-DAAP-Client
diff --git a/audio/p5-MusicBrainz-DiscID/Makefile b/audio/p5-MusicBrainz-DiscID/Makefile
new file mode 100644
index 000000000000..e7c3101ab95a
--- /dev/null
+++ b/audio/p5-MusicBrainz-DiscID/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: p5-WebService-MusicBrainz
+# Date created: 2009-12-22
+# Whom: Tobias Rehbein <tobias.rehbein@web.de>
+#
+# $FreeBSD$
+#
+
+PORTNAME= MusicBrainz-DiscID
+PORTVERSION= 0.03
+CATEGORIES= audio perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= tobias.rehbein@web.de
+COMMENT= Perl interface for the MusicBrainz libdiscid library
+
+BUILD_DEPENDS= p5-Test-Pod>=0:${PORTSDIR}/devel/p5-Test-Pod
+LIB_DEPENDS= discid.2:${PORTSDIR}/audio/libdiscid
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+USE_GNOME= pkgconfig
+PERL_MODBUILD= yes
+
+MAN3= MusicBrainz::DiscID.3
+
+.include <bsd.port.mk>
diff --git a/audio/p5-MusicBrainz-DiscID/distinfo b/audio/p5-MusicBrainz-DiscID/distinfo
new file mode 100644
index 000000000000..a9df4f0b126f
--- /dev/null
+++ b/audio/p5-MusicBrainz-DiscID/distinfo
@@ -0,0 +1,3 @@
+MD5 (MusicBrainz-DiscID-0.03.tar.gz) = 4b775f38604f15fd20298d5b443d6900
+SHA256 (MusicBrainz-DiscID-0.03.tar.gz) = 5002f92fd8f074bccf924752ef171fa11ea2431a634ff60e520a5c3fb080573a
+SIZE (MusicBrainz-DiscID-0.03.tar.gz) = 5343
diff --git a/audio/p5-MusicBrainz-DiscID/pkg-descr b/audio/p5-MusicBrainz-DiscID/pkg-descr
new file mode 100644
index 000000000000..686977f8db1e
--- /dev/null
+++ b/audio/p5-MusicBrainz-DiscID/pkg-descr
@@ -0,0 +1,6 @@
+MusicBrainz::DiscID is a class to calculate a MusicBrainz DiscID
+from an audio CD in the drive. The coding style is slightly different
+to the C interface to libdiscid, because it makes use of perl's
+Object Oriented functionality.
+
+WWW: http://search.cpan.org/dist/MusicBrainz-DiscID
diff --git a/audio/p5-MusicBrainz-DiscID/pkg-plist b/audio/p5-MusicBrainz-DiscID/pkg-plist
new file mode 100644
index 000000000000..835d84627860
--- /dev/null
+++ b/audio/p5-MusicBrainz-DiscID/pkg-plist
@@ -0,0 +1,6 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/MusicBrainz/DiscID/DiscID.bs
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/MusicBrainz/DiscID/DiscID.so
+%%SITE_PERL%%/%%PERL_ARCH%%/MusicBrainz/DiscID.pm
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/MusicBrainz/DiscID/
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/MusicBrainz/
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/MusicBrainz/