aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPietro Cerutti <gahr@FreeBSD.org>2011-09-14 07:38:20 +0000
committerPietro Cerutti <gahr@FreeBSD.org>2011-09-14 07:38:20 +0000
commit89583e1a3f8c3106f1ac6a7cc75d2b68592637c4 (patch)
tree6672a21ac51d5ae8eb31bddd7a5210fb77c32687
parent81eb9e3d0f6608cf5f6d1c980e9efbcc2062c8e3 (diff)
downloadports-89583e1a3f8c3106f1ac6a7cc75d2b68592637c4.tar.gz
ports-89583e1a3f8c3106f1ac6a7cc75d2b68592637c4.zip
Notes
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/zorba/Makefile98
-rw-r--r--textproc/zorba/distinfo2
-rw-r--r--textproc/zorba/files/patch-CMakeLists.txt13
-rw-r--r--textproc/zorba/files/patch-cmake_modules_FindPHP5.cmake44
-rw-r--r--textproc/zorba/files/patch-doc_CMakeLists.txt21
-rw-r--r--textproc/zorba/files/patch-src-context_dynamic_context.cpp47
-rw-r--r--textproc/zorba/files/patch-swig-java_CMakeLists.txt28
-rw-r--r--textproc/zorba/files/patch-swig-php_CMakeLists.txt33
-rw-r--r--textproc/zorba/files/patch-swig-python_CMakeLists.txt24
-rw-r--r--textproc/zorba/files/patch-swig-ruby_CMakeLists.txt31
-rw-r--r--textproc/zorba/files/patch-test-rbkt_CMakeLists.txt20
-rw-r--r--textproc/zorba/pkg-descr9
-rw-r--r--textproc/zorba/pkg-plist216
14 files changed, 587 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index b623968c639d..662e431f1392 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -1441,6 +1441,7 @@
SUBDIR += yi-hunspell
SUBDIR += yodl
SUBDIR += yould
+ SUBDIR += zorba
SUBDIR += zu-aspell
SUBDIR += zu-hunspell
diff --git a/textproc/zorba/Makefile b/textproc/zorba/Makefile
new file mode 100644
index 000000000000..bb5539611bd3
--- /dev/null
+++ b/textproc/zorba/Makefile
@@ -0,0 +1,98 @@
+# New ports collection Makefile for: zorba
+# Date created: 22 February 2011
+# Whom: gahr
+#
+# $FreeBSD$
+#
+
+PORTNAME= zorba
+PORTVERSION= 1.4.0
+CATEGORIES= textproc
+MASTER_SITES= SF
+
+MAINTAINER= gahr@FreeBSD.org
+COMMENT= A general purpose C++ XQuery processor
+
+LICENSE= ASL
+
+LIB_DEPENDS= xerces-c.3:${PORTSDIR}/textproc/xerces-c3 \
+ tidy:${PORTSDIR}/www/tidy-lib \
+ curl.6:${PORTSDIR}/ftp/curl \
+ icudata.48:${PORTSDIR}/devel/icu
+
+OPTIONS= PHP "PHP bindings" off \
+ PYTHON "Python bindings" off \
+ RUBY "Ruby bindings" off \
+ JAVA "Java bindings" off
+
+# Both install include/xqc.h
+CONFLICTS= xqilla-[0-9]*
+
+USE_GNOME= libxml2
+USE_LDCONFIG= yes
+USE_CMAKE= yes
+CMAKE_OUTSOURCE=yes
+CONFIGURE_ENV+= JAVA_HOME=${JAVA_HOME}
+
+DOCSDIR= ${PREFIX}/share/doc/${PKGNAME}
+
+.include <bsd.port.options.mk>
+
+.if defined(WITH_PHP)
+USE_PHP= tokenizer
+USE_PHP_BUILD= yes
+WITH_SWIG= yes
+CMAKE_ARGS+= -DWITH_PHP5:BOOL=true \
+ -DPHP5_INSTALL_PATH:PATH=lib/php/${PHP_EXT_DIR}
+PLIST_SUB+= WITH_PHP="" \
+ PHP_EXTLIBDIR="lib/php/${PHP_EXT_DIR}"
+.else
+CMAKE_ARGS+= -DWITH_PHP5:BOOL=false
+PLIST_SUB+= WITH_PHP="@comment "
+.endif
+
+.if defined(WITH_PYTHON)
+USE_PYTHON= yes
+WITH_SWIG= yes
+CMAKE_ARGS+= -DWITH_PYTHON:BOOL=true \
+ -DPYTHON_SWIG_INSTALL_DIR=${PYTHONPREFIX_SITELIBDIR:S/${PREFIX}\///}
+PLIST_SUB+= WITH_PYTHON=""
+.else
+CMAKE_ARGS+= -DWITH_PYTHON:BOOL=false
+PLIST_SUB+= WITH_PYTHON="@comment "
+.endif
+
+.if defined(WITH_RUBY)
+USE_RUBY= yes
+WITH_SWIG= yes
+CMAKE_ARGS+= -DWITH_RUBY:BOOL=true
+PLIST_SUB+= WITH_RUBY=""
+.else
+CMAKE_ARGS+= -DWITH_RUBY:BOOL=false
+PLIST_SUB+= WITH_RUBY="@comment "
+.endif
+
+.if defined(WITH_JAVA)
+USE_JAVA= yes
+WITH_SWIG= yes
+CMAKE_ARGS+= -DWITH_JAVA:BOOL=true \
+ -DJAVA_LIBDIR:PATH=${JAVALIBDIR:S/${PREFIX}//}
+PLIST_SUB+= WITH_JAVA=""
+.else
+CMAKE_ARGS+= -DWITH_JAVA:BOOL=false
+PLIST_SUB+= WITH_JAVA="@comment "
+.endif
+
+.if defined(WITH_SWIG)
+BUILD_DEPENDS+= swig:${PORTSDIR}/devel/swig13
+.endif
+
+.if !defined(NOPORTDOCS)
+BUILD_DEPENDS+= doxygen:${PORTSDIR}/devel/doxygen
+.endif
+
+post-patch:
+ ${REINPLACE_CMD} -e 's|%%LOCALBASE%%|${LOCALBASE}|g' \
+ ${WRKSRC}/cmake_modules/FindPHP5.cmake
+
+.include <bsd.port.mk>
diff --git a/textproc/zorba/distinfo b/textproc/zorba/distinfo
new file mode 100644
index 000000000000..26c30996f40b
--- /dev/null
+++ b/textproc/zorba/distinfo
@@ -0,0 +1,2 @@
+SHA256 (zorba-1.4.0.tar.gz) = 230518cdb70568f286397961f878b61e268370aca9b9d2f3817b6d1fdfb9cf86
+SIZE (zorba-1.4.0.tar.gz) = 5177139
diff --git a/textproc/zorba/files/patch-CMakeLists.txt b/textproc/zorba/files/patch-CMakeLists.txt
new file mode 100644
index 000000000000..ed27c28641ad
--- /dev/null
+++ b/textproc/zorba/files/patch-CMakeLists.txt
@@ -0,0 +1,13 @@
+--- CMakeLists.txt.orig 2011-08-12 10:26:33.000000000 +0200
++++ CMakeLists.txt 2011-08-12 10:26:28.000000000 +0200
+@@ -37,6 +37,10 @@
+ SET(LINUX "${CMAKE_SYSTEM}")
+ ENDIF("${CMAKE_SYSTEM_NAME}" MATCHES "Linux")
+
++IF("${CMAKE_SYSTEM_NAME}" MATCHES "FreeBSD")
++ SET(FREEBSD "${CMAKE_SYSTEM}")
++ENDIF("${CMAKE_SYSTEM_NAME}" MATCHES "FreeBSD")
++
+ # custom ctest options
+ CONFIGURE_FILE(${CMAKE_CURRENT_SOURCE_DIR}/CTestCustom.cmake ${CMAKE_CURRENT_BINARY_DIR}/CTestCustom.cmake)
+
diff --git a/textproc/zorba/files/patch-cmake_modules_FindPHP5.cmake b/textproc/zorba/files/patch-cmake_modules_FindPHP5.cmake
new file mode 100644
index 000000000000..5a4edaf2ca6f
--- /dev/null
+++ b/textproc/zorba/files/patch-cmake_modules_FindPHP5.cmake
@@ -0,0 +1,44 @@
+--- cmake_modules/FindPHP5.cmake.orig 2010-07-14 15:23:17.000000000 +0200
++++ cmake_modules/FindPHP5.cmake 2011-08-19 09:45:39.000000000 +0200
+@@ -26,15 +26,11 @@
+ SET(PHP5_FOUND "NO")
+
+ SET(PHP5_POSSIBLE_INCLUDE_PATHS
+- /usr/include/php5
+- /usr/local/include/php5
+- /usr/include/php
+- /usr/local/include/php
+- /usr/local/apache/php
++ %%LOCALBASE%%/include/php
+ )
+
+ SET(PHP5_POSSIBLE_LIB_PATHS
+- /usr/lib
++ %%LOCALBASE%%/lib/php
+ )
+
+ #FIND_PATH(PHP5_FOUND_INCLUDE_PATH main/php.h
+@@ -51,8 +47,7 @@
+ FIND_PROGRAM(PHP5_EXECUTABLE
+ NAMES php5 php
+ PATHS
+- /usr/bin
+- /usr/local/bin
++ %%LOCALBASE%%/bin
+ )
+
+ MARK_AS_ADVANCED(
+@@ -103,9 +98,11 @@
+ FIND_PROGRAM(PHP5_CONFIG_EXECUTABLE
+ NAMES php5-config php-config
+ PATHS
+- /usr/bin
+- /usr/local/bin
++ %%LOCALBASE%%/bin
+ )
++IF(NOT PHP5_CONFIG_EXECUTABLE)
++ MESSAGE(FATAL_ERROR "PHP config executable not found")
++ENDIF(NOT PHP5_CONFIG_EXECUTABLE)
+
+ EXECUTE_PROCESS(COMMAND ${PHP5_CONFIG_EXECUTABLE} --version
+ OUTPUT_VARIABLE PHP5_VERSION)
diff --git a/textproc/zorba/files/patch-doc_CMakeLists.txt b/textproc/zorba/files/patch-doc_CMakeLists.txt
new file mode 100644
index 000000000000..673286a1b552
--- /dev/null
+++ b/textproc/zorba/files/patch-doc_CMakeLists.txt
@@ -0,0 +1,21 @@
+--- doc/CMakeLists.txt.orig 2011-08-19 15:31:29.000000000 +0200
++++ doc/CMakeLists.txt 2011-08-19 15:32:16.000000000 +0200
+@@ -37,9 +37,15 @@
+
+ IF(ZORBA_USE_SWIG AND BUILDING_SIMPLESTORE)
+ ADD_SUBDIRECTORY(java)
+- ADD_SUBDIRECTORY(python)
+- ADD_SUBDIRECTORY(ruby)
+- ADD_SUBDIRECTORY(php)
++ IF (WITH_PYTHON)
++ ADD_SUBDIRECTORY(python)
++ ENDIF (WITH_PYTHON)
++ IF (WITH_RUBY)
++ ADD_SUBDIRECTORY(ruby)
++ ENDIF (WITH_RUBY)
++ IF (WITH_PHP5)
++ ADD_SUBDIRECTORY(php)
++ ENDIF (WITH_PHP5)
+ ENDIF(ZORBA_USE_SWIG AND BUILDING_SIMPLESTORE)
+
+ # workaround: a dir is already needed for the install command.
diff --git a/textproc/zorba/files/patch-src-context_dynamic_context.cpp b/textproc/zorba/files/patch-src-context_dynamic_context.cpp
new file mode 100644
index 000000000000..035dee2b2d88
--- /dev/null
+++ b/textproc/zorba/files/patch-src-context_dynamic_context.cpp
@@ -0,0 +1,47 @@
+--- src/context/dynamic_context.cpp.orig 2011-08-11 15:02:06.000000000 +0200
++++ src/context/dynamic_context.cpp 2011-08-11 15:10:43.000000000 +0200
+@@ -16,7 +16,9 @@
+ #include "common/common.h"
+ #include <assert.h>
+ #include <time.h>
++#if defined(WIN32)
+ #include <sys/timeb.h>
++#endif
+ #ifdef UNIX
+ #include <sys/time.h>
+ #endif
+@@ -147,10 +149,10 @@
+ if (gmtm.tm_isdst != 0)
+ lTimeShift = -timebuffer.timezone*60 + 3600;
+ #else
+- struct timeb timebuffer;
+- ftime( &timebuffer );
++ struct timeval tv;
++ gettimeofday( &tv, 0 );
+ struct ::tm gmtm;
+- localtime_r(&timebuffer.time, &gmtm); //thread safe localtime on Linux
++ localtime_r(&tv.tv_sec, &gmtm); //thread safe localtime on Linux
+ lTimeShift = gmtm.tm_gmtoff;
+ #endif
+
+@@ -162,7 +164,11 @@
+ gmtm.tm_mday,
+ gmtm.tm_hour,
+ gmtm.tm_min,
++#if defined(WIN32)
+ gmtm.tm_sec + timebuffer.millitm/1000.0,
++#else
++ gmtm.tm_sec + tv.tv_usec/1000000.0,
++#endif
+ theTimezone/3600);
+
+ #if WIN32
+@@ -170,8 +176,6 @@
+ time(&t0);
+ GENV_ITEMFACTORY->createLong(current_time_millis, t0*1000);
+ #else
+- timeval tv;
+- gettimeofday(&tv, 0);
+ long long millis = tv.tv_sec;
+ millis = millis * 1000 + tv.tv_usec/1000;
+ GENV_ITEMFACTORY->createLong(current_time_millis, millis);
diff --git a/textproc/zorba/files/patch-swig-java_CMakeLists.txt b/textproc/zorba/files/patch-swig-java_CMakeLists.txt
new file mode 100644
index 000000000000..b9fd4e831052
--- /dev/null
+++ b/textproc/zorba/files/patch-swig-java_CMakeLists.txt
@@ -0,0 +1,28 @@
+--- swig/java/CMakeLists.txt.orig 2011-08-23 09:11:30.000000000 +0200
++++ swig/java/CMakeLists.txt 2011-08-23 09:17:55.000000000 +0200
+@@ -12,6 +12,8 @@
+ # See the License for the specific language governing permissions and
+ # limitations under the License.
+
++IF (WITH_JAVA)
++
+ FIND_PACKAGE ( Java )
+ include ( FindJNI )
+
+@@ -62,8 +64,8 @@
+ INSTALL(FILES ${JAVA_SWIG_FILES} DESTINATION ${JAVA_SITEARCH_DIR})
+ ELSE ( APPLE )
+ IF(NOT WIN32)
+- INSTALL(FILES ${CMAKE_CURRENT_BINARY_DIR}/libzorba_api.so DESTINATION ${JAVA_SITEARCH_DIR})
+- INSTALL(FILES ${JAVA_SWIG_FILES} DESTINATION ${JAVA_SITEARCH_DIR})
++ INSTALL(FILES ${CMAKE_CURRENT_BINARY_DIR}/libzorba_api.so DESTINATION ${JAVA_LIBDIR})
++ INSTALL(FILES ${JAVA_SWIG_FILES} DESTINATION ${JAVA_LIBDIR})
+ ELSE(NOT WIN32)
+ INSTALL(FILES ${CMAKE_CURRENT_BINARY_DIR}/libzorba_api.dll DESTINATION bin/java/org/zorbaxquery/api )
+ INSTALL(FILES ${JAVA_SWIG_FILES} DESTINATION bin/java/org/zorbaxquery/api )
+@@ -73,3 +75,5 @@
+ ELSE (JAVA_INCLUDE_PATH)
+ MESSAGE ( STATUS "SWIG Java: not generating JAVA API because jni headers not found.")
+ ENDIF (JAVA_INCLUDE_PATH)
++
++ENDIF (WITH_JAVA)
diff --git a/textproc/zorba/files/patch-swig-php_CMakeLists.txt b/textproc/zorba/files/patch-swig-php_CMakeLists.txt
new file mode 100644
index 000000000000..26e0102a951d
--- /dev/null
+++ b/textproc/zorba/files/patch-swig-php_CMakeLists.txt
@@ -0,0 +1,33 @@
+--- swig/php/CMakeLists.txt.orig 2010-07-14 15:23:16.000000000 +0200
++++ swig/php/CMakeLists.txt 2011-08-19 13:55:46.000000000 +0200
+@@ -12,6 +12,8 @@
+ # See the License for the specific language governing permissions and
+ # limitations under the License.
+
++IF (WITH_PHP5)
++
+ INCLUDE(${CMAKE_MODULE_PATH}/FindPHP5.cmake)
+ FIND_PACKAGE(PHP5)
+
+@@ -36,13 +38,11 @@
+
+ # The following fix was added because of the changes in CMake 2.8, which have the
+ # result of naming the java binding library "liblibzorba_api.so" instead of "libzorba_api.so"
+- IF ( LINUX OR CYGWIN )
++ IF ( LINUX OR CYGWIN OR FREEBSD)
+ SET_TARGET_PROPERTIES( ${SWIG_MODULE_zorba_api_REAL_NAME} PROPERTIES PREFIX "" )
+- ENDIF ( LINUX OR CYGWIN )
++ ENDIF ( LINUX OR CYGWIN OR FREEBSD)
+
+ IF (NOT WIN32 OR CYGWIN)
+- STRING(REPLACE ${CMAKE_INSTALL_PREFIX} "" PHP5_INSTALL_PATH ${PHP5_EXTENSION_DIR})
+- SET(PHP5_INSTALL_PATH ${CMAKE_INSTALL_PREFIX}${PHP5_INSTALL_PATH})
+ MESSAGE(STATUS "SWIG PHP: PHP module install path: " ${PHP5_INSTALL_PATH})
+
+ INSTALL ( FILES ${CMAKE_CURRENT_BINARY_DIR}/zorba_api_wrapper.php
+@@ -74,3 +74,5 @@
+ ### End PHP proxy generation
+
+ ENDIF( NOT PHP5_FOUND )
++
++ENDIF (WITH_PHP5)
diff --git a/textproc/zorba/files/patch-swig-python_CMakeLists.txt b/textproc/zorba/files/patch-swig-python_CMakeLists.txt
new file mode 100644
index 000000000000..c7eb97dbfd23
--- /dev/null
+++ b/textproc/zorba/files/patch-swig-python_CMakeLists.txt
@@ -0,0 +1,24 @@
+--- swig/python/CMakeLists.txt.orig 2010-07-14 15:23:16.000000000 +0200
++++ swig/python/CMakeLists.txt 2011-08-11 17:07:52.000000000 +0200
+@@ -12,6 +12,8 @@
+ # See the License for the specific language governing permissions and
+ # limitations under the License.
+
++IF (WITH_PYTHON)
++
+ # install path determined from where Python lives
+ FIND_PACKAGE(PythonInterp)
+ FIND_PACKAGE(PythonLibs)
+@@ -43,9 +45,11 @@
+ ELSE(NOT WIN32)
+ INSTALL ( FILES ${CMAKE_CURRENT_BINARY_DIR}/zorba_api.py
+ ${CMAKE_CURRENT_BINARY_DIR}/_zorba_api.pyd
+- DESTINATION bin/python )
++ DESTINATION ${PYTHON_SWIG_INSTALL_DIR})
+ ENDIF(NOT WIN32)
+
+ ELSE (PYTHON_LIBRARIES AND PYTHON_INCLUDE_PATH)
+ MESSAGE(STATUS "SWIG Python: binding not generated because library and include files are not installed.")
+ ENDIF (PYTHON_LIBRARIES AND PYTHON_INCLUDE_PATH)
++
++ENDIF (WITH_PYTHON)
diff --git a/textproc/zorba/files/patch-swig-ruby_CMakeLists.txt b/textproc/zorba/files/patch-swig-ruby_CMakeLists.txt
new file mode 100644
index 000000000000..fbd985c58702
--- /dev/null
+++ b/textproc/zorba/files/patch-swig-ruby_CMakeLists.txt
@@ -0,0 +1,31 @@
+--- swig/ruby/CMakeLists.txt.orig 2010-07-14 15:23:16.000000000 +0200
++++ swig/ruby/CMakeLists.txt 2011-08-12 10:38:13.000000000 +0200
+@@ -12,6 +12,7 @@
+ # See the License for the specific language governing permissions and
+ # limitations under the License.
+
++IF (WITH_RUBY)
+ CMAKE_FIND_FRAMEWORKS ( Ruby )
+ FIND_PACKAGE(Ruby)
+
+@@ -27,13 +28,12 @@
+
+ # The following fix was added because of the changes in CMake 2.8, which have the
+ # result of naming the java binding library "liblibzorba_api.so" instead of "libzorba_api.so"
+- IF ( LINUX OR CYGWIN )
++ IF ( LINUX OR CYGWIN OR FREEBSD)
+ SET_TARGET_PROPERTIES( ${SWIG_MODULE_zorba_api_REAL_NAME} PROPERTIES PREFIX "" )
+- ENDIF ( LINUX OR CYGWIN )
++ ENDIF ( LINUX OR CYGWIN OR FREEBSD)
+
+ EXECUTE_PROCESS(COMMAND ${RUBY_EXECUTABLE} -r rbconfig -e "print Config::CONFIG['sitearchdir']"
+ 48 OUTPUT_VARIABLE RUBY_SITEARCH_DIR)
+- STRING(REPLACE "/usr/" "" RUBY_SITEARCH_DIR "${RUBY_SITEARCH_DIR}" )
+
+ IF ( APPLE )
+ INSTALL ( FILES ${CMAKE_CURRENT_BINARY_DIR}/${ZORBA_SWIG_LIB_PREFIX}zorba_api.bundle
+@@ -45,3 +45,4 @@
+ ELSE (RUBY_LIBRARY AND RUBY_INCLUDE_PATH)
+ MESSAGE(STATUS "SWIG Ruby: binding not generated because library and include files are not installed.")
+ ENDIF (RUBY_LIBRARY AND RUBY_INCLUDE_PATH)
++ENDIF (WITH_RUBY)
diff --git a/textproc/zorba/files/patch-test-rbkt_CMakeLists.txt b/textproc/zorba/files/patch-test-rbkt_CMakeLists.txt
new file mode 100644
index 000000000000..f13aab55b88e
--- /dev/null
+++ b/textproc/zorba/files/patch-test-rbkt_CMakeLists.txt
@@ -0,0 +1,20 @@
+--- test/rbkt/CMakeLists.txt.orig 2011-08-11 09:53:03.000000000 +0200
++++ test/rbkt/CMakeLists.txt 2011-08-11 10:08:48.000000000 +0200
+@@ -68,7 +68,7 @@
+ MESSAGE(STATUS "Did NOT find Boost SYSTEM component - not building multithreaded test driver")
+ SET (ZORBATEST_TESTDRIVER_MT_AVAILABLE FALSE)
+ ELSE (NOT Boost_SYSTEM_FOUND)
+- SET (Boost_system_lib "boost_system-mt")
++ SET (Boost_system_lib ${Boost_LIBRARIES})
+ ENDIF (NOT Boost_SYSTEM_FOUND)
+
+ ENDIF (Boost_MAJOR_VERSION EQUAL 1 AND Boost_MINOR_VERSION GREATER 34)
+@@ -88,7 +88,7 @@
+
+ ADD_EXECUTABLE(testdriver_mt ${TESTDRIVER_MT_SRCS})
+ TARGET_LINK_LIBRARIES(testdriver_mt zorba_simplestore
+- boost_filesystem-mt ${Boost_system_lib})
++ ${Boost_system_lib})
+ IF (ZORBA_BUILD_STATIC_LIBRARY)
+ ADD_EXECUTABLE(testdriver_mt_static testdriver_mt.cpp)
+ SET_TARGET_PROPERTIES(testdriver_mt_static
diff --git a/textproc/zorba/pkg-descr b/textproc/zorba/pkg-descr
new file mode 100644
index 000000000000..9ca0b612f1d5
--- /dev/null
+++ b/textproc/zorba/pkg-descr
@@ -0,0 +1,9 @@
+Zorba is a general purpose XQuery processor implementing in C++ the W3C family
+of specifications. The query processor has been designed to be embeddable in a
+variety of environments such as other programming languages extended with XML
+processing capabilities, browsers, database servers, XML message dispatchers,
+or smartphones. Zorba can be accessed through APIs from C, C++, Ruby, Python,
+Java, and PHP. Zorba runs on most platforms and is available under the Apache
+license v2.
+
+WWW: http://www.zorba-xquery.com/
diff --git a/textproc/zorba/pkg-plist b/textproc/zorba/pkg-plist
new file mode 100644
index 000000000000..31260bcf1cd4
--- /dev/null
+++ b/textproc/zorba/pkg-plist
@@ -0,0 +1,216 @@
+include/zorba/modules/org/w3/www/2005/Atom.xsd
+include/zorba/modules/org/w3/www/2005/xml.xsd
+include/zorba/modules/org/w3/www/2005/xpath_functions.xq
+include/zorba/modules/org/expath/ns/http-client.xsd
+include/zorba/modules/org/expath/ns/http-client.xq
+include/zorba/modules/org/expath/ns/httpclientimpl.xq
+include/zorba/modules/org/expath/ns/error.xq
+include/zorba/modules/com/zorba-xquery/www/modules/excel/errors.xq
+include/zorba/modules/com/zorba-xquery/www/modules/excel/information.xq
+include/zorba/modules/com/zorba-xquery/www/modules/excel/statistical.xq
+include/zorba/modules/com/zorba-xquery/www/modules/excel/math.xq
+include/zorba/modules/com/zorba-xquery/www/modules/excel/lookup.xq
+include/zorba/modules/com/zorba-xquery/www/modules/excel/datetime.xq
+include/zorba/modules/com/zorba-xquery/www/modules/excel/engineering.xq
+include/zorba/modules/com/zorba-xquery/www/modules/excel/logical.xq
+include/zorba/modules/com/zorba-xquery/www/modules/excel/math-sumproduct.xq
+include/zorba/modules/com/zorba-xquery/www/modules/excel/text.xq
+include/zorba/modules/com/zorba-xquery/www/modules/serialize.xq
+include/zorba/modules/com/zorba-xquery/www/modules/tidy.xq
+include/zorba/modules/com/zorba-xquery/www/modules/xqdoc.xq
+include/zorba/modules/com/zorba-xquery/www/modules/math.xq
+include/zorba/modules/com/zorba-xquery/www/modules/file.xq
+include/zorba/modules/com/zorba-xquery/www/modules/node-reference.xq
+include/zorba/modules/com/zorba-xquery/www/modules/random.xq
+include/zorba/modules/com/zorba-xquery/www/modules/schema.xq
+include/zorba/modules/com/zorba-xquery/www/modules/datetime.xq
+include/zorba/modules/com/zorba-xquery/www/modules/csv2xml.xq
+include/zorba/modules/com/zorba-xquery/www/modules/json.xq
+include/zorba/modules/com/zorba-xquery/www/modules/base64.xq
+include/zorba/modules/com/zorba-xquery/www/modules/email/smtp.xq
+include/zorba/modules/com/zorba-xquery/www/modules/security/hmac.xq
+include/zorba/modules/com/zorba-xquery/www/modules/process.xq
+include/zorba/modules/com/zorba-xquery/www/modules/introspection/dctx.xq
+include/zorba/modules/com/zorba-xquery/www/modules/introspection/sctx.xq
+include/zorba/modules/com/zorba-xquery/www/modules/xqddf.xq
+include/zorba/modules/com/zorba-xquery/www/modules/libfile.so.1.4.0
+include/zorba/modules/com/zorba-xquery/www/modules/libfile.so
+include/zorba/modules/com/zorba-xquery/www/modules/libprocess.so.1.4.0
+include/zorba/modules/com/zorba-xquery/www/modules/libprocess.so
+include/zorba/modules/com/zorba-xquery/www/modules/libserialize.so.1.4.0
+include/zorba/modules/com/zorba-xquery/www/modules/libserialize.so
+include/zorba/modules/com/zorba-xquery/www/modules/libdatetime.so.1.4.0
+include/zorba/modules/com/zorba-xquery/www/modules/libdatetime.so
+include/zorba/modules/com/zorba-xquery/www/modules/security/libhmac.so.1.4.0
+include/zorba/modules/com/zorba-xquery/www/modules/security/libhmac.so
+include/zorba/modules/org/expath/ns/libhttpclientimpl.so.1.4.0
+include/zorba/modules/org/expath/ns/libhttpclientimpl.so
+include/zorba/zorba/debugger_exception.h
+include/zorba/zorba/util/file.h
+include/zorba/zorba/util/path.h
+include/zorba/zorba/store_consts.h
+include/zorba/zorba/debugger_event_handler.h
+include/zorba/zorba/pure_stateless_function.h
+include/zorba/zorba/base64.h
+include/zorba/zorba/debugger_client.h
+include/zorba/zorba/store_manager_c.h
+include/zorba/zorba/item_factory.h
+include/zorba/zorba/uri_resolvers.h
+include/zorba/zorba/zorbac.h
+include/zorba/zorba/error_handler.h
+include/zorba/zorba/external_module.h
+include/zorba/zorba/printer_error_handler.h
+include/zorba/zorba/item_sequence.h
+include/zorba/zorba/exception.h
+include/zorba/zorba/static_context_consts.h
+include/zorba/zorba/vector_item_sequence.h
+include/zorba/zorba/item.h
+include/zorba/zorba/file.h
+include/zorba/zorba/properties_base.h
+include/zorba/zorba/empty_sequence.h
+include/zorba/zorba/xquery.h
+include/zorba/zorba/static_context.h
+include/zorba/zorba/declared_collection.h
+include/zorba/zorba/xmldatamanager.h
+include/zorba/zorba/default_content_handler.h
+include/zorba/zorba/nonepure_stateless_function.h
+include/zorba/zorba/zorba.h
+include/zorba/zorba/function.h
+include/zorba/zorba/default_error_handler.h
+include/zorba/zorba/version.h
+include/zorba/zorba/identtypes.h
+include/zorba/zorba/iterator.h
+include/zorba/zorba/api_shared_types.h
+include/zorba/zorba/serializable.h
+include/zorba/zorba/singleton_item_sequence.h
+include/zorba/zorba/options.h
+include/zorba/zorba/collection.h
+include/zorba/zorba/zorbastring.h
+include/zorba/zorba/external_function_data.h
+include/zorba/zorba/smart_ptr.h
+include/zorba/zorba/serialization_callback.h
+include/zorba/zorba/sax2.h
+include/zorba/zorba/typeident.h
+include/zorba/zorba/debugger_default_event_handler.h
+include/zorba/zorba/declared_index.h
+include/zorba/zorba/external_function.h
+include/zorba/zorba/stateless_function.h
+include/zorba/zorba/error.h
+include/zorba/zorba/serializer.h
+include/zorba/zorba/store_manager.h
+include/zorba/zorba/dynamic_context.h
+include/zorba/simplestore/msdom/import.h
+include/xqc.h
+include/zorba/zorba/config.h
+lib/libzorba_simplestore.so.1.4.0
+lib/libzorba_simplestore.so
+bin/zorba
+%%WITH_PHP%%%%PHP_EXTLIBDIR%%/zorba_api_wrapper.php
+%%WITH_PHP%%%%PHP_EXTLIBDIR%%/zorba_api.so
+%%WITH_PYTHON%%%%PYTHON_SITELIBDIR%%/zorba_api.py
+%%WITH_PYTHON%%%%PYTHON_SITELIBDIR%%/_zorba_api.so
+%%WITH_RUBY%%%%RUBY_SITEARCHLIBDIR%%/zorba_api.so
+%%PORTDOCS%%%%DOCSDIR%%/cxx/html/rtab_b.gif
+%%PORTDOCS%%%%DOCSDIR%%/cxx/html/rtab_r.gif
+%%PORTDOCS%%%%DOCSDIR%%/cxx/html/rtab_l.gif
+%%PORTDOCS%%%%DOCSDIR%%/c/html/rtab_b.gif
+%%PORTDOCS%%%%DOCSDIR%%/c/html/rtab_r.gif
+%%PORTDOCS%%%%DOCSDIR%%/c/html/rtab_l.gif
+%%PORTDOCS%%%%DOCSDIR%%/zorba/html/rtab_b.gif
+%%PORTDOCS%%%%DOCSDIR%%/zorba/html/rtab_r.gif
+%%PORTDOCS%%%%DOCSDIR%%/zorba/html/rtab_l.gif
+%%PORTDOCS%%%%DOCSDIR%%/zorba/xqdoc/CMakeFiles/xqdoc.dir/progress.make
+%%PORTDOCS%%%%DOCSDIR%%/zorba/xqdoc/CMakeFiles/xqdoc.dir/cmake_clean.cmake
+%%PORTDOCS%%%%DOCSDIR%%/zorba/xqdoc/CMakeFiles/xqdoc.dir/build.make
+%%PORTDOCS%%%%DOCSDIR%%/zorba/xqdoc/CMakeFiles/xqdoc.dir/DependInfo.cmake
+%%PORTDOCS%%%%DOCSDIR%%/zorba/xqdoc/CMakeFiles/CMakeDirectoryInformation.cmake
+%%PORTDOCS%%%%DOCSDIR%%/zorba/xqdoc/CMakeFiles/progress.marks
+%%PORTDOCS%%%%DOCSDIR%%/zorba/xqdoc/templates/index.html
+%%PORTDOCS%%%%DOCSDIR%%/zorba/xqdoc/xhtml/css/jquery.treeview.css
+%%PORTDOCS%%%%DOCSDIR%%/zorba/xqdoc/xhtml/css/main.css
+%%PORTDOCS%%%%DOCSDIR%%/zorba/xqdoc/xhtml/css/screen.css
+%%PORTDOCS%%%%DOCSDIR%%/zorba/xqdoc/xhtml/images/S.gif
+%%PORTDOCS%%%%DOCSDIR%%/zorba/xqdoc/xhtml/images/U.gif
+%%PORTDOCS%%%%DOCSDIR%%/zorba/xqdoc/xhtml/images/N.gif
+%%PORTDOCS%%%%DOCSDIR%%/zorba/xqdoc/xhtml/images/treeview-default.gif
+%%PORTDOCS%%%%DOCSDIR%%/zorba/xqdoc/xhtml/images/treeview-default-line.gif
+%%PORTDOCS%%%%DOCSDIR%%/zorba/xqdoc/xhtml/lib/jquery.cookie.js
+%%PORTDOCS%%%%DOCSDIR%%/zorba/xqdoc/xhtml/lib/jquery.js
+%%PORTDOCS%%%%DOCSDIR%%/zorba/xqdoc/xhtml/lib/jquery.treeview.js
+%%PORTDOCS%%%%DOCSDIR%%/zorba/xqdoc/Makefile
+%%PORTDOCS%%%%DOCSDIR%%/zorba/xqdoc/cmake_install.cmake
+%%PORTDOCS%%%%DOCSDIR%%/zorba/xqdoc/CTestTestfile.cmake
+%%PORTDOCS%%%%DOCSDIR%%/LICENSE.txt
+%%PORTDOCS%%%%DOCSDIR%%/README.txt
+%%PORTDOCS%%%%DOCSDIR%%/NOTICE.txt
+%%PORTDOCS%%%%DOCSDIR%%/AUTHORS.txt
+%%PORTDOCS%%%%DOCSDIR%%/cxx/examples/simple.cpp
+%%PORTDOCS%%%%DOCSDIR%%/cxx/examples/sax2.cpp
+%%PORTDOCS%%%%DOCSDIR%%/cxx/examples/errors.cpp
+%%PORTDOCS%%%%DOCSDIR%%/cxx/examples/context.cpp
+%%PORTDOCS%%%%DOCSDIR%%/cxx/examples/serialization.cpp
+%%PORTDOCS%%%%DOCSDIR%%/cxx/examples/chaining.cpp
+%%PORTDOCS%%%%DOCSDIR%%/cxx/examples/external_functions.cpp
+%%PORTDOCS%%%%DOCSDIR%%/cxx/examples/datamanager.cpp
+%%PORTDOCS%%%%DOCSDIR%%/cxx/examples/uri_resolvers.cpp
+%%PORTDOCS%%%%DOCSDIR%%/cxx/examples/execution_plans.cpp
+%%PORTDOCS%%%%DOCSDIR%%/cxx/examples/item_handler.cpp
+%%PORTDOCS%%%%DOCSDIR%%/cxx/examples/callback.cpp
+%%PORTDOCS%%%%DOCSDIR%%/cxx/examples/debugger.cpp
+%%PORTDOCS%%%%DOCSDIR%%/cxx/examples/examples.cpp
+%%PORTDOCS%%%%DOCSDIR%%/cxx/examples/Makefile
+%%PORTDOCS%%%%DOCSDIR%%/c/examples/csimple.c
+%%PORTDOCS%%%%DOCSDIR%%/c/examples/ccontext.c
+%%PORTDOCS%%%%DOCSDIR%%/c/examples/cerror.c
+%%PORTDOCS%%%%DOCSDIR%%/c/examples/cparsing.c
+%%PORTDOCS%%%%DOCSDIR%%/c/examples/cexternal_functions.c
+%%PORTDOCS%%%%DOCSDIR%%/c/examples/cserialization.c
+%%PORTDOCS%%%%DOCSDIR%%/c/examples/csequences.c
+%%PORTDOCS%%%%DOCSDIR%%/c/examples/cexamples.c
+%%PORTDOCS%%%%DOCSDIR%%/c/examples/cparsing.xml
+%%WITH_PHP%%%%PORTDOCS%%%%DOCSDIR%%/php/examples/simple.php
+%%WITH_PYTHON%%%%PORTDOCS%%%%DOCSDIR%%/python/examples/python_test.py
+%%WITH_RUBY%%%%PORTDOCS%%%%DOCSDIR%%/ruby/examples/ruby_test.rb
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/zorba/xqdoc/xhtml/lib
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/zorba/xqdoc/xhtml/images
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/zorba/xqdoc/xhtml/css
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/zorba/xqdoc/xhtml
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/zorba/xqdoc/templates
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/zorba/xqdoc/CMakeFiles/xqdoc.dir
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/zorba/xqdoc/CMakeFiles
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/zorba/xqdoc
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/zorba/html
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/zorba
+%%WITH_RUBY%%%%PORTDOCS%%@dirrm %%DOCSDIR%%/ruby/examples
+%%WITH_RUBY%%%%PORTDOCS%%@dirrm %%DOCSDIR%%/ruby
+%%WITH_PYTHON%%%%PORTDOCS%%@dirrm %%DOCSDIR%%/python/examples
+%%WITH_PYTHON%%%%PORTDOCS%%@dirrm %%DOCSDIR%%/python
+%%WITH_PHP%%%%PORTDOCS%%@dirrm %%DOCSDIR%%/php/examples
+%%WITH_PHP%%%%PORTDOCS%%@dirrm %%DOCSDIR%%/php
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/cxx/html
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/cxx/examples
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/cxx
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/c/html
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/c/examples
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/c
+%%PORTDOCS%%@dirrm %%DOCSDIR%%
+@dirrm include/zorba/zorba/util
+@dirrm include/zorba/zorba
+@dirrm include/zorba/simplestore/msdom
+@dirrm include/zorba/simplestore
+@dirrm include/zorba/modules/org/w3/www/2005
+@dirrm include/zorba/modules/org/w3/www
+@dirrm include/zorba/modules/org/w3
+@dirrm include/zorba/modules/org/expath/ns
+@dirrm include/zorba/modules/org/expath
+@dirrm include/zorba/modules/org
+@dirrm include/zorba/modules/com/zorba-xquery/www/modules/security
+@dirrm include/zorba/modules/com/zorba-xquery/www/modules/introspection
+@dirrm include/zorba/modules/com/zorba-xquery/www/modules/excel
+@dirrm include/zorba/modules/com/zorba-xquery/www/modules/email
+@dirrm include/zorba/modules/com/zorba-xquery/www/modules
+@dirrm include/zorba/modules/com/zorba-xquery/www
+@dirrm include/zorba/modules/com/zorba-xquery
+@dirrm include/zorba/modules/com
+@dirrm include/zorba/modules
+@dirrm include/zorba/