aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJun Kuriyama <kuriyama@FreeBSD.org>2010-01-28 04:53:50 +0000
committerJun Kuriyama <kuriyama@FreeBSD.org>2010-01-28 04:53:50 +0000
commit935c866afb7d805ed4d8c023cf28a1dee8c05f6b (patch)
tree669406cf84e1a7cbae93e65ea1ba66f693c71b1f
parentb93b277e621a46e9c3504de7d9692babe843ee32 (diff)
downloadports-935c866afb7d805ed4d8c023cf28a1dee8c05f6b.tar.gz
ports-935c866afb7d805ed4d8c023cf28a1dee8c05f6b.zip
Notes
-rw-r--r--devel/p5-Test-Kwalitee/Makefile4
-rw-r--r--devel/p5-Test-MockModule/Makefile5
-rw-r--r--devel/p5-Test-MockObject/Makefile4
-rw-r--r--devel/p5-Test-MockTime/Makefile8
-rw-r--r--devel/p5-Test-Object/Makefile5
-rw-r--r--devel/p5-Test-Portability-Files/Makefile5
-rw-r--r--devel/p5-Test-Portability-Files/pkg-plist2
-rw-r--r--devel/p5-Test-Reporter/Makefile5
-rw-r--r--devel/p5-Test-TAP-Model/Makefile4
-rw-r--r--devel/p5-Test-TempDir/Makefile3
-rw-r--r--devel/p5-Test-YAML-Meta/Makefile2
-rw-r--r--devel/p5-Thread-Queue/Makefile4
-rw-r--r--devel/p5-Tie-ShareLite/Makefile4
-rw-r--r--devel/p5-Tree-Simple-View/Makefile2
-rw-r--r--devel/p5-UUID-Tiny/Makefile6
-rw-r--r--devel/p5-Workflow/Makefile3
-rw-r--r--devel/p5-XML-Pastor/Makefile9
-rw-r--r--devel/p5-uni-perl/Makefile6
-rw-r--r--devel/perlconsole/Makefile4
-rw-r--r--devel/svk/Makefile4
-rw-r--r--dns/dnsmax-perl/Makefile3
21 files changed, 33 insertions, 59 deletions
diff --git a/devel/p5-Test-Kwalitee/Makefile b/devel/p5-Test-Kwalitee/Makefile
index 181f12e0b1eb..12e1d04780d3 100644
--- a/devel/p5-Test-Kwalitee/Makefile
+++ b/devel/p5-Test-Kwalitee/Makefile
@@ -7,7 +7,7 @@
PORTNAME= Test-Kwalitee
PORTVERSION= 1.01
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= devel perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
@@ -16,12 +16,10 @@ MAINTAINER= lippe@FreeBSD.org
COMMENT= Test the Kwalitee of a distribution before you release it
BUILD_DEPENDS+= ${SITE_PERL}/Module/CPANTS/Analyse.pm:${PORTSDIR}/devel/p5-Module-CPANTS-Analyse \
- ${SITE_PERL}/Test/Simple.pm:${PORTSDIR}/devel/p5-Test-Simple \
${SITE_PERL}/Test/Pod/Coverage.pm:${PORTSDIR}/devel/p5-Test-Pod-Coverage \
${SITE_PERL}/Test/Pod.pm:${PORTSDIR}/devel/p5-Test-Pod \
${SITE_PERL}/Module/Signature.pm:${PORTSDIR}/security/p5-Module-Signature
RUN_DEPENDS+= ${SITE_PERL}/Module/CPANTS/Analyse.pm:${PORTSDIR}/devel/p5-Module-CPANTS-Analyse \
- ${SITE_PERL}/Test/Simple.pm:${PORTSDIR}/devel/p5-Test-Simple \
${SITE_PERL}/Test/Pod/Coverage.pm:${PORTSDIR}/devel/p5-Test-Pod-Coverage \
${SITE_PERL}/Test/Pod.pm:${PORTSDIR}/devel/p5-Test-Pod \
${SITE_PERL}/Module/Signature.pm:${PORTSDIR}/security/p5-Module-Signature
diff --git a/devel/p5-Test-MockModule/Makefile b/devel/p5-Test-MockModule/Makefile
index 3603539dfefa..d7824e20bec9 100644
--- a/devel/p5-Test-MockModule/Makefile
+++ b/devel/p5-Test-MockModule/Makefile
@@ -7,6 +7,7 @@
PORTNAME= Test-MockModule
PORTVERSION= 0.05
+PORTREVISION= 1
CATEGORIES= devel perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
@@ -14,10 +15,6 @@ PKGNAMEPREFIX= p5-
MAINTAINER= lth@FreeBSD.org
COMMENT= Override subroutines in a module for unit testing
-BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Scalar/Util.pm:${PORTSDIR}/lang/p5-Scalar-List-Utils \
- ${SITE_PERL}/Test/More.pm:${PORTSDIR}/devel/p5-Test-Simple
-RUN_DEPENDS= ${BUILD_DEPENDS}
-
PERL_CONFIGURE= yes
MAN3= Test::MockModule.3
diff --git a/devel/p5-Test-MockObject/Makefile b/devel/p5-Test-MockObject/Makefile
index dfcc6a36a400..ecf039b63c76 100644
--- a/devel/p5-Test-MockObject/Makefile
+++ b/devel/p5-Test-MockObject/Makefile
@@ -7,6 +7,7 @@
PORTNAME= Test-MockObject
PORTVERSION= 1.09
+PORTREVISION= 1
CATEGORIES= devel perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
@@ -14,8 +15,7 @@ PKGNAMEPREFIX= p5-
MAINTAINER= kuriyama@FreeBSD.org
COMMENT= Tests remote URLs or local web files
-RUN_DEPENDS= p5-Scalar-List-Utils>=0:${PORTSDIR}/lang/p5-Scalar-List-Utils \
- p5-UNIVERSAL-can>=1.11:${PORTSDIR}/devel/p5-UNIVERSAL-can \
+RUN_DEPENDS= p5-UNIVERSAL-can>=1.11:${PORTSDIR}/devel/p5-UNIVERSAL-can \
p5-UNIVERSAL-isa>=0.06:${PORTSDIR}/devel/p5-UNIVERSAL-isa
PERL_CONFIGURE= yes
diff --git a/devel/p5-Test-MockTime/Makefile b/devel/p5-Test-MockTime/Makefile
index 6cf8d29c3bbd..93775e7be715 100644
--- a/devel/p5-Test-MockTime/Makefile
+++ b/devel/p5-Test-MockTime/Makefile
@@ -7,6 +7,7 @@
PORTNAME= Test-MockTime
PORTVERSION= 0.12
+PORTREVISION= 1
CATEGORIES= devel perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
@@ -14,11 +15,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= timur@FreeBSD.org
COMMENT= Replaces actual time with simulated time
-BUILD_DEPENDS= ${SITE_PERL}/Time/Local.pm:${PORTSDIR}/devel/p5-Time-Local \
- ${SITE_PERL}/${PERL_ARCH}/Time/Piece.pm:${PORTSDIR}/devel/p5-Time-Piece \
- ${SITE_PERL}/Test/More.pm:${PORTSDIR}/devel/p5-Test-Simple
-RUN_DEPENDS= ${SITE_PERL}/Time/Local.pm:${PORTSDIR}/devel/p5-Time-Local \
- ${SITE_PERL}/${PERL_ARCH}/Time/Piece.pm:${PORTSDIR}/devel/p5-Time-Piece
+BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Time/Piece.pm:${PORTSDIR}/devel/p5-Time-Piece
+RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Time/Piece.pm:${PORTSDIR}/devel/p5-Time-Piece
PERL_CONFIGURE= yes
diff --git a/devel/p5-Test-Object/Makefile b/devel/p5-Test-Object/Makefile
index b39b98565f35..b6457fc5ed3b 100644
--- a/devel/p5-Test-Object/Makefile
+++ b/devel/p5-Test-Object/Makefile
@@ -7,6 +7,7 @@
PORTNAME= Test-Object
PORTVERSION= 0.07
+PORTREVISION= 1
CATEGORIES= devel perl5
MASTER_SITES= CPAN
MASTER_SITE_SUBDIR= ../by-authors/id/A/AD/ADAMK
@@ -15,10 +16,6 @@ PKGNAMEPREFIX= p5-
MAINTAINER= lth@FreeBSD.org
COMMENT= Thoroughly testing objects via registered handlers
-RUN_DEPENDS= p5-Scalar-List-Utils>=1.16:${PORTSDIR}/lang/p5-Scalar-List-Utils \
- p5-Test-Simple>=0.63:${PORTSDIR}/devel/p5-Test-Simple
-BUILD_DEPENDS= ${RUN_DEPENDS}
-
PERL_CONFIGURE= yes
MAN3= Test::Object.3
diff --git a/devel/p5-Test-Portability-Files/Makefile b/devel/p5-Test-Portability-Files/Makefile
index a84b6a3108a0..c25b91e7f531 100644
--- a/devel/p5-Test-Portability-Files/Makefile
+++ b/devel/p5-Test-Portability-Files/Makefile
@@ -7,6 +7,7 @@
PORTNAME= Test-Portability-Files
PORTVERSION= 0.05
+PORTREVISION= 1
CATEGORIES= devel perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
@@ -14,10 +15,6 @@ PKGNAMEPREFIX= p5-
MAINTAINER= lippe@FreeBSD.org
COMMENT= Test::Portability::Files Check file names portability
-BUILD_DEPENDS+= ${SITE_PERL}/Test/Builder.pm:${PORTSDIR}/devel/p5-Test-Simple \
- ${SITE_PERL}/${PERL_ARCH}/File/Spec.pm:${PORTSDIR}/devel/p5-PathTools
-RUN_DEPENDS+= ${BUILD_DEPENDS}
-
PERL_CONFIGURE= yes
MAN3= Test::Portability::Files.3
diff --git a/devel/p5-Test-Portability-Files/pkg-plist b/devel/p5-Test-Portability-Files/pkg-plist
index a4dd19c84a7a..1b262d3d96a3 100644
--- a/devel/p5-Test-Portability-Files/pkg-plist
+++ b/devel/p5-Test-Portability-Files/pkg-plist
@@ -2,4 +2,6 @@
%%SITE_PERL%%/Test/Portability/Files.pm
@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Test/Portability/Files
@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Test/Portability
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Test
@dirrmtry %%SITE_PERL%%/Test/Portability
+@dirrmtry %%SITE_PERL%%/Test
diff --git a/devel/p5-Test-Reporter/Makefile b/devel/p5-Test-Reporter/Makefile
index eab6e29bc240..c56cd8c6788e 100644
--- a/devel/p5-Test-Reporter/Makefile
+++ b/devel/p5-Test-Reporter/Makefile
@@ -7,6 +7,7 @@
PORTNAME= Test-Reporter
PORTVERSION= 1.52.03
+PORTREVISION= 1
CATEGORIES= devel perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
@@ -15,9 +16,7 @@ DISTNAME= ${PORTNAME}-${PORTVERSION:R}${PORTVERSION:E}
MAINTAINER= lth@FreeBSD.org
COMMENT= Sends test results to cpan-testers@perl.org
-RUN_DEPENDS= p5-PathTools>0:${PORTSDIR}/devel/p5-PathTools \
- p5-File-Temp>0:${PORTSDIR}/devel/p5-File-Temp \
- p5-Net>0:${PORTSDIR}/net/p5-Net
+RUN_DEPENDS= p5-Net>0:${PORTSDIR}/net/p5-Net
BUILD_DEPENDS= ${RUN_DEPENDS}
PERL_CONFIGURE= yes
diff --git a/devel/p5-Test-TAP-Model/Makefile b/devel/p5-Test-TAP-Model/Makefile
index 756e1c100dce..e8ea01341c03 100644
--- a/devel/p5-Test-TAP-Model/Makefile
+++ b/devel/p5-Test-TAP-Model/Makefile
@@ -7,6 +7,7 @@
PORTNAME= Test-TAP-Model
PORTVERSION= 0.10
+PORTREVISION= 1
CATEGORIES= devel perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
@@ -14,8 +15,7 @@ PKGNAMEPREFIX= p5-
MAINTAINER= ports@FreeBSD.org
COMMENT= Accessible result collector for Test::Harness::Straps runs
-BUILD_DEPENDS= ${SITE_PERL}/Test/More.pm:${PORTSDIR}/devel/p5-Test-Simple \
- ${SITE_PERL}/Method/Alias.pm:${PORTSDIR}/devel/p5-Method-Alias
+BUILD_DEPENDS= ${SITE_PERL}/Method/Alias.pm:${PORTSDIR}/devel/p5-Method-Alias
RUN_DEPENDS= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
diff --git a/devel/p5-Test-TempDir/Makefile b/devel/p5-Test-TempDir/Makefile
index 35074a571e02..a07a71fd8725 100644
--- a/devel/p5-Test-TempDir/Makefile
+++ b/devel/p5-Test-TempDir/Makefile
@@ -7,7 +7,7 @@
PORTNAME= Test-TempDir
PORTVERSION= 0.05
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= devel perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
@@ -16,7 +16,6 @@ MAINTAINER= perl@FreeBSD.org
COMMENT= Temporary files support for testing
RUN_DEPENDS= p5-Test-use-ok>=0:${PORTSDIR}/devel/p5-Test-use-ok \
- p5-File-Path>=2.04:${PORTSDIR}/devel/p5-File-Path \
p5-File-NFSLock>=0:${PORTSDIR}/devel/p5-File-NFSLock \
p5-Moose>=0.87:${PORTSDIR}/devel/p5-Moose \
p5-MooseX-Types-Path-Class>=0:${PORTSDIR}/devel/p5-MooseX-Types-Path-Class \
diff --git a/devel/p5-Test-YAML-Meta/Makefile b/devel/p5-Test-YAML-Meta/Makefile
index 3a94e603069c..2b5a64858fd2 100644
--- a/devel/p5-Test-YAML-Meta/Makefile
+++ b/devel/p5-Test-YAML-Meta/Makefile
@@ -7,6 +7,7 @@
PORTNAME= Test-YAML-Meta
PORTVERSION= 0.15
+PORTREVISION= 1
CATEGORIES= devel perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
@@ -15,7 +16,6 @@ MAINTAINER= lippe@FreeBSD.org
COMMENT= Validation of the META.yml file in a distribution
BUILD_DEPENDS+= ${SITE_PERL}/Test/YAML/Valid.pm:${PORTSDIR}/devel/p5-Test-YAML-Valid \
- ${SITE_PERL}/Test/More.pm:${PORTSDIR}/devel/p5-Test-Simple \
${SITE_PERL}/Test/Pod.pm:${PORTSDIR}/devel/p5-Test-Pod \
${SITE_PERL}/Test/Pod/Coverage.pm:${PORTSDIR}/devel/p5-Test-Pod-Coverage
RUN_DEPENDS+= ${BUILD_DEPENDS}
diff --git a/devel/p5-Thread-Queue/Makefile b/devel/p5-Thread-Queue/Makefile
index 8f44e19fadda..c1da036ffedd 100644
--- a/devel/p5-Thread-Queue/Makefile
+++ b/devel/p5-Thread-Queue/Makefile
@@ -7,6 +7,7 @@
PORTNAME= Thread-Queue
PORTVERSION= 2.11
+PORTREVISION= 1
CATEGORIES= devel perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
@@ -14,8 +15,7 @@ PKGNAMEPREFIX= p5-
MAINTAINER= cm@therek.net
COMMENT= Perl5 thread-safe queues
-BUILD_DEPENDS= p5-Scalar-List-Utils>=1.10:${PORTSDIR}/lang/p5-Scalar-List-Utils \
- p5-threads-shared>=1.26:${PORTSDIR}/devel/p5-threads-shared
+BUILD_DEPENDS= p5-threads-shared>=1.26:${PORTSDIR}/devel/p5-threads-shared
RUN_DEPENDS= ${BUILD_DEPENDS}
PERL_CONFIGURE= YES
diff --git a/devel/p5-Tie-ShareLite/Makefile b/devel/p5-Tie-ShareLite/Makefile
index a9b499545ff5..64bcf9f5c58c 100644
--- a/devel/p5-Tie-ShareLite/Makefile
+++ b/devel/p5-Tie-ShareLite/Makefile
@@ -7,6 +7,7 @@
PORTNAME= Tie-ShareLite
PORTVERSION= 0.03
+PORTREVISION= 1
CATEGORIES= devel perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
@@ -14,8 +15,7 @@ PKGNAMEPREFIX= p5-
MAINTAINER= jnlin@csie.nctu.edu.tw
COMMENT= Tied hash interface to IPC::ShareLite
-RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Storable.pm:${PORTSDIR}/devel/p5-Storable \
- ${SITE_PERL}/${PERL_ARCH}/IPC/ShareLite.pm:${PORTSDIR}/devel/p5-IPC-ShareLite
+RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/IPC/ShareLite.pm:${PORTSDIR}/devel/p5-IPC-ShareLite
PERL_CONFIGURE= yes
diff --git a/devel/p5-Tree-Simple-View/Makefile b/devel/p5-Tree-Simple-View/Makefile
index 1a6dc5128d0b..6d85e03c2f96 100644
--- a/devel/p5-Tree-Simple-View/Makefile
+++ b/devel/p5-Tree-Simple-View/Makefile
@@ -7,6 +7,7 @@
PORTNAME= Tree-Simple-View
PORTVERSION= 0.17
+PORTREVISION= 1
CATEGORIES= devel perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
@@ -16,7 +17,6 @@ COMMENT= A set of classes for viewing Tree::Simple hierarchies
BUILD_DEPENDS= ${SITE_PERL}/Tree/Simple.pm:${PORTSDIR}/devel/p5-Tree-Simple \
${SITE_PERL}/Class/Throwable.pm:${PORTSDIR}/devel/p5-Class-Throwable \
- ${SITE_PERL}/${PERL_ARCH}/Scalar/Util.pm:${PORTSDIR}/lang/p5-Scalar-List-Utils \
${SITE_PERL}/Test/Exception.pm:${PORTSDIR}/devel/p5-Test-Exception \
${SITE_PERL}/Test/LongString.pm:${PORTSDIR}/devel/p5-Test-LongString
RUN_DEPENDS= ${BUILD_DEPENDS}
diff --git a/devel/p5-UUID-Tiny/Makefile b/devel/p5-UUID-Tiny/Makefile
index 2e1c32b54f04..823a4064cc61 100644
--- a/devel/p5-UUID-Tiny/Makefile
+++ b/devel/p5-UUID-Tiny/Makefile
@@ -7,6 +7,7 @@
PORTNAME= UUID-Tiny
PORTVERSION= 1.02
+PORTREVISION= 1
CATEGORIES= devel perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
@@ -14,10 +15,7 @@ PKGNAMEPREFIX= p5-
MAINTAINER= cjk32@cam.ac.uk
COMMENT= Pure Perl UUID Support With Functional Interface
-BUILD_DEPENDS= p5-Digest-MD5>=0:${PORTSDIR}/security/p5-Digest-MD5 \
- p5-Digest-SHA1>=0:${PORTSDIR}/security/p5-Digest-SHA1 \
- p5-MIME-Base64>=0:${PORTSDIR}/converters/p5-MIME-Base64 \
- p5-Time-HiRes>=0:${PORTSDIR}/devel/p5-Time-HiRes
+BUILD_DEPENDS= p5-Digest-SHA1>=0:${PORTSDIR}/security/p5-Digest-SHA1
RUN_DEPENDS= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
diff --git a/devel/p5-Workflow/Makefile b/devel/p5-Workflow/Makefile
index d20567e88a6c..9744e613739c 100644
--- a/devel/p5-Workflow/Makefile
+++ b/devel/p5-Workflow/Makefile
@@ -7,7 +7,7 @@
PORTNAME= Workflow
PORTVERSION= 1.32
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= devel perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
@@ -27,7 +27,6 @@ BUILD_DEPENDS= \
${SITE_PERL}/Log/Dispatch.pm:${PORTSDIR}/devel/p5-Log-Dispatch \
${SITE_PERL}/Log/Log4perl.pm:${PORTSDIR}/devel/p5-Log-Log4perl \
${SITE_PERL}/${PERL_ARCH}/Data/UUID.pm:${PORTSDIR}/devel/p5-Data-UUID \
- ${SITE_PERL}/${PERL_ARCH}/Data/Dumper.pm:${PORTSDIR}/devel/p5-Data-Dumper \
${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI \
${SITE_PERL}/Test/Exception.pm:${PORTSDIR}/devel/p5-Test-Exception \
${SITE_PERL}/File/Slurp.pm:${PORTSDIR}/devel/p5-File-Slurp
diff --git a/devel/p5-XML-Pastor/Makefile b/devel/p5-XML-Pastor/Makefile
index 7df53172b502..218b0a396498 100644
--- a/devel/p5-XML-Pastor/Makefile
+++ b/devel/p5-XML-Pastor/Makefile
@@ -7,6 +7,7 @@
PORTNAME= XML-Pastor
PORTVERSION= 1.0.3
+PORTREVISION= 1
CATEGORIES= devel perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
@@ -16,17 +17,9 @@ COMMENT= Generate Perl classes with XML bindings from a W3C XSD schema
BUILD_DEPENDS= p5-Class-Accessor>=0:${PORTSDIR}/devel/p5-Class-Accessor \
p5-Class-Data-Inheritable>=0:${PORTSDIR}/devel/p5-Class-Data-Inheritable \
- p5-PathTools>=0:${PORTSDIR}/devel/p5-PathTools \
- p5-Data-Dumper>=0:${PORTSDIR}/devel/p5-Data-Dumper \
p5-Data-HashArray>=0:${PORTSDIR}/devel/p5-Data-HashArray \
p5-File-chdir>=0:${PORTSDIR}/devel/p5-File-chdir \
- p5-File-Path>=0:${PORTSDIR}/devel/p5-File-Path \
- p5-Getopt-Long>=0:${PORTSDIR}/devel/p5-Getopt-Long \
- p5-IO>=0:${PORTSDIR}/devel/p5-IO \
p5-libwww>=0:${PORTSDIR}/www/p5-libwww \
- p5-MIME-Base64>=0:${PORTSDIR}/converters/p5-MIME-Base64 \
- p5-Pod-Parser>=0:${PORTSDIR}/textproc/p5-Pod-Parser \
- p5-Scalar-List-Utils>=0:${PORTSDIR}/lang/p5-Scalar-List-Utils \
p5-URI>=0:${PORTSDIR}/net/p5-URI \
p5-XML-LibXML>=0:${PORTSDIR}/textproc/p5-XML-LibXML
RUN_DEPENDS= ${BUILD_DEPENDS}
diff --git a/devel/p5-uni-perl/Makefile b/devel/p5-uni-perl/Makefile
index 7e75422fdfb4..4d17ca5e468b 100644
--- a/devel/p5-uni-perl/Makefile
+++ b/devel/p5-uni-perl/Makefile
@@ -7,6 +7,7 @@
PORTNAME= uni-perl
PORTVERSION= 0.03
+PORTREVISION= 1
CATEGORIES= devel perl5
MASTER_SITES= CPAN
MASTER_SITE_SUBDIR= ../../authors/id/M/MO/MONS
@@ -15,9 +16,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= mons@cpan.org
COMMENT= Modern perl with unicode
-RUN_DEPENDS= p5-Data-Dumper>=2:${PORTSDIR}/devel/p5-Data-Dumper \
- p5-Encode>=2.37:${PORTSDIR}/converters/p5-Encode \
- p5-lib-abs>=0.90:${PORTSDIR}/devel/p5-lib-abs
+RUN_DEPENDS= p5-Encode>=2.37:${PORTSDIR}/converters/p5-Encode \
+ p5-lib-abs>=0.90:${PORTSDIR}/devel/p5-lib-abs
BUILD_DEPENDS= ${RUN_DEPENDS}
PERL_CONFIGURE= 5.10.0+
diff --git a/devel/perlconsole/Makefile b/devel/perlconsole/Makefile
index a39679c60e2f..f52f24dc1a89 100644
--- a/devel/perlconsole/Makefile
+++ b/devel/perlconsole/Makefile
@@ -7,6 +7,7 @@
PORTNAME= perlconsole
PORTVERSION= 0.4
+PORTREVISION= 1
CATEGORIES= devel
MASTER_SITES= CPAN
MASTER_SITE_SUBDIR= ../../authors/id/S/SU/SUKRIA
@@ -14,8 +15,7 @@ MASTER_SITE_SUBDIR= ../../authors/id/S/SU/SUKRIA
MAINTAINER= jadawin@FreeBSD.org
COMMENT= A light program that lets you evaluate Perl code interactively
-RUN_DEPENDS= ${SITE_PERL}/Getopt/Long.pm:${PORTSDIR}/devel/p5-Getopt-Long \
- ${SITE_PERL}/${PERL_ARCH}/Term/ReadLine/Gnu.pm:${PORTSDIR}/devel/p5-ReadLine-Gnu \
+RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Term/ReadLine/Gnu.pm:${PORTSDIR}/devel/p5-ReadLine-Gnu \
${SITE_PERL}/Module/Refresh.pm:${PORTSDIR}/devel/p5-Module-Refresh \
${SITE_PERL}/Lexical/Persistence.pm:${PORTSDIR}/devel/p5-Lexical-Persistence \
${SITE_PERL}/B/Keywords.pm:${PORTSDIR}/devel/p5-B-Keywords
diff --git a/devel/svk/Makefile b/devel/svk/Makefile
index d9a39c8fac2f..faa9bc68f931 100644
--- a/devel/svk/Makefile
+++ b/devel/svk/Makefile
@@ -7,7 +7,7 @@
PORTNAME= svk
PORTVERSION= 2.2.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= devel perl5
MASTER_SITES= CPAN
MASTER_SITE_SUBDIR= ../../authors/id/C/CL/CLKAO
@@ -36,12 +36,10 @@ BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/List/MoreUtils.pm:${PORTSDIR}/lang/p5-L
${SITE_PERL}/URI.pm:${PORTSDIR}/net/p5-URI \
p5-Algorithm-Diff>=1.1901:${PORTSDIR}/devel/p5-Algorithm-Diff \
p5-Class-Autouse>=1.15:${PORTSDIR}/devel/p5-Class-Autouse \
- p5-File-Temp>=0.17:${PORTSDIR}/devel/p5-File-Temp \
p5-Data-Hierarchy>=0.30:${PORTSDIR}/devel/p5-Data-Hierarchy \
p5-Locale-Maketext-Lexicon>=0.62:${PORTSDIR}/devel/p5-Locale-Maketext-Lexicon \
p5-Locale-Maketext-Simple>=0.16:${PORTSDIR}/devel/p5-Locale-Maketext-Simple \
p5-Path-Class>=0.16:${PORTSDIR}/devel/p5-Path-Class \
- p5-PathTools>=3.19:${PORTSDIR}/devel/p5-PathTools \
p5-PerlIO-eol>=0.13:${PORTSDIR}/devel/p5-PerlIO-eol \
p5-PerlIO-gzip>=0.18:${PORTSDIR}/archivers/p5-PerlIO-gzip \
p5-PerlIO-via-Bzip2>=0.02:${PORTSDIR}/archivers/p5-PerlIO-via-Bzip2 \
diff --git a/dns/dnsmax-perl/Makefile b/dns/dnsmax-perl/Makefile
index 1494715c32bd..091557a68285 100644
--- a/dns/dnsmax-perl/Makefile
+++ b/dns/dnsmax-perl/Makefile
@@ -14,8 +14,7 @@ DISTNAME= ${PORTNAME:L}-${PORTVERSION:S/.p/-pre/:S/.b/-beta/}
MAINTAINER= dan@algenta.com
COMMENT= DNSMax-perl is a perl DNS update client for the REST DNSMax protocol
-BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Digest/MD5.pm:${PORTSDIR}/security/p5-Digest-MD5 \
- ${SITE_PERL}/${PERL_ARCH}/Crypt/SSLeay.pm:${PORTSDIR}/security/p5-Crypt-SSLeay \
+BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Crypt/SSLeay.pm:${PORTSDIR}/security/p5-Crypt-SSLeay \
${SITE_PERL}/XML/Simple.pm:${PORTSDIR}/textproc/p5-XML-Simple \
${SITE_PERL}/HTTP/Response.pm:${PORTSDIR}/www/p5-libwww