aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2003-12-13 15:32:41 +0000
committerPav Lucistnik <pav@FreeBSD.org>2003-12-13 15:32:41 +0000
commit96a980ce1710c727782d5ef87eb0ce27f26bb9a0 (patch)
treefdfd15c13c6cf8e7de06a3f411afdd99b16d8a0d
parent5d46b7c2db4f77df8d65e42a21121a5060634f37 (diff)
downloadports-96a980ce1710c727782d5ef87eb0ce27f26bb9a0.tar.gz
ports-96a980ce1710c727782d5ef87eb0ce27f26bb9a0.zip
Notes
-rw-r--r--emulators/bfe/Makefile40
-rw-r--r--emulators/bfe/distinfo2
-rw-r--r--emulators/bfe/files/patch-configure.sh49
-rw-r--r--emulators/bfe/pkg-plist6
4 files changed, 29 insertions, 68 deletions
diff --git a/emulators/bfe/Makefile b/emulators/bfe/Makefile
index 28c59b68ecb8..34c0e8fe01ed 100644
--- a/emulators/bfe/Makefile
+++ b/emulators/bfe/Makefile
@@ -6,36 +6,46 @@
#
PORTNAME= bfe2
-PORTVERSION= 20030124
+PORTVERSION= 20030723
CATEGORIES= emulators
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= bfe
-DISTNAME= bfe2-24jan2003
+DISTNAME= ${PORTNAME}-23jul2003
MAINTAINER= ports@FreeBSD.org
COMMENT= X11 GUI for the bochs debugger (revision 2)
RUN_DEPENDS= bochs:${PORTSDIR}/emulators/bochs
-USE_REINPLACE= yes
+WRKSRC= ${WRKDIR}/${PORTNAME}
+
USE_X_PREFIX= yes
-USE_GNOME= gtk12
+USE_REINPLACE= yes
+HAS_CONFIGURE= yes
CONFIGURE_SCRIPT= configure.sh
-WRKSRC= ${WRKDIR}/bfe2
-post-patch:
- @${REINPLACE_CMD} -e 's|%%PREFIX%%|${PREFIX}|' \
- -e 's|%%CC%%|${CC}|' -e 's|%%CFLAGS%%|${CFLAGS}|' \
- -e 's|gtk-config|${GTK_CONFIG}|' \
- ${WRKSRC}/${CONFIGURE_SCRIPT}
+.if defined(WITH_GTK2)
+USE_GNOME+= gtk20
+CONFIGURE_ARGS+= --gtk 2.0
+PKGNAMESUFFIX= -gtk2
+.else
+USE_GNOME+= gtk12
+CONFIGURE_ARGS+= --gtk 1.2
+.endif
-do-configure:
- @cd ${WRKSRC} && ${SH} ${CONFIGURE_SCRIPT}
+post-patch:
+ @${REINPLACE_CMD} -e \
+ 's|%%CFLAGS%%|"${CFLAGS}"|g ; \
+ s|%%CC%%|"${CC}"|g ; \
+ s|%%PREFIX%%|"${PREFIX}"|g ; \
+ s|gtk-config --libs|pkg-config --libs gtk+|g ; \
+ s|gtk-config --cflags|pkg-config --cflags gtk+|g' \
+ ${WRKSRC}/${CONFIGURE_SCRIPT}
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/bfe2 ${PREFIX}/bin
- -@${MKDIR} ${PREFIX}/share/bfe
- ${INSTALL_DATA} ${WRKSRC}/README.bferc ${PREFIX}/share/bfe/bferc.sample
- ${INSTALL_DATA} ${WRKSRC}/README.bferc ${PREFIX}/share/bfe
+ @${MKDIR} ${DATADIR}
+ ${INSTALL_DATA} ${WRKSRC}/README.bferc ${DATADIR}/bferc.sample
+ ${INSTALL_DATA} ${WRKSRC}/README.bferc ${DATADIR}
.include <bsd.port.mk>
diff --git a/emulators/bfe/distinfo b/emulators/bfe/distinfo
index 4fb9355bf09a..793fec15afb5 100644
--- a/emulators/bfe/distinfo
+++ b/emulators/bfe/distinfo
@@ -1 +1 @@
-MD5 (bfe2-24jan2003.tar.gz) = 83018142b4d30ba13def376f4996d845
+MD5 (bfe2-23jul2003.tar.gz) = 668837b5ce1a03f6a589a7331daadf17
diff --git a/emulators/bfe/files/patch-configure.sh b/emulators/bfe/files/patch-configure.sh
deleted file mode 100644
index 35fb2d731677..000000000000
--- a/emulators/bfe/files/patch-configure.sh
+++ /dev/null
@@ -1,49 +0,0 @@
---- configure.sh.orig Sat Jan 25 07:08:39 2003
-+++ configure.sh Thu Feb 6 02:11:55 2003
-@@ -1,26 +1,18 @@
--#!/bin/bash
--
--# csh and tcsh do not like this file
--# ash produces incorrect quoting
--
--if [ "`/bin/ls -la /bin/sh |grep '\-> ash'`" != "" ]; then
-- echo -e "\nash shell is not supported\n"
-- exit
--fi
-+#!/bin/sh
-
- ##############################################################################
-
--CC="cc"
--LD="cc"
--CFLAGS="-O2 -Wall"
-+CC=%%CC%%
-+LD=%%CC%%
-+CFLAGS=%%CFLAGS%%
- LFLAGS=""
-
- PROG="bfe2"
- OWNER="root"
--GROUP="root"
-+GROUP="whell"
-
- # install directories
--PREFIX="/usr/local"
-+PREFIX=%%PREFIX%%
- BIN="bin"
- SYSCONF="etc"
-
-@@ -106,13 +98,6 @@
- INCS="\`pkg-config --cflags gtk+-2.0\`"
- else
- echo -e "\tInvalid GTK version [$GTK]"
-- exit
--fi
--
--if [ "$BOCHS" == "2.0" ]; then
-- BOCHSPATH="$BOCHSPATH -q"
--else
-- echo -e "\tInvalid Bochs version [$BOCHS]"
- exit
- fi
-
diff --git a/emulators/bfe/pkg-plist b/emulators/bfe/pkg-plist
index 6c2f96504570..813bf626d239 100644
--- a/emulators/bfe/pkg-plist
+++ b/emulators/bfe/pkg-plist
@@ -1,4 +1,4 @@
bin/bfe2
-share/bfe/bferc.sample
-share/bfe/README.bferc
-@dirrm share/bfe
+%%DATADIR%%/bferc.sample
+%%DATADIR%%/README.bferc
+@dirrm %%DATADIR%%