aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGabor Pali <pgj@FreeBSD.org>2012-12-04 18:50:35 +0000
committerGabor Pali <pgj@FreeBSD.org>2012-12-04 18:50:35 +0000
commit994b964081dba75b26e4fd9777e1c10fd43da2f6 (patch)
tree4fa6357ed7ed831b26516abc4cecfd7c01539531
parentd0251b8742160b2c8aaff72b82bc0b8c5bd38920 (diff)
downloadports-994b964081dba75b26e4fd9777e1c10fd43da2f6.tar.gz
ports-994b964081dba75b26e4fd9777e1c10fd43da2f6.zip
Notes
-rw-r--r--devel/bisoncpp/Makefile6
-rw-r--r--devel/bisoncpp/pkg-descr2
-rw-r--r--devel/icmake/Makefile4
-rw-r--r--devel/icmake/pkg-descr2
-rw-r--r--devel/libbobcat/Makefile2
5 files changed, 10 insertions, 6 deletions
diff --git a/devel/bisoncpp/Makefile b/devel/bisoncpp/Makefile
index 2dca0ab1d47e..8d0205f62dc5 100644
--- a/devel/bisoncpp/Makefile
+++ b/devel/bisoncpp/Makefile
@@ -30,6 +30,8 @@ WRKSRC= ${WRKDIR}/bisonc++-${PORTVERSION}
USE_GCC= 4.6
+.include <bsd.port.options.mk>
+
post-patch:
@${REINPLACE_CMD} 's|"/usr"|"${PREFIX}"| ; \
s|"/share/bisonc++"|"/share/${PORTNAME}-${PORTVERSION}"| ; \
@@ -61,7 +63,7 @@ do-build:
.if !defined(NO_INSTALL_MANPAGES)
@cd ${WRKSRC} && ./build man
.endif
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
@cd ${WRKSRC} && ./build manual
.endif
@@ -70,7 +72,7 @@ do-install:
.if !defined(NO_INSTALL_MANPAGES)
cd ${WRKSRC} && ./build install man
.endif
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
cd ${WRKSRC} && ./build install manual
.endif
diff --git a/devel/bisoncpp/pkg-descr b/devel/bisoncpp/pkg-descr
index 9b37dbc0d080..3cbf857e3fc9 100644
--- a/devel/bisoncpp/pkg-descr
+++ b/devel/bisoncpp/pkg-descr
@@ -3,4 +3,4 @@ cleaner setup than the code generated by Alain Coetmeur's bison++.
Furthermore, since bisonc++ more closely follows current-day ideas about
C++ programming its code is easier to read.
-WWW: http://bisoncpp.sourceforge.net/
+WWW: http://bisoncpp.sourceforge.net/
diff --git a/devel/icmake/Makefile b/devel/icmake/Makefile
index 5042100c6bb3..71b9b28f387c 100644
--- a/devel/icmake/Makefile
+++ b/devel/icmake/Makefile
@@ -29,6 +29,8 @@ WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
REINPLACE_ARGS= -I ""
+.include <bsd.port.options.mk>
+
post-patch:
@${REINPLACE_CMD} -e 's|#!/bin/bash|#!${LOCALBASE}/bin/bash|' \
${WRKSRC}/icm_bootstrap \
@@ -103,7 +105,7 @@ do-install:
.if !defined(NO_INSTALL_MANPAGES)
cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ./icm_install man
.endif
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ./icm_install doc
cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ./icm_install docdoc
.endif
diff --git a/devel/icmake/pkg-descr b/devel/icmake/pkg-descr
index b3788d768c66..8805ba367bb6 100644
--- a/devel/icmake/pkg-descr
+++ b/devel/icmake/pkg-descr
@@ -4,4 +4,4 @@ automatic program maintenance and system administrative tasks on MS-DOS
platforms. Later on, Icmake was eventually ported to Unix platforms
(SCO and Linux). By now Icmake also runs on a HP-Unix platform.
-WWW: http://icmake.sourceforge.net/
+WWW: http://icmake.sourceforge.net/
diff --git a/devel/libbobcat/Makefile b/devel/libbobcat/Makefile
index a046eeb04a3b..512132bab871 100644
--- a/devel/libbobcat/Makefile
+++ b/devel/libbobcat/Makefile
@@ -75,7 +75,7 @@ post-patch:
s|-lX11|-lX11 -L${LOCALBASE}/lib| ; \
s|-lmilter|-lmilter -lpthread|' \
${WRKSRC}/icmake/special
-.if defined(NOPORTDOCS)
+.if empty(PORT_OPTIONS:MDOCS)
@${REINPLACE_CMD} -e 's|#define DOCOTHER||' \
${WRKSRC}/INSTALL.im
.endif