aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPalle Girgensohn <girgen@FreeBSD.org>2014-03-21 08:15:26 +0000
committerPalle Girgensohn <girgen@FreeBSD.org>2014-03-21 08:15:26 +0000
commit9b588a49ffbc9a4e0bf5324b301c1f1295bb3cc0 (patch)
tree5784c90fb8b046a61ebdfd58acb06301370705a7
parent1992bca13eda4f1aa01cec4e29c9276421f3109d (diff)
downloadports-9b588a49ffbc9a4e0bf5324b301c1f1295bb3cc0.tar.gz
ports-9b588a49ffbc9a4e0bf5324b301c1f1295bb3cc0.zip
Notes
-rw-r--r--databases/postgresql84-contrib/Makefile2
-rw-r--r--databases/postgresql84-server/files/patch-contrib-uuid10
-rw-r--r--databases/postgresql90-contrib/Makefile2
-rw-r--r--databases/postgresql90-server/files/patch-contrib-uuid10
-rw-r--r--databases/postgresql91-contrib/Makefile2
-rw-r--r--databases/postgresql91-server/files/patch-contrib-uuid10
-rw-r--r--databases/postgresql92-contrib/Makefile2
-rw-r--r--databases/postgresql92-server/files/patch-contrib-uuid10
-rw-r--r--databases/postgresql93-contrib/Makefile2
-rw-r--r--databases/postgresql93-server/files/patch-contrib-uuid10
10 files changed, 55 insertions, 5 deletions
diff --git a/databases/postgresql84-contrib/Makefile b/databases/postgresql84-contrib/Makefile
index e5afacf001ac..4375c8544c03 100644
--- a/databases/postgresql84-contrib/Makefile
+++ b/databases/postgresql84-contrib/Makefile
@@ -23,7 +23,7 @@ INSTALL_DIRS= contrib
SLAVE_ONLY= yes
COMPONENT= -contrib
-CONFIGURE_ARGS+=--with-libxslt --with-libxml --with-openssl --with-ossp-uuid
+CONFIGURE_ARGS+=--with-libxslt --with-libxml --with-openssl
post-install:
@- ${INSTALL_DATA} ${WRKSRC}/contrib/README ${STAGEDIR}${DOCSDIR}/contrib/README
diff --git a/databases/postgresql84-server/files/patch-contrib-uuid b/databases/postgresql84-server/files/patch-contrib-uuid
index a1b312cc2406..832076fd6dc7 100644
--- a/databases/postgresql84-server/files/patch-contrib-uuid
+++ b/databases/postgresql84-server/files/patch-contrib-uuid
@@ -369,3 +369,13 @@
+ return internal_uuid_create(5, (unsigned char *)ns,
+ VARDATA(name), VARSIZE(name) - VARHDRSZ);
}
+--- contrib/Makefile.orig 2014-03-21 09:09:12.000000000 +0100
++++ contrib/Makefile 2014-03-21 09:09:28.000000000 +0100
+@@ -39,6 +39,7 @@
+ tablefunc \
+ test_parser \
+ tsearch2 \
++ uuid-ossp \
+ vacuumlo
+
+ ifeq ($(with_openssl),yes)
diff --git a/databases/postgresql90-contrib/Makefile b/databases/postgresql90-contrib/Makefile
index 864079113fd0..107aef323f19 100644
--- a/databases/postgresql90-contrib/Makefile
+++ b/databases/postgresql90-contrib/Makefile
@@ -23,7 +23,7 @@ INSTALL_DIRS= contrib
SLAVE_ONLY= yes
COMPONENT= -contrib
-CONFIGURE_ARGS+=--with-libxslt --with-libxml --with-openssl --with-ossp-uuid
+CONFIGURE_ARGS+=--with-libxslt --with-libxml --with-openssl
LDFLAGS+= ${PTHREAD_LIBS} -L${PREFIX}/lib
post-install:
diff --git a/databases/postgresql90-server/files/patch-contrib-uuid b/databases/postgresql90-server/files/patch-contrib-uuid
index a1b312cc2406..715aec5f281f 100644
--- a/databases/postgresql90-server/files/patch-contrib-uuid
+++ b/databases/postgresql90-server/files/patch-contrib-uuid
@@ -369,3 +369,13 @@
+ return internal_uuid_create(5, (unsigned char *)ns,
+ VARDATA(name), VARSIZE(name) - VARHDRSZ);
}
+--- contrib/Makefile.orig 2014-03-21 08:54:03.000000000 +0100
++++ contrib/Makefile 2014-03-21 08:54:08.000000000 +0100
+@@ -43,6 +43,7 @@
+ tablefunc \
+ test_parser \
+ tsearch2 \
++ uuid-ossp \
+ unaccent \
+ vacuumlo
+
diff --git a/databases/postgresql91-contrib/Makefile b/databases/postgresql91-contrib/Makefile
index 5b3f5355d6fa..441698a1a051 100644
--- a/databases/postgresql91-contrib/Makefile
+++ b/databases/postgresql91-contrib/Makefile
@@ -22,7 +22,7 @@ INSTALL_DIRS= contrib
SLAVE_ONLY= yes
COMPONENT= -contrib
-CONFIGURE_ARGS+=--with-libxslt --with-libxml --with-openssl --with-ossp-uuid
+CONFIGURE_ARGS+=--with-libxslt --with-libxml --with-openssl
LDFLAGS+= ${PTHREAD_LIBS} -L${PREFIX}/lib
post-install:
diff --git a/databases/postgresql91-server/files/patch-contrib-uuid b/databases/postgresql91-server/files/patch-contrib-uuid
index bead2c6afd77..0d4c7accbbc4 100644
--- a/databases/postgresql91-server/files/patch-contrib-uuid
+++ b/databases/postgresql91-server/files/patch-contrib-uuid
@@ -391,3 +391,13 @@
+ return internal_uuid_create(5, (unsigned char *)ns,
+ VARDATA(name), VARSIZE(name) - VARHDRSZ);
}
+--- contrib/Makefile.orig 2014-03-21 09:05:11.000000000 +0100
++++ contrib/Makefile 2014-03-21 09:05:29.000000000 +0100
+@@ -48,6 +48,7 @@
+ test_parser \
+ tsearch2 \
+ unaccent \
++ uuid-ossp \
+ vacuumlo
+
+ ifeq ($(with_openssl),yes)
diff --git a/databases/postgresql92-contrib/Makefile b/databases/postgresql92-contrib/Makefile
index 7c947dca17f6..11cd33f74b4a 100644
--- a/databases/postgresql92-contrib/Makefile
+++ b/databases/postgresql92-contrib/Makefile
@@ -22,7 +22,7 @@ INSTALL_DIRS= contrib
SLAVE_ONLY= yes
COMPONENT= -contrib
-CONFIGURE_ARGS+=--with-libxslt --with-libxml --with-ossp-uuid --with-openssl
+CONFIGURE_ARGS+=--with-libxslt --with-libxml --with-openssl
LDFLAGS+= ${PTHREAD_LIBS} -L${PREFIX}/lib
post-install:
diff --git a/databases/postgresql92-server/files/patch-contrib-uuid b/databases/postgresql92-server/files/patch-contrib-uuid
index bead2c6afd77..c7b003bb39a5 100644
--- a/databases/postgresql92-server/files/patch-contrib-uuid
+++ b/databases/postgresql92-server/files/patch-contrib-uuid
@@ -391,3 +391,13 @@
+ return internal_uuid_create(5, (unsigned char *)ns,
+ VARDATA(name), VARSIZE(name) - VARHDRSZ);
}
+--- contrib/Makefile.orig 2014-03-21 09:01:58.000000000 +0100
++++ contrib/Makefile 2014-03-21 09:02:16.000000000 +0100
+@@ -50,6 +50,7 @@
+ test_parser \
+ tsearch2 \
+ unaccent \
++ uuid-ossp \
+ vacuumlo
+
+ ifeq ($(with_openssl),yes)
diff --git a/databases/postgresql93-contrib/Makefile b/databases/postgresql93-contrib/Makefile
index a02a6e53125d..6356dbc1d94a 100644
--- a/databases/postgresql93-contrib/Makefile
+++ b/databases/postgresql93-contrib/Makefile
@@ -23,7 +23,7 @@ INSTALL_DIRS= contrib
SLAVE_ONLY= yes
COMPONENT= -contrib
-CONFIGURE_ARGS+=--with-libxslt --with-libxml --with-openssl --with-ossp-uuid --disable-nls
+CONFIGURE_ARGS+=--with-libxslt --with-libxml --with-openssl --disable-nls
LDFLAGS+= ${PTHREAD_LIBS} -L${PREFIX}/lib
post-install:
diff --git a/databases/postgresql93-server/files/patch-contrib-uuid b/databases/postgresql93-server/files/patch-contrib-uuid
index 7cbcb6f7a81e..73c836c36e1e 100644
--- a/databases/postgresql93-server/files/patch-contrib-uuid
+++ b/databases/postgresql93-server/files/patch-contrib-uuid
@@ -397,3 +397,13 @@
+ return internal_uuid_create(5, (unsigned char *)ns,
+ VARDATA(name), VARSIZE(name) - VARHDRSZ);
}
+--- contrib/Makefile.orig 2014-03-21 08:58:32.000000000 +0100
++++ contrib/Makefile 2014-03-21 08:59:13.000000000 +0100
+@@ -52,6 +52,7 @@
+ test_parser \
+ tsearch2 \
+ unaccent \
++ uuid-ossp \
+ vacuumlo \
+ worker_spi
+