aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlejandro Pulver <alepulver@FreeBSD.org>2006-11-05 16:59:44 +0000
committerAlejandro Pulver <alepulver@FreeBSD.org>2006-11-05 16:59:44 +0000
commita00130e684e68fc41e7965376358594e7588a50f (patch)
tree5d49824f2406c86509603be9bdc89e30c21df58b
parent43cc549f306ac08cf1be3d9a265170180dbe4f35 (diff)
downloadports-a00130e684e68fc41e7965376358594e7588a50f.tar.gz
ports-a00130e684e68fc41e7965376358594e7588a50f.zip
Notes
-rw-r--r--sysutils/Makefile1
-rw-r--r--sysutils/xsi/Makefile44
-rw-r--r--sysutils/xsi/distinfo3
-rw-r--r--sysutils/xsi/files/xsi.in23
-rw-r--r--sysutils/xsi/pkg-descr6
-rw-r--r--sysutils/xsi/pkg-install37
-rw-r--r--sysutils/xsi/pkg-plist8
7 files changed, 122 insertions, 0 deletions
diff --git a/sysutils/Makefile b/sysutils/Makefile
index 4d0a3c834cce..573fde01503c 100644
--- a/sysutils/Makefile
+++ b/sysutils/Makefile
@@ -718,6 +718,7 @@
SUBDIR += xosview
SUBDIR += xperfmon
SUBDIR += xperfmon3
+ SUBDIR += xsi
SUBDIR += xstow
SUBDIR += xsu
SUBDIR += xsysinfo
diff --git a/sysutils/xsi/Makefile b/sysutils/xsi/Makefile
new file mode 100644
index 000000000000..b235a2ca63c0
--- /dev/null
+++ b/sysutils/xsi/Makefile
@@ -0,0 +1,44 @@
+# New ports collection makefile for: xsi
+# Date created: 18 October 2006
+# Whom: Tom McLaughlin <tmclaugh@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= xsi
+PORTVERSION= 0.98.20
+CATEGORIES= sysutils
+MASTER_SITES= http://xsi.kolabore.ath.cx/download/
+
+MAINTAINER= tmclaugh@FreeBSD.org
+COMMENT= System monitor that provides XML encoded stats
+
+LIB_DEPENDS= xml2.5:${PORTSDIR}/textproc/libxml2
+
+USE_GNOME= gnometarget
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS+= --mandir=${MANPREFIX}/man \
+ --enable-user=_xsi
+
+USE_RC_SUBR= xsi
+
+MAN8= xsi.8
+
+post-configure:
+.if defined(NOPORTDOCS)
+ ${REINPLACE_CMD} -e 's|-exec-am install-data-am|-exec-am|' \
+ ${WRKSRC}/Makefile
+.endif
+
+post-install:
+.if !defined(PACKAGE_BUILDING)
+ @${SETENV} PKG_PREFIX=${PREFIX} ${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
+.endif
+
+.include <bsd.port.pre.mk>
+
+.if (${OSVERSION} < 600007)
+IGNORE= is not supported on FreeBSD < 6.0
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/sysutils/xsi/distinfo b/sysutils/xsi/distinfo
new file mode 100644
index 000000000000..1f7a22d89bb4
--- /dev/null
+++ b/sysutils/xsi/distinfo
@@ -0,0 +1,3 @@
+MD5 (xsi-0.98.20.tar.gz) = 7d3f2f9fd83c2ff8f4d1112f8dfec525
+SHA256 (xsi-0.98.20.tar.gz) = 29c36617e2e534c74b99f5cfbc1722a2b45226fa676d41977d91a20dba4e7802
+SIZE (xsi-0.98.20.tar.gz) = 444983
diff --git a/sysutils/xsi/files/xsi.in b/sysutils/xsi/files/xsi.in
new file mode 100644
index 000000000000..0245ac34ca5d
--- /dev/null
+++ b/sysutils/xsi/files/xsi.in
@@ -0,0 +1,23 @@
+#!/bin/sh
+#
+# $FreeBSD$
+#
+# PROVIDE: xsi
+# REQUIRE: NETWORKING
+#
+# Add the following line to /etc/rc.conf to enable the XSI daemon
+#
+# xsi_enable="YES"
+#
+
+xsi_enable=${hald_enable-"NO"}
+xsi_flags=${hald_flags-""}
+
+. %%RC_SUBR%%
+
+name=xsi
+rcvar=`set_rcvar`
+
+command=%%PREFIX%%/bin/${name}
+load_rc_config ${name}
+run_rc_command "$1"
diff --git a/sysutils/xsi/pkg-descr b/sysutils/xsi/pkg-descr
new file mode 100644
index 000000000000..f322f59fe241
--- /dev/null
+++ b/sysutils/xsi/pkg-descr
@@ -0,0 +1,6 @@
+XSI is a system monitoring daemon that replies to network queries with
+XML-encoded system information and statistics. This data can then be
+analyzed, graphed or otherwise presented by a front-end. It is BSD-licensed
+and free for anyone to use for any purpose.
+
+WWW: http://xsi.kolabore.ath.cx/index.html
diff --git a/sysutils/xsi/pkg-install b/sysutils/xsi/pkg-install
new file mode 100644
index 000000000000..e62572033c4a
--- /dev/null
+++ b/sysutils/xsi/pkg-install
@@ -0,0 +1,37 @@
+#!/bin/sh
+
+case $2 in
+POST-INSTALL)
+ USER=_xsi
+ GROUP=${USER}
+ UID=600
+ GID=${UID}
+ PW=/usr/sbin/pw
+
+ if ${PW} group show "${GROUP}" 2>/dev/null; then
+ echo "You already have a group \"${GROUP}\", so I will use it."
+ else
+ if ${PW} groupadd ${GROUP} -g ${GID}; then
+ echo "Added group \"${GROUP}\"."
+ else
+ echo "Adding group \"${GROUP}\" failed..."
+ exit 1
+ fi
+ fi
+
+ if ${PW} user show "${USER}" 2>/dev/null; then
+ echo "You already have a user \"${USER}\", so I will use it."
+ else
+ if ${PW} useradd ${USER} -u ${UID} -g ${GROUP} -h - \
+ -d "/nonexistent" -s /sbin/nologin -c "XMLSysInfo User"
+ then
+ echo "Added user \"${USER}\"."
+ else
+ echo "Adding user \"${USER}\" failed..."
+ exit 1
+ fi
+ fi
+
+ exit 0
+ ;;
+esac
diff --git a/sysutils/xsi/pkg-plist b/sysutils/xsi/pkg-plist
new file mode 100644
index 000000000000..c2467463e590
--- /dev/null
+++ b/sysutils/xsi/pkg-plist
@@ -0,0 +1,8 @@
+bin/xsi
+%%PORTDOCS%%%%DOCSDIR%%/CHANGELOG
+%%PORTDOCS%%%%DOCSDIR%%/COPYING
+%%PORTDOCS%%%%DOCSDIR%%/FRONTENDS
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%PORTDOCS%%%%DOCSDIR%%/xmlsysinfo-1.0.xsd
+%%PORTDOCS%%%%DOCSDIR%%/xsi-output.xml
+%%PORTDOCS%%@dirrm %%DOCSDIR%%