aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYen-Ming Lee <leeym@FreeBSD.org>2004-02-08 15:45:10 +0000
committerYen-Ming Lee <leeym@FreeBSD.org>2004-02-08 15:45:10 +0000
commita0162b67bde15c6e0d5d4cff314063987a8265e8 (patch)
tree323e1831ce31e133ab374631c475e0b40d7092f9
parent21919f264b1b40b71f6cba53e84b9a88e91e4ec9 (diff)
downloadports-a0162b67bde15c6e0d5d4cff314063987a8265e8.tar.gz
ports-a0162b67bde15c6e0d5d4cff314063987a8265e8.zip
Notes
-rw-r--r--mail/zmailer/Makefile17
1 files changed, 6 insertions, 11 deletions
diff --git a/mail/zmailer/Makefile b/mail/zmailer/Makefile
index ed95ec73c938..12311ca7f759 100644
--- a/mail/zmailer/Makefile
+++ b/mail/zmailer/Makefile
@@ -16,21 +16,16 @@ COMMENT= A fully functional fast, robust SMTP server and transport agent
CONFLICTS= courier-0.* postfix-1.* postfix-2.* sendmail-8.* sendmail-*-8.* smail-3.*
GNU_CONFIGURE= yes
+USE_GCC= 2.95
.if defined(WITH_SSL)
USE_OPENSSL= YES
-CONFIGURE_ARGS= --with-openssl
+CONFIGURE_ARGS= --with-openssl
.else
-CONFIGURE_ARGS= --without-openssl
+CONFIGURE_ARGS= --without-openssl
.endif
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} >= 500113
-BROKEN= "Does not compile on FreeBSD ${OSVERSION}"
-.endif
-
-CONFIGURE_ARGS+= --prefix=${PREFIX}/ \
+CONFIGURE_ARGS+=--prefix=${PREFIX}/ \
--with-bundled-libresolv \
--with-mailbin=${PREFIX}/sbin \
--with-mailbox=/var/mail \
@@ -48,7 +43,7 @@ CONFIGURE_ARGS+= --prefix=${PREFIX}/ \
--libdir=${PREFIX}/lib \
--with-ta-mmap
-MAN1= rmail.1 vacation.1 zmailer.1 zmsh.1 mboxpath.1 ssl.1 mailq.1 \
+MAN1= rmail.1 vacation.1 zmailer.1 zmsh.1 mboxpath.1 ssl.1 mailq.1 \
mailrm.1 newaliases.1
MAN3= zmailer.3
MAN5= aliases.5
@@ -120,4 +115,4 @@ replace:
${LN} -s ${PREFIX}/sbin/rmail /bin/rmail; \
fi
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>