aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPietro Cerutti <gahr@FreeBSD.org>2013-04-24 09:35:31 +0000
committerPietro Cerutti <gahr@FreeBSD.org>2013-04-24 09:35:31 +0000
commita13a205e28c04a269d373bcebae8f0241c05986a (patch)
treeeeffffc2697c02443e15b0cfa0c6743b43ac7662
parente23e1f671e08952ece99cbffde67053d4ad34d80 (diff)
downloadports-a13a205e28c04a269d373bcebae8f0241c05986a.tar.gz
ports-a13a205e28c04a269d373bcebae8f0241c05986a.zip
Notes
-rw-r--r--devel/tclreadline/Makefile17
1 files changed, 9 insertions, 8 deletions
diff --git a/devel/tclreadline/Makefile b/devel/tclreadline/Makefile
index 77f2b9748cc2..e0d3c00fc400 100644
--- a/devel/tclreadline/Makefile
+++ b/devel/tclreadline/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: tclreadline
-# Date created: 21 September 1999
-# Whom: darius@dons.net.au
-#
+# Created by: darius@dons.net.au
# $FreeBSD$
-#
PORTNAME= tclreadline
PORTVERSION= 2.1.0
@@ -11,17 +7,22 @@ PORTREVISION= 3
CATEGORIES= devel tcl
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTNAME}-${PORTVERSION}
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= tcltk@FreeBSD.org
COMMENT= GNU readline for TCL
USE_TCL= 84+
USE_AUTOTOOLS= libtool
-GNU_CONFIGURE= yes
USE_LDCONFIG= yes
MANN= tclreadline.n
PLIST_SUB+= VERSION="${PORTVERSION}"
-CONFIGURE_ARGS= --with-tcl=${TCL_LIBDIR} --with-tcl-includes=${TCL_INCLUDEDIR}
+CONFIGURE_ARGS+=--with-tcl=${TCL_LIBDIR} \
+ --with-tcl-includes=${TCL_INCLUDEDIR}
+
+post-patch:
+ ${REINPLACE_CMD} \
+ -e '/^#define MALLOC/d; /^#define FREE/d; s|MALLOC|malloc|g; s|FREE|free|g' \
+ ${WRKSRC}/tclreadline.c
.include <bsd.port.mk>