aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorErwin Lansing <erwin@FreeBSD.org>2003-10-14 10:57:45 +0000
committerErwin Lansing <erwin@FreeBSD.org>2003-10-14 10:57:45 +0000
commita63c2f44b779f102354b1fafd8ad3f531c9ad0c3 (patch)
tree56836d9b89c6b848e77ffb6d928cdf06d5209a59
parentd3fb9ee8eab6532e8d8e56a901b8c2982e601672 (diff)
downloadports-a63c2f44b779f102354b1fafd8ad3f531c9ad0c3.tar.gz
ports-a63c2f44b779f102354b1fafd8ad3f531c9ad0c3.zip
Notes
-rw-r--r--www/Makefile1
-rw-r--r--www/mod_auth_external2/Makefile36
-rw-r--r--www/mod_auth_external2/distinfo1
-rw-r--r--www/mod_auth_external2/pkg-descr9
-rw-r--r--www/mod_auth_external2/pkg-plist7
5 files changed, 54 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 0ab58493db04..0b3971d0421f 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -187,6 +187,7 @@
SUBDIR += mod_auth_any
SUBDIR += mod_auth_cookie_mysql
SUBDIR += mod_auth_external
+ SUBDIR += mod_auth_external2
SUBDIR += mod_auth_kerb
SUBDIR += mod_auth_mysql
SUBDIR += mod_auth_mysql_another
diff --git a/www/mod_auth_external2/Makefile b/www/mod_auth_external2/Makefile
new file mode 100644
index 000000000000..37a948453f99
--- /dev/null
+++ b/www/mod_auth_external2/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for: mod_auth_external2
+# Date created: Fri Oct 10
+# Whom: Clement Laforet <sheepkiller@cultdeadsheep.org>
+#
+# $FreeBSD$
+
+PORTNAME= mod_auth_external
+PORTVERSION= 2.2.6
+CATEGORIES= www
+MASTER_SITES= http://www.unixpapa.com/software/
+DIST_SUBDIR= apache
+
+MAINTAINER= sheeepkiller@cultdeadsheep.org
+COMMENT= Allows users authentication based on external mechanisms
+
+BUILD_DEPENDS= ${LOCALBASE}/sbin/apxs:${PORTSDIR}/www/apache2
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+LATEST_LINK= mod_auth_external2
+
+APXS?= ${LOCALBASE}/sbin/apxs
+
+DOC_FILES= AUTHENTICATORS INSTALL README
+do-build:
+ @(cd ${WRKSRC}/ && ${APXS} -I. -c ${PORTNAME}.c)
+
+do-install:
+ @(cd ${WRKSRC}/ && ${APXS} -A -i ${PORTNAME}.la)
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+. for f in ${DOC_FILES}
+ @${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}
+. endfor
+.endif
+
+.include <bsd.port.mk>
diff --git a/www/mod_auth_external2/distinfo b/www/mod_auth_external2/distinfo
new file mode 100644
index 000000000000..db712b500b3d
--- /dev/null
+++ b/www/mod_auth_external2/distinfo
@@ -0,0 +1 @@
+MD5 (apache/mod_auth_external-2.2.6.tar.gz) = e06e9593816f81597f06f88555ff4658
diff --git a/www/mod_auth_external2/pkg-descr b/www/mod_auth_external2/pkg-descr
new file mode 100644
index 000000000000..85407668527f
--- /dev/null
+++ b/www/mod_auth_external2/pkg-descr
@@ -0,0 +1,9 @@
+Mod_Auth_External is an Apache module used for authentication. The Apache HTTP
+Daemon can be configured to require users to supply logins and passwords
+before accessing pages in some directories. Authentication is the process of
+checking if the password given is correct for a user. Apache has standard
+modules for authenticating out of several different kinds of databases.
+Mod_Auth_External is a flexible tool for creating authentication systems based
+on other databases.
+
+WWW: http://www.unixpapa.com/mod_auth_external.html
diff --git a/www/mod_auth_external2/pkg-plist b/www/mod_auth_external2/pkg-plist
new file mode 100644
index 000000000000..8a91733f0681
--- /dev/null
+++ b/www/mod_auth_external2/pkg-plist
@@ -0,0 +1,7 @@
+libexec/apache2/mod_auth_external.so
+%%PORTDOCS%%%%DOCSDIR%%/AUTHENTICATORS
+%%PORTDOCS%%%%DOCSDIR%%/INSTALL
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%PORTDOCS%%@dirrm %%DOCSDIR%%
+@exec %D/sbin/apxs -e -a -n auth_external %D/%f
+@unexec echo "===> If you do not plan on reinstalling mod_auth_external, you must manually remove"; echo "===> references to it in httpd.conf."