aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJun Kuriyama <kuriyama@FreeBSD.org>2013-12-31 12:26:35 +0000
committerJun Kuriyama <kuriyama@FreeBSD.org>2013-12-31 12:26:35 +0000
commitbb5d2a3f2802d0751511171436c621da193ad64b (patch)
tree7e9761a56634a7d3381547a38a0e9f88e917096e
parent513cdd04772f169471f11b823de20c321469b57f (diff)
downloadports-bb5d2a3f2802d0751511171436c621da193ad64b.tar.gz
ports-bb5d2a3f2802d0751511171436c621da193ad64b.zip
Notes
-rw-r--r--lang/phantomjs/Makefile7
-rw-r--r--lang/phantomjs/files/patch-config.tests-fontconfig.pro8
-rw-r--r--lang/phantomjs/files/patch-configure50
-rw-r--r--lang/phantomjs/files/patch-mkspecs-freebsd-g++-qmake.conf11
4 files changed, 73 insertions, 3 deletions
diff --git a/lang/phantomjs/Makefile b/lang/phantomjs/Makefile
index 3fb71452e581..78007dbc49a6 100644
--- a/lang/phantomjs/Makefile
+++ b/lang/phantomjs/Makefile
@@ -2,7 +2,7 @@
PORTNAME= phantomjs
PORTVERSION= 1.9.2
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= lang
MASTER_SITES= ${MASTER_SITE_GOOGLE_CODE}
DISTNAME= ${PORTNAME}-${PORTVERSION}-source
@@ -17,12 +17,13 @@ LIB_DEPENDS= libfreetype.so:${PORTSDIR}/print/freetype2 \
libfontconfig.so:${PORTSDIR}/x11-fonts/fontconfig
PROJECTHOST= phantomjs
-USES= gmake dos2unix
+USE_GCC= 4.2+
+USES= gmake dos2unix pkgconfig
USE_ZIP= YES
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
do-build:
- cd ${WRKSRC} && ${SETENV} OSTYPE=freebsd MAKEFLAGS= bash -x build.sh --jobs ${MAKE_JOBS_NUMBER} --confirm
+ cd ${WRKSRC} && ${SETENV} CC=${CC} CXX=${CXX} OSTYPE=freebsd MAKEFLAGS= PATH=${PATH} bash -x build.sh --jobs ${MAKE_JOBS_NUMBER} --confirm
do-install:
cd ${WRKSRC} && ${INSTALL_PROGRAM} bin/phantomjs ${STAGEDIR}${PREFIX}/bin/
diff --git a/lang/phantomjs/files/patch-config.tests-fontconfig.pro b/lang/phantomjs/files/patch-config.tests-fontconfig.pro
new file mode 100644
index 000000000000..13a09dbdd692
--- /dev/null
+++ b/lang/phantomjs/files/patch-config.tests-fontconfig.pro
@@ -0,0 +1,8 @@
+--- src/qt/config.tests/x11/fontconfig/fontconfig.pro.orig 2013-12-31 13:08:24.457123877 +0900
++++ src/qt/config.tests/x11/fontconfig/fontconfig.pro 2013-12-31 13:08:35.878125769 +0900
+@@ -1,5 +1,4 @@
+ SOURCES = fontconfig.cpp
+-CONFIG += x11
+ CONFIG -= qt
+ LIBS += -lfreetype -lfontconfig
+ include(../../unix/freetype/freetype.pri)
diff --git a/lang/phantomjs/files/patch-configure b/lang/phantomjs/files/patch-configure
new file mode 100644
index 000000000000..2eaec84b01e7
--- /dev/null
+++ b/lang/phantomjs/files/patch-configure
@@ -0,0 +1,50 @@
+--- src/qt/configure.orig 2013-12-31 18:16:16.149123834 +0900
++++ src/qt/configure 2013-12-31 18:21:26.989125910 +0900
+@@ -2707,8 +2707,8 @@
+ ShadowMkspecs()
+ {
+ rm -rf "$outpath/mkspecs/$1"
+- find "$relpath/mkspecs/$1" -type d | sed "s,^$relpath,$outpath," | xargs mkdir -p
+- find "$relpath/mkspecs/$1" -type f | sed "s,^$relpath/,," | while read f; do ln -s "$relpath/$f" "$outpath/$f"; done
++ find -s "$relpath/mkspecs/$1" -type d | sed "s,^$relpath,$outpath," | xargs mkdir -p
++ find -s "$relpath/mkspecs/$1" -type f | sed "s,^$relpath/,," | while read f; do ln -s "$relpath/$f" "$outpath/$f"; done
+ }
+
+ # Special case for mkspecs/features directory.
+@@ -2880,6 +2880,10 @@
+ ULTRIX:*)
+ PLATFORM=ultrix-g++
+ ;;
++# FreeBSD:10.[0-9]*)
++# echo "=== ($UNAME_RELEASE) ==="
++# PLATFORM=freebsd-clang
++# ;;
+ FreeBSD:*)
+ PLATFORM=freebsd-g++
+ PLATFORM_NOTES="
+@@ -3017,7 +3021,7 @@
+ CFG_SM=no
+ PLATFORMS=`find "$relpath/mkspecs/qws" | sed "s,$relpath/mkspecs/qws/,,"`
+ else
+- PLATFORMS=`find "$relpath/mkspecs/" -type f | grep -v qws | sed "s,$relpath/mkspecs/qws/,,"`
++ PLATFORMS=`find -s "$relpath/mkspecs/" -type f | grep -v qws | sed "s,$relpath/mkspecs/qws/,,"`
+ fi
+
+ [ -z "$XPLATFORM" ] && XPLATFORM="$PLATFORM"
+@@ -5118,6 +5122,7 @@
+ # tests that need qmake
+ #-------------------------------------------------------------------------------
+
++export CXX="${CXX}"
+ # detect availability of float math.h functions
+ if "$unixtests/compile.test" "$XQMAKESPEC" "$QMAKE_CONFIG" $OPT_VERBOSE "$relpath" "$outpath" config.tests/unix/floatmath "floatmath" $L_FLAGS $I_FLAGS $l_FLAGS; then
+ CFG_USE_FLOATMATH=yes
+@@ -7665,7 +7670,7 @@
+ ;;
+ *-g++*)
+ # Check gcc's version
+- case "$(${QMAKE_CONF_COMPILER} -dumpversion)" in
++ case "$(${TEST_COMPILER} -dumpversion)" in
+ 4*|3.4*)
+ ;;
+ 3.3*)
diff --git a/lang/phantomjs/files/patch-mkspecs-freebsd-g++-qmake.conf b/lang/phantomjs/files/patch-mkspecs-freebsd-g++-qmake.conf
new file mode 100644
index 000000000000..e08a0ec4d300
--- /dev/null
+++ b/lang/phantomjs/files/patch-mkspecs-freebsd-g++-qmake.conf
@@ -0,0 +1,11 @@
+--- src/qt/mkspecs/freebsd-g++/qmake.conf.orig 2013-12-23 19:04:54.234123703 +0900
++++ src/qt/mkspecs/freebsd-g++/qmake.conf 2013-12-23 23:55:19.434123270 +0900
+@@ -51,4 +51,8 @@
+ include(../common/unix.conf)
+ include(../common/gcc-base-unix.conf)
+ include(../common/g++-unix.conf)
++QMAKE_CC = $$(CC)
++QMAKE_CXX = $$(CXX)
++#QMAKE_LINK_SHLIB = $$(CXX)
++QMAKE_LINK = $$(CXX)
+ load(qt_config)