aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2017-11-11 08:38:39 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2017-11-11 08:38:39 +0000
commitc0db7230c3a79b025ff42da12e02a1a03f9863b9 (patch)
tree740e5aeebe0b45cc667ee0d2d3366c1dcb297f2a
parent2b017c55df1ce269e7d1167bee3aaea094445347 (diff)
downloadports-c0db7230c3a79b025ff42da12e02a1a03f9863b9.tar.gz
ports-c0db7230c3a79b025ff42da12e02a1a03f9863b9.zip
Notes
-rw-r--r--audio/Makefile1
-rw-r--r--audio/libmusicxml/Makefile29
-rw-r--r--audio/libmusicxml/distinfo3
-rw-r--r--audio/libmusicxml/files/patch-build_CMakeLists.txt11
-rw-r--r--audio/libmusicxml/pkg-descr5
-rw-r--r--audio/libmusicxml/pkg-plist49
6 files changed, 98 insertions, 0 deletions
diff --git a/audio/Makefile b/audio/Makefile
index 13030f4325fe..6df20038732c 100644
--- a/audio/Makefile
+++ b/audio/Makefile
@@ -415,6 +415,7 @@
SUBDIR += libmpdclient
SUBDIR += libmusicbrainz3
SUBDIR += libmusicbrainz5
+ SUBDIR += libmusicxml
SUBDIR += libnjb
SUBDIR += libnoise
SUBDIR += libogg
diff --git a/audio/libmusicxml/Makefile b/audio/libmusicxml/Makefile
new file mode 100644
index 000000000000..1a45fee65fd1
--- /dev/null
+++ b/audio/libmusicxml/Makefile
@@ -0,0 +1,29 @@
+# $FreeBSD$
+
+PORTNAME= libmusicxml
+DISTVERSION= 3.11
+CATEGORIES= audio
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Library and tools for the MusicXML format
+
+LICENSE= MPL20
+LICENSE_FILE= ${WRKSRC}/license.txt
+
+USES= cmake:outsource
+USE_GITHUB= yes
+GH_ACCOUNT= grame-cncm
+GH_TAGNAME= 91347ae
+USE_LDCONFIG= yes
+CMAKE_SOURCE_PATH= ${WRKSRC}/build
+
+OPTIONS_DEFINE= DOCS
+PORTDOCS= *
+
+post-build-DOCS-on:
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} \
+ ${WRKSRC}/doc/presentation/libmusicxml2.pdf \
+ ${STAGEDIR}${DOCSDIR}
+
+.include <bsd.port.mk>
diff --git a/audio/libmusicxml/distinfo b/audio/libmusicxml/distinfo
new file mode 100644
index 000000000000..bb79fd7f2491
--- /dev/null
+++ b/audio/libmusicxml/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1509525124
+SHA256 (grame-cncm-libmusicxml-3.11-91347ae_GH0.tar.gz) = 4f9a7009631a2baca9cfa4898603abd851f6be72f5e8d9d0eb5c0cfdc2ffcb55
+SIZE (grame-cncm-libmusicxml-3.11-91347ae_GH0.tar.gz) = 3106105
diff --git a/audio/libmusicxml/files/patch-build_CMakeLists.txt b/audio/libmusicxml/files/patch-build_CMakeLists.txt
new file mode 100644
index 000000000000..8e9244415ca7
--- /dev/null
+++ b/audio/libmusicxml/files/patch-build_CMakeLists.txt
@@ -0,0 +1,11 @@
+--- build/CMakeLists.txt.orig 2017-10-30 10:42:38 UTC
++++ build/CMakeLists.txt
+@@ -146,7 +146,7 @@ endif()
+ if(NOT APPLE)
+ install ( TARGETS ${target} ${TOOLS}
+ RUNTIME DESTINATION bin
+- LIBRARY DESTINATION /usr/lib
++ LIBRARY DESTINATION ${CMAKE_INSTALL_PREFIX}/lib
+ ARCHIVE DESTINATION lib
+ # FRAMEWORK DESTINATION "/Library/Frameworks" CONFIGURATIONS Release
+ PUBLIC_HEADER DESTINATION include/libmusicxml
diff --git a/audio/libmusicxml/pkg-descr b/audio/libmusicxml/pkg-descr
new file mode 100644
index 000000000000..a204c98b7371
--- /dev/null
+++ b/audio/libmusicxml/pkg-descr
@@ -0,0 +1,5 @@
+The MusicXML format represents common Western musical notation from the
+17th century onwards. It is an xml format that organizes the music into
+a header followed by the core music data.
+
+WWW: https://github.com/grame-cncm/libmusicxml
diff --git a/audio/libmusicxml/pkg-plist b/audio/libmusicxml/pkg-plist
new file mode 100644
index 000000000000..9f3243f11177
--- /dev/null
+++ b/audio/libmusicxml/pkg-plist
@@ -0,0 +1,49 @@
+bin/xml2guido
+bin/xmltranspose
+include/libmusicxml/basevisitor.h
+include/libmusicxml/bimap.h
+include/libmusicxml/browser.h
+include/libmusicxml/clefvisitor.h
+include/libmusicxml/clonevisitor.h
+include/libmusicxml/conversions.h
+include/libmusicxml/ctree.h
+include/libmusicxml/elements.h
+include/libmusicxml/exports.h
+include/libmusicxml/factory.h
+include/libmusicxml/functor.h
+include/libmusicxml/guido.h
+include/libmusicxml/keysignvisitor.h
+include/libmusicxml/keyvisitor.h
+include/libmusicxml/libmusicxml.h
+include/libmusicxml/metronomevisitor.h
+include/libmusicxml/midicontextvisitor.h
+include/libmusicxml/musicxmlfactory.h
+include/libmusicxml/notevisitor.h
+include/libmusicxml/partlistvisitor.h
+include/libmusicxml/partsummary.h
+include/libmusicxml/rational.h
+include/libmusicxml/reader.h
+include/libmusicxml/singleton.h
+include/libmusicxml/smartlist.h
+include/libmusicxml/smartpointer.h
+include/libmusicxml/sortvisitor.h
+include/libmusicxml/timesignvisitor.h
+include/libmusicxml/transposevisitor.h
+include/libmusicxml/transposition.h
+include/libmusicxml/tree_browser.h
+include/libmusicxml/typedefs.h
+include/libmusicxml/types.h
+include/libmusicxml/unrolled_clonevisitor.h
+include/libmusicxml/unrolled_xml_tree_browser.h
+include/libmusicxml/versions.h
+include/libmusicxml/visitable.h
+include/libmusicxml/visitor.h
+include/libmusicxml/xml.h
+include/libmusicxml/xml2guidovisitor.h
+include/libmusicxml/xml_tree_browser.h
+include/libmusicxml/xmlfile.h
+include/libmusicxml/xmlpart2guido.h
+include/libmusicxml/xmlreader.h
+include/libmusicxml/xmlvisitor.h
+lib/libmusicxml2.so
+lib/libmusicxml2.so.3.11