aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRenato Botelho <garga@FreeBSD.org>2006-02-10 17:02:54 +0000
committerRenato Botelho <garga@FreeBSD.org>2006-02-10 17:02:54 +0000
commitc1349884a09dd844b827bd72aa7686e38e5fa9a3 (patch)
tree483801d584bdaf9b362efce697423544aeca280e
parent2cd927ef3ba6e3c59c7a78b8a6931c9fa1fef5b4 (diff)
downloadports-c1349884a09dd844b827bd72aa7686e38e5fa9a3.tar.gz
ports-c1349884a09dd844b827bd72aa7686e38e5fa9a3.zip
Notes
-rw-r--r--mail/dspam-devel/Makefile61
-rw-r--r--mail/dspam-devel/distinfo6
-rw-r--r--mail/dspam-devel/files/UPDATING12
-rw-r--r--mail/dspam-devel/files/dspam-devel.sh.in2
4 files changed, 31 insertions, 50 deletions
diff --git a/mail/dspam-devel/Makefile b/mail/dspam-devel/Makefile
index 406d1b8795b4..54392b0b75d0 100644
--- a/mail/dspam-devel/Makefile
+++ b/mail/dspam-devel/Makefile
@@ -3,7 +3,7 @@
# Whom: Ion-Mihai "IOnut" Tetcu <itetcu@people.tecnik93.com>
#
# $FreeBSD$
-# $Tecnik: ports/mail/dspam-devel/Makefile,v 1.26 2006/02/03 22:06:14 itetcu Exp $
+# $Tecnik: ports/mail/dspam-devel/Makefile,v 1.32 2006/02/08 18:50:32 itetcu Exp $
#
# Note to commiters: If don't commit a maintainer patch and as a result PKGNAME
@@ -21,7 +21,10 @@ MAINTAINER= itetcu@people.tecnik93.com
COMMENT= Bayesian spam filter - development version
PORTVER_MAJ= 3.6.3
-SNAP_DATE= .20060203.1409
+SNAP_DATE= .20060208.1807
+_UPD_LINE_NO= 11
+
+MIN_OPTIONS_VER= ${PORTNAME}-3.6.3.20060203.1409
.ifdef(SNAP_DATE)
MASTER_SITES= http://people.tecnik93.com/~itetcu/FreeBSD/ports/${PORTNAME}/sources/
@@ -35,8 +38,6 @@ DISTFILES= dspam-${PORTVER_MAJ}.tar.gz
WRKSRC= ${WRKDIR}/dspam-${PORTVER_MAJ}
.endif
-_UPD_LINE_NO= 31
-
## debug / log / admin options
OPTIONS= DEBUG "Enable debugging logging" on
OPTIONS+= VERBOSE_DEBUG "Enable debug in LOGDIR/dspam.debug" off
@@ -125,14 +126,6 @@ DSPAM_HOME_MODE?= 0770
.include <bsd.port.pre.mk>
-MIN_OPTIONS_VER= ${PORTNAME}-3.6.3.20060203.1409
-.ifdef(_OPTIONS_READ)
-OPTIONS_CMP!= ${PKG_VERSION} -t ${_OPTIONS_READ} ${MIN_OPTIONS_VER}
-. if ${OPTIONS_CMP} == "<"
-OPTIONS_MESSAGE= "You have unsupported (old) OPTIONS, please do a 'make config; make'"
-. endif
-.endif
-
CONFIGURE_ARGS+= --with-logdir=${LOG_DIR}
PLIST_SUB+= LOG_DIR=${LOG_DIR}
@@ -453,13 +446,7 @@ pre-everything::
@sleep 5
.endif
-pre-extract:
-.ifdef(OPTIONS_MESSAGE)
- @${ECHO_CMD} ""
- @${ECHO_CMD} ${OPTIONS_MESSAGE}
- @${ECHO_CMD} ""
- @exit 1
-.endif
+pre-extract: check-options-version
.ifndef(MAINT)
@${ECHO_CMD} ""
@${ECHO_CMD} "Define vars below before make-ing if you need:"
@@ -482,32 +469,6 @@ pre-extract:
@sleep 5
.endif
-.for old_opt in MAILDROP PROCMAIL TRAD_BAYES ALT_BAYES SPAM_SUBJ \
- USER_LOGGING SYSTEM_LOGGING WEBMAIL OPT_IN SAT PARSE_TO_HEADERS \
- BROKEN_MTA BROKEN_ERR_CODES SIGNATURE_HEADERS SIGNATURE_ATACH \
- HOMEDIR_DOT SIGNATURE_LIFE SQLITE QUARANTINE_AGENT WHITELIST \
- POSTGRESQL73 POSTGRESQL74 GRAHAM_BAYES BURTON_BAYES RNB \
- TEST_COND NO_BIAS CHI_SQUARE RPV
-. if defined(WITH_${old_opt}) || defined(WITHOUT_${old_opt})
- @${ECHO_CMD} ""
- @${ECHO_CMD} "******************************************************************"
- @${ECHO_CMD} "******************************************************************"
- @${ECHO_CMD} "Either:"
- @${ECHO_CMD} "an old option ${old_opt} or an old"
- @${ECHO_CMD} "OPTIONS config-file ${_OPTIONS_READ} has been detected !!!"
- @${ECHO_CMD} "Trying to prevent self-shooting this port's make ends here."
- @${ECHO_CMD} "You shold always read ${PORTSDIR}/UPDATING before installing/updating"
- @${ECHO_CMD} "any port. Please remove/adjust your pkgtools.conf, environment and"
- @${ECHO_CMD} "your make command-line and/or do 'make rmconfig' as appropiate."
- @${ECHO_CMD} "But before read ${FILESDIR}/UPDATING"
- @${ECHO_CMD} "as a lot of things have changed.
- @${ECHO_CMD} "******************************************************************"
- @${ECHO_CMD} "******************************************************************"
- @${ECHO_CMD} ""
- @${FALSE}
-. endif
-.endfor
-
post-patch:
@${REINPLACE_CMD} -e 's|where @a-14 > to_days(created_on);|where @a-${SIGNATURE_LIFE} > to_days(created_on);|' \
${WRKSRC}/src/tools.mysql_drv/purge.sql
@@ -568,7 +529,7 @@ pre-configure:
@${FALSE}
.endif
.ifdef(SNAP_DATE)
- @${ECHO_CMD} "You can safely ignore the following auto* errors"
+ @${ECHO_CMD} "You can safely ignore the following auto* errors"
@(cd ${WRKSRC} && ${SETENV} ${CONFIGURE_ENV} ./autogen.sh)
.endif
@@ -658,4 +619,12 @@ post-install:
@${ECHO_CMD} "message in ${DOCSDIR}/README.FreeBSD"
@${ECHO_CMD}
+check-options-version:
+.ifdef(_OPTIONS_READ)
+ @(if ${PKG_VERSION} -t ${_OPTIONS_READ} ${MIN_OPTIONS_VER} | ${GREP} -q '<'; \
+ then ${ECHO_CMD} "You have unsupported (old) OPTIONS, please do a 'make config; make'\n" \
+ exit 1; \
+ fi)
+.endif
+
.include <bsd.port.post.mk>
diff --git a/mail/dspam-devel/distinfo b/mail/dspam-devel/distinfo
index 750c481db666..d845347db444 100644
--- a/mail/dspam-devel/distinfo
+++ b/mail/dspam-devel/distinfo
@@ -1,3 +1,3 @@
-MD5 (dspam-devel-3.6.3.20060203.1409.tar.gz) = 31a970ba8cf8b7a9aa1d45db04127bda
-SHA256 (dspam-devel-3.6.3.20060203.1409.tar.gz) = 556cc67532ef9a1110541aee24aea8a84684d34179a670b1e6320ed97908b8a7
-SIZE (dspam-devel-3.6.3.20060203.1409.tar.gz) = 391316
+MD5 (dspam-devel-3.6.3.20060208.1807.tar.gz) = 333138bb844a6fb6f8515500c7a52286
+SHA256 (dspam-devel-3.6.3.20060208.1807.tar.gz) = 361897b8704114411a19ab67765ea1fc9072bb34bceb578ad14d37f14b009a49
+SIZE (dspam-devel-3.6.3.20060208.1807.tar.gz) = 393609
diff --git a/mail/dspam-devel/files/UPDATING b/mail/dspam-devel/files/UPDATING
index ed1d9fe53a38..ac64df1314e5 100644
--- a/mail/dspam-devel/files/UPDATING
+++ b/mail/dspam-devel/files/UPDATING
@@ -11,6 +11,18 @@ in the port directory:
make extract; more `find . -type f -maxdepth 2 -name UPGRADING`
###########################################################################
+# dspam-devel-3.6.3.20060208.1807
+#
+
+WebUI:
+- undo option for retraining
+- support for existing storeFragments option to recall message in history
+
+Documentation:
+- of all user preferences in the README.
+
+
+###########################################################################
# dspam-devel-3.6.3.20060203.1409
#
diff --git a/mail/dspam-devel/files/dspam-devel.sh.in b/mail/dspam-devel/files/dspam-devel.sh.in
index 78bec67d8320..1857a01f6f01 100644
--- a/mail/dspam-devel/files/dspam-devel.sh.in
+++ b/mail/dspam-devel/files/dspam-devel.sh.in
@@ -1,7 +1,7 @@
#!/bin/sh
# $FreeBSD$
# formerly $ FreeBSD: ports/mail/dspam-devel/files/dspam.rc,v 1.2 2005/02/25 03:09:26 leeym Exp $
-# $Tecnik: ports/mail/dspam-devel/files/dspam-devel.sh.in,v 1.5 2006/02/03 13:56:46 itetcu Exp $
+# $Tecnik: ports/mail/dspam-devel/files/dspam-devel.sh.in,v 1.6 2006/02/07 20:42:07 itetcu Exp $
# PROVIDE: dspam
# REQUIRE: DAEMON %%MYSQL%% %%PGSQL%% %%CLAMD%%