aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Li <pat@FreeBSD.org>2002-01-15 23:28:29 +0000
committerPatrick Li <pat@FreeBSD.org>2002-01-15 23:28:29 +0000
commitc93e2468f6a42e35bf3889e70926a9ff6ab2bad0 (patch)
tree65b50b7794a05bb98cabc827bebe67de39c5df13
parentf5ee20dc56c81ad887714e72d9dd551e843c889f (diff)
downloadports-c93e2468f6a42e35bf3889e70926a9ff6ab2bad0.tar.gz
ports-c93e2468f6a42e35bf3889e70926a9ff6ab2bad0.zip
Notes
-rw-r--r--astro/Makefile1
-rw-r--r--astro/wmjupiter/Makefile27
-rw-r--r--astro/wmjupiter/distinfo1
-rw-r--r--astro/wmjupiter/files/patch-Makefile22
-rw-r--r--astro/wmjupiter/pkg-comment1
-rw-r--r--astro/wmjupiter/pkg-descr11
-rw-r--r--astro/wmjupiter/pkg-plist1
7 files changed, 64 insertions, 0 deletions
diff --git a/astro/Makefile b/astro/Makefile
index 4d584da085c1..66ae06aded71 100644
--- a/astro/Makefile
+++ b/astro/Makefile
@@ -35,6 +35,7 @@
SUBDIR += sunclock
SUBDIR += tkseti
SUBDIR += wmglobe
+ SUBDIR += wmjupiter
SUBDIR += wmmoonclock
SUBDIR += wmspaceweather
SUBDIR += wmsun
diff --git a/astro/wmjupiter/Makefile b/astro/wmjupiter/Makefile
new file mode 100644
index 000000000000..312b3da3bdaa
--- /dev/null
+++ b/astro/wmjupiter/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: wmjupiter
+# Date created: Tue Jan 15 17:28:49 EST 2002
+# Whom: pat
+#
+# $FreeBSD$
+#
+
+PORTNAME= wmjupiter
+PORTVERSION= 1.1
+CATEGORIES= astro windowmaker
+MASTER_SITES= http://www.inxsoft.net/wmjupiter/
+
+MAINTAINER= pat@FreeBSD.org
+
+WRKSRC= ${WRKDIR}/wmJupiter
+USE_X_PREFIX= yes
+USE_XPM= yes
+USE_GMAKE= yes
+
+pre-patch:
+ @${PERL} -pi.orig -e 's|values.h|float.h|; s|MAXDOUBLE|DBL_MAX|g' \
+ ${WRKSRC}/wmJupiter.c
+
+do-install:
+ @${INSTALL_PROGRAM} ${WRKSRC}/wmJupiter ${PREFIX}/bin
+
+.include <bsd.port.mk>
diff --git a/astro/wmjupiter/distinfo b/astro/wmjupiter/distinfo
new file mode 100644
index 000000000000..4816118bd37f
--- /dev/null
+++ b/astro/wmjupiter/distinfo
@@ -0,0 +1 @@
+MD5 (wmjupiter-1.1.tar.gz) = 7a28fefc981fdf062ff229cfa9241730
diff --git a/astro/wmjupiter/files/patch-Makefile b/astro/wmjupiter/files/patch-Makefile
new file mode 100644
index 000000000000..114129bd213a
--- /dev/null
+++ b/astro/wmjupiter/files/patch-Makefile
@@ -0,0 +1,22 @@
+--- Makefile.orig Wed Jan 9 11:31:34 2002
++++ Makefile Tue Jan 15 17:40:12 2002
+@@ -1,8 +1,6 @@
+-CC = gcc
+-CFLAGS = -O2 -Wall
+-INCDIR = -I/usr/X11R6/include/X11 -I/usr/X11R6/include
++INCDIR = -I${X11BASE}/include
+ DESTDIR= /usr/X11R6
+-LIBDIR = -L/usr/X11R6/lib
++LIBDIR = -L${X11BASE}/lib
+ # for linux
+ LIBS = -lXpm -lX11 -lXext -lm
+ # for Solaris
+@@ -12,7 +10,7 @@
+
+
+ .c.o:
+- $(CC) $(CFLAGS) -D$(shell echo `uname -s`) -c $< -o $*.o $(INCDIR)
++ $(CC) $(CFLAGS) -c $< -o $*.o $(INCDIR)
+
+
+ all: wmJupiter.o wmJupiter
diff --git a/astro/wmjupiter/pkg-comment b/astro/wmjupiter/pkg-comment
new file mode 100644
index 000000000000..6bd5c79aa68a
--- /dev/null
+++ b/astro/wmjupiter/pkg-comment
@@ -0,0 +1 @@
+Dockapp that displays information on jupiter
diff --git a/astro/wmjupiter/pkg-descr b/astro/wmjupiter/pkg-descr
new file mode 100644
index 000000000000..711dbab93d31
--- /dev/null
+++ b/astro/wmjupiter/pkg-descr
@@ -0,0 +1,11 @@
+[from website]
+This dockapp shows you the actual distance of Jupiter in astronomical
+units (AE) and when the red spot crosses (which is a weather feature
+on jupiter). The four Gallileo Moons are displayed too but only
+when they are near the planet (Io, Europa, Ganymede, and Calisto).
+The position of the red spot changes on the surface so you need to
+change that value within few months or so. The current position can
+be found on the internet. It was 80 deg. as of 11th Jan 2002.
+
+WWW: http://www.inxsoft.net/wmjupiter/
+Author: Thomas Kuiper <tkuiper@inxsoft.net>
diff --git a/astro/wmjupiter/pkg-plist b/astro/wmjupiter/pkg-plist
new file mode 100644
index 000000000000..eaf6555a27c5
--- /dev/null
+++ b/astro/wmjupiter/pkg-plist
@@ -0,0 +1 @@
+bin/wmJupiter