aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOliver Lehmann <oliver@FreeBSD.org>2010-04-19 10:59:37 +0000
committerOliver Lehmann <oliver@FreeBSD.org>2010-04-19 10:59:37 +0000
commitcf6cee91ef51b5c7130430c3929b477b93c47446 (patch)
tree47c243a465f15667ff23e82181e4f6cc45052a11
parentbf330a57d40cb5c6f57f61de4d24c0dcbf14dbee (diff)
downloadports-cf6cee91ef51b5c7130430c3929b477b93c47446.tar.gz
ports-cf6cee91ef51b5c7130430c3929b477b93c47446.zip
Notes
-rw-r--r--audio/audacious-dumb/Makefile2
-rw-r--r--audio/mp3splt-gtk/Makefile7
-rw-r--r--audio/wmauda/Makefile5
-rw-r--r--audio/xmp/Makefile1
-rw-r--r--multimedia/audacious-plugins/Makefile36
-rw-r--r--multimedia/audacious-plugins/distinfo6
-rw-r--r--multimedia/audacious-plugins/pkg-plist10
-rw-r--r--multimedia/audacious/Makefile3
-rw-r--r--multimedia/audacious/distinfo6
-rw-r--r--multimedia/audacious/files/patch-src-audacious-Makefile48
-rw-r--r--multimedia/audacious/pkg-plist13
-rw-r--r--multimedia/tunapie/Makefile2
-rw-r--r--multimedia/xfce4-xmms-plugin/Makefile2
-rw-r--r--sysutils/conky/Makefile2
-rw-r--r--x11-themes/audacious-skins/Makefile2
15 files changed, 63 insertions, 82 deletions
diff --git a/audio/audacious-dumb/Makefile b/audio/audacious-dumb/Makefile
index b4b6e72b25bd..b2ce92db3d43 100644
--- a/audio/audacious-dumb/Makefile
+++ b/audio/audacious-dumb/Makefile
@@ -7,7 +7,7 @@
PORTNAME= audacious-dumb
PORTVERSION= 0.62
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= audio
MASTER_SITES= http://www.netswarm.net/misc/ \
CRITICAL
diff --git a/audio/mp3splt-gtk/Makefile b/audio/mp3splt-gtk/Makefile
index cb5f213d90f4..0e198e3c81a4 100644
--- a/audio/mp3splt-gtk/Makefile
+++ b/audio/mp3splt-gtk/Makefile
@@ -6,7 +6,7 @@
PORTNAME= mp3splt-gtk
PORTVERSION= 0.5.7a
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= audio
MASTER_SITES= SF/mp3splt/${PORTNAME}/${PORTVERSION}
@@ -29,4 +29,9 @@ CONFIGURE_ARGS+= --enable-audacious --with-mp3splt=${LOCALBASE} --with-mp3splt-i
MAN1= mp3splt-gtk.1
+post-patch:
+ @${REINPLACE_CMD} -e 's|"audacious |& audclient |g' \
+ ${WRKSRC}/configure
+
+
.include <bsd.port.mk>
diff --git a/audio/wmauda/Makefile b/audio/wmauda/Makefile
index e68b777f72e9..86d7bea66675 100644
--- a/audio/wmauda/Makefile
+++ b/audio/wmauda/Makefile
@@ -7,7 +7,7 @@
PORTNAME= wmauda
PORTVERSION= 0.7
-PORTREVISION= 7
+PORTREVISION= 8
CATEGORIES= audio windowmaker
MASTER_SITES= http://www.netswarm.net/misc/ \
${MASTER_SITE_GENTOO}
@@ -33,7 +33,8 @@ MAN1= wmauda.1
post-patch:
@${REINPLACE_CMD} -E 's,^(MANPAGE_DIR.*):=,\1\?=,; \
- s,^(LIBS.*):=,\1\+=,' \
+ s,^(LIBS.*):=,\1\+=,; \
+ s,audacious,& audclient,' \
${WRKSRC}/Makefile
@${REINPLACE_CMD} -e 's,/usr/share/pixmaps,${PREFIX}/share/pixmaps,g' \
${WRKSRC}/config.h
diff --git a/audio/xmp/Makefile b/audio/xmp/Makefile
index 4105bbb0c513..fe7303291c11 100644
--- a/audio/xmp/Makefile
+++ b/audio/xmp/Makefile
@@ -7,6 +7,7 @@
PORTNAME= xmp
PORTVERSION= 3.1.0
+PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= audio
MASTER_SITES= SF
diff --git a/multimedia/audacious-plugins/Makefile b/multimedia/audacious-plugins/Makefile
index 8d7818b5393d..7c92635c2220 100644
--- a/multimedia/audacious-plugins/Makefile
+++ b/multimedia/audacious-plugins/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= audacious-plugins
-PORTVERSION= 2.2
-PORTREVISION= 5
+PORTVERSION= 2.3
CATEGORIES= multimedia audio
MASTER_SITES= http://distfiles.atheme.org/
EXTRACT_SUFX= .tgz
@@ -60,11 +59,10 @@ OPTIONS= DBUS "Enable dbus support" on \
MMS "Enable mms support" off \
MTP "Enable MTP upload support" off \
PARANORMAL "Enable paranormal vis plugin" on \
- XSPF "Enable XSPF support" on \
GNOME "Build with gnomevfs/gconf support" off \
NLS "Native Language Support" on \
- CURL "curl for lastfm/scrobbler support" off \
- SSE2 "Enable SSE2 support" on
+ SSE2 "Enable SSE2 support" on \
+ RESAMPLE "Enable resample support" off
.include <bsd.port.pre.mk>
@@ -301,33 +299,26 @@ CONFIGURE_ARGS+=--disable-mtp_up
PLIST_SUB+= MTPPLUGIN="@comment "
.endif
-.if !defined(WITHOUT_XSPF)
-USE_GNOME+= libxml2
-CONFIGURE_ARGS+=--enable-xspf
-PLIST_SUB+= XSPFPLUGIN=""
-.else
-CONFIGURE_ARGS+=--disable-xspf
-PLIST_SUB+= XSPFPLUGIN="@comment "
-.endif
-
.if defined(WITH_GNOME)
USE_GNOME+= gnomevfs2 gconf2
CONFIGURE_ARGS+=--enable-gnome-vfs --enable-gconf
.endif
-.if !defined(WITHOUT_CURL) || exists(${LOCALBASE}/lib/libcurl.so)
-LIB_DEPENDS+= curl.6:${PORTSDIR}/ftp/curl
-PLIST_SUB+= CURLPLUGIN=""
-.else
-PLIST_SUB+= CURLPLUGIN="@comment "
-.endif
-
.if !defined(WITHOUT_SSE2)
CONFIGURE_ARGS+=--disable-sse2
.else
CONFIGURE_ARGS+=--enable-sse2
.endif
+.if !defined(WITHOUT_RESAMPLE)
+LIB_DEPENDS+= samplerate.1:${PORTSDIR}/audio/libsamplerate
+CONFIGURE_ARGS+=--enable-resample
+PLIST_SUB+= RESAMPLEPLUGIN=""
+.else
+CONFIGURE_ARGS+=--disable-resample
+PLIST_SUB+= RESAMPLEPLUGIN="@comment "
+.endif
+
.if !defined(WITHOUT_NLS)
USE_GETTEXT= yes
CONFIGURE_ARGS+=--enable-nls
@@ -347,6 +338,9 @@ pre-everything::
post-patch:
@${REINPLACE_CMD} -e 's|$$EGREP|egrep|g; \
s| -ldl||g' ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e 's|malloc\.h|stdlib\.h|g' \
+ ${WRKSRC}/src/neon/cert_verification.c \
+ ${WRKSRC}/src/usf/memory.c
pre-configure:
.if defined(WITH_AUDIOCD) && !exists(${LOCALBASE}/lib/libcdio_cdda.so)
diff --git a/multimedia/audacious-plugins/distinfo b/multimedia/audacious-plugins/distinfo
index 0fa721069fc0..006ecd604d0d 100644
--- a/multimedia/audacious-plugins/distinfo
+++ b/multimedia/audacious-plugins/distinfo
@@ -1,3 +1,3 @@
-MD5 (audacious-plugins-2.2.tgz) = ed6790bf5667c824eda72301f0a886a8
-SHA256 (audacious-plugins-2.2.tgz) = aee812b34aa057bfff9e38dda29f1261e8e8cbdde65cf5fe553ab6b6a9ae33c8
-SIZE (audacious-plugins-2.2.tgz) = 3135776
+MD5 (audacious-plugins-2.3.tgz) = de350b7612ff42e3719ae19a36389118
+SHA256 (audacious-plugins-2.3.tgz) = 7da44d2aaccceea6ad838a8b677abd5f3e5e10ad168f6f478d3e5e2c4aacaa41
+SIZE (audacious-plugins-2.3.tgz) = 3273590
diff --git a/multimedia/audacious-plugins/pkg-plist b/multimedia/audacious-plugins/pkg-plist
index d565a8e43959..6d1e0f7bbc7a 100644
--- a/multimedia/audacious-plugins/pkg-plist
+++ b/multimedia/audacious-plugins/pkg-plist
@@ -1,20 +1,21 @@
lib/audacious/Container/m3u.so
lib/audacious/Container/pls.so
-%%XSPFPLUGIN%%lib/audacious/Container/xspf.so
-lib/audacious/Effect/audiocompress.so
+lib/audacious/Container/xspf.so
+lib/audacious/Effect/compressor.so
lib/audacious/Effect/crystalizer.so
lib/audacious/Effect/ladspa.so
lib/audacious/Effect/echo.so
+%%RESAMPLEPLUGIN%%lib/audacious/Effect/resample.so
lib/audacious/Effect/sndstretch.so
lib/audacious/Effect/stereo.so
lib/audacious/Effect/voice_removal.so
lib/audacious/General/alarm.so
%%AOSDPLUGIN%%lib/audacious/General/aosd.so
+%%CDAUDIOPLUGIN%%lib/audacious/General/cd-menu-items.so
%%DBUS%%lib/audacious/General/gnomeshortcuts.so
lib/audacious/General/gtkui.so
lib/audacious/General/hotkey.so
%%LIRCPLUGIN%%lib/audacious/General/lirc.so
-%%CURLPLUGIN%%lib/audacious/General/scrobbler.so
lib/audacious/General/skins.so
lib/audacious/General/song_change.so
%%STATUSICONPLUGIN%%lib/audacious/General/statusicon.so
@@ -86,8 +87,6 @@ lib/audacious/Visualization/spectrum.so
%%PARANORMALPLUGIN%%share/audacious/paranormal/Presets/nenolod_-_worms.pnv
%%PARANORMALPLUGIN%%share/audacious/paranormal/Presets/ticpu_-_colored_beat-o-scope.pnv
%%PARANORMALPLUGIN%%share/audacious/paranormal/Presets/aerdan_-_bloody_vortex.pnv
-%%CURLPLUGIN%%share/audacious/images/audioscrobbler.png
-%%CURLPLUGIN%%share/audacious/images/audioscrobbler_badge.png
share/audacious/images/bookmarks.png
share/audacious/images/shoutcast.png
share/audacious/images/streambrowser-16x16.png
@@ -312,6 +311,7 @@ share/audacious/Skins/TinyPlayer/volume.png
%%NLS%%share/locale/cy/LC_MESSAGES/audacious-plugins.mo
%%NLS%%share/locale/de/LC_MESSAGES/audacious-plugins.mo
%%NLS%%share/locale/et/LC_MESSAGES/audacious-plugins.mo
+%%NLS%%share/locale/eu/LC_MESSAGES/audacious-plugins.mo
%%NLS%%share/locale/fr/LC_MESSAGES/audacious-plugins.mo
%%NLS%%share/locale/ja/LC_MESSAGES/audacious-plugins.mo
%%NLS%%share/locale/lv/LC_MESSAGES/audacious-plugins.mo
diff --git a/multimedia/audacious/Makefile b/multimedia/audacious/Makefile
index 648396c504f1..5d23411c85b3 100644
--- a/multimedia/audacious/Makefile
+++ b/multimedia/audacious/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= audacious
-PORTVERSION= 2.2
-PORTREVISION= 2
+PORTVERSION= 2.3
CATEGORIES= multimedia audio
MASTER_SITES= http://distfiles.atheme.org/
MASTER_SITE_SUBDIR=oliver
diff --git a/multimedia/audacious/distinfo b/multimedia/audacious/distinfo
index 91717f312251..7b156aaa517c 100644
--- a/multimedia/audacious/distinfo
+++ b/multimedia/audacious/distinfo
@@ -1,3 +1,3 @@
-MD5 (audacious-2.2.tgz) = ad0f7484692c529acfa91ce784170478
-SHA256 (audacious-2.2.tgz) = f15af7a90085e7be86f7f876a8e74a5ba03385880a165c4b2033944219213bea
-SIZE (audacious-2.2.tgz) = 1581717
+MD5 (audacious-2.3.tgz) = b65753880c6762cdad6423df48590304
+SHA256 (audacious-2.3.tgz) = b19b3a75d4bac535231a77b6f993519b599a9619ac46c4d5627fd2bc8337416f
+SIZE (audacious-2.3.tgz) = 1564114
diff --git a/multimedia/audacious/files/patch-src-audacious-Makefile b/multimedia/audacious/files/patch-src-audacious-Makefile
index 3afc0b9c871d..d05e3d1e733d 100644
--- a/multimedia/audacious/files/patch-src-audacious-Makefile
+++ b/multimedia/audacious/files/patch-src-audacious-Makefile
@@ -1,53 +1,39 @@
---- src/audacious/Makefile.orig 2009-07-07 00:39:12.000000000 +0200
-+++ src/audacious/Makefile 2009-07-18 09:41:46.000000000 +0200
-@@ -127,15 +127,8 @@
-
+--- src/audacious/Makefile.orig 2010-04-06 22:01:24.000000000 +0200
++++ src/audacious/Makefile 2010-04-17 13:02:28.000000000 +0200
+@@ -108,14 +108,15 @@
include ../../buildsys.mk
--ifeq ($(USE_DBUS),yes)
+ ifeq ($(USE_DBUS),yes)
-CPPFLAGS += -I../libaudclient
--DBUS_BINDINGS = dbus-server-bindings.h dbus-client-bindings.h
++CPPFLAGS = -I../libaudclient
+ DBUS_BINDINGS = dbus-server-bindings.h dbus-client-bindings.h
-LIBS += -L../libaudclient -laudclient
--endif
--
--pre-depend: ${DBUS_BINDINGS}
--
--CPPFLAGS += -DHAVE_CONFIG_H \
-+CPPFLAGS = -I.. -I../.. \
-+ -DHAVE_CONFIG_H \
++LIBS = -L../libaudclient -laudclient
+ endif
+
+ pre-depend: ${DBUS_BINDINGS}
+
+ CPPFLAGS += -DHAVE_CONFIG_H \
++ -I.. -I../.. \
${MOWGLI_CFLAGS} \
${GLIB_CFLAGS} \
${GTHREAD_CFLAGS} \
-@@ -149,13 +142,12 @@
- ${SIMD_CFLAGS} \
- -D_AUDACIOUS_CORE \
- ${EGGSM_CFLAGS} \
-- -I.. -I../.. \
- -I./intl \
+@@ -133,7 +134,7 @@
-I. \
- -I../libSAD \
-I../libaudcore
-LIBS += ${LDADD} \
-+LIBS = \
++LIBS += \
-L../libaudcore -laudcore \
${LIBINTL} \
- ${SAMPLERATE_LIBS} \
-@@ -168,7 +160,16 @@
+ ../libguess/libguess.a \
+@@ -144,7 +145,8 @@
${DBUS_LIBS} \
${MOWGLI_LIBS} \
${LIBMCS_LIBS} \
- ${REGEX_LIBS}
+ ${REGEX_LIBS} \
+ ${LDADD}
-+
-+ifeq ($(USE_DBUS),yes)
-+CPPFLAGS += -I../libaudclient
-+DBUS_BINDINGS = dbus-server-bindings.h dbus-client-bindings.h
-+LIBS += -L../libaudclient -laudclient
-+endif
-+
-+pre-depend: ${DBUS_BINDINGS}
LDFLAGS += ${PROG_IMPLIB_LDFLAGS} ${AUDLDFLAGS}
diff --git a/multimedia/audacious/pkg-plist b/multimedia/audacious/pkg-plist
index 5819fbae80a6..4305ec2c39ab 100644
--- a/multimedia/audacious/pkg-plist
+++ b/multimedia/audacious/pkg-plist
@@ -6,7 +6,6 @@ bin/audacious2
include/audacious/audconfig.h
include/audacious/auddrct.h
include/audacious/configdb.h
-include/audacious/custom_uri.h
include/audacious/dbus.h
include/audacious/dbus-service.h
include/audacious/equalizer_preset.h
@@ -18,7 +17,6 @@ include/audacious/id3tag.h
include/audacious/input.h
include/audacious/interface.h
include/audacious/main.h
-include/audacious/mime.h
include/audacious/output.h
include/audacious/playback.h
include/audacious/playlist_container.h
@@ -29,9 +27,7 @@ include/audacious/ui_fileinfopopup.h
include/audacious/ui_plugin_menu.h
include/audacious/ui_preferences.h
include/audacious/util.h
-include/libSAD/libSAD.h
-include/libSAD/common.h
-include/libSAD/dither.h
+include/libaudcore/audio.h
include/libaudcore/audstrings.h
include/libaudcore/index.h
include/libaudcore/stringpool.h
@@ -44,6 +40,7 @@ include/libaudcore/vfs.h
include/libaudcore/vfs_buffer.h
include/libaudcore/vfs_buffered_file.h
include/libaudgui/libaudgui.h
+include/libaudgui/libaudgui-gtk.h
include/libaudtag/audtag.h
include/libaudtag/util.h
%%WITH_DBUS%%lib/libaudclient.so
@@ -61,9 +58,6 @@ lib/libaudid3tag.so.2.0.0
lib/libaudtag.so
lib/libaudtag.so.1
lib/libaudtag.so.1.0.0
-lib/libSAD.so
-lib/libSAD.so.2
-lib/libSAD.so.2.0.0
libdata/pkgconfig/audacious.pc
libdata/pkgconfig/audclient.pc
share/applications/audacious2.desktop
@@ -89,6 +83,7 @@ share/applications/audacious2-gtkui.desktop
%%DATADIR%%/ui/mainwin.ui
%%DATADIR%%/ui/player.ui
%%DATADIR%%/ui/playlist.ui
+%%NLS%%share/locale/be/LC_MESSAGES/audacious.mo
%%NLS%%share/locale/bg/LC_MESSAGES/audacious.mo
%%NLS%%share/locale/br/LC_MESSAGES/audacious.mo
%%NLS%%share/locale/ca/LC_MESSAGES/audacious.mo
@@ -113,6 +108,7 @@ share/applications/audacious2-gtkui.desktop
%%NLS%%share/locale/mk/LC_MESSAGES/audacious.mo
%%NLS%%share/locale/nl/LC_MESSAGES/audacious.mo
%%NLS%%share/locale/pl/LC_MESSAGES/audacious.mo
+%%NLS%%share/locale/pt_PT/LC_MESSAGES/audacious.mo
%%NLS%%share/locale/pt_BR/LC_MESSAGES/audacious.mo
%%NLS%%share/locale/ro/LC_MESSAGES/audacious.mo
%%NLS%%share/locale/ru/LC_MESSAGES/audacious.mo
@@ -129,7 +125,6 @@ share/pixmaps/audacious2.png
@dirrm %%DATADIR%%/ui
@dirrmtry %%DATADIR%%
@dirrm include/audacious
-@dirrm include/libSAD
@dirrm include/libaudcore
@dirrm include/libaudgui
@dirrm include/libaudtag
diff --git a/multimedia/tunapie/Makefile b/multimedia/tunapie/Makefile
index a4d3b51018e7..61fa149d7eb1 100644
--- a/multimedia/tunapie/Makefile
+++ b/multimedia/tunapie/Makefile
@@ -7,7 +7,7 @@
PORTNAME= tunapie
PORTVERSION= 2.1.17
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= multimedia audio
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/2.1
DISTNAME= ${PORTNAME}-${PORTVERSION:S,.r,rc,}
diff --git a/multimedia/xfce4-xmms-plugin/Makefile b/multimedia/xfce4-xmms-plugin/Makefile
index dcf9a873802f..bf36de680be7 100644
--- a/multimedia/xfce4-xmms-plugin/Makefile
+++ b/multimedia/xfce4-xmms-plugin/Makefile
@@ -7,7 +7,7 @@
PORTNAME= xfce4-xmms-plugin
PORTVERSION= 0.5.2
-PORTREVISION= 8
+PORTREVISION= 9
CATEGORIES= multimedia audio xfce
MASTER_SITES= http://goodies.xfce.org/releases/${PORTNAME}/
DIST_SUBDIR= xfce4
diff --git a/sysutils/conky/Makefile b/sysutils/conky/Makefile
index d723dc114a75..9fd6cdf8a86f 100644
--- a/sysutils/conky/Makefile
+++ b/sysutils/conky/Makefile
@@ -7,7 +7,7 @@
PORTNAME= conky
PORTVERSION= 1.7.2
-PORTREVISION= 6
+PORTREVISION= 7
CATEGORIES= sysutils
MASTER_SITES= SF
diff --git a/x11-themes/audacious-skins/Makefile b/x11-themes/audacious-skins/Makefile
index 93184ea79ffa..10318b0cebc8 100644
--- a/x11-themes/audacious-skins/Makefile
+++ b/x11-themes/audacious-skins/Makefile
@@ -7,7 +7,7 @@
PORTNAME= audacious-skins
PORTVERSION= 0.1
-PORTREVISION= 6
+PORTREVISION= 7
CATEGORIES= x11-themes
MASTER_SITES= CRITICAL