aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-09-26 23:34:14 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-09-26 23:34:14 +0000
commitd20c85f90e0e22e49454833f617143c47d35ecae (patch)
tree23a81494afbcc7bed4e13d3170c2146401dffd58
parentf7acb6707d288a58daf38b586c5dbb0b74341e98 (diff)
downloadports-d20c85f90e0e22e49454833f617143c47d35ecae.tar.gz
ports-d20c85f90e0e22e49454833f617143c47d35ecae.zip
Notes
-rw-r--r--sysutils/Makefile1
-rw-r--r--sysutils/monkeytail/Makefile40
-rw-r--r--sysutils/monkeytail/distinfo3
-rw-r--r--sysutils/monkeytail/pkg-descr9
4 files changed, 53 insertions, 0 deletions
diff --git a/sysutils/Makefile b/sysutils/Makefile
index fa24fa025a7b..65314a716e99 100644
--- a/sysutils/Makefile
+++ b/sysutils/Makefile
@@ -446,6 +446,7 @@
SUBDIR += modules
SUBDIR += monit
SUBDIR += monitord
+ SUBDIR += monkeytail
SUBDIR += mono-kmod
SUBDIR += most
SUBDIR += mount.app
diff --git a/sysutils/monkeytail/Makefile b/sysutils/monkeytail/Makefile
new file mode 100644
index 000000000000..66ad18ba4807
--- /dev/null
+++ b/sysutils/monkeytail/Makefile
@@ -0,0 +1,40 @@
+# New ports collection makefile for: monkeytail
+# Date created: 2008-09-13
+# Whom: Yi-Jheng Lin <yzlin@cs.nctu.edu.tw>
+#
+# $FreeBSD$
+#
+
+PORTNAME= monkeytail
+PORTVERSION= 0.3.0
+CATEGORIES= sysutils
+MASTER_SITES= http://git.dollyfish.net.nz/releases/${MASTER_SITE_SUBDIR}/
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= yzlin@cs.nctu.edu.tw
+COMMENT= A multi-file tail on both local and remote hosts
+
+RUN_DEPENDS= p5-IO>=0:${PORTSDIR}/devel/p5-IO \
+ ${SITE_PERL}/Config/General.pm:${PORTSDIR}/devel/p5-Config-General \
+ ${SITE_PERL}/Getopt/Declare.pm:${PORTSDIR}/devel/p5-Getopt-Declare
+
+USE_PERL5_RUN= yes
+
+NO_BUILD= yes
+
+PORTDOCS= COPYING README
+PLIST_FILES= bin/mtail
+
+MAN1= mtail.1
+MAN5= mtailrc.5
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/mtail ${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/doc/mtail.1 ${MAN1PREFIX}/man/man1
+ ${INSTALL_MAN} ${WRKSRC}/doc/mtailrc.5 ${MAN5PREFIX}/man/man5
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ ${INSTALL_MAN} ${PORTDOCS:S,^,${WRKSRC}/,} ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/sysutils/monkeytail/distinfo b/sysutils/monkeytail/distinfo
new file mode 100644
index 000000000000..1147d47dc6e6
--- /dev/null
+++ b/sysutils/monkeytail/distinfo
@@ -0,0 +1,3 @@
+MD5 (monkeytail-0.3.0.tar.gz) = 92ce6f85672c4e9654fd8b13f4582936
+SHA256 (monkeytail-0.3.0.tar.gz) = 925eaf4bb7924c3a24891f4725bc583bed21bdaf648e24cd76f9212afd9e0575
+SIZE (monkeytail-0.3.0.tar.gz) = 16486
diff --git a/sysutils/monkeytail/pkg-descr b/sysutils/monkeytail/pkg-descr
new file mode 100644
index 000000000000..a2f205bb8839
--- /dev/null
+++ b/sysutils/monkeytail/pkg-descr
@@ -0,0 +1,9 @@
+tail variant designed for web developers monitoring logfiles
+MonkeyTail allows a user to tail multiple files on both local and remote hosts
+and clearly marks inactivity by putting 5 newlines in the output whenever a
+pause in output over 3 seconds is detected.
+
+MonkeyTail is implemented a fairly simple wrapper script around standard tail,
+ssh, and sudo.
+
+WWW: http://dollyfish.net.nz/projects/monkeytail