aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2006-01-03 01:19:15 +0000
committerMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2006-01-03 01:19:15 +0000
commitd2798fc8cd145a6c038f80856896dceb1f8a61bf (patch)
tree805e1ba9c485a8f5f9faea4afa759850d799e333
parent1c26130210de68c0dba9797c03d46d2a40cbea74 (diff)
downloadports-d2798fc8cd145a6c038f80856896dceb1f8a61bf.tar.gz
ports-d2798fc8cd145a6c038f80856896dceb1f8a61bf.zip
Notes
-rw-r--r--sysutils/Makefile1
-rw-r--r--sysutils/vstrip/Makefile44
-rw-r--r--sysutils/vstrip/distinfo3
-rw-r--r--sysutils/vstrip/files/patch-Makefile27
-rw-r--r--sysutils/vstrip/files/patch-dvd2avi_plugin.c11
-rw-r--r--sysutils/vstrip/pkg-descr16
6 files changed, 102 insertions, 0 deletions
diff --git a/sysutils/Makefile b/sysutils/Makefile
index 0c6987e3a2d0..449c2c491441 100644
--- a/sysutils/Makefile
+++ b/sysutils/Makefile
@@ -557,6 +557,7 @@
SUBDIR += vii
SUBDIR += virtualmin
SUBDIR += vobcopy
+ SUBDIR += vstrip
SUBDIR += vttest
SUBDIR += wait_on
SUBDIR += watchdog
diff --git a/sysutils/vstrip/Makefile b/sysutils/vstrip/Makefile
new file mode 100644
index 000000000000..8cc6bcad1e43
--- /dev/null
+++ b/sysutils/vstrip/Makefile
@@ -0,0 +1,44 @@
+# New ports collection makefile for: vstrip
+# Date created: Mon Jan 2 18:13:03 UTC 2006
+# Whom: Mario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= vstrip
+DISTVERSION= 0.8f
+CATEGORIES= sysutils
+MASTER_SITES= http://files.digital-digest.com/downloads/files/encode/
+DISTNAME= vStrip_${DISTVERSION:C/\.//g}
+
+MAINTAINER= lioux@FreeBSD.org
+COMMENT= A VOB de-multiplexing tool, splitter and VOB/IFO files processor
+
+LIB_DEPENDS= dvdread.3:${PORTSDIR}/multimedia/libdvdread
+
+USE_ZIP= yes
+USE_REINPLACE= yes
+MAKE_ENV= LDFLAGS="${LDFLAGS}"
+WRKSRC= ${WRKDIR}/${PORTNAME}
+
+post-extract:
+ @${FIND} ${WRKSRC} -type f -print0 | \
+ ${XARGS} -0 -x -n 10 \
+ ${REINPLACE_CMD} -E \
+ -e 's|[[:cntrl:]]$$||'
+post-patch:
+ @${REINPLACE_CMD} -E \
+ -e 's|malloc.h|stdlib.h|' \
+ -e 's|<io.h>|<unistd.h>|' \
+ -e 's|__int64[[:space:]]+fposition[[:space:]]*=[[:space:]]*_filelengthi64\(fp\);|off_t fposition=lseek(fp, 0, SEEK_END);|' \
+ ${WRKSRC}/*.c \
+ ${WRKSRC}/*.h
+
+LDFLAGS+= -lm
+
+PLIST_FILES= bin/${PORTNAME}
+
+do-install:
+ @${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
+
+.include <bsd.port.mk>
diff --git a/sysutils/vstrip/distinfo b/sysutils/vstrip/distinfo
new file mode 100644
index 000000000000..35c8a48a1833
--- /dev/null
+++ b/sysutils/vstrip/distinfo
@@ -0,0 +1,3 @@
+MD5 (vStrip_08f.zip) = 7bb1fd2cca6517d4d51e30456a58448d
+SHA256 (vStrip_08f.zip) = 0813be0b20ab7eeacd7213df7fe1704ef6070471c953a705391d82bba78e8fff
+SIZE (vStrip_08f.zip) = 409157
diff --git a/sysutils/vstrip/files/patch-Makefile b/sysutils/vstrip/files/patch-Makefile
new file mode 100644
index 000000000000..42f744e390ac
--- /dev/null
+++ b/sysutils/vstrip/files/patch-Makefile
@@ -0,0 +1,27 @@
+--- Makefile.orig Mon Jan 2 17:38:10 2006
++++ Makefile Mon Jan 2 17:42:28 2006
+@@ -1,10 +1,10 @@
+-CFLAGS := -W -Wall -O2 -D__UNIX__
+-CC := gcc
++CFLAGS += -D__UNIX__
+
+
+ ### Sources
+
+ SOURCE_FILES=file_io.h file_io.c in_buffer.h in_buffer.c parse_ifo.h parse_ifo.c s_types.h main.c vstrip.h vstrip.c
++SOURCE_FILES+=dvd2avi_plugin.c
+
+ ### Objects and executables
+
+@@ -27,8 +27,9 @@
+
+ ### Details
+
+-vstrip : file_io.o in_buffer.o main.o parse_ifo.o vstrip.o
+- $(CC) -g file_io.o in_buffer.o main.o parse_ifo.o vstrip.o -o vstrip
++vstrip : file_io.o in_buffer.o main.o parse_ifo.o vstrip.o \
++ dvd2avi_plugin.o
++ $(CC) $(LDFLAGS) file_io.o in_buffer.o main.o parse_ifo.o vstrip.o dvd2avi_plugin.o -o vstrip
+ file_io.o : s_types.h file_io.h file_io.c
+ in_buffer.o : s_types.h file_io.h in_buffer.h in_buffer.c
+ main.o : s_types.h file_io.h vstrip.h main.c
diff --git a/sysutils/vstrip/files/patch-dvd2avi_plugin.c b/sysutils/vstrip/files/patch-dvd2avi_plugin.c
new file mode 100644
index 000000000000..1a44b595ffd9
--- /dev/null
+++ b/sysutils/vstrip/files/patch-dvd2avi_plugin.c
@@ -0,0 +1,11 @@
+--- dvd2avi_plugin.c.orig Mon Jan 2 17:49:31 2006
++++ dvd2avi_plugin.c Mon Jan 2 17:49:53 2006
+@@ -13,6 +13,8 @@
+ #include "vstrip.h"
+ #include "dvd2avi_plugin.h"
+
++#define max(a,b) ((a) >= (b) ? (a) : (b))
++
+ bool dvd2avi_process(byte *data, tp_vs_streaminfo const si, void *user_data)
+ {
+ t_dvd2avi* d2v = (t_dvd2avi *)user_data;
diff --git a/sysutils/vstrip/pkg-descr b/sysutils/vstrip/pkg-descr
new file mode 100644
index 000000000000..1802c6712bf7
--- /dev/null
+++ b/sysutils/vstrip/pkg-descr
@@ -0,0 +1,16 @@
+[ excerpt from developer's www site with modifications ]
+
+vStrip is a VOB de-multiplexing tool, splitter and some other
+functions that work on VOB/IFO files.
+
+vStrip is a small command-line utility for stripping (=removing)
+unwanted streams (=data packets) out of VOBs (Video Objects) without
+having to reweave the VOB, or extracting the data contained inside
+a single stream.
+
+It also parses IFO-files so it (hopefully) doesn't get confused by
+multi-angle VOBs.
+
+WWW: http://www.digital-digest.com/dvd/downloads/showsoftware_vstrip_80.html
+
+-- lioux@FreeBSD.org