aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Pentchev <roam@FreeBSD.org>2001-10-15 14:00:24 +0000
committerPeter Pentchev <roam@FreeBSD.org>2001-10-15 14:00:24 +0000
commitd348593ca6a9bd80dc8062857e10319a2baa178e (patch)
treecec7b91637ffbf33753559df68f2ffe5c7cd141a
parent5adaaaa27032d82b3eed0de11490a4c1528a8f59 (diff)
downloadports-d348593ca6a9bd80dc8062857e10319a2baa178e.tar.gz
ports-d348593ca6a9bd80dc8062857e10319a2baa178e.zip
Notes
-rw-r--r--net-mgmt/netqc/Makefile33
-rw-r--r--net-mgmt/netqc/distinfo1
-rw-r--r--net-mgmt/netqc/pkg-comment1
-rw-r--r--net-mgmt/netqc/pkg-descr5
-rw-r--r--net-mgmt/netqc/pkg-plist5
-rw-r--r--net/Makefile1
-rw-r--r--net/netqc/Makefile33
-rw-r--r--net/netqc/distinfo1
-rw-r--r--net/netqc/pkg-comment1
-rw-r--r--net/netqc/pkg-descr5
-rw-r--r--net/netqc/pkg-plist5
11 files changed, 91 insertions, 0 deletions
diff --git a/net-mgmt/netqc/Makefile b/net-mgmt/netqc/Makefile
new file mode 100644
index 000000000000..5712028770f3
--- /dev/null
+++ b/net-mgmt/netqc/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: netqc
+# Date created: Sep 28 2001
+# Whom: Radoslav Vasilev <rvasilev@uni-svishtov.bg>
+#
+# $FreeBSD$
+#
+
+PORTNAME= netqc
+PORTVERSION= 1.2.1
+CATEGORIES= net
+MASTER_SITES= http://web.uni-svishtov.bg/netqc/
+
+MAINTAINER= rvasilev@uni-svishtov.bg
+
+LIB_DEPENDS= mysqlclient.10:${PORTSDIR}/databases/mysql323-client \
+ snmp.4:${PORTSDIR}/net/net-snmp
+
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+MAN1= netqc.1
+DOCFILES= COPYING README
+
+post-install:
+ ${INSTALL_DATA} ${WRKSRC}/conf ${PREFIX}/etc/netqc.conf.sample
+.for file in ${MAN1}
+ ${INSTALL_MAN} ${WRKSRC}/${file} ${MANPREFIX}/man/man1/${file}
+.endfor
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${DOCFILES:S,^,${WRKSRC}/,} ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/net-mgmt/netqc/distinfo b/net-mgmt/netqc/distinfo
new file mode 100644
index 000000000000..502c9b86ef74
--- /dev/null
+++ b/net-mgmt/netqc/distinfo
@@ -0,0 +1 @@
+MD5 (netqc-1.2.1.tar.gz) = bdd25cb501dfdd8a6c6bcd8555b1414b
diff --git a/net-mgmt/netqc/pkg-comment b/net-mgmt/netqc/pkg-comment
new file mode 100644
index 000000000000..98aba65b4172
--- /dev/null
+++ b/net-mgmt/netqc/pkg-comment
@@ -0,0 +1 @@
+Network Monitoring System based on Net-Snmp
diff --git a/net-mgmt/netqc/pkg-descr b/net-mgmt/netqc/pkg-descr
new file mode 100644
index 000000000000..d26aa6be1161
--- /dev/null
+++ b/net-mgmt/netqc/pkg-descr
@@ -0,0 +1,5 @@
+Network Monitoring System based on Net-snmp package.
+Netqc monitores preconfigured entities using SNMP protocol(v1,v2c,v3).
+It watches for degined ``events'' (onSame, onChange, onNonZero..) and
+react with different ``actions'' like logging (mysql, netqc-log file) &
+notification.
diff --git a/net-mgmt/netqc/pkg-plist b/net-mgmt/netqc/pkg-plist
new file mode 100644
index 000000000000..d53b5a3afd0b
--- /dev/null
+++ b/net-mgmt/netqc/pkg-plist
@@ -0,0 +1,5 @@
+bin/netqc
+etc/netqc.conf.sample
+%%PORTDOCS%%share/doc/netqc/COPYING
+%%PORTDOCS%%share/doc/netqc/README
+%%PORTDOCS%%@dirrm share/doc/netqc
diff --git a/net/Makefile b/net/Makefile
index 2b17760a654d..f56ff4894805 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -227,6 +227,7 @@
SUBDIR += netcat
SUBDIR += netmask
SUBDIR += netpipes
+ SUBDIR += netqc
SUBDIR += netsaint
SUBDIR += netsaint-plugins
SUBDIR += netscript
diff --git a/net/netqc/Makefile b/net/netqc/Makefile
new file mode 100644
index 000000000000..5712028770f3
--- /dev/null
+++ b/net/netqc/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: netqc
+# Date created: Sep 28 2001
+# Whom: Radoslav Vasilev <rvasilev@uni-svishtov.bg>
+#
+# $FreeBSD$
+#
+
+PORTNAME= netqc
+PORTVERSION= 1.2.1
+CATEGORIES= net
+MASTER_SITES= http://web.uni-svishtov.bg/netqc/
+
+MAINTAINER= rvasilev@uni-svishtov.bg
+
+LIB_DEPENDS= mysqlclient.10:${PORTSDIR}/databases/mysql323-client \
+ snmp.4:${PORTSDIR}/net/net-snmp
+
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+MAN1= netqc.1
+DOCFILES= COPYING README
+
+post-install:
+ ${INSTALL_DATA} ${WRKSRC}/conf ${PREFIX}/etc/netqc.conf.sample
+.for file in ${MAN1}
+ ${INSTALL_MAN} ${WRKSRC}/${file} ${MANPREFIX}/man/man1/${file}
+.endfor
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${DOCFILES:S,^,${WRKSRC}/,} ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/net/netqc/distinfo b/net/netqc/distinfo
new file mode 100644
index 000000000000..502c9b86ef74
--- /dev/null
+++ b/net/netqc/distinfo
@@ -0,0 +1 @@
+MD5 (netqc-1.2.1.tar.gz) = bdd25cb501dfdd8a6c6bcd8555b1414b
diff --git a/net/netqc/pkg-comment b/net/netqc/pkg-comment
new file mode 100644
index 000000000000..98aba65b4172
--- /dev/null
+++ b/net/netqc/pkg-comment
@@ -0,0 +1 @@
+Network Monitoring System based on Net-Snmp
diff --git a/net/netqc/pkg-descr b/net/netqc/pkg-descr
new file mode 100644
index 000000000000..d26aa6be1161
--- /dev/null
+++ b/net/netqc/pkg-descr
@@ -0,0 +1,5 @@
+Network Monitoring System based on Net-snmp package.
+Netqc monitores preconfigured entities using SNMP protocol(v1,v2c,v3).
+It watches for degined ``events'' (onSame, onChange, onNonZero..) and
+react with different ``actions'' like logging (mysql, netqc-log file) &
+notification.
diff --git a/net/netqc/pkg-plist b/net/netqc/pkg-plist
new file mode 100644
index 000000000000..d53b5a3afd0b
--- /dev/null
+++ b/net/netqc/pkg-plist
@@ -0,0 +1,5 @@
+bin/netqc
+etc/netqc.conf.sample
+%%PORTDOCS%%share/doc/netqc/COPYING
+%%PORTDOCS%%share/doc/netqc/README
+%%PORTDOCS%%@dirrm share/doc/netqc