aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSteve Price <steve@FreeBSD.org>1998-06-27 01:30:31 +0000
committerSteve Price <steve@FreeBSD.org>1998-06-27 01:30:31 +0000
commitd787371c3884a468504887cce1ee11466a1e339e (patch)
treef85d0c48e1c0a58522320b633fa5e207bc2a8c69
parent8e11d8e08b538a0e2dcd10df0abbf9fcbcb083eb (diff)
downloadports-d787371c3884a468504887cce1ee11466a1e339e.tar.gz
ports-d787371c3884a468504887cce1ee11466a1e339e.zip
Notes
-rw-r--r--www/p5-Apache/Makefile7
-rw-r--r--www/p5-Apache/files/patch-aa4
2 files changed, 5 insertions, 6 deletions
diff --git a/www/p5-Apache/Makefile b/www/p5-Apache/Makefile
index 745c01cc869f..aaf89a21bb0c 100644
--- a/www/p5-Apache/Makefile
+++ b/www/p5-Apache/Makefile
@@ -3,7 +3,7 @@
# Date created: April 26th 1997
# Whom: James FitzGibbon <jfitz@FreeBSD.org>
#
-# $Id: Makefile,v 1.7 1997/12/04 10:54:03 asami Exp $
+# $Id: Makefile,v 1.8 1998/01/25 16:33:23 steve Exp $
#
DISTNAME= mod_perl-1.07
@@ -14,6 +14,8 @@ MASTER_SITE_SUBDIR= Apache
MAINTAINER= jfitz@FreeBSD.ORG
+BUILD_DEPENDS= /nonexistent:${PORTSDIR}/www/apache12:patch
+
USE_PERL5= YES
CONFIGURE_ENV= PORTSDIR=${PORTSDIR} INSTALL_PROGRAM="${INSTALL_PROGRAM}"
MAN3= Apache.3 Apache::Constants.3 Apache::Options.3 \
@@ -24,9 +26,6 @@ MAN3= Apache.3 Apache::Constants.3 Apache::Options.3 \
mod_perl_tuning.3
MANPREFIX= ${PREFIX}/lib/perl5
-pre-configure:
- @ cd ${PORTSDIR}/www/apache && ${MAKE} clean patch
-
do-configure:
@ cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ${CONFIGURE_ENV} ${PREFIX}/bin/perl Makefile.PL
diff --git a/www/p5-Apache/files/patch-aa b/www/p5-Apache/files/patch-aa
index be5daab7feb3..b88da40d2e00 100644
--- a/www/p5-Apache/files/patch-aa
+++ b/www/p5-Apache/files/patch-aa
@@ -13,10 +13,10 @@
-$APACHE_SRC_DEFAULT = $@ ?
- '../apache_x.x/src' :
- $Apache::MyConfig::Setup{Apache_Src} ;
-+opendir( WRKDIR, "$ENV{PORTSDIR}/www/apache/work" ) || die( "Can't open $ENV{PORTSDIR}/www/apache/work: $!\n" );
++opendir( WRKDIR, "$ENV{PORTSDIR}/www/apache12/work" ) || die( "Can't open $ENV{PORTSDIR}/www/apache/work: $!\n" );
+( $srcdir ) = grep( /^apache/, readdir( WRKDIR ) );
+closedir( WRKDIR );
-+$APACHE_SRC_DEFAULT = "$ENV{PORTSDIR}/www/apache/work/" . $srcdir . "/src";
++$APACHE_SRC_DEFAULT = "$ENV{PORTSDIR}/www/apache12/work/" . $srcdir . "/src";
my $PWD = cwd;
my %SSL = (