aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2014-08-19 19:51:01 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2014-08-19 19:51:01 +0000
commitdb54263dde8084bf3ec1b7f8932404d6a512a1cb (patch)
tree1eaf9a6a277e7afb46630e42a4dd5b152aee345e
parent979faff7c192b7fe4fea81af7fcd804529e05dcc (diff)
downloadports-db54263dde8084bf3ec1b7f8932404d6a512a1cb.tar.gz
ports-db54263dde8084bf3ec1b7f8932404d6a512a1cb.zip
Notes
-rw-r--r--misc/getopt/Makefile23
-rw-r--r--misc/getopt/pkg-plist5
2 files changed, 12 insertions, 16 deletions
diff --git a/misc/getopt/Makefile b/misc/getopt/Makefile
index f16c8d9c841c..9b4940da81b8 100644
--- a/misc/getopt/Makefile
+++ b/misc/getopt/Makefile
@@ -4,26 +4,25 @@
PORTNAME= getopt
PORTVERSION= 1.1.5
CATEGORIES= misc
-MASTER_SITES= http://software.frodo.looijaard.name/getopt/files/
+MASTER_SITES= http://software.frodo.looijaard.name/getopt/files/ \
+ LOCAL/sunpoet
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= sunpoetFreeBSD.org
COMMENT= Replacement for getopt(1) that supports GNU-style long options
-USES= gettext gmake
+OPTIONS_DEFINE= DOCS
CFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib -lintl
-MAKE_ENV+= LIBCGETOPT=0
-
-DOCS= Changelog README
-
-OPTIONS_DEFINE= DOCS
+MAKE_ARGS= CC=${CC}
+MAKE_ENV= LIBCGETOPT=0
+USES= gettext gmake
-post-patch:
- ${REINPLACE_CMD} -e 's|CC=gcc|CC=${CC}|' ${WRKSRC}/Makefile
+PORTDOCS= Changelog README
post-install:
- ${MKDIR} ${STAGEDIR}${DOCSDIR}
- cd ${WRKSRC} && ${INSTALL_DATA} ${DOCS} ${STAGEDIR}${DOCSDIR}
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}/
+ cd ${WRKSRC}/ && ${INSTALL_DATA} ${PORTDOCS} ${STAGEDIR}${DOCSDIR}/
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/getopt
.include <bsd.port.mk>
diff --git a/misc/getopt/pkg-plist b/misc/getopt/pkg-plist
index 365a28d3ac18..d396e9fe60f6 100644
--- a/misc/getopt/pkg-plist
+++ b/misc/getopt/pkg-plist
@@ -1,7 +1,5 @@
bin/getopt
-%%PORTDOCS%%%%DOCSDIR%%/Changelog
-%%PORTDOCS%%%%DOCSDIR%%/README
-%%PORTDOCS%%@dirrm %%DOCSDIR%%
+man/man1/getopt.1.gz
share/locale/ca/LC_MESSAGES/getopt.mo
share/locale/cs/LC_MESSAGES/getopt.mo
share/locale/da/LC_MESSAGES/getopt.mo
@@ -27,4 +25,3 @@ share/locale/uk/LC_MESSAGES/getopt.mo
share/locale/vi/LC_MESSAGES/getopt.mo
share/locale/zh_CN/LC_MESSAGES/getopt.mo
share/locale/zh_TW/LC_MESSAGES/getopt.mo
-man/man1/getopt.1.gz