aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey A. Osokin <osa@FreeBSD.org>2016-12-10 18:45:04 +0000
committerSergey A. Osokin <osa@FreeBSD.org>2016-12-10 18:45:04 +0000
commitdde6bea763013f5cf853ee78ed7e964cd1b3b290 (patch)
treeefce9c39be0f34bf6527c78daff8443efa269530
parentaa580bb515baa68c915d14ba23a9d85bb5b89286 (diff)
downloadports-dde6bea763013f5cf853ee78ed7e964cd1b3b290.tar.gz
ports-dde6bea763013f5cf853ee78ed7e964cd1b3b290.zip
Notes
-rw-r--r--www/nginx-devel/Makefile3
-rw-r--r--www/nginx/Makefile3
2 files changed, 6 insertions, 0 deletions
diff --git a/www/nginx-devel/Makefile b/www/nginx-devel/Makefile
index ba13e062b49f..78ac8eb066f1 100644
--- a/www/nginx-devel/Makefile
+++ b/www/nginx-devel/Makefile
@@ -540,6 +540,7 @@ NGINX_HTTP_GEOIP2_VERSION= 2.0
GH_ACCOUNT+= leev:geoip2
GH_PROJECT+= ngx_http_geoip2_module:geoip2
GH_TAGNAME+= ${NGINX_HTTP_GEOIP2_VERSION}:geoip2
+CFLAGS+= "-I${LOCALBASE}/include"
.if !empty(PORT_OPTIONS:MDSO)
CONFIGURE_ARGS+=--add-dynamic-module=${WRKSRC_geoip2}
.else
@@ -788,6 +789,8 @@ CONFIGURE_ARGS+=--add-module=${WRKDIR}/mod_zip-${NGINX_ZIP_VERSION}
.if ${PORT_OPTIONS:MDRIZZLE}
LIB_DEPENDS+= libdrizzle.so:databases/libdrizzle
+CONFIGURE_ENV+= "LIBDRIZZLE_INC=${LOCALBASE}/include"
+CONFIGURE_ENV+= "LIBDRIZZLE_LIB=${LOCALBASE}/lib"
NGINX_DRIZZLE_VERSION= 0.1.9
GH_ACCOUNT+= openresty:drizzle
GH_PROJECT+= drizzle-nginx-module:drizzle
diff --git a/www/nginx/Makefile b/www/nginx/Makefile
index 4ae5706bb76f..4b84d0e512cb 100644
--- a/www/nginx/Makefile
+++ b/www/nginx/Makefile
@@ -535,6 +535,7 @@ NGINX_HTTP_GEOIP2_VERSION= 2.0
GH_ACCOUNT+= leev:geoip2
GH_PROJECT+= ngx_http_geoip2_module:geoip2
GH_TAGNAME+= ${NGINX_HTTP_GEOIP2_VERSION}:geoip2
+CFLAGS+= "-I${LOCALBASE}/include"
.if !empty(PORT_OPTIONS:MDSO)
CONFIGURE_ARGS+=--add-dynamic-module=${WRKSRC_geoip2}
.else
@@ -780,6 +781,8 @@ CONFIGURE_ARGS+=--add-module=${WRKDIR}/mod_zip-${NGINX_ZIP_VERSION}
.if ${PORT_OPTIONS:MDRIZZLE}
LIB_DEPENDS+= libdrizzle.so:databases/libdrizzle
+CONFIGURE_ENV+= "LIBDRIZZLE_INC=${LOCALBASE}/include"
+CONFIGURE_ENV+= "LIBDRIZZLE_LIB=${LOCALBASE}/lib"
NGINX_DRIZZLE_VERSION= 0.1.9
GH_ACCOUNT+= openresty:drizzle
GH_PROJECT+= drizzle-nginx-module:drizzle