aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorErwin Lansing <erwin@FreeBSD.org>2005-07-18 10:34:34 +0000
committerErwin Lansing <erwin@FreeBSD.org>2005-07-18 10:34:34 +0000
commitde58abb96b3df92321086a0bd83e95662a31de26 (patch)
treec4c231376f0da6b1b18e30eaad93637ade44da6a
parentf3fb2dddd747c550fa6bdfb937b63cdf88904f87 (diff)
downloadports-de58abb96b3df92321086a0bd83e95662a31de26.tar.gz
ports-de58abb96b3df92321086a0bd83e95662a31de26.zip
Notes
-rw-r--r--www/Makefile1
-rw-r--r--www/p5-Template-Multilingual/Makefile31
-rw-r--r--www/p5-Template-Multilingual/distinfo2
-rw-r--r--www/p5-Template-Multilingual/pkg-descr16
-rw-r--r--www/p5-Template-Multilingual/pkg-plist6
5 files changed, 56 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 688d5b4eb5b0..939b685fd700 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -588,6 +588,7 @@
SUBDIR += p5-Sledge-Plugin-XSLT
SUBDIR += p5-Sledge-SessionManager-CookieStore
SUBDIR += p5-Sledge-Template-Expr
+ SUBDIR += p5-Template-Multilingual
SUBDIR += p5-Template-Plugin-Class
SUBDIR += p5-Template-Plugin-Comma
SUBDIR += p5-Template-Plugin-MP3
diff --git a/www/p5-Template-Multilingual/Makefile b/www/p5-Template-Multilingual/Makefile
new file mode 100644
index 000000000000..4aaaff61e411
--- /dev/null
+++ b/www/p5-Template-Multilingual/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: p5-Template-Multilingual
+# Date created: 19 June 2005
+# Whom: TAKAHASHI Kaoru <kaoru@kaisei.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Template-Multilingual
+PORTVERSION= 0.05
+CATEGORIES= www textproc perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Template
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= kaoru@kaisei.org
+COMMENT= Multilingual templates for Template Toolkit
+
+RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Template.pm:${PORTSDIR}/www/p5-Template-Toolkit
+
+PERL_CONFIGURE= yes
+
+MAN3= Template::Multilingual.3 \
+ Template::Multilingual::Parser.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+IGNORE= Port requires perl 5.6.x or later. Install lang/perl5 then try again
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/www/p5-Template-Multilingual/distinfo b/www/p5-Template-Multilingual/distinfo
new file mode 100644
index 000000000000..e5d892e391f4
--- /dev/null
+++ b/www/p5-Template-Multilingual/distinfo
@@ -0,0 +1,2 @@
+MD5 (Template-Multilingual-0.05.tar.gz) = acf1750f70f4bc96e2f16fc678f65a60
+SIZE (Template-Multilingual-0.05.tar.gz) = 5665
diff --git a/www/p5-Template-Multilingual/pkg-descr b/www/p5-Template-Multilingual/pkg-descr
new file mode 100644
index 000000000000..14b6840ec644
--- /dev/null
+++ b/www/p5-Template-Multilingual/pkg-descr
@@ -0,0 +1,16 @@
+This subclass of Template Toolkit's Template::Parser parses multilingual
+templates: templates that contain text in several languages.
+
+ <t>
+ <en>Hello!</en>
+ <fr>Bonjour !</fr>
+ </t>
+
+Use this module directly if you have subclassed Template, otherwise you may
+find it easier to use Template::Multilingual.
+
+Language codes can be any string that matches \w+, but we suggest sticking
+to ISO-639 which provides 2-letter codes for common languages and 3-letter
+codes for many others.
+
+WWW: http://search.cpan.org/~cholet/Template-Multilingual/
diff --git a/www/p5-Template-Multilingual/pkg-plist b/www/p5-Template-Multilingual/pkg-plist
new file mode 100644
index 000000000000..a916f9d76242
--- /dev/null
+++ b/www/p5-Template-Multilingual/pkg-plist
@@ -0,0 +1,6 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Template/Multilingual/.packlist
+%%SITE_PERL%%/Template/Multilingual/Parser.pm
+%%SITE_PERL%%/Template/Multilingual.pm
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Template/Multilingual
+@dirrm %%SITE_PERL%%/Template/Multilingual
+@unexec rmdir %D/%%SITE_PERL%%/Template 2>/dev/null || true