aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2008-05-05 14:38:25 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2008-05-05 14:38:25 +0000
commite15eb67265e0a539b617852b39f321fc1fc09672 (patch)
tree5b483e0019e4fc3b4c0e88159e3f95a072ea6b31
parent53d5af5fb8205fbfae401958a1835a2819d1ef10 (diff)
downloadports-e15eb67265e0a539b617852b39f321fc1fc09672.tar.gz
ports-e15eb67265e0a539b617852b39f321fc1fc09672.zip
Notes
-rw-r--r--databases/gdl2/files/patch-EOClassDescription.h10
-rw-r--r--databases/gdl2/files/patch-NSArray+GSDoc.m10
-rw-r--r--deskutils/cartotheque/files/patch-CardView.m10
-rw-r--r--deskutils/toolbox/files/patch-DefaultView.h10
-rw-r--r--devel/performance/files/patch-GSSkipMutableArray.m10
-rw-r--r--devel/projectmanager/files/patch-EditorRulerView.m10
-rw-r--r--devel/projectmanager/files/patch-MakeBuilder.m10
-rw-r--r--devel/projectmanager/files/patch-SourceEditorDocument.m10
-rw-r--r--games/nextgo/Makefile2
-rw-r--r--graphics/pixen/files/patch-PXInfoPanelController.m10
-rw-r--r--graphics/svgviewer/files/patch-Document.m10
-rw-r--r--net/tryst/files/patch-NSNetServices.m10
-rw-r--r--sysutils/burn/files/patch-ExtProgressIndicator.m10
-rw-r--r--www/gnustep-ticker/files/patch-CellAdditions.m9
-rw-r--r--www/gnustep-ticker/files/patch-TempFilename.m9
-rw-r--r--x11-toolkits/renaissance/files/patch-GSMarkupCoder.m10
-rw-r--r--x11-toolkits/renaissance/files/patch-GSMarkupTagInstance.m10
-rw-r--r--x11/terminal.app/files/patch-TerminalViewPrefs.m10
18 files changed, 170 insertions, 0 deletions
diff --git a/databases/gdl2/files/patch-EOClassDescription.h b/databases/gdl2/files/patch-EOClassDescription.h
new file mode 100644
index 000000000000..47209dd147cb
--- /dev/null
+++ b/databases/gdl2/files/patch-EOClassDescription.h
@@ -0,0 +1,10 @@
+--- EOControl/EOClassDescription.h.orig 2006-12-30 18:41:02.000000000 +0100
++++ EOControl/EOClassDescription.h 2008-05-03 09:09:20.000000000 +0200
+@@ -29,6 +29,7 @@
+
+ #ifdef GNUSTEP
+ #include <Foundation/NSArray.h>
++#include <Foundation/NSDictionary.h>
+ #include <Foundation/NSException.h>
+ #include <Foundation/NSZone.h>
+ #else
diff --git a/databases/gdl2/files/patch-NSArray+GSDoc.m b/databases/gdl2/files/patch-NSArray+GSDoc.m
new file mode 100644
index 000000000000..877337df0b85
--- /dev/null
+++ b/databases/gdl2/files/patch-NSArray+GSDoc.m
@@ -0,0 +1,10 @@
+--- Tools/NSArray+GSDoc.m.orig 2005-08-17 10:07:57.000000000 +0200
++++ Tools/NSArray+GSDoc.m 2008-05-03 09:10:55.000000000 +0200
+@@ -36,6 +36,7 @@
+
+ #ifdef GNUSTEP
+ #include <Foundation/NSAutoreleasePool.h>
++#include <Foundation/NSString.h>
+ #else
+ #include <Foundation/Foundation.h>
+ #endif
diff --git a/deskutils/cartotheque/files/patch-CardView.m b/deskutils/cartotheque/files/patch-CardView.m
new file mode 100644
index 000000000000..9600dc96e9de
--- /dev/null
+++ b/deskutils/cartotheque/files/patch-CardView.m
@@ -0,0 +1,10 @@
+--- CardView.m.orig 2005-03-13 18:52:24.000000000 +0100
++++ CardView.m 2008-05-03 09:38:44.000000000 +0200
+@@ -11,6 +11,7 @@
+ #import "CardView.h"
+
+ #import <Foundation/NSDictionary.h>
++#import <AppKit/NSAttributedString.h>
+ #import <AppKit/NSColor.h>
+ #import <AppKit/NSFont.h>
+ #import <AppKit/NSTextStorage.h>
diff --git a/deskutils/toolbox/files/patch-DefaultView.h b/deskutils/toolbox/files/patch-DefaultView.h
new file mode 100644
index 000000000000..2ca11054e907
--- /dev/null
+++ b/deskutils/toolbox/files/patch-DefaultView.h
@@ -0,0 +1,10 @@
+--- DefaultEditor/DefaultView.h.orig 2003-03-28 17:09:41.000000000 +0100
++++ DefaultEditor/DefaultView.h 2008-05-03 09:50:08.000000000 +0200
+@@ -27,6 +27,7 @@
+ #ifndef _Toolbox_DefaultEditor_H_DefaultView
+ #define _Toolbox_DefaultEditor_H_DefaultView
+
++#include <Foundation/NSDictionary.h>
+ #include <AppKit/NSView.h>
+
+ @class NSOutlineView;
diff --git a/devel/performance/files/patch-GSSkipMutableArray.m b/devel/performance/files/patch-GSSkipMutableArray.m
new file mode 100644
index 000000000000..be115b1af750
--- /dev/null
+++ b/devel/performance/files/patch-GSSkipMutableArray.m
@@ -0,0 +1,10 @@
+--- GSSkipMutableArray.m.orig 2006-11-12 08:30:09.000000000 +0100
++++ GSSkipMutableArray.m 2008-05-03 09:01:46.000000000 +0200
+@@ -24,6 +24,7 @@
+ #include <Foundation/NSException.h>
+ #include <Foundation/NSValue.h>
+ #include <Foundation/NSEnumerator.h>
++#include <Foundation/NSDictionary.h>
+
+ #include "GSSkipMutableArray.h"
+ #include "GSIndexedSkipList.h"
diff --git a/devel/projectmanager/files/patch-EditorRulerView.m b/devel/projectmanager/files/patch-EditorRulerView.m
new file mode 100644
index 000000000000..c3b1d7aaf011
--- /dev/null
+++ b/devel/projectmanager/files/patch-EditorRulerView.m
@@ -0,0 +1,10 @@
+--- EditorRulerView.m.orig 2006-07-09 16:11:43.000000000 +0200
++++ EditorRulerView.m 2008-05-03 08:53:45.000000000 +0200
+@@ -23,6 +23,7 @@
+
+ #import "EditorRulerView.h"
+
++#import <AppKit/NSAttributedString.h>
+ #import <AppKit/NSColor.h>
+ #import <AppKit/NSEvent.h>
+ #import <AppKit/NSFont.h>
diff --git a/devel/projectmanager/files/patch-MakeBuilder.m b/devel/projectmanager/files/patch-MakeBuilder.m
new file mode 100644
index 000000000000..5466a7acaabc
--- /dev/null
+++ b/devel/projectmanager/files/patch-MakeBuilder.m
@@ -0,0 +1,10 @@
+--- ProjectModules/MakeBuilder/MakeBuilder.m.orig 2006-07-09 16:11:41.000000000 +0200
++++ ProjectModules/MakeBuilder/MakeBuilder.m 2008-05-03 08:58:15.000000000 +0200
+@@ -30,6 +30,7 @@
+ #import <Foundation/NSTask.h>
+ #import <Foundation/NSUserDefaults.h>
+
++#import <AppKit/NSAttributedString.h>
+ #import <AppKit/NSButton.h>
+ #import <AppKit/NSCell.h>
+ #import <AppKit/NSDocumentController.h>
diff --git a/devel/projectmanager/files/patch-SourceEditorDocument.m b/devel/projectmanager/files/patch-SourceEditorDocument.m
new file mode 100644
index 000000000000..e0b613615933
--- /dev/null
+++ b/devel/projectmanager/files/patch-SourceEditorDocument.m
@@ -0,0 +1,10 @@
+--- SourceEditorDocument.m.orig 2006-07-09 16:11:44.000000000 +0200
++++ SourceEditorDocument.m 2008-05-03 08:55:28.000000000 +0200
+@@ -33,6 +33,7 @@
+ #import <Foundation/NSUserDefaults.h>
+ #import <Foundation/NSValue.h>
+
++#import <AppKit/NSAttributedString.h>
+ #import <AppKit/NSFont.h>
+ #import <AppKit/NSImage.h>
+ #import <AppKit/NSLayoutManager.h>
diff --git a/games/nextgo/Makefile b/games/nextgo/Makefile
index 80bb8102d216..3d0443932d02 100644
--- a/games/nextgo/Makefile
+++ b/games/nextgo/Makefile
@@ -24,5 +24,7 @@ USE_GNUSTEP_INSTALL= yes
post-patch:
${REINPLACE_CMD} -e 's|^GNUSTEP_INSTALLATION_DIR|#GNUSTEP_INSTALLATION_DIR|' \
${WRKSRC}/GNUmakefile
+ ${REINPLACE_CMD} -e 's|PSWait|myPSWait|' \
+ ${WRKSRC}/Board.m
.include <bsd.port.mk>
diff --git a/graphics/pixen/files/patch-PXInfoPanelController.m b/graphics/pixen/files/patch-PXInfoPanelController.m
new file mode 100644
index 000000000000..ebbb1f5bbec2
--- /dev/null
+++ b/graphics/pixen/files/patch-PXInfoPanelController.m
@@ -0,0 +1,10 @@
+--- PXInfoPanelController.m.orig 2004-12-15 16:11:49.000000000 +0100
++++ PXInfoPanelController.m 2008-05-03 09:37:17.000000000 +0200
+@@ -25,6 +25,7 @@
+ #import <Foundation/NSUserDefaults.h>
+
+ #import <AppKit/NSColor.h>
++#import <AppKit/NSGraphics.h>
+ #import <AppKit/NSNibLoading.h>
+ #import <AppKit/NSPanel.h>
+ #import <AppKit/NSTextField.h>
diff --git a/graphics/svgviewer/files/patch-Document.m b/graphics/svgviewer/files/patch-Document.m
new file mode 100644
index 000000000000..1bb00218bd03
--- /dev/null
+++ b/graphics/svgviewer/files/patch-Document.m
@@ -0,0 +1,10 @@
+--- Document.m.orig 2005-05-23 21:30:29.000000000 +0200
++++ Document.m 2008-05-03 09:33:21.000000000 +0200
+@@ -10,6 +10,7 @@
+ #include <Foundation/NSFileManager.h>
+ #include <AppKit/NSBezierPath.h>
+ #include <AppKit/NSFontManager.h>
++#include <AppKit/NSGraphics.h>
+ #include <AppKit/NSScrollView.h>
+ #include <AppKit/NSWindow.h>
+ #include <AppKit/DPSOperators.h>
diff --git a/net/tryst/files/patch-NSNetServices.m b/net/tryst/files/patch-NSNetServices.m
new file mode 100644
index 000000000000..f933bea8c31b
--- /dev/null
+++ b/net/tryst/files/patch-NSNetServices.m
@@ -0,0 +1,10 @@
+--- Source/NSNetServices.m.orig 2007-01-23 09:56:58.000000000 +0100
++++ Source/NSNetServices.m 2008-05-03 09:52:00.000000000 +0200
+@@ -23,6 +23,7 @@
+ #if defined( VERBOSE )
+ # import <Foundation/NSDebug.h>
+ #endif /* VERBOSE */
++#import <Foundation/NSDictionary.h>
+ #if defined( _REENTRANT )
+ # import <Foundation/NSLock.h>
+ #endif /* _REENTRANT */
diff --git a/sysutils/burn/files/patch-ExtProgressIndicator.m b/sysutils/burn/files/patch-ExtProgressIndicator.m
new file mode 100644
index 000000000000..518d3df0c8cd
--- /dev/null
+++ b/sysutils/burn/files/patch-ExtProgressIndicator.m
@@ -0,0 +1,10 @@
+--- ExtProgressIndicator.m.orig 2005-05-12 17:58:49.000000000 +0200
++++ ExtProgressIndicator.m 2008-05-03 09:35:27.000000000 +0200
+@@ -21,6 +21,7 @@
+ * Foundation, Inc., 675 Mass Ave, Cambridge, MA 02139, USA.
+ */
+
++#include <AppKit/NSAttributedString.h>
+ #include <AppKit/NSColor.h>
+ #include <AppKit/NSParagraphStyle.h>
+ #include <Foundation/Foundation.h>
diff --git a/www/gnustep-ticker/files/patch-CellAdditions.m b/www/gnustep-ticker/files/patch-CellAdditions.m
new file mode 100644
index 000000000000..30143e6307d3
--- /dev/null
+++ b/www/gnustep-ticker/files/patch-CellAdditions.m
@@ -0,0 +1,9 @@
+--- CellAdditions.m.orig 2006-03-31 01:10:38.000000000 +0200
++++ CellAdditions.m 2008-05-03 09:04:25.000000000 +0200
+@@ -1,5 +1,6 @@
+
+ #import "CellAdditions.h"
++#import <AppKit/NSAttributedString.h>
+
+ @implementation NSCell (CellAdditions)
+
diff --git a/www/gnustep-ticker/files/patch-TempFilename.m b/www/gnustep-ticker/files/patch-TempFilename.m
new file mode 100644
index 000000000000..5cd4bdfeb816
--- /dev/null
+++ b/www/gnustep-ticker/files/patch-TempFilename.m
@@ -0,0 +1,9 @@
+--- TempFilename.m.orig 2006-03-31 01:10:38.000000000 +0200
++++ TempFilename.m 2008-05-03 09:04:46.000000000 +0200
+@@ -1,5 +1,6 @@
+
+ #import "TempFilename.h"
++#import <Foundation/NSString.h>
+
+ @implementation NSFileManager (TempFilename)
+
diff --git a/x11-toolkits/renaissance/files/patch-GSMarkupCoder.m b/x11-toolkits/renaissance/files/patch-GSMarkupCoder.m
new file mode 100644
index 000000000000..22b507e6f59a
--- /dev/null
+++ b/x11-toolkits/renaissance/files/patch-GSMarkupCoder.m
@@ -0,0 +1,10 @@
+--- Source/Markup/GSMarkupCoder.m.orig 2003-07-15 11:40:54.000000000 +0200
++++ Source/Markup/GSMarkupCoder.m 2008-05-02 18:18:37.000000000 +0200
+@@ -31,6 +31,7 @@
+ # include <Foundation/Foundation.h>
+ # include "GNUstep.h"
+ #else
++# include <Foundation/NSString.h>
+ # include <Foundation/NSArray.h>
+ # include <Foundation/NSData.h>
+ #endif
diff --git a/x11-toolkits/renaissance/files/patch-GSMarkupTagInstance.m b/x11-toolkits/renaissance/files/patch-GSMarkupTagInstance.m
new file mode 100644
index 000000000000..24c47a2c0c18
--- /dev/null
+++ b/x11-toolkits/renaissance/files/patch-GSMarkupTagInstance.m
@@ -0,0 +1,10 @@
+--- Source/Markup/GSMarkupTagInstance.m.orig 2003-02-05 03:38:14.000000000 +0100
++++ Source/Markup/GSMarkupTagInstance.m 2008-05-02 18:18:45.000000000 +0200
+@@ -30,6 +30,7 @@
+ # include <Foundation/Foundation.h>
+ # include "GNUstep.h"
+ #else
++# include <Foundation/NSString.h>
+ # include <Foundation/NSArray.h>
+ # include <Foundation/NSDictionary.h>
+ #endif
diff --git a/x11/terminal.app/files/patch-TerminalViewPrefs.m b/x11/terminal.app/files/patch-TerminalViewPrefs.m
new file mode 100644
index 000000000000..bc84f935158a
--- /dev/null
+++ b/x11/terminal.app/files/patch-TerminalViewPrefs.m
@@ -0,0 +1,10 @@
+--- TerminalViewPrefs.m.orig 2003-08-10 14:00:23.000000000 +0200
++++ TerminalViewPrefs.m 2008-05-03 08:04:31.000000000 +0200
+@@ -15,6 +15,7 @@
+ #include <AppKit/NSColorPanel.h>
+ #include <AppKit/NSColorWell.h>
+ #include <AppKit/NSFont.h>
++#include <AppKit/NSFontManager.h>
+ #include <AppKit/NSGraphics.h>
+ #include <AppKit/NSImage.h>
+ #include <AppKit/NSTextField.h>