aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrooks Davis <brooks@FreeBSD.org>2009-12-31 17:53:45 +0000
committerBrooks Davis <brooks@FreeBSD.org>2009-12-31 17:53:45 +0000
commite77540ccc59091d6b7e3d692d2a16ff5da4958f2 (patch)
tree4aec77209ff3a28bfb73c9d55419fdce3a6df40d
parent5dc9feaf861642dab8c4f7a1ca4294002046fbcf (diff)
downloadports-e77540ccc59091d6b7e3d692d2a16ff5da4958f2.tar.gz
ports-e77540ccc59091d6b7e3d692d2a16ff5da4958f2.zip
Notes
-rw-r--r--www/Makefile1
-rw-r--r--www/trac-ticketimport/Makefile50
-rw-r--r--www/trac-ticketimport/distinfo3
-rw-r--r--www/trac-ticketimport/pkg-descr15
-rw-r--r--www/trac-ticketimport/pkg-plist1
5 files changed, 70 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 38e48a9a42f9..d565a34b9930 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -1587,6 +1587,7 @@
SUBDIR += trac-tags
SUBDIR += trac-themeengine
SUBDIR += trac-ticketdelete
+ SUBDIR += trac-ticketimport
SUBDIR += trac-tocmacro
SUBDIR += trac-tweakui
SUBDIR += trac-wantedpages
diff --git a/www/trac-ticketimport/Makefile b/www/trac-ticketimport/Makefile
new file mode 100644
index 000000000000..ff26dba21eb4
--- /dev/null
+++ b/www/trac-ticketimport/Makefile
@@ -0,0 +1,50 @@
+# New ports collection makefile for: trac-ticketimport
+# Date created: Dec 31, 2009
+# Whom: Brooks Davis <brooks@freebsd.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= ${PYDISTUTILS_PKGNAME:S;^Trac;;S;Plugin$;;:L}
+PORTVERSION= 0.7c
+CATEGORIES= www devel python
+MASTER_SITES= ${MASTER_SITE_LOCAL}
+MASTER_SITE_SUBDIR= brooks
+PKGNAMEPREFIX= trac-
+
+MAINTAINER= brooks@freebsd.org
+COMMENT= Import or update tickets from a CSV file or Excel file
+
+RUN_DEPENDS+= tracd:${PORTSDIR}/www/trac \
+ ${PYTHON_PKGNAMEPREFIX}xlrd>=0.7.1:${PORTSDIR}/textproc/py-xlrd
+BUILD_DEPENDS+= easy_install:${PORTSDIR}/devel/py-setuptools
+
+USE_PYTHON= yes
+USE_PYDISTUTILS=easy_install
+PYDISTUTILS_PKGNAME= TicketImport
+
+# Maintainter targets below this point
+
+# Retrieve the latest version from SVN and package in a tarball.
+.if defined(BOOTSTRAP)
+FETCH_DEPENDS+= svn:${PORTSDIR}/devel/subversion
+do-fetch:
+ ${MKDIR} ${WRKDIR}
+ cd ${WRKDIR} && \
+ svn export http://trac-hacks.org/svn/ticketimportplugin/0.11/ \
+ ${DISTNAME}
+ cd ${WRKDIR} && tar cvf ${DISTDIR}/${DISTNAME}.tar.gz ${DISTNAME}
+.endif
+
+# Create a pkg-plist after the package is installed.
+EGGDIR= ${PYTHON_SITELIBDIR}/${PYEASYINSTALL_EGG}
+PLIST_EGGDIR= %%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%
+build-plist:
+ ${FIND} ${EGGDIR} -type f | \
+ ${SED} -e 's|${EGGDIR}|${PLIST_EGGDIR}|' | \
+ ${SORT} > pkg-plist
+ ${FIND} ${EGGDIR} -type d | \
+ ${SED} -e 's|${EGGDIR}|@dirrm ${PLIST_EGGDIR}|' | \
+ ${SORT} -r >> pkg-plist
+
+.include <bsd.port.mk>
diff --git a/www/trac-ticketimport/distinfo b/www/trac-ticketimport/distinfo
new file mode 100644
index 000000000000..55e5bd89fcad
--- /dev/null
+++ b/www/trac-ticketimport/distinfo
@@ -0,0 +1,3 @@
+MD5 (ticketimport-0.7c.tar.gz) = 3ec880a69b07be6b351940b8ff8420e6
+SHA256 (ticketimport-0.7c.tar.gz) = a6cab62cc62ba0d599107869b862951f2826e1fce4ac65f57eb066e4d3843643
+SIZE (ticketimport-0.7c.tar.gz) = 2811904
diff --git a/www/trac-ticketimport/pkg-descr b/www/trac-ticketimport/pkg-descr
new file mode 100644
index 000000000000..91e6afcc20f6
--- /dev/null
+++ b/www/trac-ticketimport/pkg-descr
@@ -0,0 +1,15 @@
+This plugin lets you import into Trac a series of tickets from a CSV
+file or (if the xlrd library is installed) from an Excel file.
+
+You can also use it to modify tickets in batch, by saving a report as
+CSV, editing the CSV file, and re-importing the tickets.
+
+This plugin is very useful when starting a new project: you can import a
+list of requirements that may have come from meeting notes, list of
+features, other ticketing systems... It's also great to review the
+tickets off-line, or to do massive changes to tickets.
+
+Based on the ticket id (or, if no id exists, on the summary) in the
+imported file, tickets are either created or updated.
+
+WWW: http://trac-hacks.org/wiki/TicketImportPlugin
diff --git a/www/trac-ticketimport/pkg-plist b/www/trac-ticketimport/pkg-plist
new file mode 100644
index 000000000000..ddf68a1c022f
--- /dev/null
+++ b/www/trac-ticketimport/pkg-plist
@@ -0,0 +1 @@
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%