aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2006-01-23 19:37:26 +0000
committerPav Lucistnik <pav@FreeBSD.org>2006-01-23 19:37:26 +0000
commitf0081a9d3c97e750887f439db4c9690115a58763 (patch)
treea53fa8269d55f4514c6d509f9390b8c58dd36d4b
parent350af59f7cca08461cfc253a09655802486cbb34 (diff)
downloadports-f0081a9d3c97e750887f439db4c9690115a58763.tar.gz
ports-f0081a9d3c97e750887f439db4c9690115a58763.zip
Notes
-rw-r--r--ftp/Makefile1
-rw-r--r--ftp/smbftpd/Makefile22
-rw-r--r--ftp/smbftpd/distinfo3
-rw-r--r--ftp/smbftpd/files/patch-Makefile.in13
-rw-r--r--ftp/smbftpd/pkg-descr6
-rw-r--r--ftp/smbftpd/pkg-plist6
6 files changed, 51 insertions, 0 deletions
diff --git a/ftp/Makefile b/ftp/Makefile
index 4e4211d1c6da..f204fdb2ed6a 100644
--- a/ftp/Makefile
+++ b/ftp/Makefile
@@ -88,6 +88,7 @@
SUBDIR += py-curl
SUBDIR += quftp
SUBDIR += rexx-curl
+ SUBDIR += smbftpd
SUBDIR += spegla
SUBDIR += tftp-hpa
SUBDIR += tnftp
diff --git a/ftp/smbftpd/Makefile b/ftp/smbftpd/Makefile
new file mode 100644
index 000000000000..575b302aeeb1
--- /dev/null
+++ b/ftp/smbftpd/Makefile
@@ -0,0 +1,22 @@
+# New ports collection makefile for: smbftpd
+# Date created: 2006-01-22
+# Whom: Jui-Nan Lin <jnlin@csie.nctu.edu.tw>
+#
+# $FreeBSD$
+#
+
+PORTNAME= smbftpd
+PORTVERSION= 0.96
+CATEGORIES= ftp
+MASTER_SITES= http://www.twbsd.org/download/download.php?file=smbftpd/
+
+MAINTAINER= jnlin@csie.nctu.edu.tw
+COMMENT= FTP daemon using Samba-like share management mechanism
+
+HAS_CONFIGURE= yes
+USE_OPENSSL= yes
+USE_PERL5= yes
+
+MAKE_ENV= OSTYPE=FreeBSD
+
+.include <bsd.port.mk>
diff --git a/ftp/smbftpd/distinfo b/ftp/smbftpd/distinfo
new file mode 100644
index 000000000000..0d2861374541
--- /dev/null
+++ b/ftp/smbftpd/distinfo
@@ -0,0 +1,3 @@
+MD5 (smbftpd-0.96.tar.gz) = bd44ae80674993793c7206818b17d755
+SHA256 (smbftpd-0.96.tar.gz) = b2f9fb2614c0af2da7404e4228257d66ee463c0bcdb7a0aabc4317689c6e9a6b
+SIZE (smbftpd-0.96.tar.gz) = 124016
diff --git a/ftp/smbftpd/files/patch-Makefile.in b/ftp/smbftpd/files/patch-Makefile.in
new file mode 100644
index 000000000000..53dbc3f1af21
--- /dev/null
+++ b/ftp/smbftpd/files/patch-Makefile.in
@@ -0,0 +1,13 @@
+--- Makefile.in.old Mon Jan 23 12:43:31 2006
++++ Makefile.in Mon Jan 23 12:44:39 2006
+@@ -110,8 +110,8 @@
+ fi;
+
+ @if [ "$(OSTYPE)" = "FreeBSD" ]; then \
+- echo "install -c -m 755 os/FreeBSD/smbftpd.sh /usr/local/etc/rc.d/"; \
+- install -c -m 755 os/FreeBSD/smbftpd.sh /usr/local/etc/rc.d/; \
++ echo "install -c -m 755 os/FreeBSD/smbftpd.sh $(PREFIX)/etc/rc.d/"; \
++ install -c -m 755 os/FreeBSD/smbftpd.sh $(PREFIX)/etc/rc.d/; \
+ elif [ "$(OSTYPE)" = "linux" ]; then \
+ if [ ! -f /etc/pam.d/ftpd ]; then \
+ echo "install install -c -m 644 os/linux/ftpd.pam /etc/pam.d/ftpd"; \
diff --git a/ftp/smbftpd/pkg-descr b/ftp/smbftpd/pkg-descr
new file mode 100644
index 000000000000..8b14736ef39f
--- /dev/null
+++ b/ftp/smbftpd/pkg-descr
@@ -0,0 +1,6 @@
+SmbFTPD is a FTP daemon modified from the FTP daemon of FreeBSD 5.4. Besides
+original FreeBSD ftpd features, it enhances the user permission control,
+integrate configuration files, and more useful features. SmbFTPD also support
+SSL/TLS encryption.
+
+WWW: http://www.twbsd.org/enu/smbftpd/index.php
diff --git a/ftp/smbftpd/pkg-plist b/ftp/smbftpd/pkg-plist
new file mode 100644
index 000000000000..a2e7b6b52eb3
--- /dev/null
+++ b/ftp/smbftpd/pkg-plist
@@ -0,0 +1,6 @@
+@comment $FreeBSD$
+etc/rc.d/smbftpd.sh
+etc/smbftpd/smbftpd.conf
+etc/smbftpd/smbftpd_share.conf
+sbin/smbftpd
+@dirrmtry etc/smbftpd