aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTilman Keskinoz <arved@FreeBSD.org>2003-07-21 14:28:32 +0000
committerTilman Keskinoz <arved@FreeBSD.org>2003-07-21 14:28:32 +0000
commitf334b33c50a3f4e936d6a1f48b6a3c83bfb2e24d (patch)
treeda3beac8220875ea74b8fcc88f908ecfd54dd5f6
parent568128bcfeb180b70fd057818d29f1d0abb24a71 (diff)
downloadports-f334b33c50a3f4e936d6a1f48b6a3c83bfb2e24d.tar.gz
ports-f334b33c50a3f4e936d6a1f48b6a3c83bfb2e24d.zip
Notes
-rw-r--r--print/cups-base/Makefile29
-rw-r--r--print/cups-base/distinfo1
-rw-r--r--print/cups-base/files/patch-Makefile13
-rw-r--r--print/cups-base/files/patch-cgi-bin-ipp-var.c-1.1.1953
-rw-r--r--print/cups-base/pkg-plist135
-rw-r--r--print/cups-lpr/Makefile11
-rw-r--r--print/cups-lpr/distinfo1
-rw-r--r--print/cups-lpr/files/patch-Makefile13
-rw-r--r--print/cups-lpr/files/patch-man-Makefile.common9
-rw-r--r--print/cups-lpr/pkg-plist4
-rw-r--r--print/cups/Makefile.common18
-rw-r--r--print/cups/distinfo2
12 files changed, 170 insertions, 119 deletions
diff --git a/print/cups-base/Makefile b/print/cups-base/Makefile
index fccff4cdf16d..e6a4aa2a9bc1 100644
--- a/print/cups-base/Makefile
+++ b/print/cups-base/Makefile
@@ -17,26 +17,37 @@ MASTER_SITES= ${CUPS_MASTER_SITES}
MAINTAINER= ports@FreeBSD.org
COMMENT= The Common UNIX Printing System: headers, libs, & daemons
+USE_REINPLACE= yes
INSTALLS_SHLIB= yes
+MANLANG= "" fr
+
+post-patch:
+ @${REINPLACE_CMD} -e '/SILENT/d' \
+ ${WRKSRC}/Makedefs.in
+ @${REINPLACE_CMD} -e '/LN/d' \
+ ${WRKSRC}/man/Makefile ${WRKSRC}/man/fr/Makefile
+
pre-install:
- -@${ECHO_CMD} "===>" Stopping cupsd ...
- -killall cupsd || true
- -rm -fr ${PREFIX}/etc/cups/certs/* || true
+ @${ECHO_MSG} "===>" Stopping cupsd ...
+ -killall cupsd || ${TRUE}
+ ${RM} -fr ${PREFIX}/etc/cups/certs/* || ${TRUE}
post-install:
+ ${MKDIR} ${CUPS_ETCDIR}
+.for f in classes.conf client.conf cupsd.conf printers.conf
+ ${INSTALL_DATA} ${WRKSRC}/conf/${f} ${CUPS_ETCDIR}/${f}.N
+ cd ${CUPS_ETCDIR}; if test ! -f ${f}; then ${CP} -p ${f}.N ${f}; fi
+.endfor # classes.conf client.conf cupsd.conf printers.conf
+.for f in mime.convs mime.types
+ ${INSTALL_DATA} ${WRKSRC}/conf/${f} ${CUPS_ETCDIR}/${f}
+.endfor # mime.convs mime.types
cd ${CUPS_RCDIR}; ${MV} cups cups.sh.sample
${FIND} ${PREFIX}/man/cat* -type l -name '*.0' -delete
${FIND} ${PREFIX}/man/fr/cat* -type l -name '*.0' -delete
${MKDIR} ${CUPS_SPOOLDIR} ${CUPS_SPOOLDIR}/tmp
${CHOWN} -R ${CUPSOWN}:${CUPSGRP} ${CUPS_SPOOLDIR}
${CHMOD} -R g+w ${CUPS_SPOOLDIR}
-.for f in classes.conf client.conf cupsd.conf printers.conf
- cd ${CUPS_ETCDIR};\
- if test ! -f ${f}.N; then cp -p ${f} ${f}.N; else true; fi
-.endfor # classes.conf client.conf cupsd.conf printers.conf
-
-MANLANG= "" fr
.include "${.CURDIR}/../../print/cups/Makefile.common"
.include <bsd.port.pre.mk>
diff --git a/print/cups-base/distinfo b/print/cups-base/distinfo
deleted file mode 100644
index 7c4c9f612542..000000000000
--- a/print/cups-base/distinfo
+++ /dev/null
@@ -1 +0,0 @@
-MD5 (cups-1.1.18-source.tar.bz2) = 4a8a423a8268d088bffa19f6515883a7
diff --git a/print/cups-base/files/patch-Makefile b/print/cups-base/files/patch-Makefile
index 55c49f2ec9aa..5cb9d44d5209 100644
--- a/print/cups-base/files/patch-Makefile
+++ b/print/cups-base/files/patch-Makefile
@@ -1,5 +1,5 @@
---- Makefile.orig Tue Dec 17 13:56:25 2002
-+++ Makefile Wed Jan 22 06:18:57 2003
+--- Makefile.orig Fri Mar 7 01:36:00 2003
++++ Makefile Wed Jun 11 01:03:08 2003
@@ -28,8 +28,8 @@
# Directories to make...
#
@@ -11,3 +11,12 @@
#
# Make all targets...
+@@ -72,8 +72,6 @@
+ echo Installing in $$dir... ;\
+ (cd $$dir; $(MAKE) $(MFLAGS) install) || exit 1;\
+ done
+- echo Installing in conf...
+- (cd conf; $(MAKE) $(MFLAGS) install)
+ echo Installing in data...
+ (cd data; $(MAKE) $(MFLAGS) install)
+ echo Installing in doc...
diff --git a/print/cups-base/files/patch-cgi-bin-ipp-var.c-1.1.19 b/print/cups-base/files/patch-cgi-bin-ipp-var.c-1.1.19
deleted file mode 100644
index bbad5c0db0ac..000000000000
--- a/print/cups-base/files/patch-cgi-bin-ipp-var.c-1.1.19
+++ /dev/null
@@ -1,53 +0,0 @@
---- cgi-bin/ipp-var.c.orig Sat Jan 25 10:07:30 2003
-+++ cgi-bin/ipp-var.c Sat Jan 25 10:08:15 2003
-@@ -103,14 +103,35 @@
- int port; /* URI data */
- int ishttps; /* Using encryption? */
- const char *server; /* Name of server */
-+ char servername[1024];/* Locale server name */
- struct tm *date; /* Date information */
-
-
-+ /*
-+ * Set common CGI template variables...
-+ */
-+
- ippSetServerVersion();
-
-- server = getenv("SERVER_NAME");
-+ /*
-+ * Get the server name associated with the client interface as well as
-+ * the locally configured hostname. We'll check *both* of these to
-+ * see if the printer URL is local...
-+ */
-+
-+ server = getenv("SERVER_NAME");
-+ gethostname(servername, sizeof(servername));
-+
-+ /*
-+ * Flag whether we are using SSL on this connection...
-+ */
-+
- ishttps = getenv("HTTPS") != NULL;
-
-+ /*
-+ * Loop through the attributes and set them for the template...
-+ */
-+
- for (attr = response->attrs;
- attr && attr->group_tag == IPP_TAG_OPERATION;
- attr = attr->next);
-@@ -239,10 +260,11 @@
- strcmp(method, "http") == 0)
- {
- /*
-- * Map localhost access to localhost and local port...
-+ * Map local access to a local URI...
- */
-
-- if (strcasecmp(hostname, server) == 0)
-+ if (strcasecmp(hostname, server) == 0 ||
-+ strcasecmp(hostname, servername) == 0)
- {
- /*
- * Make URI relative to the current server...
diff --git a/print/cups-base/pkg-plist b/print/cups-base/pkg-plist
index 1227b1fde61c..b60da0702e43 100644
--- a/print/cups-base/pkg-plist
+++ b/print/cups-base/pkg-plist
@@ -2,16 +2,20 @@
@exec /usr/bin/killall cupsd || true
@exec /bin/rm -fr %D/etc/cups/certs/* 2>/dev/null || true
bin/cups-config
+@unexec if cmp -s %D/etc/cups/classes.conf.N %D/etc/cups/classes.conf; then rm -f %D/etc/cups/classes.conf; fi
etc/cups/classes.conf.N
-@exec if ! /bin/test -f %D/etc/cups/classes.conf; then /bin/cp -p %D/etc/cups/classes.conf.N %D/etc/cups/classes.conf; else true; fi
+@exec if test ! -f %D/etc/cups/classes.conf; then cp -p %D/etc/cups/classes.conf.N %D/etc/cups/classes.conf; fi
+@unexec if cmp -s %D/etc/cups/client.conf.N %D/etc/cups/client.conf; then rm -f %D/etc/cups/client.conf; fi
etc/cups/client.conf.N
-@exec if ! /bin/test -f %D/etc/cups/client.conf; then /bin/cp -p %D/etc/cups/client.conf.N %D/etc/cups/client.conf; else true; fi
+@exec if test ! -f %D/etc/cups/client.conf; then cp -p %D/etc/cups/client.conf.N %D/etc/cups/client.conf; fi
+@unexec if cmp -s %D/etc/cups/cupsd.conf.N %D/etc/cups/cupsd.conf; then rm -f %D/etc/cups/cupsd.conf; fi
etc/cups/cupsd.conf.N
-@exec if ! /bin/test -f %D/etc/cups/cupsd.conf; then /bin/cp -p %D/etc/cups/cupsd.conf.N %D/etc/cups/cupsd.conf; else true; fi
+@exec if test ! -f %D/etc/cups/cupsd.conf; then cp -p %D/etc/cups/cupsd.conf.N %D/etc/cups/cupsd.conf; fi
etc/cups/mime.convs
etc/cups/mime.types
+@unexec if cmp -s %D/etc/cups/printers.conf.N %D/etc/cups/printers.conf; then rm -f %D/etc/cups/printers.conf; fi
etc/cups/printers.conf.N
-@exec if ! /bin/test -f %D/etc/cups/printers.conf; then /bin/cp -p %D/etc/cups/printers.conf.N %D/etc/cups/printers.conf; else true; fi
+@exec if test ! -f %D/etc/cups/printers.conf; then cp -p %D/etc/cups/printers.conf.N %D/etc/cups/printers.conf; fi
etc/rc.d/cups.sh.sample
include/cups/cups.h
include/cups/http.h
@@ -41,9 +45,11 @@ libexec/cups/cgi-bin/jobs.cgi
libexec/cups/cgi-bin/printers.cgi
libexec/cups/daemon/cups-lpd
libexec/cups/daemon/cups-polld
+libexec/cups/filter/gziptoany
libexec/cups/filter/hpgltops
libexec/cups/filter/imagetops
libexec/cups/filter/imagetoraster
+libexec/cups/filter/libcupsimage.a
libexec/cups/filter/pdftops
libexec/cups/filter/pstops
libexec/cups/filter/rastertodymo
@@ -120,6 +126,51 @@ share/cups/templates/class-modified.tmpl
share/cups/templates/classes.tmpl
share/cups/templates/config-printer.tmpl
share/cups/templates/config-printer2.tmpl
+share/cups/templates/de/add-class.tmpl
+share/cups/templates/de/add-printer.tmpl
+share/cups/templates/de/admin-op.tmpl
+share/cups/templates/de/admin.tmpl
+share/cups/templates/de/choose-device.tmpl
+share/cups/templates/de/choose-make.tmpl
+share/cups/templates/de/choose-members.tmpl
+share/cups/templates/de/choose-model.tmpl
+share/cups/templates/de/choose-serial.tmpl
+share/cups/templates/de/choose-uri.tmpl
+share/cups/templates/de/class-added.tmpl
+share/cups/templates/de/class-confirm.tmpl
+share/cups/templates/de/class-deleted.tmpl
+share/cups/templates/de/class-modified.tmpl
+share/cups/templates/de/classes.tmpl
+share/cups/templates/de/config-printer.tmpl
+share/cups/templates/de/config-printer2.tmpl
+share/cups/templates/de/error.tmpl
+share/cups/templates/de/header.tmpl
+share/cups/templates/de/job-cancel.tmpl
+share/cups/templates/de/job-hold.tmpl
+share/cups/templates/de/job-op.tmpl
+share/cups/templates/de/job-release.tmpl
+share/cups/templates/de/job-restart.tmpl
+share/cups/templates/de/jobs.tmpl
+share/cups/templates/de/modify-class.tmpl
+share/cups/templates/de/modify-printer.tmpl
+share/cups/templates/de/option-boolean.tmpl
+share/cups/templates/de/option-header.tmpl
+share/cups/templates/de/option-pickmany.tmpl
+share/cups/templates/de/option-pickone.tmpl
+share/cups/templates/de/option-trailer.tmpl
+share/cups/templates/de/printer-accept.tmpl
+share/cups/templates/de/printer-added.tmpl
+share/cups/templates/de/printer-configured.tmpl
+share/cups/templates/de/printer-confirm.tmpl
+share/cups/templates/de/printer-deleted.tmpl
+share/cups/templates/de/printer-modified.tmpl
+share/cups/templates/de/printer-purge.tmpl
+share/cups/templates/de/printer-reject.tmpl
+share/cups/templates/de/printer-start.tmpl
+share/cups/templates/de/printer-stop.tmpl
+share/cups/templates/de/printers.tmpl
+share/cups/templates/de/test-page.tmpl
+share/cups/templates/de/trailer.tmpl
share/cups/templates/error.tmpl
share/cups/templates/fr/add-class.tmpl
share/cups/templates/fr/add-printer.tmpl
@@ -198,6 +249,33 @@ share/doc/cups/cmp.html
share/doc/cups/cmp.pdf
share/doc/cups/cups.css
share/doc/cups/cupsdoc.css
+share/doc/cups/de/documentation.html
+share/doc/cups/de/images/accept-jobs.gif
+share/doc/cups/de/images/add-class.gif
+share/doc/cups/de/images/add-printer.gif
+share/doc/cups/de/images/cancel-job.gif
+share/doc/cups/de/images/config-printer.gif
+share/doc/cups/de/images/continue.gif
+share/doc/cups/de/images/delete-class.gif
+share/doc/cups/de/images/delete-printer.gif
+share/doc/cups/de/images/hold-job.gif
+share/doc/cups/de/images/manage-classes.gif
+share/doc/cups/de/images/manage-jobs.gif
+share/doc/cups/de/images/manage-printers.gif
+share/doc/cups/de/images/modify-class.gif
+share/doc/cups/de/images/modify-printer.gif
+share/doc/cups/de/images/navbar.gif
+share/doc/cups/de/images/print-test-page.gif
+share/doc/cups/de/images/reject-jobs.gif
+share/doc/cups/de/images/release-job.gif
+share/doc/cups/de/images/restart-job.gif
+share/doc/cups/de/images/show-active.gif
+share/doc/cups/de/images/show-completed.gif
+share/doc/cups/de/images/start-class.gif
+share/doc/cups/de/images/start-printer.gif
+share/doc/cups/de/images/stop-class.gif
+share/doc/cups/de/images/stop-printer.gif
+share/doc/cups/de/index.html
share/doc/cups/documentation.html
share/doc/cups/fr/cups.css
share/doc/cups/fr/cupsdoc.css
@@ -206,8 +284,6 @@ share/doc/cups/fr/images/accept-jobs.gif
share/doc/cups/fr/images/add-class.gif
share/doc/cups/fr/images/add-printer.gif
share/doc/cups/fr/images/cancel-job.gif
-share/doc/cups/fr/images/cancel-jobs.gif
-share/doc/cups/fr/images/cancel.gif
share/doc/cups/fr/images/config-printer.gif
share/doc/cups/fr/images/continue.gif
share/doc/cups/fr/images/delete-class.gif
@@ -242,8 +318,6 @@ share/doc/cups/images/accept-jobs.gif
share/doc/cups/images/add-class.gif
share/doc/cups/images/add-printer.gif
share/doc/cups/images/cancel-job.gif
-share/doc/cups/images/cancel-jobs.gif
-share/doc/cups/images/cancel.gif
share/doc/cups/images/classes.gif
share/doc/cups/images/config-printer.gif
share/doc/cups/images/continue.gif
@@ -253,7 +327,6 @@ share/doc/cups/images/cups-medium.gif
share/doc/cups/images/cups-small.gif
share/doc/cups/images/delete-class.gif
share/doc/cups/images/delete-printer.gif
-share/doc/cups/images/draft.gif
share/doc/cups/images/hold-job.gif
share/doc/cups/images/left.gif
share/doc/cups/images/logo.gif
@@ -282,6 +355,7 @@ share/doc/cups/ipp.html
share/doc/cups/ipp.pdf
share/doc/cups/overview.html
share/doc/cups/overview.pdf
+share/doc/cups/robots.txt
share/doc/cups/sam.html
share/doc/cups/sam.pdf
share/doc/cups/sdd.html
@@ -305,37 +379,39 @@ share/locale/be/cups_be
share/locale/cs/cups_cs
share/locale/de/cups_de
share/locale/en/cups_en
+share/locale/en_US/cups_en_US
share/locale/es/cups_es
share/locale/fr/cups_fr
share/locale/he/cups_he
share/locale/it/cups_it
-share/locale/ru_RU.cp1251/cups_ru_RU.cp1251
-share/locale/ru_RU.koi8r/cups_ru_RU.koi8r
+share/locale/ru_RU/cups_ru_RU
share/locale/sv/cups_sv
share/locale/uk/cups_uk
-share/locale/uk_UA.cp1251/cups_uk_UA.cp1251
+share/locale/uk_UA/cups_uk_UA
share/locale/zh_CN/cups_zh_CN
-@dirrm share/locale/zh_CN
-@dirrm share/locale/uk_UA.cp1251
-@dirrm share/locale/uk
-@dirrm share/locale/sv
-@dirrm share/locale/ru_RU.koi8r
-@dirrm share/locale/ru_RU.cp1251
-@dirrm share/locale/it
-@dirrm share/locale/he
-@dirrm share/locale/fr
-@dirrm share/locale/es
-@dirrm share/locale/en
-@dirrm share/locale/de
-@dirrm share/locale/cs
-@dirrm share/locale/be
-@dirrm share/locale/C
+@unexec rmdir %D/share/locale/zh_CN 2>/dev/null || true
+@unexec rmdir %D/share/locale/uk_UA 2>/dev/null || true
+@unexec rmdir %D/share/locale/uk 2>/dev/null || true
+@unexec rmdir %D/share/locale/sv 2>/dev/null || true
+@unexec rmdir %D/share/locale/ru_RU 2>/dev/null || true
+@unexec rmdir %D/share/locale/it 2>/dev/null || true
+@unexec rmdir %D/share/locale/he 2>/dev/null || true
+@unexec rmdir %D/share/locale/fr 2>/dev/null || true
+@unexec rmdir %D/share/locale/es 2>/dev/null || true
+@unexec rmdir %D/share/locale/en 2>/dev/null || true
+@unexec rmdir %D/share/locale/de 2>/dev/null || true
+@unexec rmdir %D/share/locale/cs 2>/dev/null || true
+@unexec rmdir %D/share/locale/be 2>/dev/null || true
+@unexec rmdir %D/share/locale/C 2>/dev/null || true
+@unexec rmdir %D/share/locale 2>/dev/null || true
@dirrm share/doc/cups/images
@dirrm share/doc/cups/fr/images
@dirrm share/doc/cups/fr
+@dirrm share/doc/cups/de/images
+@dirrm share/doc/cups/de
@dirrm share/doc/cups
-@dirrm share/doc
@dirrm share/cups/templates/fr
+@dirrm share/cups/templates/de
@dirrm share/cups/templates
@dirrm share/cups/model
@dirrm share/cups/fonts
@@ -349,6 +425,7 @@ share/locale/zh_CN/cups_zh_CN
@dirrm libexec/cups/backend
@dirrm libexec/cups
@dirrm include/cups
+@dirrm etc/cups/ppd
@dirrm etc/cups/interfaces
@dirrm etc/cups/certs
-@dirrm etc/cups
+@unexec rmdir %D/etc/cups 2>/dev/null || true
diff --git a/print/cups-lpr/Makefile b/print/cups-lpr/Makefile
index 6d47ef0bba97..aec4c29becbe 100644
--- a/print/cups-lpr/Makefile
+++ b/print/cups-lpr/Makefile
@@ -17,11 +17,20 @@ MASTER_SITES= ${CUPS_MASTER_SITES}
MAINTAINER= ports@FreeBSD.org
COMMENT= The CUPS BSD and system V compatibility binaries (lp* commands)
+USE_REINPLACE= yes
+
+MANLANG= "" fr
+
+post-patch:
+ @${REINPLACE_CMD} -e '/SILENT/d' \
+ ${WRKSRC}/Makedefs.in
+ @${REINPLACE_CMD} -e '/LN/d' \
+ ${WRKSRC}/man/Makefile ${WRKSRC}/man/fr/Makefile
+
post-install:
${FIND} ${PREFIX}/man/cat* -type l -name '*.0' -delete
${FIND} ${PREFIX}/man/fr/cat* -type l -name '*.0' -delete
-MANLANG= "" fr
.include "${.CURDIR}/../../print/cups/Makefile.common"
.include <bsd.port.pre.mk>
diff --git a/print/cups-lpr/distinfo b/print/cups-lpr/distinfo
deleted file mode 100644
index 7c4c9f612542..000000000000
--- a/print/cups-lpr/distinfo
+++ /dev/null
@@ -1 +0,0 @@
-MD5 (cups-1.1.18-source.tar.bz2) = 4a8a423a8268d088bffa19f6515883a7
diff --git a/print/cups-lpr/files/patch-Makefile b/print/cups-lpr/files/patch-Makefile
index 133708751f6d..bb32b26ef5e5 100644
--- a/print/cups-lpr/files/patch-Makefile
+++ b/print/cups-lpr/files/patch-Makefile
@@ -1,5 +1,5 @@
---- Makefile.orig Tue Dec 17 13:56:25 2002
-+++ Makefile Wed Jan 22 08:02:38 2003
+--- Makefile.orig Fri Mar 7 01:36:00 2003
++++ Makefile Tue Jun 10 22:24:03 2003
@@ -28,8 +28,7 @@
# Directories to make...
#
@@ -19,7 +19,7 @@
echo Making all in $$dir... ;\
(cd $$dir ; $(MAKE) $(MFLAGS)) || exit 1;\
done
-@@ -67,104 +66,11 @@
+@@ -67,103 +66,11 @@
# Install object and target files...
#
@@ -62,7 +62,7 @@
- if test "x$(INITDIR)" = "x" -a "x$(INITDDIR)" != "x"; then \
- $(INSTALL_DIR) $(BUILDROOT)$(INITDDIR); \
- if test "$(INITDDIR)" = "/System/Library/StartupItems/PrintingServices"; then \
-- $(INSTALL_SCRIPT) cups.sh $(BUILDROOT)$(INITDDIR)/PrintingServices; \
+- $(INSTALL_SCRIPT) cups.osx $(BUILDROOT)$(INITDDIR)/PrintingServices; \
- $(INSTALL_DATA) cups.plist $(BUILDROOT)$(INITDDIR)/StartupParameters.plist; \
- $(INSTALL_DIR) $(BUILDROOT)$(INITDDIR)/Resources/English.lproj; \
- $(INSTALL_DATA) cups.strings $(BUILDROOT)$(INITDDIR)/Resources/English.lproj/Localizable.strings; \
@@ -121,7 +121,6 @@
-
-tardist:
- epm $(EPMFLAGS) -f tardist cups
--
- #
- # End of "$Id: Makefile,v 1.47 2002/12/17 18:56:25 swdev Exp $".
+
#
+ # End of "$Id: Makefile,v 1.48 2003/03/06 16:36:00 mike Exp $".
diff --git a/print/cups-lpr/files/patch-man-Makefile.common b/print/cups-lpr/files/patch-man-Makefile.common
index b160843f0ed0..73cbbca70975 100644
--- a/print/cups-lpr/files/patch-man-Makefile.common
+++ b/print/cups-lpr/files/patch-man-Makefile.common
@@ -1,14 +1,13 @@
---- man/Makefile.common.orig Tue Dec 17 13:59:55 2002
-+++ man/Makefile.common Wed Jan 22 07:38:08 2003
+--- man/Makefile.common.orig Wed Dec 18 03:59:55 2002
++++ man/Makefile.common Tue Jun 10 22:32:41 2003
@@ -26,9 +26,8 @@
# Man pages...
#
-MAN1 = backend.man \
-- cupstestppd.man \
++MAN1 = cupsaddsmb.man \
+ cupstestppd.man \
- filter.man \
-+MAN1 = cupsaddsmb.man\
-+ cupstestppd.man\
lp.man \
lpoptions.man \
lppasswd.man \
diff --git a/print/cups-lpr/pkg-plist b/print/cups-lpr/pkg-plist
index 310bf8bd6315..71a869e594ee 100644
--- a/print/cups-lpr/pkg-plist
+++ b/print/cups-lpr/pkg-plist
@@ -1,4 +1,5 @@
bin/cancel
+bin/cupstestppd
bin/disable
bin/enable
bin/lp
@@ -9,10 +10,9 @@ bin/lpr
bin/lprm
bin/lpstat
sbin/accept
-sbin/reject
sbin/cupsaddsmb
-sbin/cupstestppd
sbin/lpadmin
sbin/lpc
sbin/lpinfo
sbin/lpmove
+sbin/reject
diff --git a/print/cups/Makefile.common b/print/cups/Makefile.common
index 6312c7572f02..d3039cc18691 100644
--- a/print/cups/Makefile.common
+++ b/print/cups/Makefile.common
@@ -9,10 +9,10 @@ CUPS_MASTER_SITES=\
ftp://ftp.fisek.com.tr/pub/cups/${CUPS_VERSION}/ \
ftp://ftp.mpg.goe.ni.schule.de/pub/internet/printing/cups/${CUPS_VERSION}/
-CUPS_VERSION= 1.1.18
+CUPS_VERSION= 1.1.19
CUPS_REVISION= 0
CUPS_PORTVER= ${CUPS_VERSION}.${CUPS_REVISION}
-CUPS_PORTREV= 5
+CUPS_PORTREV= 0
CUPS_PORTEPOCH= 0
CUPS_FILESDIR= ${.CURDIR}/../../print/cups/files
CUPS_ETCDIR= ${PREFIX}/etc/cups
@@ -39,6 +39,8 @@ DISTNAME= cups-${CUPS_VERSION}-${CUPS_REVISION}-source
.endif # ${CUPS_REVISION} < 1
DISTFILES= ${DISTNAME}.tar.bz2
+
+MD5_FILE= ${.CURDIR}/../../print/cups/distinfo
WRKSRC= ${WRKDIR}/cups-${CUPS_VERSION}
LIB_DEPENDS+= jpeg.9:${PORTSDIR}/graphics/jpeg \
@@ -52,6 +54,8 @@ USE_GMAKE= yes
USE_PERL5_RUN= yes
GNU_CONFIGURE= yes
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+
CONFIGURE_ARGS+= --localstatedir=/var \
--disable-pam \
--disable-slp \
@@ -60,14 +64,12 @@ CONFIGURE_ARGS+= --localstatedir=/var \
--with-docdir=${CUPS_DOCSDIR} \
--with-rcdir=${CUPS_RCDIR}
-CONFIGURE_ARGS+= CPPFLAGS="-I${PREFIX}/include"
-CONFIGURE_ARGS+= CFLAGS="${CFLAGS} -I.. -I${PREFIX}/include"
-CONFIGURE_ARGS+= CXXFLAGS="${CFLAGS} -I.. -I${PREFIX}/include"
+CONFIGURE_ARGS+= CPPFLAGS="-I.. -I${LOCALBASE}/include"
CONFIGURE_ARGS+= DSOFLAGS="-Wl,-rpath,${PREFIX}/lib -L${PREFIX}/lib"
-CONFIGURE_ARGS+= LDFLAGS="-L${PREFIX}/lib"
+CONFIGURE_ARGS+= LDFLAGS="-L${LOCALBASE}/lib"
pre-configure::
- @${ECHO_CMD} Configuring CUPS with options:
- @${ECHO_CMD} ${CONFIGURE_ARGS} | fmt
+ @${ECHO_MSG} Configuring CUPS with options:
+ @${ECHO_MSG} ${CONFIGURE_ARGS} | fmt
.endif # ${PORTNAME} != "cups"
diff --git a/print/cups/distinfo b/print/cups/distinfo
index cd633b7b6417..a3bdf9c9e305 100644
--- a/print/cups/distinfo
+++ b/print/cups/distinfo
@@ -1 +1 @@
-This is a metaport; it has no source of its own.
+MD5 (cups-1.1.19-source.tar.bz2) = 04cbeed9a8acfe23624f1cb6be9c3eac