aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2003-11-20 14:50:03 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2003-11-20 14:50:03 +0000
commitf3ec3b60437732d44d00d4b3badf5bc14f497770 (patch)
treeae9f7a69ace80d981e421967e1d56263ec0af031
parent5ef1c5da7afca2da88c34ce3c094fe4c4d7e5f63 (diff)
downloadports-f3ec3b60437732d44d00d4b3badf5bc14f497770.tar.gz
ports-f3ec3b60437732d44d00d4b3badf5bc14f497770.zip
Notes
-rw-r--r--www/mod_musicindex/Makefile26
-rw-r--r--www/mod_musicindex/distinfo2
-rw-r--r--www/mod_musicindex/files/patch-Makefile13
-rw-r--r--www/mod_musicindex/files/patch-Makefile.apache234
-rw-r--r--www/mod_musicindex/pkg-plist9
5 files changed, 67 insertions, 17 deletions
diff --git a/www/mod_musicindex/Makefile b/www/mod_musicindex/Makefile
index 50d5c2c9e29c..ef0043df1334 100644
--- a/www/mod_musicindex/Makefile
+++ b/www/mod_musicindex/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= mod_musicindex
-PORTVERSION= 0.8.9
+PORTVERSION= 0.9.0
CATEGORIES= www audio
MASTER_SITES= http://www.esiee.fr/~puffin/musicindex/
DISTNAME= libapache-mod-musicindex_${PORTVERSION}
@@ -22,18 +22,34 @@ LIB_DEPENDS= ogg.4:${PORTSDIR}/audio/libogg \
mad.1:${PORTSDIR}/audio/mad
APXS?= ${LOCALBASE}/sbin/apxs
-APACHE_PORT?= ${PORTSDIR}/www/apache13
USE_GMAKE= yes
WRKSRC= ${WRKDIR}/libapache-mod-musicindex-${PORTVERSION}
+MAKE_ENV+= APXS=${APXS} BUILDDIR=${WRKSRC}
-DOCS_HTMLIMAGES= directory.png musicindex.css fetch.png \
+PORTDOCS= directory.png musicindex.css fetch.png \
right_arrow.gif general.png sound.png
+.if defined (WITH_APACHE2)
+MODULE_EXT= la
+MAKEFILE= Makefile.apache2
+PLIST_SUB+= MOD_DIR=libexec/apache2
+APACHE_PORT?= ${PORTSDIR}/www/apache2
+MAKE_TARGET= all
+.else
+MODULE_EXT= so
+PLIST_SUB+= MOD_DIR=libexec/apache
+APACHE_PORT?= ${PORTSDIR}/www/apache13
+.endif
+
+post-patch:
+ @${CP} ${WRKSRC}/modules.mk.apache2 ${WRKSRC}/modules.mk
+ @${TOUCH} ${WRKSRC}/.deps
+
do-install:
- ${APXS} -i -A -n musicindex ${WRKSRC}/mod_musicindex.so
+ ${APXS} -i -n musicindex -A ${WRKSRC}/mod_musicindex.${MODULE_EXT}
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
-.for f in ${DOCS_HTMLIMAGES}
+.for f in ${PORTDOCS}
${INSTALL_DATA} ${WRKSRC}/musicindex/${f} ${DOCSDIR}
.endfor
.endif
diff --git a/www/mod_musicindex/distinfo b/www/mod_musicindex/distinfo
index 97a394aa0d69..364af9214b92 100644
--- a/www/mod_musicindex/distinfo
+++ b/www/mod_musicindex/distinfo
@@ -1 +1 @@
-MD5 (libapache-mod-musicindex_0.8.9.tar.gz) = 49eede2e4935f32b7f5f60a4782aa9a0
+MD5 (libapache-mod-musicindex_0.9.0.tar.gz) = 81bc6f199801b6a4dc6e91d52b87c3b3
diff --git a/www/mod_musicindex/files/patch-Makefile b/www/mod_musicindex/files/patch-Makefile
index beac1087907e..71caab7dec2c 100644
--- a/www/mod_musicindex/files/patch-Makefile
+++ b/www/mod_musicindex/files/patch-Makefile
@@ -1,6 +1,13 @@
---- Makefile.orig Thu Oct 30 20:41:45 2003
-+++ Makefile Tue Nov 4 00:03:52 2003
-@@ -15,8 +15,8 @@
+--- Makefile.orig Thu Oct 30 12:41:45 2003
++++ Makefile Thu Nov 20 12:35:49 2003
+@@ -8,15 +8,13 @@
+ ## @todo auto-dep
+
+ # the tools
+-APXS = apxs
+ APACHECTL = apachectl
+-CC = gcc
+ INSTALL = install
# additional user defines, includes and libraries
#DEF =
diff --git a/www/mod_musicindex/files/patch-Makefile.apache2 b/www/mod_musicindex/files/patch-Makefile.apache2
new file mode 100644
index 000000000000..bbf7664bb3ad
--- /dev/null
+++ b/www/mod_musicindex/files/patch-Makefile.apache2
@@ -0,0 +1,34 @@
+--- Makefile.apache2.orig Tue Nov 11 18:58:43 2003
++++ Makefile.apache2 Thu Nov 20 14:09:38 2003
+@@ -3,23 +3,23 @@
+ ## Autogenerated via ``apxs -n musicindex -g''.
+ ##
+
+-builddir=.
+-top_srcdir=/usr/share/apache2
+-top_builddir=/usr/share/apache2
+-include /usr/share/apache2/build/special.mk
++builddir=${BUILDDIR}
++top_srcdir=${LOCALBASE}/share/apache2
++top_builddir=${LOCALBASE}/share/apache2
++include ${LOCALBASE}/share/apache2/build/special.mk
+
+ # the used tools
+-APXS=apxs2
+ APACHECTL=apache2ctl
+
+ # additional defines, includes and libraries
+ DEF = -DEAPI
+-#INCLUDES=-Imy/include/dir
+-LIBS= -logg -lvorbis -lvorbisfile -lid3tag -lmad -lz
+-CFLAGS += -Wall -I/usr/include/apr-0
++INCLUDES=-I${LOCALBASE}/include/ -I${LOCALBASE}/include/apache2
++LIBS= -logg -lvorbis -lvorbisfile -lid3tag -lmad -lz -L${LOCALBASE}/lib
++CFLAGS += -Wall -I${LOCALBASE}/include/ -I${LOCALBASE}/include/apache2
+
+ # the default target
+ all: local-shared-build
++ ${APXS} -c mod_musicindex.c
+
+ # install the shared object file into Apache
+ install: install-modules
diff --git a/www/mod_musicindex/pkg-plist b/www/mod_musicindex/pkg-plist
index a0105dbfeaad..62812974bc6d 100644
--- a/www/mod_musicindex/pkg-plist
+++ b/www/mod_musicindex/pkg-plist
@@ -1,10 +1,3 @@
-libexec/apache/mod_musicindex.so
+%%MOD_DIR%%/mod_musicindex.so
@exec %D/sbin/apxs -e -A -n musicindex %D/%F
@unexec %D/sbin/apxs -e -A -n musicindex %D/%F
-%%PORTDOCS%%%%DOCSDIR%%/directory.png
-%%PORTDOCS%%%%DOCSDIR%%/fetch.png
-%%PORTDOCS%%%%DOCSDIR%%/general.png
-%%PORTDOCS%%%%DOCSDIR%%/musicindex.css
-%%PORTDOCS%%%%DOCSDIR%%/right_arrow.gif
-%%PORTDOCS%%%%DOCSDIR%%/sound.png
-%%PORTDOCS%%@dirrm %%DOCSDIR%%