aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSatoshi Asami <asami@FreeBSD.org>1995-05-31 06:01:49 +0000
committerSatoshi Asami <asami@FreeBSD.org>1995-05-31 06:01:49 +0000
commit7d52e87445093ef7003e7b404bb33e03046cc803 (patch)
treef0a3d8a7051888780f86f08e4eb56e29f0314c33
parent3eb81720164bcde2400975ba5c36311ab3f55cd0 (diff)
downloadports-7d52e87445093ef7003e7b404bb33e03046cc803.tar.gz
ports-7d52e87445093ef7003e7b404bb33e03046cc803.zip
Add post-install target to make symbolic links for shared libraries
(to make ldconfig happy) and gzip manpages.
Notes
Notes: svn path=/head/; revision=1815
-rw-r--r--x11-toolkits/iv/Makefile8
1 files changed, 7 insertions, 1 deletions
diff --git a/x11-toolkits/iv/Makefile b/x11-toolkits/iv/Makefile
index 110a71f6a47a..baa51e136302 100644
--- a/x11-toolkits/iv/Makefile
+++ b/x11-toolkits/iv/Makefile
@@ -3,7 +3,7 @@
# Date created: 23.sept.1994
# Whom: adam
#
-# $Id: Makefile,v 1.6 1995/04/16 15:33:42 ache Exp $
+# $Id: Makefile,v 1.7 1995/05/29 12:42:41 asami Exp $
#
VERSION= 3.1
@@ -28,4 +28,10 @@ pre-fetch:
fi
.endif
+post-install:
+ cd ${PREFIX}/interviews/man/mann; gzip -9nf *.n
+# need these in ${PREFIX}/lib so that ldconfig can find them
+ ln -fs ../interviews/lib/FREEBSD/libIV.so.3.1 ${PREFIX}/lib
+ ln -fs ../interviews/lib/FREEBSD/libUnidraw.so.3.1 ${PREFIX}/lib
+
.include <bsd.port.mk>