aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Sobolev <sobomax@FreeBSD.org>2000-06-16 13:25:32 +0000
committerMaxim Sobolev <sobomax@FreeBSD.org>2000-06-16 13:25:32 +0000
commit261d43c63fadf7047db4b35d9f6150c44a465b2e (patch)
treeb51a26795b85eac5e737b72d3c13fe37da37aef1
parent99dc9a613447c30bef644b45ef2e16163e4bbc58 (diff)
downloadports-261d43c63fadf7047db4b35d9f6150c44a465b2e.tar.gz
ports-261d43c63fadf7047db4b35d9f6150c44a465b2e.zip
Initial import of grdb - an application to match Motif/Athena/Tk widgets
with the current GTK theme. PR: 19243 Submitted by: Stijn Hoop <stijn@win.tue.nl>
Notes
Notes: svn path=/head/; revision=29640
-rw-r--r--misc/grdb/Makefile56
-rw-r--r--misc/grdb/distinfo1
-rw-r--r--misc/grdb/pkg-comment1
-rw-r--r--misc/grdb/pkg-descr6
-rw-r--r--misc/grdb/pkg-plist17
5 files changed, 81 insertions, 0 deletions
diff --git a/misc/grdb/Makefile b/misc/grdb/Makefile
new file mode 100644
index 000000000000..1d7f27844600
--- /dev/null
+++ b/misc/grdb/Makefile
@@ -0,0 +1,56 @@
+# New ports collection makefile for: grdb
+# Date created: 13 June 2000
+# Whom: Stijn Hoop <stijn@win.tue.nl>
+#
+# $FreeBSD$
+#
+
+PORTNAME= grdb
+PORTVERSION= 0.2.1
+CATEGORIES= misc gnome
+MASTER_SITES= http://bucket.pp.ualr.edu/~bit/download/
+
+MAINTAINER= stijn@win.tue.nl
+
+LIB_DEPENDS= popt.0:${PORTSDIR}/devel/popt \
+ gtk12.2:${PORTSDIR}/x11-toolkits/gtk12 \
+ ${GNOME_DEPENDS}
+
+.if !defined(WITHOUT_GNOME)
+GNOME_DEPENDS= gnome.4:${PORTSDIR}/x11/gnomelibs
+.endif
+
+USE_X_PREFIX= yes
+
+USE_GMAKE= yes
+GNU_CONFIGURE= yes
+GTK_CONFIG?= ${PREFIX}/bin/gtk12-config
+CONFIGURE_ENV= GTK_CONFIG="${GTK_CONFIG}" \
+ CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+
+.if defined(WITHOUT_GNOME)
+CONFIGURE_ARGS= --disable-gnome
+.endif
+
+.if !defined(WITHOUT_GNOME)
+pre-extract:
+ @${ECHO} "===> NOTE: You can remove support for the Gnome control panel"
+ @${ECHO} "===> by defining WITHOUT_GNOME"
+.endif
+
+post-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${PREFIX}/share/doc/grdb
+ ${INSTALL_MAN} ${WRKSRC}/README ${PREFIX}/share/doc/grdb
+ @${ECHO} "share/doc/grdb/README" >> ${TMPPLIST}
+ @${ECHO} "@dirrm share/doc/grdb" >> ${TMPPLIST}
+.endif
+.if !defined(WITHOUT_GNOME)
+ @${ECHO} "bin/grdb-capplet" >> ${TMPPLIST}
+ @${ECHO} "share/gnome/control-center/Desktop/grdb-capplet.desktop" >> ${TMPPLIST}
+ @${ECHO} "share/gnome/apps/Settings/Desktop/grdb-capplet.desktop" >> ${TMPPLIST}
+ @${ECHO} "share/gnome/pixmaps/grdb-capplet.png" >> ${TMPPLIST}
+.endif
+
+.include <bsd.port.mk>
diff --git a/misc/grdb/distinfo b/misc/grdb/distinfo
new file mode 100644
index 000000000000..901380b15dca
--- /dev/null
+++ b/misc/grdb/distinfo
@@ -0,0 +1 @@
+MD5 (grdb-0.2.1.tar.gz) = de0c758d3553a287b25927036e604eaf
diff --git a/misc/grdb/pkg-comment b/misc/grdb/pkg-comment
new file mode 100644
index 000000000000..1a031ce3e039
--- /dev/null
+++ b/misc/grdb/pkg-comment
@@ -0,0 +1 @@
+Matches Motif/Athena/Tk widgets with the current GTK theme
diff --git a/misc/grdb/pkg-descr b/misc/grdb/pkg-descr
new file mode 100644
index 000000000000..afde3f3f51e1
--- /dev/null
+++ b/misc/grdb/pkg-descr
@@ -0,0 +1,6 @@
+A utility that updates X applications that use Motif/Athena/Tk to use
+the colors of the current GTK+ theme. Based on the KDE equivalent krdb.
+
+WWW: http://bucket.pp.ualr.edu/~bit/grdb.html
+
+--Stijn Hoop
diff --git a/misc/grdb/pkg-plist b/misc/grdb/pkg-plist
new file mode 100644
index 000000000000..d43d9aa5b0e4
--- /dev/null
+++ b/misc/grdb/pkg-plist
@@ -0,0 +1,17 @@
+bin/grdb
+share/grdb/AAAAAAGeneral.ad
+share/grdb/AAAMotif.ad
+share/grdb/AAATk.ad
+share/grdb/AAAXaw.ad
+share/grdb/Ddd.ad
+share/grdb/Editres.ad
+share/grdb/Emacs.ad
+share/grdb/ML.ad
+share/grdb/Nedit.ad
+share/grdb/Netscape.ad
+share/grdb/RVPlayer.ad
+share/grdb/XCalc.ad
+share/grdb/XTerm.ad
+share/grdb/XV.ad
+share/grdb/XWp.ad
+@dirrm share/grdb