aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Sobolev <sobomax@FreeBSD.org>2000-06-15 10:48:01 +0000
committerMaxim Sobolev <sobomax@FreeBSD.org>2000-06-15 10:48:01 +0000
commita0a204939cb7695e9c3fdd2a206fe8e023c60356 (patch)
tree96f1a00f35ab9d33e86cf0a42c0b02a9fee4304e
parent7c22eb053a44d5a94fc375daf00d0e1c40309c8e (diff)
downloadports-a0a204939cb7695e9c3fdd2a206fe8e023c60356.tar.gz
ports-a0a204939cb7695e9c3fdd2a206fe8e023c60356.zip
Initial import of xmps - a nice Gnome MPEG videoplayer.
Notes
Notes: svn path=/head/; revision=29608
-rw-r--r--graphics/xmps/Makefile33
-rw-r--r--graphics/xmps/distinfo1
-rw-r--r--graphics/xmps/files/patch-aa92
-rw-r--r--graphics/xmps/files/patch-ab11
-rw-r--r--graphics/xmps/files/patch-ac11
-rw-r--r--graphics/xmps/files/patch-ad43
-rw-r--r--graphics/xmps/files/patch-ae11
-rw-r--r--graphics/xmps/pkg-comment1
-rw-r--r--graphics/xmps/pkg-descr11
-rw-r--r--graphics/xmps/pkg-plist32
-rw-r--r--multimedia/xmps/Makefile33
-rw-r--r--multimedia/xmps/distinfo1
-rw-r--r--multimedia/xmps/files/patch-aa92
-rw-r--r--multimedia/xmps/files/patch-ab11
-rw-r--r--multimedia/xmps/files/patch-ac11
-rw-r--r--multimedia/xmps/files/patch-ad43
-rw-r--r--multimedia/xmps/files/patch-ae11
-rw-r--r--multimedia/xmps/pkg-comment1
-rw-r--r--multimedia/xmps/pkg-descr11
-rw-r--r--multimedia/xmps/pkg-plist32
20 files changed, 492 insertions, 0 deletions
diff --git a/graphics/xmps/Makefile b/graphics/xmps/Makefile
new file mode 100644
index 000000000000..cb70ed2e4d13
--- /dev/null
+++ b/graphics/xmps/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: xmps
+# Date created: 15 June 2000
+# Whom: Maxim Sobolev <sobomax@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= xmps
+PORTVERSION= 0.1.0
+CATEGORIES= graphics gnome
+MASTER_SITES= http://www-eleves.enst-bretagne.fr/~chavarri/xmps/sources/
+
+MAINTAINER= sobomax@FreeBSD.org
+
+LIB_DEPENDS= smpeg.0:${PORTSDIR}/graphics/smpeg \
+ gnome.4:${PORTSDIR}/x11/gnomelibs \
+ gdk_pixbuf.2:${PORTSDIR}/graphics/gdk-pixbuf
+BUILD_DEPENDS= nasm:${PORTSDIR}/devel/nasm
+
+USE_X_PREFIX= yes
+USE_LIBTOOL= yes
+
+GTK_CONFIG?= ${X11BASE}/bin/gtk12-config
+GLIB_CONFIG?= ${LOCALBASE}/bin/glib12-config
+SDL_CONFIG?= ${LOCALBASE}/bin/sdl11-config
+
+CONFIGURE_ENV= GTK_CONFIG="${GTK_CONFIG}" \
+ GLIB_CONFIG="${GLIB_CONFIG}" \
+ SDL_CONFIG="${SDL_CONFIG}" \
+ CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+
+.include <bsd.port.mk>
diff --git a/graphics/xmps/distinfo b/graphics/xmps/distinfo
new file mode 100644
index 000000000000..8c197f1213cf
--- /dev/null
+++ b/graphics/xmps/distinfo
@@ -0,0 +1 @@
+MD5 (xmps-0.1.0.tar.gz) = 858bc03bc9747516b4135df0be7f7a3c
diff --git a/graphics/xmps/files/patch-aa b/graphics/xmps/files/patch-aa
new file mode 100644
index 000000000000..7ae2c2967701
--- /dev/null
+++ b/graphics/xmps/files/patch-aa
@@ -0,0 +1,92 @@
+--- configure.orig Wed May 17 23:43:36 2000
++++ configure Thu Jun 15 13:32:11 2000
+@@ -1536,6 +1536,7 @@
+
+
+ STRETCHER_SRC=
++STRETCHER_OBJ=
+ # Extract the first word of "nasm", so it can be a program name with args.
+ set dummy nasm; ac_word=$2
+ echo $ac_n "checking for $ac_word""... $ac_c" 1>&6
+@@ -1568,6 +1569,7 @@
+
+ if test "$have_nasm" = "yes"; then
+ STRETCHER_SRC="stretch.h stretch.c stretchblt.asm"
++ STRETCHER_OBJ="stretch.lo stretchblt.o"
+ cat >> confdefs.h <<\EOF
+ #define AS_STRETCHER 1
+ EOF
+@@ -2979,14 +2981,14 @@
+ { echo "configure: error: *** POSIX thread support not installed ***" 1>&2; exit 1; }
+ fi
+
+-echo $ac_n "checking for pthread_attr_init in -lpthread""... $ac_c" 1>&6
+-echo "configure:2984: checking for pthread_attr_init in -lpthread" >&5
++echo $ac_n "checking for pthread_attr_init in -pthread""... $ac_c" 1>&6
++echo "configure:2984: checking for pthread_attr_init in -pthread" >&5
+ ac_lib_var=`echo pthread'_'pthread_attr_init | sed 'y%./+-%__p_%'`
+ if eval "test \"`echo '$''{'ac_cv_lib_$ac_lib_var'+set}'`\" = set"; then
+ echo $ac_n "(cached) $ac_c" 1>&6
+ else
+ ac_save_LIBS="$LIBS"
+-LIBS="-lpthread $LIBS"
++LIBS="-pthread $LIBS"
+ cat > conftest.$ac_ext <<EOF
+ #line 2992 "configure"
+ #include "confdefs.h"
+@@ -3020,7 +3022,7 @@
+ #define $ac_tr_lib 1
+ EOF
+
+- LIBS="-lpthread $LIBS"
++ LIBS="-pthread $LIBS"
+
+ else
+ echo "$ac_t""no" 1>&6
+@@ -4060,16 +4062,16 @@
+ { echo "configure: error: **** Cannot find stat.h ****" 1>&2; exit 1; }
+ fi
+
+-ac_safe=`echo "sys/dir.h" | sed 'y%./+-%__p_%'`
+-echo $ac_n "checking for sys/dir.h""... $ac_c" 1>&6
+-echo "configure:4066: checking for sys/dir.h" >&5
++ac_safe=`echo "dirent.h" | sed 'y%./+-%__p_%'`
++echo $ac_n "checking for dirent.h""... $ac_c" 1>&6
++echo "configure:4066: checking for dirent.h" >&5
+ if eval "test \"`echo '$''{'ac_cv_header_$ac_safe'+set}'`\" = set"; then
+ echo $ac_n "(cached) $ac_c" 1>&6
+ else
+ cat > conftest.$ac_ext <<EOF
+ #line 4071 "configure"
+ #include "confdefs.h"
+-#include <sys/dir.h>
++#include <dirent.h>
+ EOF
+ ac_try="$ac_cpp conftest.$ac_ext >/dev/null 2>conftest.out"
+ { (eval echo configure:4076: \"$ac_try\") 1>&5; (eval $ac_try) 2>&5; }
+@@ -4091,7 +4093,7 @@
+ :
+ else
+ echo "$ac_t""no" 1>&6
+-{ echo "configure: error: **** Cannot find dir.h ****" 1>&2; exit 1; }
++{ echo "configure: error: **** Cannot find dirent.h ****" 1>&2; exit 1; }
+ fi
+
+
+@@ -6001,7 +6003,7 @@
+ < $srcdir/po/POTFILES.in > po/POTFILES
+
+
+-CFLAGS="$CFLAGS `gtk-config --cflags`"
++CFLAGS="$CFLAGS `$GTK_CONFIG --cflags`"
+
+
+ CODEC_PLUGINS_DIR=Codecs
+@@ -6188,6 +6190,7 @@
+ s%@LIBTOOL@%$LIBTOOL%g
+ s%@have_nasm@%$have_nasm%g
+ s%@STRETCHER_SRC@%$STRETCHER_SRC%g
++s%@STRETCHER_OBJ@%$STRETCHER_OBJ%g
+ s%@CPP@%$CPP%g
+ s%@X_CFLAGS@%$X_CFLAGS%g
+ s%@X_PRE_LIBS@%$X_PRE_LIBS%g
diff --git a/graphics/xmps/files/patch-ab b/graphics/xmps/files/patch-ab
new file mode 100644
index 000000000000..270474988096
--- /dev/null
+++ b/graphics/xmps/files/patch-ab
@@ -0,0 +1,11 @@
+--- Output/SDL/sdl_renderer.h.orig Thu Jun 15 11:33:24 2000
++++ Output/SDL/sdl_renderer.h Thu Jun 15 11:33:35 2000
+@@ -25,7 +25,7 @@
+ #ifndef _SDL_RENDERER_H
+ #define _SDL_RENDERER_H
+
+-#include <SDL/SDL.h>
++#include <SDL.h>
+
+ #include <src/types.h>
+ #include <src/xmps_utils.h>
diff --git a/graphics/xmps/files/patch-ac b/graphics/xmps/files/patch-ac
new file mode 100644
index 000000000000..fc6db3042567
--- /dev/null
+++ b/graphics/xmps/files/patch-ac
@@ -0,0 +1,11 @@
+--- Output/X11/stretch.h.orig Thu Jun 15 11:36:00 2000
++++ Output/X11/stretch.h Thu Jun 15 11:36:11 2000
+@@ -27,7 +27,7 @@
+ #ifndef _STRETCH_H
+ #define _STRETCH_H
+
+-#include <SDL/SDL.h>
++#include <SDL.h>
+
+ /* setup scaling routine. must be called before AS_stretchBlit
+ Returns 0 on success, nonzero if bit depth is invalid (not 16 nor 32),
diff --git a/graphics/xmps/files/patch-ad b/graphics/xmps/files/patch-ad
new file mode 100644
index 000000000000..fc3a22211a35
--- /dev/null
+++ b/graphics/xmps/files/patch-ad
@@ -0,0 +1,43 @@
+--- Output/X11/Makefile.in.orig Wed May 17 23:45:19 2000
++++ Output/X11/Makefile.in Thu Jun 15 13:26:45 2000
+@@ -100,6 +100,7 @@
+ SDL_CONFIG = @SDL_CONFIG@
+ SDL_LIBS = @SDL_LIBS@
+ STRETCHER_SRC = @STRETCHER_SRC@
++STRETCHER_OBJ = @STRETCHER_OBJ@
+ USE_INCLUDED_LIBINTL = @USE_INCLUDED_LIBINTL@
+ USE_NLS = @USE_NLS@
+ VERSION = @VERSION@
+@@ -115,12 +116,12 @@
+ libdir = $(PLUGINS_DIR)/$(RENDERER_PLUGINS_DIR)
+
+ libX11_la_LDFLAGS = -module -avoid-version
+-libX11_la_LIBADD = @GTK_LIBS@ -ldl -lXi -lXext -lX11 -lm
++libX11_la_LIBADD = @GTK_LIBS@ -lXi -lXext -lX11 -lm
+
+ libX11_la_SOURCES = x11_renderer.c x11_renderer.h @STRETCHER_SRC@
+
+
+-INCLUDES = @GTK_CFLAGS@
++INCLUDES = @GTK_CFLAGS@ @SDL_CFLAGS@
+ mkinstalldirs = $(SHELL) $(top_srcdir)/mkinstalldirs
+ CONFIG_HEADER = ../../config.h
+ CONFIG_CLEAN_FILES =
+@@ -132,7 +133,7 @@
+ LDFLAGS = @LDFLAGS@
+ LIBS = @LIBS@
+ libX11_la_DEPENDENCIES =
+-libX11_la_OBJECTS = x11_renderer.lo
++libX11_la_OBJECTS = x11_renderer.lo @STRETCHER_OBJ@
+ CFLAGS = @CFLAGS@
+ COMPILE = $(CC) $(DEFS) $(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) $(AM_CFLAGS) $(CFLAGS)
+ LTCOMPILE = $(LIBTOOL) --mode=compile $(CC) $(DEFS) $(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) $(AM_CFLAGS) $(CFLAGS)
+@@ -346,6 +347,8 @@
+ distclean-generic clean-generic maintainer-clean-generic clean \
+ mostlyclean distclean maintainer-clean
+
++stretchblt.o:
++ nasm -f elf stretchblt.asm
+
+ # Tell versions [3.59,3.63) of GNU make to not export all variables.
+ # Otherwise a system limit (for SysV at least) may be exceeded.
diff --git a/graphics/xmps/files/patch-ae b/graphics/xmps/files/patch-ae
new file mode 100644
index 000000000000..04a473858aaa
--- /dev/null
+++ b/graphics/xmps/files/patch-ae
@@ -0,0 +1,11 @@
+--- Output/Makefile.in.orig Thu Jun 15 11:44:17 2000
++++ Output/Makefile.in Thu Jun 15 11:44:28 2000
+@@ -111,7 +111,7 @@
+ have_nasm = @have_nasm@
+ l = @l@
+
+-SUBDIRS = SDL X11 OpenGL
++SUBDIRS = SDL X11
+ mkinstalldirs = $(SHELL) $(top_srcdir)/mkinstalldirs
+ CONFIG_HEADER = ../config.h
+ CONFIG_CLEAN_FILES =
diff --git a/graphics/xmps/pkg-comment b/graphics/xmps/pkg-comment
new file mode 100644
index 000000000000..f4d8e4a417eb
--- /dev/null
+++ b/graphics/xmps/pkg-comment
@@ -0,0 +1 @@
+X MPEG Player System - a MPEG-1 video player with a very nice GUI
diff --git a/graphics/xmps/pkg-descr b/graphics/xmps/pkg-descr
new file mode 100644
index 000000000000..0de095ec6507
--- /dev/null
+++ b/graphics/xmps/pkg-descr
@@ -0,0 +1,11 @@
+XMPS stands for X MPEG Player System. It's a simple Gtk program that will
+(hopefully) play MPEG-1 files with sound under the *nix platforms. It has very
+attractive skinnable user interface.
+
+And what more?
+
+XMPS is built on top of the SMPEG library from Loki entertainment. It has full
+playlist support, can use OpenGL for the display if available, so that you can
+play full-screen MPEGs without having to change screen resolution.
+
+WWW: http://www-eleves.enst-bretagne.fr/~chavarri/xmps/
diff --git a/graphics/xmps/pkg-plist b/graphics/xmps/pkg-plist
new file mode 100644
index 000000000000..f8ddd7348a30
--- /dev/null
+++ b/graphics/xmps/pkg-plist
@@ -0,0 +1,32 @@
+bin/xmps
+lib/xmps/Codecs/libsmpeg.so
+lib/xmps/Renderers/libSDL.so
+lib/xmps/Renderers/libX11.a
+share/gnome/apps/Multimedia/XMPS.desktop
+share/locale/fi/LC_MESSAGES/xmps.mo
+share/locale/fr/LC_MESSAGES/xmps.mo
+share/locale/pl/LC_MESSAGES/xmps.mo
+share/locale/sv/LC_MESSAGES/xmps.mo
+share/gnome/pixmaps/xmps.png
+share/xmps/skins/DarkDepth/buttons.xpm
+share/xmps/skins/DarkDepth/config
+share/xmps/skins/DarkDepth/controls.xpm
+share/xmps/skins/DarkDepth/digits.xpm
+share/xmps/skins/DarkDepth/main.xpm
+share/xmps/skins/DarkDepth/playlist.xpm
+share/xmps/skins/DarkDepth/titlebar.xpm
+share/xmps/skins/default/buttons.xpm
+share/xmps/skins/default/config
+share/xmps/skins/default/controls.xpm
+share/xmps/skins/default/digits.xpm
+share/xmps/skins/default/main.xpm
+share/xmps/skins/default/playlist.xpm
+share/xmps/skins/default/titlebar.xpm
+share/xmps/xmps_intro.xpm
+@dirrm share/xmps/skins/default
+@dirrm share/xmps/skins/DarkDepth
+@dirrm share/xmps/skins
+@dirrm share/xmps
+@dirrm lib/xmps/Renderers
+@dirrm lib/xmps/Codecs
+@dirrm lib/xmps
diff --git a/multimedia/xmps/Makefile b/multimedia/xmps/Makefile
new file mode 100644
index 000000000000..cb70ed2e4d13
--- /dev/null
+++ b/multimedia/xmps/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: xmps
+# Date created: 15 June 2000
+# Whom: Maxim Sobolev <sobomax@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= xmps
+PORTVERSION= 0.1.0
+CATEGORIES= graphics gnome
+MASTER_SITES= http://www-eleves.enst-bretagne.fr/~chavarri/xmps/sources/
+
+MAINTAINER= sobomax@FreeBSD.org
+
+LIB_DEPENDS= smpeg.0:${PORTSDIR}/graphics/smpeg \
+ gnome.4:${PORTSDIR}/x11/gnomelibs \
+ gdk_pixbuf.2:${PORTSDIR}/graphics/gdk-pixbuf
+BUILD_DEPENDS= nasm:${PORTSDIR}/devel/nasm
+
+USE_X_PREFIX= yes
+USE_LIBTOOL= yes
+
+GTK_CONFIG?= ${X11BASE}/bin/gtk12-config
+GLIB_CONFIG?= ${LOCALBASE}/bin/glib12-config
+SDL_CONFIG?= ${LOCALBASE}/bin/sdl11-config
+
+CONFIGURE_ENV= GTK_CONFIG="${GTK_CONFIG}" \
+ GLIB_CONFIG="${GLIB_CONFIG}" \
+ SDL_CONFIG="${SDL_CONFIG}" \
+ CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+
+.include <bsd.port.mk>
diff --git a/multimedia/xmps/distinfo b/multimedia/xmps/distinfo
new file mode 100644
index 000000000000..8c197f1213cf
--- /dev/null
+++ b/multimedia/xmps/distinfo
@@ -0,0 +1 @@
+MD5 (xmps-0.1.0.tar.gz) = 858bc03bc9747516b4135df0be7f7a3c
diff --git a/multimedia/xmps/files/patch-aa b/multimedia/xmps/files/patch-aa
new file mode 100644
index 000000000000..7ae2c2967701
--- /dev/null
+++ b/multimedia/xmps/files/patch-aa
@@ -0,0 +1,92 @@
+--- configure.orig Wed May 17 23:43:36 2000
++++ configure Thu Jun 15 13:32:11 2000
+@@ -1536,6 +1536,7 @@
+
+
+ STRETCHER_SRC=
++STRETCHER_OBJ=
+ # Extract the first word of "nasm", so it can be a program name with args.
+ set dummy nasm; ac_word=$2
+ echo $ac_n "checking for $ac_word""... $ac_c" 1>&6
+@@ -1568,6 +1569,7 @@
+
+ if test "$have_nasm" = "yes"; then
+ STRETCHER_SRC="stretch.h stretch.c stretchblt.asm"
++ STRETCHER_OBJ="stretch.lo stretchblt.o"
+ cat >> confdefs.h <<\EOF
+ #define AS_STRETCHER 1
+ EOF
+@@ -2979,14 +2981,14 @@
+ { echo "configure: error: *** POSIX thread support not installed ***" 1>&2; exit 1; }
+ fi
+
+-echo $ac_n "checking for pthread_attr_init in -lpthread""... $ac_c" 1>&6
+-echo "configure:2984: checking for pthread_attr_init in -lpthread" >&5
++echo $ac_n "checking for pthread_attr_init in -pthread""... $ac_c" 1>&6
++echo "configure:2984: checking for pthread_attr_init in -pthread" >&5
+ ac_lib_var=`echo pthread'_'pthread_attr_init | sed 'y%./+-%__p_%'`
+ if eval "test \"`echo '$''{'ac_cv_lib_$ac_lib_var'+set}'`\" = set"; then
+ echo $ac_n "(cached) $ac_c" 1>&6
+ else
+ ac_save_LIBS="$LIBS"
+-LIBS="-lpthread $LIBS"
++LIBS="-pthread $LIBS"
+ cat > conftest.$ac_ext <<EOF
+ #line 2992 "configure"
+ #include "confdefs.h"
+@@ -3020,7 +3022,7 @@
+ #define $ac_tr_lib 1
+ EOF
+
+- LIBS="-lpthread $LIBS"
++ LIBS="-pthread $LIBS"
+
+ else
+ echo "$ac_t""no" 1>&6
+@@ -4060,16 +4062,16 @@
+ { echo "configure: error: **** Cannot find stat.h ****" 1>&2; exit 1; }
+ fi
+
+-ac_safe=`echo "sys/dir.h" | sed 'y%./+-%__p_%'`
+-echo $ac_n "checking for sys/dir.h""... $ac_c" 1>&6
+-echo "configure:4066: checking for sys/dir.h" >&5
++ac_safe=`echo "dirent.h" | sed 'y%./+-%__p_%'`
++echo $ac_n "checking for dirent.h""... $ac_c" 1>&6
++echo "configure:4066: checking for dirent.h" >&5
+ if eval "test \"`echo '$''{'ac_cv_header_$ac_safe'+set}'`\" = set"; then
+ echo $ac_n "(cached) $ac_c" 1>&6
+ else
+ cat > conftest.$ac_ext <<EOF
+ #line 4071 "configure"
+ #include "confdefs.h"
+-#include <sys/dir.h>
++#include <dirent.h>
+ EOF
+ ac_try="$ac_cpp conftest.$ac_ext >/dev/null 2>conftest.out"
+ { (eval echo configure:4076: \"$ac_try\") 1>&5; (eval $ac_try) 2>&5; }
+@@ -4091,7 +4093,7 @@
+ :
+ else
+ echo "$ac_t""no" 1>&6
+-{ echo "configure: error: **** Cannot find dir.h ****" 1>&2; exit 1; }
++{ echo "configure: error: **** Cannot find dirent.h ****" 1>&2; exit 1; }
+ fi
+
+
+@@ -6001,7 +6003,7 @@
+ < $srcdir/po/POTFILES.in > po/POTFILES
+
+
+-CFLAGS="$CFLAGS `gtk-config --cflags`"
++CFLAGS="$CFLAGS `$GTK_CONFIG --cflags`"
+
+
+ CODEC_PLUGINS_DIR=Codecs
+@@ -6188,6 +6190,7 @@
+ s%@LIBTOOL@%$LIBTOOL%g
+ s%@have_nasm@%$have_nasm%g
+ s%@STRETCHER_SRC@%$STRETCHER_SRC%g
++s%@STRETCHER_OBJ@%$STRETCHER_OBJ%g
+ s%@CPP@%$CPP%g
+ s%@X_CFLAGS@%$X_CFLAGS%g
+ s%@X_PRE_LIBS@%$X_PRE_LIBS%g
diff --git a/multimedia/xmps/files/patch-ab b/multimedia/xmps/files/patch-ab
new file mode 100644
index 000000000000..270474988096
--- /dev/null
+++ b/multimedia/xmps/files/patch-ab
@@ -0,0 +1,11 @@
+--- Output/SDL/sdl_renderer.h.orig Thu Jun 15 11:33:24 2000
++++ Output/SDL/sdl_renderer.h Thu Jun 15 11:33:35 2000
+@@ -25,7 +25,7 @@
+ #ifndef _SDL_RENDERER_H
+ #define _SDL_RENDERER_H
+
+-#include <SDL/SDL.h>
++#include <SDL.h>
+
+ #include <src/types.h>
+ #include <src/xmps_utils.h>
diff --git a/multimedia/xmps/files/patch-ac b/multimedia/xmps/files/patch-ac
new file mode 100644
index 000000000000..fc6db3042567
--- /dev/null
+++ b/multimedia/xmps/files/patch-ac
@@ -0,0 +1,11 @@
+--- Output/X11/stretch.h.orig Thu Jun 15 11:36:00 2000
++++ Output/X11/stretch.h Thu Jun 15 11:36:11 2000
+@@ -27,7 +27,7 @@
+ #ifndef _STRETCH_H
+ #define _STRETCH_H
+
+-#include <SDL/SDL.h>
++#include <SDL.h>
+
+ /* setup scaling routine. must be called before AS_stretchBlit
+ Returns 0 on success, nonzero if bit depth is invalid (not 16 nor 32),
diff --git a/multimedia/xmps/files/patch-ad b/multimedia/xmps/files/patch-ad
new file mode 100644
index 000000000000..fc3a22211a35
--- /dev/null
+++ b/multimedia/xmps/files/patch-ad
@@ -0,0 +1,43 @@
+--- Output/X11/Makefile.in.orig Wed May 17 23:45:19 2000
++++ Output/X11/Makefile.in Thu Jun 15 13:26:45 2000
+@@ -100,6 +100,7 @@
+ SDL_CONFIG = @SDL_CONFIG@
+ SDL_LIBS = @SDL_LIBS@
+ STRETCHER_SRC = @STRETCHER_SRC@
++STRETCHER_OBJ = @STRETCHER_OBJ@
+ USE_INCLUDED_LIBINTL = @USE_INCLUDED_LIBINTL@
+ USE_NLS = @USE_NLS@
+ VERSION = @VERSION@
+@@ -115,12 +116,12 @@
+ libdir = $(PLUGINS_DIR)/$(RENDERER_PLUGINS_DIR)
+
+ libX11_la_LDFLAGS = -module -avoid-version
+-libX11_la_LIBADD = @GTK_LIBS@ -ldl -lXi -lXext -lX11 -lm
++libX11_la_LIBADD = @GTK_LIBS@ -lXi -lXext -lX11 -lm
+
+ libX11_la_SOURCES = x11_renderer.c x11_renderer.h @STRETCHER_SRC@
+
+
+-INCLUDES = @GTK_CFLAGS@
++INCLUDES = @GTK_CFLAGS@ @SDL_CFLAGS@
+ mkinstalldirs = $(SHELL) $(top_srcdir)/mkinstalldirs
+ CONFIG_HEADER = ../../config.h
+ CONFIG_CLEAN_FILES =
+@@ -132,7 +133,7 @@
+ LDFLAGS = @LDFLAGS@
+ LIBS = @LIBS@
+ libX11_la_DEPENDENCIES =
+-libX11_la_OBJECTS = x11_renderer.lo
++libX11_la_OBJECTS = x11_renderer.lo @STRETCHER_OBJ@
+ CFLAGS = @CFLAGS@
+ COMPILE = $(CC) $(DEFS) $(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) $(AM_CFLAGS) $(CFLAGS)
+ LTCOMPILE = $(LIBTOOL) --mode=compile $(CC) $(DEFS) $(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) $(AM_CFLAGS) $(CFLAGS)
+@@ -346,6 +347,8 @@
+ distclean-generic clean-generic maintainer-clean-generic clean \
+ mostlyclean distclean maintainer-clean
+
++stretchblt.o:
++ nasm -f elf stretchblt.asm
+
+ # Tell versions [3.59,3.63) of GNU make to not export all variables.
+ # Otherwise a system limit (for SysV at least) may be exceeded.
diff --git a/multimedia/xmps/files/patch-ae b/multimedia/xmps/files/patch-ae
new file mode 100644
index 000000000000..04a473858aaa
--- /dev/null
+++ b/multimedia/xmps/files/patch-ae
@@ -0,0 +1,11 @@
+--- Output/Makefile.in.orig Thu Jun 15 11:44:17 2000
++++ Output/Makefile.in Thu Jun 15 11:44:28 2000
+@@ -111,7 +111,7 @@
+ have_nasm = @have_nasm@
+ l = @l@
+
+-SUBDIRS = SDL X11 OpenGL
++SUBDIRS = SDL X11
+ mkinstalldirs = $(SHELL) $(top_srcdir)/mkinstalldirs
+ CONFIG_HEADER = ../config.h
+ CONFIG_CLEAN_FILES =
diff --git a/multimedia/xmps/pkg-comment b/multimedia/xmps/pkg-comment
new file mode 100644
index 000000000000..f4d8e4a417eb
--- /dev/null
+++ b/multimedia/xmps/pkg-comment
@@ -0,0 +1 @@
+X MPEG Player System - a MPEG-1 video player with a very nice GUI
diff --git a/multimedia/xmps/pkg-descr b/multimedia/xmps/pkg-descr
new file mode 100644
index 000000000000..0de095ec6507
--- /dev/null
+++ b/multimedia/xmps/pkg-descr
@@ -0,0 +1,11 @@
+XMPS stands for X MPEG Player System. It's a simple Gtk program that will
+(hopefully) play MPEG-1 files with sound under the *nix platforms. It has very
+attractive skinnable user interface.
+
+And what more?
+
+XMPS is built on top of the SMPEG library from Loki entertainment. It has full
+playlist support, can use OpenGL for the display if available, so that you can
+play full-screen MPEGs without having to change screen resolution.
+
+WWW: http://www-eleves.enst-bretagne.fr/~chavarri/xmps/
diff --git a/multimedia/xmps/pkg-plist b/multimedia/xmps/pkg-plist
new file mode 100644
index 000000000000..f8ddd7348a30
--- /dev/null
+++ b/multimedia/xmps/pkg-plist
@@ -0,0 +1,32 @@
+bin/xmps
+lib/xmps/Codecs/libsmpeg.so
+lib/xmps/Renderers/libSDL.so
+lib/xmps/Renderers/libX11.a
+share/gnome/apps/Multimedia/XMPS.desktop
+share/locale/fi/LC_MESSAGES/xmps.mo
+share/locale/fr/LC_MESSAGES/xmps.mo
+share/locale/pl/LC_MESSAGES/xmps.mo
+share/locale/sv/LC_MESSAGES/xmps.mo
+share/gnome/pixmaps/xmps.png
+share/xmps/skins/DarkDepth/buttons.xpm
+share/xmps/skins/DarkDepth/config
+share/xmps/skins/DarkDepth/controls.xpm
+share/xmps/skins/DarkDepth/digits.xpm
+share/xmps/skins/DarkDepth/main.xpm
+share/xmps/skins/DarkDepth/playlist.xpm
+share/xmps/skins/DarkDepth/titlebar.xpm
+share/xmps/skins/default/buttons.xpm
+share/xmps/skins/default/config
+share/xmps/skins/default/controls.xpm
+share/xmps/skins/default/digits.xpm
+share/xmps/skins/default/main.xpm
+share/xmps/skins/default/playlist.xpm
+share/xmps/skins/default/titlebar.xpm
+share/xmps/xmps_intro.xpm
+@dirrm share/xmps/skins/default
+@dirrm share/xmps/skins/DarkDepth
+@dirrm share/xmps/skins
+@dirrm share/xmps
+@dirrm lib/xmps/Renderers
+@dirrm lib/xmps/Codecs
+@dirrm lib/xmps