aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2001-10-10 02:54:00 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2001-10-10 02:54:00 +0000
commit2d5d53a4fe943537dc1fab6be0bb00f3b3c3881c (patch)
treeb5a1567e8563ef6b8d3103bbd8e0ede1c78706c6
parent67fe376f99395fa53da26d7613b0e9d2b90ecdfd (diff)
downloadports-2d5d53a4fe943537dc1fab6be0bb00f3b3c3881c.tar.gz
ports-2d5d53a4fe943537dc1fab6be0bb00f3b3c3881c.zip
Notes
-rw-r--r--graphics/Makefile1
-rw-r--r--graphics/gsculpt/Makefile31
-rw-r--r--graphics/gsculpt/distinfo1
-rw-r--r--graphics/gsculpt/pkg-comment1
-rw-r--r--graphics/gsculpt/pkg-descr5
-rw-r--r--graphics/gsculpt/pkg-plist1
6 files changed, 40 insertions, 0 deletions
diff --git a/graphics/Makefile b/graphics/Makefile
index 2cc4acae5d53..74da0c85fe0d 100644
--- a/graphics/Makefile
+++ b/graphics/Makefile
@@ -88,6 +88,7 @@
SUBDIR += gracula
SUBDIR += graphviz
SUBDIR += gridpix
+ SUBDIR += gsculpt
SUBDIR += gtkdps
SUBDIR += gtkfig
SUBDIR += gtkgraph
diff --git a/graphics/gsculpt/Makefile b/graphics/gsculpt/Makefile
new file mode 100644
index 000000000000..331b5ce33ea0
--- /dev/null
+++ b/graphics/gsculpt/Makefile
@@ -0,0 +1,31 @@
+# ex:ts=8
+# New ports collection makefile for: gSculpt
+# Date created: Oct 10, 2001
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= gsculpt
+PORTVERSION= 0.3
+CATEGORIES= graphics
+MASTER_SITES= http://gsculpt.sourceforge.net/downloads/
+DISTNAME= gSculpt-${PORTVERSION}-src
+
+MAINTAINER= ports@FreeBSD.org
+
+WRKSRC= ${WRKDIR}/gSculpt-${PORTVERSION}
+USE_GTK= yes
+USE_GMAKE= yes
+
+post-patch:
+ @${PERL} -pi -e "s,-O3 -Wall -Werror,${CXXFLAGS},g ; \
+ s,gtk-config,${GTK_CONFIG},g ; \
+ s,/usr/include/glib.h,${LOCALBASE}/include/glib12/glib.h,g ; \
+ s,/usr/include/gtk/,${X11BASE}/include/gtk12/gtk/,g ; \
+ s,/usr/include/gdk/,${X11BASE}/include/gtk12/gdk/,g" ${WRKSRC}/Makefile
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/bin/gsculpt ${PREFIX}/bin
+
+.include <bsd.port.mk>
diff --git a/graphics/gsculpt/distinfo b/graphics/gsculpt/distinfo
new file mode 100644
index 000000000000..e7f5ba835f8f
--- /dev/null
+++ b/graphics/gsculpt/distinfo
@@ -0,0 +1 @@
+MD5 (gSculpt-0.3-src.tar.gz) = 6f242136a4dc3d2550b679bfda7dd350
diff --git a/graphics/gsculpt/pkg-comment b/graphics/gsculpt/pkg-comment
new file mode 100644
index 000000000000..861e38f7aa26
--- /dev/null
+++ b/graphics/gsculpt/pkg-comment
@@ -0,0 +1 @@
+An Opensource 3D modelling application
diff --git a/graphics/gsculpt/pkg-descr b/graphics/gsculpt/pkg-descr
new file mode 100644
index 000000000000..395eda6fd55c
--- /dev/null
+++ b/graphics/gsculpt/pkg-descr
@@ -0,0 +1,5 @@
+gSculpt is a 3D modelling program that allows models to be built by
+performing sweeps on polylines. These models can then be transformed
+using a variety of tools. Aimed at hobbyists, and demo coders.
+
+WWW: http://gsculpt.sourceforge.net/
diff --git a/graphics/gsculpt/pkg-plist b/graphics/gsculpt/pkg-plist
new file mode 100644
index 000000000000..fd27c6df9c59
--- /dev/null
+++ b/graphics/gsculpt/pkg-plist
@@ -0,0 +1 @@
+bin/gsculpt