aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexander Nedotsukov <bland@FreeBSD.org>2003-12-06 08:18:02 +0000
committerAlexander Nedotsukov <bland@FreeBSD.org>2003-12-06 08:18:02 +0000
commit96c9e1ad1a304453dee4bdbd56ef5fea4411548e (patch)
tree866488124cf69d7c3916b7dbbb7ef0b3a4c41d4a
parent838517183ab5de8c4219b1909bb8912c9c50469a (diff)
downloadports-96c9e1ad1a304453dee4bdbd56ef5fea4411548e.tar.gz
ports-96c9e1ad1a304453dee4bdbd56ef5fea4411548e.zip
Notes
-rw-r--r--devel/gnome-vfsmm/Makefile7
-rw-r--r--devel/gnome-vfsmm/distinfo2
-rw-r--r--devel/gnome-vfsmm/files/extra-patch-old_gcc_bugs90
-rw-r--r--devel/gnome-vfsmm/pkg-plist2
4 files changed, 26 insertions, 75 deletions
diff --git a/devel/gnome-vfsmm/Makefile b/devel/gnome-vfsmm/Makefile
index 95e79dc7c150..b75eae561ab6 100644
--- a/devel/gnome-vfsmm/Makefile
+++ b/devel/gnome-vfsmm/Makefile
@@ -6,10 +6,10 @@
#
PORTNAME= gnome-vfsmm
-PORTVERSION= 1.3.3
+PORTVERSION= 1.3.4
CATEGORIES= devel gnome
-MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
-MASTER_SITE_SUBDIR= gtkmm
+MASTER_SITES= ${MASTER_SITE_GNOME}
+MASTER_SITE_SUBDIR= sources/${PORTNAME}/${PORTVERSION:R}
DIST_SUBDIR= gnome2
MAINTAINER= bland@FreeBSD.org
@@ -18,6 +18,7 @@ COMMENT= C++ wrapper for gnomevfs2 library
LIB_DEPENDS= gtkmm-2.0:${PORTSDIR}/x11-toolkits/gtk--2
BUILD_DEPENDS= gm4:${PORTSDIR}/devel/m4
+USE_BZIP2= yes
USE_X_PREFIX= yes
USE_GMAKE= yes
USE_GNOME= gnomehack gnomevfs2
diff --git a/devel/gnome-vfsmm/distinfo b/devel/gnome-vfsmm/distinfo
index aebdafd4952d..b0ade72caeae 100644
--- a/devel/gnome-vfsmm/distinfo
+++ b/devel/gnome-vfsmm/distinfo
@@ -1 +1 @@
-MD5 (gnome2/gnome-vfsmm-1.3.3.tar.gz) = 3ba4b37358765d064d66a1c772492c61
+MD5 (gnome2/gnome-vfsmm-1.3.4.tar.bz2) = 69b660ec6e2c87b554b27dde764b38cc
diff --git a/devel/gnome-vfsmm/files/extra-patch-old_gcc_bugs b/devel/gnome-vfsmm/files/extra-patch-old_gcc_bugs
index a08f3341f9c1..17eca88377cf 100644
--- a/devel/gnome-vfsmm/files/extra-patch-old_gcc_bugs
+++ b/devel/gnome-vfsmm/files/extra-patch-old_gcc_bugs
@@ -57,29 +57,28 @@
handle_result(result);
}
---- ./libgnomevfs/libgnomevfsmm/file-info.cc.orig Tue Jul 22 01:02:02 2003
-+++ ./libgnomevfs/libgnomevfsmm/file-info.cc Thu Jul 31 21:57:31 2003
-@@ -149,17 +149,17 @@
-
- FileType FileInfo::get_type() const
- {
-- return static_cast<FileType>(gobj()->type);
-+ return FileType(gobj()->type);
- }
-
- FilePermissions FileInfo::get_permissions() const
- {
-- return static_cast<FilePermissions>(gobj()->permissions);
-+ return FilePermissions(gobj()->permissions);
- }
-
- FileFlags FileInfo::get_flags() const
+--- ./libgnomevfs/libgnomevfsmm/uri.cc.orig Tue Jul 22 01:39:50 2003
++++ ./libgnomevfs/libgnomevfsmm/uri.cc Thu Jul 31 22:09:38 2003
+@@ -42,7 +42,7 @@
+ Glib::RefPtr<FileInfo> Uri::get_file_info(FileInfoOptions options) const throw(exception)
{
-- return static_cast<FileFlags>(gobj()->flags);
-+ return FileFlags(gobj()->flags);
+ GnomeVFSFileInfo* file_info = gnome_vfs_file_info_new();
+- GnomeVFSResult result = gnome_vfs_get_file_info_uri(const_cast<GnomeVFSURI*>(gobj()), file_info, static_cast<GnomeVFSFileInfoOptions>(options));
++ GnomeVFSResult result = gnome_vfs_get_file_info_uri(const_cast<GnomeVFSURI*>(gobj()), file_info, GnomeVFSFileInfoOptions(options));
+ handle_result(result);
+ return Glib::wrap(file_info);
}
-
- guint FileInfo::get_link_count() const
+--- ./libgnomevfs/libgnomevfsmm/mime-application.cc.orig Thu Jul 31 22:10:37 2003
++++ ./libgnomevfs/libgnomevfsmm/mime-application.cc Thu Jul 31 22:12:01 2003
+@@ -42,7 +42,7 @@
+ gobject_->id = g_strdup(id.c_str());
+ gobject_->name = g_strdup(name.c_str());
+ gobject_->command = g_strdup(command.c_str());
+- gobject_->expects_uris = static_cast<GnomeVFSMimeApplicationArgumentType>(argument_type);
++ gobject_->expects_uris = GnomeVFSMimeApplicationArgumentType(argument_type);
+ gobject_->supported_uri_schemes = supported_uri_schemes.data();
+ gobject_->can_open_multiple_files = multiple_files;
+ gobject_->requires_terminal = requires_terminal;
--- ./libgnomevfs/libgnomevfsmm/handle.cc.orig Fri Jul 18 13:53:54 2003
+++ ./libgnomevfs/libgnomevfsmm/handle.cc Thu Jul 31 22:23:31 2003
@@ -49,25 +49,25 @@
@@ -156,55 +155,6 @@
handle_result(result);
}
---- ./libgnomevfs/libgnomevfsmm/uri.cc.orig Tue Jul 22 01:39:50 2003
-+++ ./libgnomevfs/libgnomevfsmm/uri.cc Thu Jul 31 22:09:38 2003
-@@ -42,7 +42,7 @@
- Glib::RefPtr<FileInfo> Uri::get_file_info(FileInfoOptions options) const throw(exception)
- {
- GnomeVFSFileInfo* file_info = gnome_vfs_file_info_new();
-- GnomeVFSResult result = gnome_vfs_get_file_info_uri(const_cast<GnomeVFSURI*>(gobj()), file_info, static_cast<GnomeVFSFileInfoOptions>(options));
-+ GnomeVFSResult result = gnome_vfs_get_file_info_uri(const_cast<GnomeVFSURI*>(gobj()), file_info, GnomeVFSFileInfoOptions(options));
- handle_result(result);
- return Glib::wrap(file_info);
- }
-@@ -160,7 +160,7 @@
-
- Glib::ustring Uri::to_string(URIHideOptions hide_options) const
- {
-- return Glib::convert_return_gchar_ptr_to_ustring(gnome_vfs_uri_to_string(const_cast<GnomeVFSURI*>(gobj()), static_cast<GnomeVFSURIHideOptions>(hide_options)));
-+ return Glib::convert_return_gchar_ptr_to_ustring(gnome_vfs_uri_to_string(const_cast<GnomeVFSURI*>(gobj()), GnomeVFSURIHideOptions(hide_options)));
- }
-
- Glib::RefPtr<Uri> Uri::dup()
---- ./libgnomevfs/libgnomevfsmm/mime-application.cc.orig Thu Jul 31 22:10:37 2003
-+++ ./libgnomevfs/libgnomevfsmm/mime-application.cc Thu Jul 31 22:12:01 2003
-@@ -42,7 +42,7 @@
- gobject_->id = g_strdup(id.c_str());
- gobject_->name = g_strdup(name.c_str());
- gobject_->command = g_strdup(command.c_str());
-- gobject_->expects_uris = static_cast<GnomeVFSMimeApplicationArgumentType>(argument_type);
-+ gobject_->expects_uris = GnomeVFSMimeApplicationArgumentType(argument_type);
- gobject_->supported_uri_schemes = supported_uri_schemes.data();
- gobject_->can_open_multiple_files = multiple_files;
- gobject_->requires_terminal = requires_terminal;
-@@ -263,7 +263,7 @@
-
- MimeApplicationArgumentType MimeApplication::get_argument_type() const
- {
-- return static_cast<MimeApplicationArgumentType>(gobj()->expects_uris);
-+ return MimeApplicationArgumentType(gobj()->expects_uris);
- }
-
- Glib::ListHandle<Glib::ustring> MimeApplication::get_supported_uri_schemes() const
-@@ -288,7 +288,7 @@
-
- void MimeApplication::set_argument_type(const MimeApplicationArgumentType& value)
- {
-- gobj()->expects_uris = static_cast<GnomeVFSMimeApplicationArgumentType>(value);
-+ gobj()->expects_uris = GnomeVFSMimeApplicationArgumentType(value);
- }
-
- void MimeApplication::set_supported_uri_schemes(const Glib::ListHandle<Glib::ustring>& value)
--- ./libgnomevfs/libgnomevfsmm/transfer-progress.cc.orig Thu Jul 31 22:12:40 2003
+++ ./libgnomevfs/libgnomevfsmm/transfer-progress.cc Thu Jul 31 22:13:38 2003
@@ -58,17 +58,17 @@
diff --git a/devel/gnome-vfsmm/pkg-plist b/devel/gnome-vfsmm/pkg-plist
index 94c8f63f7873..1f0476ef871d 100644
--- a/devel/gnome-vfsmm/pkg-plist
+++ b/devel/gnome-vfsmm/pkg-plist
@@ -29,7 +29,7 @@ lib/gnome-vfsmm-2.0/proc/m4/convert.m4
lib/gnome-vfsmm-2.0/proc/m4/convert_gnome_vfsmm.m4
lib/libgnomevfsmm-1.3.a
lib/libgnomevfsmm-1.3.so
-lib/libgnomevfsmm-1.3.so.4
+lib/libgnomevfsmm-1.3.so.5
libdata/pkgconfig/gnome-vfsmm-2.0.pc
@dirrm lib/gnome-vfsmm-2.0/include
@dirrm lib/gnome-vfsmm-2.0/proc/m4