aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2004-04-05 02:05:46 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2004-04-05 02:05:46 +0000
commite50209a594fc084075273bc1bda8b3a716bd9370 (patch)
treecf9602d4dc23b6ff352338f9edc2b439e5ddf3c8
parent4cf4a502297be5e8393ea3d01f4e57e410af07f4 (diff)
downloadports-e50209a594fc084075273bc1bda8b3a716bd9370.tar.gz
ports-e50209a594fc084075273bc1bda8b3a716bd9370.zip
Notes
-rw-r--r--x11-toolkits/gai/Makefile20
-rw-r--r--x11-toolkits/gai/distinfo4
-rw-r--r--x11-toolkits/gai/files/patch-gai:gai-gnome.c12
-rw-r--r--x11-toolkits/gai/pkg-descr30
4 files changed, 34 insertions, 32 deletions
diff --git a/x11-toolkits/gai/Makefile b/x11-toolkits/gai/Makefile
index 025ffc658b6b..55a637169fb7 100644
--- a/x11-toolkits/gai/Makefile
+++ b/x11-toolkits/gai/Makefile
@@ -7,8 +7,8 @@
#
PORTNAME= gai
-PORTVERSION= 0.5.2
-PORTREVISION= 1
+PORTVERSION= 0.5.3
+PORTREVISION= 0
CATEGORIES= x11-toolkits gnome
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -26,7 +26,7 @@ USE_GNOME= gnomehack gnomeprefix gdkpixbuf gtk20 pango gnomepanel
GNU_CONFIGURE= yes
CONFIGURE_ENV= SDLCONF=${SDL_CONFIG}
-PLIST_FILES= include/gai/gai.h lib/libgai.so.0.5.2 lib/libgai.so.0 \
+PLIST_FILES= include/gai/gai.h lib/libgai.so.0.5.3 lib/libgai.so.0 \
lib/libgai.so libdata/pkgconfig/gai.pc
PLIST_DIRS= include/gai
INSTALLS_SHLIB= yes
@@ -37,17 +37,17 @@ CFLAGS+= -fPIC
post-patch:
@${REINPLACE_CMD} -e "s|sdl-config --|${SDL_CONFIG} --|g" ${WRKSRC}/configure
- @${REINPLACE_CMD} -e "s|lib/pkgconfig/|libdata/pkgconfig/|" ${WRKSRC}/gai/Makefile.in
- ${REINPLACE_CMD} -e "s|-O2|${CFLAGS}|g" ${WRKSRC}/gai/Makefile.in
+ @${REINPLACE_CMD} -e "s|lib/pkgconfig|libdata/pkgconfig|g" \
+ -e "s|-O2|${CFLAGS}|g" ${WRKSRC}/gai/Makefile.in
.if !defined(NOPORTDOCS)
post-install:
@${MKDIR} ${DOCSDIR}
-.for file in FAQ.html referenceguide.html
- ${INSTALL_DATA} ${WRKSRC}/docs/${file} ${DOCSDIR}
- @${ECHO_CMD} "${DOCSDIR:S,^${PREFIX}/,,}/${file}" >> ${TMPPLIST}
-.endfor
- @${ECHO_CMD} "@dirrm ${DOCSDIR:S,^${PREFIX}/,,}" >> ${TMPPLIST}
+ @${CP} -R ${WRKSRC}/docs/ ${DOCSDIR}
+ @${FIND} ${DOCSDIR} -type f | \
+ ${SED} "s,^${PREFIX}/,," >> ${TMPPLIST}
+ @${FIND} ${DOCSDIR} -type d | ${SORT} -r | \
+ ${SED} "s,^${PREFIX}/,@dirrm ," >> ${TMPPLIST}
@${MKDIR} ${EXAMPLESDIR}
.for dir in docking examples templates
${CP} -R ${WRKSRC}/${dir} ${EXAMPLESDIR}
diff --git a/x11-toolkits/gai/distinfo b/x11-toolkits/gai/distinfo
index 42385444a31a..3ee80cc904cd 100644
--- a/x11-toolkits/gai/distinfo
+++ b/x11-toolkits/gai/distinfo
@@ -1,2 +1,2 @@
-MD5 (gai-0.5.2.tar.bz2) = a9d53513b002cedabf2a1ee29ad2d712
-SIZE (gai-0.5.2.tar.bz2) = 185549
+MD5 (gai-0.5.3.tar.bz2) = 732016d4cf133a50d2226153db395b85
+SIZE (gai-0.5.3.tar.bz2) = 233198
diff --git a/x11-toolkits/gai/files/patch-gai:gai-gnome.c b/x11-toolkits/gai/files/patch-gai:gai-gnome.c
deleted file mode 100644
index 6fda8f540493..000000000000
--- a/x11-toolkits/gai/files/patch-gai:gai-gnome.c
+++ /dev/null
@@ -1,12 +0,0 @@
---- gai/gai-gnome.c.orig Mon Mar 15 10:36:46 2004
-+++ gai/gai-gnome.c Mon Mar 15 10:37:15 2004
-@@ -537,8 +537,8 @@
- void gai_gnome_about_show (void)
- {
- char *authors[3];
-- GAI_ENTER;
- GdkPixbuf *pixbuf;
-+ GAI_ENTER;
-
- if (GAI.about!=NULL)
- {
diff --git a/x11-toolkits/gai/pkg-descr b/x11-toolkits/gai/pkg-descr
index ac401c502f11..1b2a81e4fa41 100644
--- a/x11-toolkits/gai/pkg-descr
+++ b/x11-toolkits/gai/pkg-descr
@@ -1,10 +1,24 @@
-GAI, The General Applet Interface library is a library that will help applet
-programmers a lot. The goal of this library is to give programmers a simple yet
-powerful applet interface. This library supports both Dockapps and Gnome 2
-Panel Applets. The applet program doesn't have to care about if the applet
-will be used on the Gnome panel or in the dock. The library handles that.
-Over 50% of the code in a Dockapp and a Gnome 2 Panel applet does actually
-only one thing, setting up the applet window. With GAI, this can be reduced
-to just a few lines of code.
+This library is intended to simplify the development and use of Dockapps, ROX
+panel applets and Gnome 2 Panel Applets. With this library the programmer can
+focus on what the applet shall do, not on the interface.
+
+What this library provides:
+ - Dockapp support.
+ - Gnome 2 Panel support.
+ - ROX panel support.
+ - Handling of all sizes of the Gnome Panel.
+ - Handle Gnome Panel rotation.
+ - Simple image file handeling via gdk_pixbuf.
+ - Loading and storing of configuration values and strings.
+ - A simple structual way of making preferences window.
+ - Generates images from ascii text based upon fonts.
+ - Support for both Gnome 2 Panel Applets, ROX panel applets and
+ Dockaps/wmapplets.
+ - Support for OpenGL applets.
+ - Simple interface to connect events, like mouse button clicks, joystick
+ events and so on.
+ - Easy to add support for other panels.
+ - Nice configure and makefile scripts that generates the needed files
+ for ROX and Gnome.
WWW: http://gai.sourceforge.net/