aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2001-04-18 11:09:55 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2001-04-18 11:09:55 +0000
commit07831d9d80f4f8ef0979a864d5bf9da5f5575d21 (patch)
treea763edf8311861bd4b8cf39d3a2ed21be3418e33
parente4f245f5c9fc8f1174630840efb4747db9914601 (diff)
downloadports-07831d9d80f4f8ef0979a864d5bf9da5f5575d21.tar.gz
ports-07831d9d80f4f8ef0979a864d5bf9da5f5575d21.zip
add p5-tagged
Read, change and write different tags of MP3 audio files
Notes
Notes: svn path=/head/; revision=41641
-rw-r--r--audio/Makefile1
-rw-r--r--audio/p5-tagged/Makefile28
-rw-r--r--audio/p5-tagged/distinfo1
-rw-r--r--audio/p5-tagged/pkg-comment1
-rw-r--r--audio/p5-tagged/pkg-descr4
-rw-r--r--audio/p5-tagged/pkg-plist9
6 files changed, 44 insertions, 0 deletions
diff --git a/audio/Makefile b/audio/Makefile
index 58feab55fe82..cb4d0ac0fb94 100644
--- a/audio/Makefile
+++ b/audio/Makefile
@@ -134,6 +134,7 @@
SUBDIR += p5-MP3-Info
SUBDIR += p5-MPEG-ID3v2Tag
SUBDIR += p5-Xmms
+ SUBDIR += p5-tagged
SUBDIR += pimp3
SUBDIR += play
SUBDIR += playmidi
diff --git a/audio/p5-tagged/Makefile b/audio/p5-tagged/Makefile
new file mode 100644
index 000000000000..5474d120230b
--- /dev/null
+++ b/audio/p5-tagged/Makefile
@@ -0,0 +1,28 @@
+# ex:ts=8
+# New ports collection makefile for: p5-tagged
+# Date created: Apr 18, 2001
+# Whom: Ying-Chieh Liao <ijliao@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= tagged
+PORTVERSION= 0.30
+CATEGORIES= audio perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN} \
+ ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= MP3 ${PORTNAME}
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= ijliao@FreeBSD.org
+
+BUILD_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/Compress/Zlib.pm:${PORTSDIR}/archivers/p5-Compress-Zlib
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+MAN3= MP3::Tag::ID3v2.3 MP3::Tag.3 MP3::Tag::File.3 \
+ MP3::Tag::ID3v2-Data.3 MP3::Tag::ID3v1.3
+
+.include <bsd.port.mk>
diff --git a/audio/p5-tagged/distinfo b/audio/p5-tagged/distinfo
new file mode 100644
index 000000000000..0d10cf582c76
--- /dev/null
+++ b/audio/p5-tagged/distinfo
@@ -0,0 +1 @@
+MD5 (tagged-0.30.tar.gz) = 5b915eaa9a4af6dc2bcc6f77aff80511
diff --git a/audio/p5-tagged/pkg-comment b/audio/p5-tagged/pkg-comment
new file mode 100644
index 000000000000..def315190d5a
--- /dev/null
+++ b/audio/p5-tagged/pkg-comment
@@ -0,0 +1 @@
+Read, change and write different tags of MP3 audio files
diff --git a/audio/p5-tagged/pkg-descr b/audio/p5-tagged/pkg-descr
new file mode 100644
index 000000000000..0b6fe6dc623a
--- /dev/null
+++ b/audio/p5-tagged/pkg-descr
@@ -0,0 +1,4 @@
+tagged should become a collection of perl tools to read, change and write
+different tags of MP3 audio files.
+
+WWW: http://tagged.sourceforge.net/
diff --git a/audio/p5-tagged/pkg-plist b/audio/p5-tagged/pkg-plist
new file mode 100644
index 000000000000..540509ef84e5
--- /dev/null
+++ b/audio/p5-tagged/pkg-plist
@@ -0,0 +1,9 @@
+lib/perl5/site_perl/%%PERL_VER%%/MP3/Tag.pm
+lib/perl5/site_perl/%%PERL_VER%%/MP3/Tag/File.pm
+lib/perl5/site_perl/%%PERL_VER%%/MP3/Tag/ID3v1.pm
+lib/perl5/site_perl/%%PERL_VER%%/MP3/Tag/ID3v2.pm
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/MP3/Tag/.packlist
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/MP3/Tag
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/MP3 2>/dev/null || true
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/MP3/Tag 2>/dev/null || true
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/MP3 2>/dev/null || true