aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2001-04-18 11:52:37 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2001-04-18 11:52:37 +0000
commit51bbf3bf87dcf52d10b2d66719ec39262bd5163f (patch)
tree39131b2f9a0935a4de5a7d95729af97ec8002ec5
parentf642a6e9bec05e029b55e277015c16ae7060401b (diff)
downloadports-51bbf3bf87dcf52d10b2d66719ec39262bd5163f.tar.gz
ports-51bbf3bf87dcf52d10b2d66719ec39262bd5163f.zip
add mp3mover
Rename mp3s and manipulate them
Notes
Notes: svn path=/head/; revision=41643
-rw-r--r--audio/Makefile1
-rw-r--r--audio/mp3mover/Makefile28
-rw-r--r--audio/mp3mover/distinfo1
-rw-r--r--audio/mp3mover/pkg-comment1
-rw-r--r--audio/mp3mover/pkg-descr3
-rw-r--r--audio/mp3mover/pkg-plist3
6 files changed, 37 insertions, 0 deletions
diff --git a/audio/Makefile b/audio/Makefile
index cb4d0ac0fb94..38925c83f2e9 100644
--- a/audio/Makefile
+++ b/audio/Makefile
@@ -109,6 +109,7 @@
SUBDIR += mp3chew
SUBDIR += mp3encode
SUBDIR += mp3info
+ SUBDIR += mp3mover
SUBDIR += mp3rename
SUBDIR += mpegaudio
SUBDIR += mpg123
diff --git a/audio/mp3mover/Makefile b/audio/mp3mover/Makefile
new file mode 100644
index 000000000000..9ea52e8601aa
--- /dev/null
+++ b/audio/mp3mover/Makefile
@@ -0,0 +1,28 @@
+# ex:ts=8
+# New ports collection makefile for: mp3mover
+# Date created: Apr 18, 2001
+# Whom: Ying-Chieh Liao <ijliao@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= mp3mover
+PORTVERSION= 1.2
+CATEGORIES= audio perl5
+MASTER_SITES= http://www.doc.ic.ac.uk/~jsm00/scripts/
+
+MAINTAINER= ijliao@FreeBSD.org
+
+RUN_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/MP3/Tag.pm:${PORTSDIR}/audio/p5-tagged
+
+USE_PERL5= yes
+
+WRKSRC= ${WRKDIR}/${PORTNAME}
+NO_BUILD= yes
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/mp3mover.pl ${PREFIX}/bin/mp3mover
+ @${MKDIR} ${PREFIX}/share/${PORTNAME}
+ ${CP} ${WRKSRC}/sample-.mp3moverrc ${PREFIX}/share/${PORTNAME}
+
+.include <bsd.port.mk>
diff --git a/audio/mp3mover/distinfo b/audio/mp3mover/distinfo
new file mode 100644
index 000000000000..7b44a794cb08
--- /dev/null
+++ b/audio/mp3mover/distinfo
@@ -0,0 +1 @@
+MD5 (mp3mover-1.2.tar.gz) = 48214ab56a0c9879f6468d8a51e99e3e
diff --git a/audio/mp3mover/pkg-comment b/audio/mp3mover/pkg-comment
new file mode 100644
index 000000000000..0ebcdce20212
--- /dev/null
+++ b/audio/mp3mover/pkg-comment
@@ -0,0 +1 @@
+Rename mp3s and manipulate them
diff --git a/audio/mp3mover/pkg-descr b/audio/mp3mover/pkg-descr
new file mode 100644
index 000000000000..9f57ef6ee0f8
--- /dev/null
+++ b/audio/mp3mover/pkg-descr
@@ -0,0 +1,3 @@
+Rename mp3s and manipulate them.
+
+WWW: http://www.doc.ic.ac.uk/~jsm00/
diff --git a/audio/mp3mover/pkg-plist b/audio/mp3mover/pkg-plist
new file mode 100644
index 000000000000..a5f9010ffdfe
--- /dev/null
+++ b/audio/mp3mover/pkg-plist
@@ -0,0 +1,3 @@
+bin/mp3mover
+share/mp3mover/sample-.mp3moverrc
+@dirrm share/mp3mover