aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRoger Hardiman <roger@FreeBSD.org>2002-05-24 23:44:43 +0000
committerRoger Hardiman <roger@FreeBSD.org>2002-05-24 23:44:43 +0000
commit21de9cd5657bf58af599059d6a2dc20131377cfe (patch)
treebed98d096d7792b357e97e14105e962d9cc68126
parentaf31751f9a5d9016964f44e28a3b1f34d834bf19 (diff)
downloadports-21de9cd5657bf58af599059d6a2dc20131377cfe.tar.gz
ports-21de9cd5657bf58af599059d6a2dc20131377cfe.zip
Make sure we use the static openh323 libraries (as the openh323
port does not actually install the .so files)
Notes
Notes: svn path=/head/; revision=59935
-rw-r--r--net/gatekeeper/Makefile3
-rw-r--r--net/gatekeeper/files/patch-aa44
2 files changed, 46 insertions, 1 deletions
diff --git a/net/gatekeeper/Makefile b/net/gatekeeper/Makefile
index a21fe74116fe..3d7475d636fa 100644
--- a/net/gatekeeper/Makefile
+++ b/net/gatekeeper/Makefile
@@ -7,6 +7,7 @@
PORTNAME= gatekeeper
PORTVERSION= 1.0
+PORTREVISION= 1
CATEGORIES= net
MASTER_SITES= http://www.willamowius.de/download/gatekeeper/
DISTNAME= gk10
@@ -23,7 +24,7 @@ NOCLEANDEPENDS= yes
USE_NEWGCC= yes
USE_BISON= yes
USE_GMAKE= yes
-ALL_TARGET= opt
+ALL_TARGET= optnoshared
MAKE_ENV= PWLIBDIR=${WRKDIRPREFIX}${.CURDIR}/../openh323/work/pwlib \
OPENH323DIR=${WRKDIRPREFIX}${.CURDIR}/../openh323/work/openh323
THE_MACHTYPE= ${ARCH:S/i386/x86/}
diff --git a/net/gatekeeper/files/patch-aa b/net/gatekeeper/files/patch-aa
new file mode 100644
index 000000000000..428c2a656d1f
--- /dev/null
+++ b/net/gatekeeper/files/patch-aa
@@ -0,0 +1,44 @@
+*** Makefile.orig Sat May 25 00:20:04 2002
+--- Makefile Sat May 25 00:21:51 2002
+*************** ifndef OPENH323DIR
+*** 13,26 ****
+ OPENH323DIR=$(HOME)/openh323
+ endif
+
+! H323_INCDIR = ${OPENH323DIR}/include
+! H323_LIBDIR = ${OPENH323DIR}/lib
+! H323_LIB = h323_$(PLATFORM_TYPE)_$(OBJ_SUFFIX)
+
+! LDFLAGS = -L$(H323_LIBDIR)
+! LDLIBS = -l$(H323_LIB)
+
+! STDCCFLAGS := -I${H323_INCDIR} -DPTRACING #-DPASN_NOPRINT
+
+
+ ifndef PWLIBDIR
+--- 13,26 ----
+ OPENH323DIR=$(HOME)/openh323
+ endif
+
+! ##H323_INCDIR = ${OPENH323DIR}/include
+! ##H323_LIBDIR = ${OPENH323DIR}/lib
+! ##H323_LIB = h323_$(PLATFORM_TYPE)_$(OBJ_SUFFIX)
+
+! ##LDFLAGS = -L$(H323_LIBDIR)
+! ##LDLIBS = -l$(H323_LIB)
+
+! ##STDCCFLAGS := -I${H323_INCDIR} -DPTRACING #-DPASN_NOPRINT
+
+
+ ifndef PWLIBDIR
+*************** ifndef PWLIBDIR
+*** 28,33 ****
+--- 28,35 ----
+ endif
+
+ include $(PWLIBDIR)/make/ptlib.mak
++ include $(OPENH323DIR)/openh323u.mak
++
+
+
+ # Extra dependencies