aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGerald Pfeifer <gerald@FreeBSD.org>2003-09-23 09:08:06 +0000
committerGerald Pfeifer <gerald@FreeBSD.org>2003-09-23 09:08:06 +0000
commit37ad838ffa0d496a425651688c5400c7b2f4e7a1 (patch)
tree280746a3e4575e9d9c7b1e9a1a0a85a980b678c2
parent71225ba5abfac0ac27d9d81caeb2c9a245761f71 (diff)
downloadports-37ad838ffa0d496a425651688c5400c7b2f4e7a1.tar.gz
ports-37ad838ffa0d496a425651688c5400c7b2f4e7a1.zip
Unbreak build on -STABLE (partly by fixing the incorrect PERL->REINPLACE_CMD
substitution). PR: 55475 Submitted by: Michael Hsin <mhsin@mhsin.org>
Notes
Notes: svn path=/head/; revision=89119
-rw-r--r--devel/arm-elf-gcc295/Makefile6
1 files changed, 4 insertions, 2 deletions
diff --git a/devel/arm-elf-gcc295/Makefile b/devel/arm-elf-gcc295/Makefile
index 9c56e44aff63..a5ccd0dd1718 100644
--- a/devel/arm-elf-gcc295/Makefile
+++ b/devel/arm-elf-gcc295/Makefile
@@ -58,9 +58,11 @@ pre-extract:
post-configure:
${REINPLACE_CMD} -Ee 's,^(TARGET_CONFIGDIRS\s*=),\1#,' \
${WRKSRC}/Makefile
- ${REINPLACE_CMD} -Ee 's,^(install-info:),\1\ndonot-\1,; \
- s,\$$\(bindir\)/(\$$\(DEMANGLER_CROSS_NAME\)),./\1,' \
+ ${PERL} -i -ne 's/^(install-info:)/\1\ndonot-\1/; print' ${WRKSRC}/gcc/Makefile
+ ${REINPLACE_CMD} -Ee 's,\$$\(bindir\)/(\$$\(DEMANGLER_CROSS_NAME\)),./\1,' \
${WRKSRC}/gcc/Makefile
+ ${REINPLACE_CMD} -Ee 's/^(TARGET_CONFIGDIRS =)/\1#/' \
+ ${WRKSRC}/Makefile
post-install:
@${MV} ${PREFIX}/bin/cpp ${PREFIX}/bin/${PKGNAMEPREFIX}cpp