aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2002-03-15 19:39:21 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2002-03-15 19:39:21 +0000
commitb46611d8cf5744f43a12213e07177cfde2b532fe (patch)
treee2b2b2506dec9b407f62fb595c5fe1d38f379aee
parent35b7c3b1debe0d86ae6c2325e8e9c503d49341ca (diff)
downloadports-b46611d8cf5744f43a12213e07177cfde2b532fe.tar.gz
ports-b46611d8cf5744f43a12213e07177cfde2b532fe.zip
Notes
-rw-r--r--security/hpn-ssh/Makefile14
-rw-r--r--security/openssh-portable/Makefile14
2 files changed, 26 insertions, 2 deletions
diff --git a/security/hpn-ssh/Makefile b/security/hpn-ssh/Makefile
index 940730c77a44..cfe8163d7664 100644
--- a/security/hpn-ssh/Makefile
+++ b/security/hpn-ssh/Makefile
@@ -77,4 +77,16 @@ pre-configure:
post-install:
@${CAT} ${PKGMESSAGE}
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 430000
+OPENSSLBASE= /usr/local
+OPENSSLDIR= ${OPENSSLBASE}/openssl
+LIB_DEPENDS+= crypto.2:${PORTSDIR}/security/openssl
+OPENSSLLIB= ${OPENSSLBASE}/lib
+OPENSSLINC= ${OPENSSLBASE}/include
+MAKE_ENV+= OPENSSLLIB=${OPENSSLLIB} OPENSSLINC=${OPENSSLINC} \
+ OPENSSLBASE=${OPENSSLBASE} OPENSSLDIR=${OPENSSLDIR}
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/security/openssh-portable/Makefile b/security/openssh-portable/Makefile
index 940730c77a44..cfe8163d7664 100644
--- a/security/openssh-portable/Makefile
+++ b/security/openssh-portable/Makefile
@@ -77,4 +77,16 @@ pre-configure:
post-install:
@${CAT} ${PKGMESSAGE}
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 430000
+OPENSSLBASE= /usr/local
+OPENSSLDIR= ${OPENSSLBASE}/openssl
+LIB_DEPENDS+= crypto.2:${PORTSDIR}/security/openssl
+OPENSSLLIB= ${OPENSSLBASE}/lib
+OPENSSLINC= ${OPENSSLBASE}/include
+MAKE_ENV+= OPENSSLLIB=${OPENSSLLIB} OPENSSLINC=${OPENSSLINC} \
+ OPENSSLBASE=${OPENSSLBASE} OPENSSLDIR=${OPENSSLDIR}
+.endif
+
+.include <bsd.port.post.mk>