aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGerald Pfeifer <gerald@FreeBSD.org>2003-05-22 23:12:06 +0000
committerGerald Pfeifer <gerald@FreeBSD.org>2003-05-22 23:12:06 +0000
commit355c47d5118677c578d6889a92e4200cdbfd1403 (patch)
tree8ef9cd66679b29d567ebe8df661e5fd27049edfb
parent1d53a50eaae3ccbb5edc0e881ba0df32aaec1892 (diff)
downloadports-355c47d5118677c578d6889a92e4200cdbfd1403.tar.gz
ports-355c47d5118677c578d6889a92e4200cdbfd1403.zip
Track upstream update of the patch for WITH_BOUNDSCHECKING (which removed
the previous patch). Submitted by: lioux
Notes
Notes: svn path=/head/; revision=81750
-rw-r--r--lang/gcc32/Makefile2
-rw-r--r--lang/gcc32/distinfo2
-rw-r--r--lang/gcc32/files/opt.patch-bc8
3 files changed, 6 insertions, 6 deletions
diff --git a/lang/gcc32/Makefile b/lang/gcc32/Makefile
index c4b686a9e2ea..ce132099c17f 100644
--- a/lang/gcc32/Makefile
+++ b/lang/gcc32/Makefile
@@ -24,7 +24,7 @@ COMMENT?= GNU Compiler Collection 3.2.3
.if defined (WITH_BOUNDSCHECKING)
# Fetch another file, but don't extract it. Also add another patchfile.
-BCPATCH= bounds-checking-gcc-3.2.3-1.00.patch.bz2
+BCPATCH= bounds-checking-gcc-3.2.3-1.01.patch.bz2
DISTFILES+= ${BCPATCH}:bc
EXTRACT_ONLY= ${DISTFILES:S/${BCPATCH}:bc//}
EXTRA_PATCHES= ${FILESDIR}/opt.patch-bc
diff --git a/lang/gcc32/distinfo b/lang/gcc32/distinfo
index 186f6fb6949c..1b3fc3e50db6 100644
--- a/lang/gcc32/distinfo
+++ b/lang/gcc32/distinfo
@@ -4,4 +4,4 @@ MD5 (gcc-g++-3.2.3.tar.bz2) = ebb7932d0dc526b10c222a22cc02f180
MD5 (gcc-g77-3.2.3.tar.bz2) = 8bea8cf9734995738552d90cf3f80b62
MD5 (gcc-java-3.2.3.tar.bz2) = 9cf2c5162a582705c1cae06c206e06de
MD5 (gcc-objc-3.2.3.tar.bz2) = eaca8b22d4ef2b42b84b877edbdf896b
-MD5 (bounds-checking-gcc-3.2.3-1.00.patch.bz2) = fdb0c0af4502a74e774c869f96eec102
+MD5 (bounds-checking-gcc-3.2.3-1.01.patch.bz2) = d1cbfed54d714c69ab09042807c591f9
diff --git a/lang/gcc32/files/opt.patch-bc b/lang/gcc32/files/opt.patch-bc
index 8b310da4e992..024997f4c17c 100644
--- a/lang/gcc32/files/opt.patch-bc
+++ b/lang/gcc32/files/opt.patch-bc
@@ -1,7 +1,7 @@
---- gcc/bounds/lib/malloc/Makefile.orig Fri Sep 28 15:31:19 2001
-+++ gcc/bounds/lib/malloc/Makefile Mon Oct 1 13:58:20 2001
-@@ -52,7 +52,7 @@ VPATH = $(srcdir)/bounds/lib/malloc
- SUBDIR_INCLUDES = -I$(srcdir)/bounds/lib/malloc -I../../.. -I$(srcdir) -I$(srcdir)/config -I../../../../include
+--- gcc/bounds/lib/Makefile.orig Tue May 20 16:35:05 2003
++++ gcc/bounds/lib/Makefile Tue May 20 16:35:19 2003
+@@ -14,7 +14,7 @@
+ SUBDIR_INCLUDES = -I../.. -I$(srcdir)/bounds/lib -I$(srcdir) -I$(srcdir)/config -I$(srcdir)/../include
# Use this on System V.
-CPPFLAGS = -DUSG