aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Blapp <mbr@FreeBSD.org>2002-08-01 12:29:21 +0000
committerMartin Blapp <mbr@FreeBSD.org>2002-08-01 12:29:21 +0000
commitf813c6b4708380bb8059bcb1ddfa89d14bf7e158 (patch)
tree66c47e0c9b6278ec093be16e3c91d319651a5ebf
parent6516e752a10d7dcced35de994960c9772ce10226 (diff)
downloadports-f813c6b4708380bb8059bcb1ddfa89d14bf7e158.tar.gz
ports-f813c6b4708380bb8059bcb1ddfa89d14bf7e158.zip
Notes
-rw-r--r--editors/openoffice-1.0/Makefile17
-rw-r--r--editors/openoffice-1.0/files/openoffice-wrapper15
-rw-r--r--editors/openoffice-1.0/pkg-message60
-rw-r--r--editors/openoffice.org-1.0/Makefile17
-rw-r--r--editors/openoffice.org-1.0/files/openoffice-wrapper15
-rw-r--r--editors/openoffice.org-1.0/pkg-message60
-rw-r--r--editors/openoffice/Makefile17
-rw-r--r--editors/openoffice/files/openoffice-wrapper15
-rw-r--r--editors/openoffice/pkg-message60
9 files changed, 246 insertions, 30 deletions
diff --git a/editors/openoffice-1.0/Makefile b/editors/openoffice-1.0/Makefile
index 6a68dc752369..eca356ee6aa3 100644
--- a/editors/openoffice-1.0/Makefile
+++ b/editors/openoffice-1.0/Makefile
@@ -330,6 +330,8 @@ do-build:
pre-install:
@${SED} -e 's#%%PREFIX%%#${PREFIX}#g' < ${FILESDIR}/oo_setup.resp \
> ${WRKSRC}/../instsetoo/unxfbsd.pro/${LANG_EXT}/normal/oo_setup.resp
+ @${SED} -e 's#%%PREFIX%%#${PREFIX}#g' < ${FILESDIR}/openoffice-wrapper \
+ > ${WRKSRC}/openoffice
do-install:
.if !defined(DISPLAY)
@@ -369,7 +371,20 @@ post-install:
${ECHO_CMD} "DICT $$COUNTRY $$LANGUAGE $$ABRV" >> \
${DICT_DIR}/dictionary.lst ; \
done
- @cd ${PREFIX} && ${FIND} -s ${INSTALLATION_BASEDIR} -type f > ${TMPPLIST}
+ @${ECHO_MSG} "===> Add wrapper scripts";
+ @${INSTALL_SCRIPT} ${WRKSRC}/openoffice ${PREFIX}/bin/openoffice
+ @${LN} -fs ${PREFIX}/bin/openoffice ${PREFIX}/bin/openoffice-sagenda
+ @${LN} -fs ${PREFIX}/bin/openoffice ${PREFIX}/bin/openoffice-scalc
+ @${LN} -fs ${PREFIX}/bin/openoffice ${PREFIX}/bin/openoffice-sdraw
+ @${LN} -fs ${PREFIX}/bin/openoffice ${PREFIX}/bin/openoffice-setup
+ @${LN} -fs ${PREFIX}/bin/openoffice ${PREFIX}/bin/openoffice-sfax
+ @${LN} -fs ${PREFIX}/bin/openoffice ${PREFIX}/bin/openoffice-simpress
+ @${LN} -fs ${PREFIX}/bin/openoffice ${PREFIX}/bin/openoffice-spadmin
+ @${LN} -fs ${PREFIX}/bin/openoffice ${PREFIX}/bin/openoffice-sweb
+ @${LN} -fs ${PREFIX}/bin/openoffice ${PREFIX}/bin/openoffice-swriter
+ @cd ${PREFIX} && ${FIND} -s bin -type f | ${GREP} openoffice > ${TMPPLIST}
+ @cd ${PREFIX} && ${FIND} -s bin -type l | ${GREP} openoffice >> ${TMPPLIST}
+ @cd ${PREFIX} && ${FIND} -s ${INSTALLATION_BASEDIR} -type f >> ${TMPPLIST}
@cd ${PREFIX} && ${FIND} -s ${INSTALLATION_BASEDIR} -type l >> ${TMPPLIST}
@cd ${PREFIX} && ${FIND} -s ${INSTALLATION_BASEDIR} -type d > ${WRKDIR}/dir.tmp
@${SORT} -r ${WRKDIR}/dir.tmp | ${XARGS} -n 1 ${ECHO_CMD} @dirrm >> ${TMPPLIST}
diff --git a/editors/openoffice-1.0/files/openoffice-wrapper b/editors/openoffice-1.0/files/openoffice-wrapper
new file mode 100644
index 000000000000..a07bfe416b2c
--- /dev/null
+++ b/editors/openoffice-1.0/files/openoffice-wrapper
@@ -0,0 +1,15 @@
+#!/bin/sh
+#
+# $FreeBSD: /tmp/pcvs/ports/editors/openoffice-1.0/files/Attic/openoffice-wrapper,v 1.1 2002-08-01 12:29:21 mbr Exp $
+
+cd %%PREFIX%%/OpenOffice.org1.0/program/
+program=`echo $0 | sed -e 's|.*-||'`
+
+case $program in
+$0)
+ exec ./soffice "$@"
+ ;;
+ *)
+ exec ./$program "$@"
+ ;;
+esac
diff --git a/editors/openoffice-1.0/pkg-message b/editors/openoffice-1.0/pkg-message
index a003d1d3eb8a..6395b787b3e0 100644
--- a/editors/openoffice-1.0/pkg-message
+++ b/editors/openoffice-1.0/pkg-message
@@ -1,17 +1,59 @@
-OpenOffice.org Build 641 Personal Install How-To
+OpenOffice.org Build 1.0.1 Personal Install How-To
-Written by: Matthias Rauch <mrauch@netbsd.org>
- Martin Blapp <mbr@freebsd.org>
+Written by: Martin Blapp <mbr@freebsd.org>
OpenOffice.org will soon been installed in
${PREFIX}/OpenOffice.org1.0/
-Once this is done run "make install-user" as the user you like to
-use OpenOffice.org and choose a standard workstation installation.
-Thereafter, OpenOffice.org can be started with
-${PREFIX}/OpenOffice.org1.0/program/soffice.
+1 User installation
+-------------------
-If OpenOffice.org asks you to choose the Java JDK during
+1.1 OO.org installed from the ports collection
+
+Once this is done you have to run "make install-user" as the
+user you like to use OO.org and choose a standard workstation
+installation.
+
+1.2 OO.org installed as package
+
+If you have just installed OO.org as package, there is no
+"make install-user" option available. Instead you'll have
+to run as the user you like to use OO.org:
+
+"${PREFIX}/bin/openoffice-setup" and choose a standard workstation
+installation.
+
+2 JDK-Installation
+------------------
+
+If OO.org asks you to choose the Java JDK during
"make install-user", you must choose the linux jdk1.3.1.
Native FreeBSD jdk1.3.1 does not work yet with FreeBSD
-openoffice and OO does ignore it.
+OO.org does ignore it.
+
+3 Start OO.org
+--------------
+
+There are some wrappers installed for fast startup.
+Add "${PREFIX}/bin/" to your PATH and you will be able
+to use them.
+
+${PREFIX}/bin/openoffice
+${PREFIX}/bin/openoffice-sagenda
+${PREFIX}/bin/openoffice-scalc
+${PREFIX}/bin/openoffice-sdraw
+${PREFIX}/bin/openoffice-setup
+${PREFIX}/bin/openoffice-sfax
+${PREFIX}/bin/openoffice-simpress
+${PREFIX}/bin/openoffice-spadmin
+${PREFIX}/bin/openoffice-sweb
+${PREFIX}/bin/openoffice-swriter
+
+4 Setup problems
+----------------
+
+If the setup complains about a missing file
+"setup.ins", it's time to upgrade your FreeBSD system
+to the lastest version. You will encounter this bug
+only if your OS is older than FreeBSD 4.6 STABLE.
+4.6 RELEASE is still affected.
diff --git a/editors/openoffice.org-1.0/Makefile b/editors/openoffice.org-1.0/Makefile
index 6a68dc752369..eca356ee6aa3 100644
--- a/editors/openoffice.org-1.0/Makefile
+++ b/editors/openoffice.org-1.0/Makefile
@@ -330,6 +330,8 @@ do-build:
pre-install:
@${SED} -e 's#%%PREFIX%%#${PREFIX}#g' < ${FILESDIR}/oo_setup.resp \
> ${WRKSRC}/../instsetoo/unxfbsd.pro/${LANG_EXT}/normal/oo_setup.resp
+ @${SED} -e 's#%%PREFIX%%#${PREFIX}#g' < ${FILESDIR}/openoffice-wrapper \
+ > ${WRKSRC}/openoffice
do-install:
.if !defined(DISPLAY)
@@ -369,7 +371,20 @@ post-install:
${ECHO_CMD} "DICT $$COUNTRY $$LANGUAGE $$ABRV" >> \
${DICT_DIR}/dictionary.lst ; \
done
- @cd ${PREFIX} && ${FIND} -s ${INSTALLATION_BASEDIR} -type f > ${TMPPLIST}
+ @${ECHO_MSG} "===> Add wrapper scripts";
+ @${INSTALL_SCRIPT} ${WRKSRC}/openoffice ${PREFIX}/bin/openoffice
+ @${LN} -fs ${PREFIX}/bin/openoffice ${PREFIX}/bin/openoffice-sagenda
+ @${LN} -fs ${PREFIX}/bin/openoffice ${PREFIX}/bin/openoffice-scalc
+ @${LN} -fs ${PREFIX}/bin/openoffice ${PREFIX}/bin/openoffice-sdraw
+ @${LN} -fs ${PREFIX}/bin/openoffice ${PREFIX}/bin/openoffice-setup
+ @${LN} -fs ${PREFIX}/bin/openoffice ${PREFIX}/bin/openoffice-sfax
+ @${LN} -fs ${PREFIX}/bin/openoffice ${PREFIX}/bin/openoffice-simpress
+ @${LN} -fs ${PREFIX}/bin/openoffice ${PREFIX}/bin/openoffice-spadmin
+ @${LN} -fs ${PREFIX}/bin/openoffice ${PREFIX}/bin/openoffice-sweb
+ @${LN} -fs ${PREFIX}/bin/openoffice ${PREFIX}/bin/openoffice-swriter
+ @cd ${PREFIX} && ${FIND} -s bin -type f | ${GREP} openoffice > ${TMPPLIST}
+ @cd ${PREFIX} && ${FIND} -s bin -type l | ${GREP} openoffice >> ${TMPPLIST}
+ @cd ${PREFIX} && ${FIND} -s ${INSTALLATION_BASEDIR} -type f >> ${TMPPLIST}
@cd ${PREFIX} && ${FIND} -s ${INSTALLATION_BASEDIR} -type l >> ${TMPPLIST}
@cd ${PREFIX} && ${FIND} -s ${INSTALLATION_BASEDIR} -type d > ${WRKDIR}/dir.tmp
@${SORT} -r ${WRKDIR}/dir.tmp | ${XARGS} -n 1 ${ECHO_CMD} @dirrm >> ${TMPPLIST}
diff --git a/editors/openoffice.org-1.0/files/openoffice-wrapper b/editors/openoffice.org-1.0/files/openoffice-wrapper
new file mode 100644
index 000000000000..881d40e90c3a
--- /dev/null
+++ b/editors/openoffice.org-1.0/files/openoffice-wrapper
@@ -0,0 +1,15 @@
+#!/bin/sh
+#
+# $FreeBSD: /tmp/pcvs/ports/editors/openoffice.org-1.0/files/Attic/openoffice-wrapper,v 1.1 2002-08-01 12:29:21 mbr Exp $
+
+cd %%PREFIX%%/OpenOffice.org1.0/program/
+program=`echo $0 | sed -e 's|.*-||'`
+
+case $program in
+$0)
+ exec ./soffice "$@"
+ ;;
+ *)
+ exec ./$program "$@"
+ ;;
+esac
diff --git a/editors/openoffice.org-1.0/pkg-message b/editors/openoffice.org-1.0/pkg-message
index a003d1d3eb8a..6395b787b3e0 100644
--- a/editors/openoffice.org-1.0/pkg-message
+++ b/editors/openoffice.org-1.0/pkg-message
@@ -1,17 +1,59 @@
-OpenOffice.org Build 641 Personal Install How-To
+OpenOffice.org Build 1.0.1 Personal Install How-To
-Written by: Matthias Rauch <mrauch@netbsd.org>
- Martin Blapp <mbr@freebsd.org>
+Written by: Martin Blapp <mbr@freebsd.org>
OpenOffice.org will soon been installed in
${PREFIX}/OpenOffice.org1.0/
-Once this is done run "make install-user" as the user you like to
-use OpenOffice.org and choose a standard workstation installation.
-Thereafter, OpenOffice.org can be started with
-${PREFIX}/OpenOffice.org1.0/program/soffice.
+1 User installation
+-------------------
-If OpenOffice.org asks you to choose the Java JDK during
+1.1 OO.org installed from the ports collection
+
+Once this is done you have to run "make install-user" as the
+user you like to use OO.org and choose a standard workstation
+installation.
+
+1.2 OO.org installed as package
+
+If you have just installed OO.org as package, there is no
+"make install-user" option available. Instead you'll have
+to run as the user you like to use OO.org:
+
+"${PREFIX}/bin/openoffice-setup" and choose a standard workstation
+installation.
+
+2 JDK-Installation
+------------------
+
+If OO.org asks you to choose the Java JDK during
"make install-user", you must choose the linux jdk1.3.1.
Native FreeBSD jdk1.3.1 does not work yet with FreeBSD
-openoffice and OO does ignore it.
+OO.org does ignore it.
+
+3 Start OO.org
+--------------
+
+There are some wrappers installed for fast startup.
+Add "${PREFIX}/bin/" to your PATH and you will be able
+to use them.
+
+${PREFIX}/bin/openoffice
+${PREFIX}/bin/openoffice-sagenda
+${PREFIX}/bin/openoffice-scalc
+${PREFIX}/bin/openoffice-sdraw
+${PREFIX}/bin/openoffice-setup
+${PREFIX}/bin/openoffice-sfax
+${PREFIX}/bin/openoffice-simpress
+${PREFIX}/bin/openoffice-spadmin
+${PREFIX}/bin/openoffice-sweb
+${PREFIX}/bin/openoffice-swriter
+
+4 Setup problems
+----------------
+
+If the setup complains about a missing file
+"setup.ins", it's time to upgrade your FreeBSD system
+to the lastest version. You will encounter this bug
+only if your OS is older than FreeBSD 4.6 STABLE.
+4.6 RELEASE is still affected.
diff --git a/editors/openoffice/Makefile b/editors/openoffice/Makefile
index 6a68dc752369..eca356ee6aa3 100644
--- a/editors/openoffice/Makefile
+++ b/editors/openoffice/Makefile
@@ -330,6 +330,8 @@ do-build:
pre-install:
@${SED} -e 's#%%PREFIX%%#${PREFIX}#g' < ${FILESDIR}/oo_setup.resp \
> ${WRKSRC}/../instsetoo/unxfbsd.pro/${LANG_EXT}/normal/oo_setup.resp
+ @${SED} -e 's#%%PREFIX%%#${PREFIX}#g' < ${FILESDIR}/openoffice-wrapper \
+ > ${WRKSRC}/openoffice
do-install:
.if !defined(DISPLAY)
@@ -369,7 +371,20 @@ post-install:
${ECHO_CMD} "DICT $$COUNTRY $$LANGUAGE $$ABRV" >> \
${DICT_DIR}/dictionary.lst ; \
done
- @cd ${PREFIX} && ${FIND} -s ${INSTALLATION_BASEDIR} -type f > ${TMPPLIST}
+ @${ECHO_MSG} "===> Add wrapper scripts";
+ @${INSTALL_SCRIPT} ${WRKSRC}/openoffice ${PREFIX}/bin/openoffice
+ @${LN} -fs ${PREFIX}/bin/openoffice ${PREFIX}/bin/openoffice-sagenda
+ @${LN} -fs ${PREFIX}/bin/openoffice ${PREFIX}/bin/openoffice-scalc
+ @${LN} -fs ${PREFIX}/bin/openoffice ${PREFIX}/bin/openoffice-sdraw
+ @${LN} -fs ${PREFIX}/bin/openoffice ${PREFIX}/bin/openoffice-setup
+ @${LN} -fs ${PREFIX}/bin/openoffice ${PREFIX}/bin/openoffice-sfax
+ @${LN} -fs ${PREFIX}/bin/openoffice ${PREFIX}/bin/openoffice-simpress
+ @${LN} -fs ${PREFIX}/bin/openoffice ${PREFIX}/bin/openoffice-spadmin
+ @${LN} -fs ${PREFIX}/bin/openoffice ${PREFIX}/bin/openoffice-sweb
+ @${LN} -fs ${PREFIX}/bin/openoffice ${PREFIX}/bin/openoffice-swriter
+ @cd ${PREFIX} && ${FIND} -s bin -type f | ${GREP} openoffice > ${TMPPLIST}
+ @cd ${PREFIX} && ${FIND} -s bin -type l | ${GREP} openoffice >> ${TMPPLIST}
+ @cd ${PREFIX} && ${FIND} -s ${INSTALLATION_BASEDIR} -type f >> ${TMPPLIST}
@cd ${PREFIX} && ${FIND} -s ${INSTALLATION_BASEDIR} -type l >> ${TMPPLIST}
@cd ${PREFIX} && ${FIND} -s ${INSTALLATION_BASEDIR} -type d > ${WRKDIR}/dir.tmp
@${SORT} -r ${WRKDIR}/dir.tmp | ${XARGS} -n 1 ${ECHO_CMD} @dirrm >> ${TMPPLIST}
diff --git a/editors/openoffice/files/openoffice-wrapper b/editors/openoffice/files/openoffice-wrapper
new file mode 100644
index 000000000000..c3b59d544ee9
--- /dev/null
+++ b/editors/openoffice/files/openoffice-wrapper
@@ -0,0 +1,15 @@
+#!/bin/sh
+#
+# $FreeBSD: /tmp/pcvs/ports/editors/openoffice/files/Attic/openoffice-wrapper,v 1.1 2002-08-01 12:29:21 mbr Exp $
+
+cd %%PREFIX%%/OpenOffice.org1.0/program/
+program=`echo $0 | sed -e 's|.*-||'`
+
+case $program in
+$0)
+ exec ./soffice "$@"
+ ;;
+ *)
+ exec ./$program "$@"
+ ;;
+esac
diff --git a/editors/openoffice/pkg-message b/editors/openoffice/pkg-message
index a003d1d3eb8a..6395b787b3e0 100644
--- a/editors/openoffice/pkg-message
+++ b/editors/openoffice/pkg-message
@@ -1,17 +1,59 @@
-OpenOffice.org Build 641 Personal Install How-To
+OpenOffice.org Build 1.0.1 Personal Install How-To
-Written by: Matthias Rauch <mrauch@netbsd.org>
- Martin Blapp <mbr@freebsd.org>
+Written by: Martin Blapp <mbr@freebsd.org>
OpenOffice.org will soon been installed in
${PREFIX}/OpenOffice.org1.0/
-Once this is done run "make install-user" as the user you like to
-use OpenOffice.org and choose a standard workstation installation.
-Thereafter, OpenOffice.org can be started with
-${PREFIX}/OpenOffice.org1.0/program/soffice.
+1 User installation
+-------------------
-If OpenOffice.org asks you to choose the Java JDK during
+1.1 OO.org installed from the ports collection
+
+Once this is done you have to run "make install-user" as the
+user you like to use OO.org and choose a standard workstation
+installation.
+
+1.2 OO.org installed as package
+
+If you have just installed OO.org as package, there is no
+"make install-user" option available. Instead you'll have
+to run as the user you like to use OO.org:
+
+"${PREFIX}/bin/openoffice-setup" and choose a standard workstation
+installation.
+
+2 JDK-Installation
+------------------
+
+If OO.org asks you to choose the Java JDK during
"make install-user", you must choose the linux jdk1.3.1.
Native FreeBSD jdk1.3.1 does not work yet with FreeBSD
-openoffice and OO does ignore it.
+OO.org does ignore it.
+
+3 Start OO.org
+--------------
+
+There are some wrappers installed for fast startup.
+Add "${PREFIX}/bin/" to your PATH and you will be able
+to use them.
+
+${PREFIX}/bin/openoffice
+${PREFIX}/bin/openoffice-sagenda
+${PREFIX}/bin/openoffice-scalc
+${PREFIX}/bin/openoffice-sdraw
+${PREFIX}/bin/openoffice-setup
+${PREFIX}/bin/openoffice-sfax
+${PREFIX}/bin/openoffice-simpress
+${PREFIX}/bin/openoffice-spadmin
+${PREFIX}/bin/openoffice-sweb
+${PREFIX}/bin/openoffice-swriter
+
+4 Setup problems
+----------------
+
+If the setup complains about a missing file
+"setup.ins", it's time to upgrade your FreeBSD system
+to the lastest version. You will encounter this bug
+only if your OS is older than FreeBSD 4.6 STABLE.
+4.6 RELEASE is still affected.