aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2003-12-01 05:26:38 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2003-12-01 05:26:38 +0000
commiteb07a748fcde9d94400f55ba6ec6d9abe6efed3b (patch)
treef249ff48015cf84e05ecff169cee45d7175ab6b6
parentb4f67189ec844fe9c87197c9932376301a51a877 (diff)
downloadports-eb07a748fcde9d94400f55ba6ec6d9abe6efed3b.tar.gz
ports-eb07a748fcde9d94400f55ba6ec6d9abe6efed3b.zip
Add gnome2-lite, a trimmed down version of the GNOME 2 desktop that will
be used on FreeBSD release CDs. Requested by: re Approved by: portmgr (implicit)
Notes
Notes: svn path=/head/; revision=94833
-rw-r--r--x11/Makefile1
-rw-r--r--x11/gnome2-lite/Makefile58
-rw-r--r--x11/gnome2-lite/pkg-descr8
-rw-r--r--x11/gnome2-lite/pkg-install21
-rw-r--r--x11/gnome2-lite/pkg-message14
-rw-r--r--x11/gnome2-lite/pkg-plist1
6 files changed, 103 insertions, 0 deletions
diff --git a/x11/Makefile b/x11/Makefile
index cac67eec910c..0240735a9599 100644
--- a/x11/Makefile
+++ b/x11/Makefile
@@ -46,6 +46,7 @@
SUBDIR += gnome-swallow
SUBDIR += gnome2
SUBDIR += gnome2-fifth-toe
+ SUBDIR += gnome2-lite
SUBDIR += gnomeapplets2
SUBDIR += gnomedesktop
SUBDIR += gnomelibs
diff --git a/x11/gnome2-lite/Makefile b/x11/gnome2-lite/Makefile
new file mode 100644
index 000000000000..cdae845aa66e
--- /dev/null
+++ b/x11/gnome2-lite/Makefile
@@ -0,0 +1,58 @@
+# New ports collection makefile for: gnome2-lite
+# Date created: 30 November 2003
+# Whom: Joe Marcus Clarke <marcus@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= gnome2
+PORTVERSION= 2.4.0
+CATEGORIES= x11 gnome
+MASTER_SITES= # empty
+PKGNAMESUFFIX= -lite
+DISTFILES= # empty
+EXTRACT_ONLY= # empty
+
+MAINTAINER= gnome@FreeBSD.org
+COMMENT= The "meta-port" of the GNOME desktop slimmed down for FreeBSD releases
+
+RUN_DEPENDS= ${X11BASE}/libexec/cdplayer_applet2:${PORTSDIR}/x11/gnomeapplets2 \
+ gnome-cd:${PORTSDIR}/audio/gnomemedia2 \
+ gnome-dictionary:${PORTSDIR}/deskutils/gnomeutils2 \
+ eog:${PORTSDIR}/graphics/eog2 \
+ gnome-control-center:${PORTSDIR}/sysutils/gnomecontrolcenter2 \
+ gedit:${PORTSDIR}/editors/gedit2 \
+ gnome-terminal:${PORTSDIR}/x11/gnometerminal \
+ gnome-session:${PORTSDIR}/x11/gnomesession \
+ gnome-system-monitor:${PORTSDIR}/sysutils/gnomesystemmonitor \
+ nautilus:${PORTSDIR}/x11-fm/nautilus2 \
+ yelp:${PORTSDIR}/x11/yelp \
+ screensaver-properties-capplet:${PORTSDIR}/x11/xscreensaver-gnome \
+ ${X11BASE}/share/gnome/help/user-guide/C/user-guide.xml:${PORTSDIR}/misc/gnomeuserdocs2 \
+ ${X11BASE}/share/gnome/sounds/question.wav:${PORTSDIR}/audio/gnomeaudio2 \
+ file-roller:${PORTSDIR}/archivers/fileroller \
+ ${X11BASE}/share/themes/HighContrast/gtk-2.0/gtkrc:${PORTSDIR}/x11-toolkits/gnome-themes \
+ ggv:${PORTSDIR}/print/ggv2 \
+ gcalctool:${PORTSDIR}/math/gcalctool \
+ gucharmap:${PORTSDIR}/deskutils/gucharmap \
+ gst-thumbnail:${PORTSDIR}/multimedia/nautilus-media \
+ ${X11BASE}/lib/X11/fonts/bitstream-vera/Vera.ttf:${PORTSDIR}/x11-fonts/bitstream-vera
+
+NO_BUILD= yes
+
+USE_PYTHON= yes
+
+.if !defined(BATCH) && !defined(PACKAGE_BUILDING)
+pre-configure:
+ @${SH} ${PKGINSTALL} ${PKGNAME} PRE-INSTALL
+.endif
+
+do-install: # empty
+
+.include <bsd.port.pre.mk>
+
+.if ${ARCH} != "amd64" && ( ${ARCH} == "i386" || ${OSVERSION} > 500035 )
+RUN_DEPENDS+= epiphany:${PORTSDIR}/www/epiphany
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/x11/gnome2-lite/pkg-descr b/x11/gnome2-lite/pkg-descr
new file mode 100644
index 000000000000..4fd87114cf26
--- /dev/null
+++ b/x11/gnome2-lite/pkg-descr
@@ -0,0 +1,8 @@
+GNU Network Object Model Environment
+
+This package does not contain anything by itself -- it is a
+"meta-port" that depends on other GNOME packages. Its sole purpose is
+to require dependencies so users can install the basic set of
+components necessary to start a GNOME 2 desktop session.
+
+WWW: http://www.FreeBSD.org/gnome/
diff --git a/x11/gnome2-lite/pkg-install b/x11/gnome2-lite/pkg-install
new file mode 100644
index 000000000000..892e5ee4c4cd
--- /dev/null
+++ b/x11/gnome2-lite/pkg-install
@@ -0,0 +1,21 @@
+#!/bin/sh
+
+if [ -n "${PACKAGE_BUILDING}" ]; then
+ exit 0
+fi
+
+PATH=/bin:/usr/bin:/sbin:/usr/sbin:${PATH}
+export PATH
+
+if [ "$2" = "PRE-INSTALL" ]; then
+ GNOME_ONE_DESKTOP="gnomecore gnomeapplets gnomemedia gnomeutils gtop libgtop sawfish nautilus gedit xalf bugbuddy gnomegames gdm eog ggv gnomeaudio"
+ for package in ${GNOME_ONE_DESKTOP}; do
+ if pkg_info | grep "^${package}-[0-9]" >/dev/null 2>&1; then
+ echo "${package} was detected on the system. This package is part of the GNOME 1.x"
+ echo "desktop, and cannot coexist with the GNOME 2 desktop."
+ echo ""
+ echo "Please deinstall the GNOME 1.x desktop before installing this package."
+ false
+ fi
+ done
+fi
diff --git a/x11/gnome2-lite/pkg-message b/x11/gnome2-lite/pkg-message
new file mode 100644
index 000000000000..b99bc4e4a2b8
--- /dev/null
+++ b/x11/gnome2-lite/pkg-message
@@ -0,0 +1,14 @@
+************************************************************
+
+The GNOME 2 desktop Lite edition has been successfully installed.
+
+The Lite edition does not include all the components of the standard
+GNOME 2 desktop as detailed at http://www.gnome.org. If you wish to
+install the full desktop, you can remove this port, and install the
+x11/gnome2 port or package. Alternatively, you can install additional
+GNOME components individually using either their ports or packages.
+
+For more help on using GNOME on FreeBSD, please see the FreeBSD GNOME project
+site at http://www.FreeBSD.org/gnome.
+
+************************************************************
diff --git a/x11/gnome2-lite/pkg-plist b/x11/gnome2-lite/pkg-plist
new file mode 100644
index 000000000000..549a621fec0c
--- /dev/null
+++ b/x11/gnome2-lite/pkg-plist
@@ -0,0 +1 @@
+@comment this plist intentionally left empty