aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Pentchev <roam@FreeBSD.org>2003-11-28 06:16:45 +0000
committerPeter Pentchev <roam@FreeBSD.org>2003-11-28 06:16:45 +0000
commitf953b139e5096ff0bc0af14ebec55836c25c9ba0 (patch)
treec6a3dd26d894519b14c0167daa18eb0c370fc9b3
parentf6e92007240a4d9f5cd57f188771564fb17dd104 (diff)
downloadports-f953b139e5096ff0bc0af14ebec55836c25c9ba0.tar.gz
ports-f953b139e5096ff0bc0af14ebec55836c25c9ba0.zip
Update qmailadmin to 1.0.29 for much better interoperability with vpopmail.
PR: 59606 Submitted by: Alex Dupre <sysadmin@alexdupre.com> Approved by: portmgr (will)
Notes
Notes: svn path=/head/; revision=94817
-rw-r--r--mail/qmailadmin-devel/Makefile19
-rw-r--r--mail/qmailadmin-devel/distinfo2
-rw-r--r--mail/qmailadmin-devel/files/patch-Makefile.in42
-rw-r--r--mail/qmailadmin-devel/pkg-plist35
-rw-r--r--mail/qmailadmin/Makefile19
-rw-r--r--mail/qmailadmin/distinfo2
-rw-r--r--mail/qmailadmin/files/patch-Makefile.in42
-rw-r--r--mail/qmailadmin/pkg-plist35
8 files changed, 146 insertions, 50 deletions
diff --git a/mail/qmailadmin-devel/Makefile b/mail/qmailadmin-devel/Makefile
index c6e1800e50c3..83ad75da565b 100644
--- a/mail/qmailadmin-devel/Makefile
+++ b/mail/qmailadmin-devel/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= qmailadmin
-PORTVERSION= 1.0.26
+PORTVERSION= 1.0.29
CATEGORIES= mail www
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -51,6 +51,7 @@ USE_GMAKE= YES
# WITH_DOMAIN_AUTOFILL - autofill the domain on login page based on the
# hostname
# WITHOUT_IDX_SQL - disable the SQL support for mailing lists
+# WITH_HELP - display help links on login page
#
CGIBINDIR?= www/cgi-bin.default
@@ -81,7 +82,7 @@ CONFIGURE_ARGS+= \
--enable-htmldir=${PREFIX}/${WEBDATADIR}/${WEBDATASUBDIR} \
--enable-imagedir=${PREFIX}/${WEBDATADIR}/${WEBDATASUBDIR}/images \
--enable-imageurl=${WEBDATAURL}/${WEBDATASUBDIR}/images \
- --with-htmllibdir=${DATADIR} \
+ --enable-htmllibdir=${DATADIR} \
--enable-cgibindir=${PREFIX}/${CGIBINDIR}/${CGIBINSUBDIR} \
--enable-cgipath=${CGIBINURL}/${CGIBINSUBDIR}/qmailadmin \
--enable-vpopmaildir=${LOCALBASE}/vpopmail \
@@ -89,23 +90,27 @@ CONFIGURE_ARGS+= \
--enable-ezmlmdir=${LOCALBASE}/bin
.if defined(WITHOUT_IPAUTH)
-CONFIGURE_ARGS+= --enable-ipauth=n
+CONFIGURE_ARGS+= --disable-ipauth
.endif
.if defined(WITHOUT_USER_INDEX)
-CONFIGURE_ARGS+= --enable-user-index=n
+CONFIGURE_ARGS+= --disable-user-index
.endif
.if defined(WITH_MODIFY_QUOTA)
-CONFIGURE_ARGS+= --enable-modify-quota=y
+CONFIGURE_ARGS+= --enable-modify-quota
.endif
.if defined(WITH_DOMAIN_AUTOFILL)
-CONFIGURE_ARGS+= --enable-domain-autofill=y
+CONFIGURE_ARGS+= --enable-domain-autofill
.endif
.if defined(WITHOUT_IDX_SQL)
-CONFIGURE_ARGS+= --enable-ezmlm-mysql=n
+CONFIGURE_ARGS+= --disable-ezmlm-mysql
+.endif
+
+.if defined(WITH_HELP)
+CONFIGURE_ARGS+= --enable-help
.endif
.include <bsd.port.post.mk>
diff --git a/mail/qmailadmin-devel/distinfo b/mail/qmailadmin-devel/distinfo
index 67b25af8c336..bc0795a9e86d 100644
--- a/mail/qmailadmin-devel/distinfo
+++ b/mail/qmailadmin-devel/distinfo
@@ -1 +1 @@
-MD5 (qmailadmin-1.0.26.tar.gz) = aebf27ff839bae13cefb09e444a59bdd
+MD5 (qmailadmin-1.0.29.tar.gz) = 2664fdc0ef0350abea1aacc270ba8d25
diff --git a/mail/qmailadmin-devel/files/patch-Makefile.in b/mail/qmailadmin-devel/files/patch-Makefile.in
new file mode 100644
index 000000000000..0f8ec64c4935
--- /dev/null
+++ b/mail/qmailadmin-devel/files/patch-Makefile.in
@@ -0,0 +1,42 @@
+--- Makefile.in.orig Sat Oct 18 01:37:05 2003
++++ Makefile.in Mon Oct 20 22:37:00 2003
+@@ -131,39 +131,6 @@
+ all: all-redirect
+ .SUFFIXES:
+ .SUFFIXES: .S .c .o .s
+-$(srcdir)/Makefile.in: Makefile.am $(top_srcdir)/configure.in $(ACLOCAL_M4)
+- cd $(top_srcdir) && $(AUTOMAKE) --foreign --include-deps Makefile
+-
+-Makefile: $(srcdir)/Makefile.in $(top_builddir)/config.status
+- cd $(top_builddir) \
+- && CONFIG_FILES=$@ CONFIG_HEADERS= $(SHELL) ./config.status
+-
+-$(ACLOCAL_M4): configure.in
+- cd $(srcdir) && $(ACLOCAL)
+-
+-config.status: $(srcdir)/configure $(CONFIG_STATUS_DEPENDENCIES)
+- $(SHELL) ./config.status --recheck
+-$(srcdir)/configure: $(srcdir)/configure.in $(ACLOCAL_M4) $(CONFIGURE_DEPENDENCIES)
+- cd $(srcdir) && $(AUTOCONF)
+-
+-config.h: stamp-h
+- @if test ! -f $@; then \
+- rm -f stamp-h; \
+- $(MAKE) stamp-h; \
+- else :; fi
+-stamp-h: $(srcdir)/config.h.in $(top_builddir)/config.status
+- cd $(top_builddir) \
+- && CONFIG_FILES= CONFIG_HEADERS=config.h \
+- $(SHELL) ./config.status
+- @echo timestamp > stamp-h 2> /dev/null
+-$(srcdir)/config.h.in: $(srcdir)/stamp-h.in
+- @if test ! -f $@; then \
+- rm -f $(srcdir)/stamp-h.in; \
+- $(MAKE) $(srcdir)/stamp-h.in; \
+- else :; fi
+-$(srcdir)/stamp-h.in: $(top_srcdir)/configure.in $(ACLOCAL_M4)
+- cd $(top_srcdir) && $(AUTOHEADER)
+- @echo timestamp > $(srcdir)/stamp-h.in 2> /dev/null
+
+ mostlyclean-hdr:
+
diff --git a/mail/qmailadmin-devel/pkg-plist b/mail/qmailadmin-devel/pkg-plist
index c7f175ea520d..ae28c9066c6b 100644
--- a/mail/qmailadmin-devel/pkg-plist
+++ b/mail/qmailadmin-devel/pkg-plist
@@ -7,8 +7,6 @@
%%DATADIR%%/html/add_mailinglist-no-idx.html
%%DATADIR%%/html/add_user.html
%%DATADIR%%/html/colortable
-%%DATADIR%%/html/da
-%%DATADIR%%/html/de
%%DATADIR%%/html/del_autorespond_confirm.html
%%DATADIR%%/html/del_forward_confirm.html
%%DATADIR%%/html/del_listdig.html
@@ -16,24 +14,13 @@
%%DATADIR%%/html/del_listuser.html
%%DATADIR%%/html/del_mailinglist_confirm.html
%%DATADIR%%/html/del_user_confirm.html
-%%DATADIR%%/html/en
-%%DATADIR%%/html/es
%%DATADIR%%/html/footer.html
-%%DATADIR%%/html/fr
%%DATADIR%%/html/header.html
-%%DATADIR%%/html/hu
-%%DATADIR%%/html/it
-%%DATADIR%%/html/ja
%%DATADIR%%/html/main_menu.html
%%DATADIR%%/html/mod_autorespond.html
%%DATADIR%%/html/mod_dotqmail.html
%%DATADIR%%/html/mod_mailinglist-idx.html
%%DATADIR%%/html/mod_user.html
-%%DATADIR%%/html/nl
-%%DATADIR%%/html/no
-%%DATADIR%%/html/pt-BR
-%%DATADIR%%/html/pl
-%%DATADIR%%/html/ru
%%DATADIR%%/html/setremotecatchall.html
%%DATADIR%%/html/show_autorespond.html
%%DATADIR%%/html/show_digest_subscribers.html
@@ -43,10 +30,23 @@
%%DATADIR%%/html/show_moderators.html
%%DATADIR%%/html/show_subscribers.html
%%DATADIR%%/html/show_users.html
-%%DATADIR%%/html/sk
-%%DATADIR%%/html/sv
-%%DATADIR%%/html/tr
-%%DATADIR%%/html/xaa
+%%DATADIR%%/lang/bg
+%%DATADIR%%/lang/da
+%%DATADIR%%/lang/de
+%%DATADIR%%/lang/en
+%%DATADIR%%/lang/es
+%%DATADIR%%/lang/fr
+%%DATADIR%%/lang/hu
+%%DATADIR%%/lang/it
+%%DATADIR%%/lang/ja
+%%DATADIR%%/lang/nl
+%%DATADIR%%/lang/no
+%%DATADIR%%/lang/pl
+%%DATADIR%%/lang/pt-BR
+%%DATADIR%%/lang/ru
+%%DATADIR%%/lang/sk
+%%DATADIR%%/lang/sv
+%%DATADIR%%/lang/tr
%%CGIBINDIR%%/%%CGIBINSUBDIR%%/qmailadmin
%%WEBDATADIR%%/%%WEBDATASUBDIR%%/images/delete.png
%%WEBDATADIR%%/%%WEBDATASUBDIR%%/images/disabled.png
@@ -74,4 +74,5 @@
@unexec /bin/rmdir %D/%%CGIBINDIR%%/%%CGIBINSUBDIR%% 2> /dev/null || true
@unexec /bin/rmdir %D/%%CGIBINDIR%% 2> /dev/null || true
@dirrm %%DATADIR%%/html
+@dirrm %%DATADIR%%/lang
@dirrm %%DATADIR%%
diff --git a/mail/qmailadmin/Makefile b/mail/qmailadmin/Makefile
index c6e1800e50c3..83ad75da565b 100644
--- a/mail/qmailadmin/Makefile
+++ b/mail/qmailadmin/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= qmailadmin
-PORTVERSION= 1.0.26
+PORTVERSION= 1.0.29
CATEGORIES= mail www
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -51,6 +51,7 @@ USE_GMAKE= YES
# WITH_DOMAIN_AUTOFILL - autofill the domain on login page based on the
# hostname
# WITHOUT_IDX_SQL - disable the SQL support for mailing lists
+# WITH_HELP - display help links on login page
#
CGIBINDIR?= www/cgi-bin.default
@@ -81,7 +82,7 @@ CONFIGURE_ARGS+= \
--enable-htmldir=${PREFIX}/${WEBDATADIR}/${WEBDATASUBDIR} \
--enable-imagedir=${PREFIX}/${WEBDATADIR}/${WEBDATASUBDIR}/images \
--enable-imageurl=${WEBDATAURL}/${WEBDATASUBDIR}/images \
- --with-htmllibdir=${DATADIR} \
+ --enable-htmllibdir=${DATADIR} \
--enable-cgibindir=${PREFIX}/${CGIBINDIR}/${CGIBINSUBDIR} \
--enable-cgipath=${CGIBINURL}/${CGIBINSUBDIR}/qmailadmin \
--enable-vpopmaildir=${LOCALBASE}/vpopmail \
@@ -89,23 +90,27 @@ CONFIGURE_ARGS+= \
--enable-ezmlmdir=${LOCALBASE}/bin
.if defined(WITHOUT_IPAUTH)
-CONFIGURE_ARGS+= --enable-ipauth=n
+CONFIGURE_ARGS+= --disable-ipauth
.endif
.if defined(WITHOUT_USER_INDEX)
-CONFIGURE_ARGS+= --enable-user-index=n
+CONFIGURE_ARGS+= --disable-user-index
.endif
.if defined(WITH_MODIFY_QUOTA)
-CONFIGURE_ARGS+= --enable-modify-quota=y
+CONFIGURE_ARGS+= --enable-modify-quota
.endif
.if defined(WITH_DOMAIN_AUTOFILL)
-CONFIGURE_ARGS+= --enable-domain-autofill=y
+CONFIGURE_ARGS+= --enable-domain-autofill
.endif
.if defined(WITHOUT_IDX_SQL)
-CONFIGURE_ARGS+= --enable-ezmlm-mysql=n
+CONFIGURE_ARGS+= --disable-ezmlm-mysql
+.endif
+
+.if defined(WITH_HELP)
+CONFIGURE_ARGS+= --enable-help
.endif
.include <bsd.port.post.mk>
diff --git a/mail/qmailadmin/distinfo b/mail/qmailadmin/distinfo
index 67b25af8c336..bc0795a9e86d 100644
--- a/mail/qmailadmin/distinfo
+++ b/mail/qmailadmin/distinfo
@@ -1 +1 @@
-MD5 (qmailadmin-1.0.26.tar.gz) = aebf27ff839bae13cefb09e444a59bdd
+MD5 (qmailadmin-1.0.29.tar.gz) = 2664fdc0ef0350abea1aacc270ba8d25
diff --git a/mail/qmailadmin/files/patch-Makefile.in b/mail/qmailadmin/files/patch-Makefile.in
new file mode 100644
index 000000000000..0f8ec64c4935
--- /dev/null
+++ b/mail/qmailadmin/files/patch-Makefile.in
@@ -0,0 +1,42 @@
+--- Makefile.in.orig Sat Oct 18 01:37:05 2003
++++ Makefile.in Mon Oct 20 22:37:00 2003
+@@ -131,39 +131,6 @@
+ all: all-redirect
+ .SUFFIXES:
+ .SUFFIXES: .S .c .o .s
+-$(srcdir)/Makefile.in: Makefile.am $(top_srcdir)/configure.in $(ACLOCAL_M4)
+- cd $(top_srcdir) && $(AUTOMAKE) --foreign --include-deps Makefile
+-
+-Makefile: $(srcdir)/Makefile.in $(top_builddir)/config.status
+- cd $(top_builddir) \
+- && CONFIG_FILES=$@ CONFIG_HEADERS= $(SHELL) ./config.status
+-
+-$(ACLOCAL_M4): configure.in
+- cd $(srcdir) && $(ACLOCAL)
+-
+-config.status: $(srcdir)/configure $(CONFIG_STATUS_DEPENDENCIES)
+- $(SHELL) ./config.status --recheck
+-$(srcdir)/configure: $(srcdir)/configure.in $(ACLOCAL_M4) $(CONFIGURE_DEPENDENCIES)
+- cd $(srcdir) && $(AUTOCONF)
+-
+-config.h: stamp-h
+- @if test ! -f $@; then \
+- rm -f stamp-h; \
+- $(MAKE) stamp-h; \
+- else :; fi
+-stamp-h: $(srcdir)/config.h.in $(top_builddir)/config.status
+- cd $(top_builddir) \
+- && CONFIG_FILES= CONFIG_HEADERS=config.h \
+- $(SHELL) ./config.status
+- @echo timestamp > stamp-h 2> /dev/null
+-$(srcdir)/config.h.in: $(srcdir)/stamp-h.in
+- @if test ! -f $@; then \
+- rm -f $(srcdir)/stamp-h.in; \
+- $(MAKE) $(srcdir)/stamp-h.in; \
+- else :; fi
+-$(srcdir)/stamp-h.in: $(top_srcdir)/configure.in $(ACLOCAL_M4)
+- cd $(top_srcdir) && $(AUTOHEADER)
+- @echo timestamp > $(srcdir)/stamp-h.in 2> /dev/null
+
+ mostlyclean-hdr:
+
diff --git a/mail/qmailadmin/pkg-plist b/mail/qmailadmin/pkg-plist
index c7f175ea520d..ae28c9066c6b 100644
--- a/mail/qmailadmin/pkg-plist
+++ b/mail/qmailadmin/pkg-plist
@@ -7,8 +7,6 @@
%%DATADIR%%/html/add_mailinglist-no-idx.html
%%DATADIR%%/html/add_user.html
%%DATADIR%%/html/colortable
-%%DATADIR%%/html/da
-%%DATADIR%%/html/de
%%DATADIR%%/html/del_autorespond_confirm.html
%%DATADIR%%/html/del_forward_confirm.html
%%DATADIR%%/html/del_listdig.html
@@ -16,24 +14,13 @@
%%DATADIR%%/html/del_listuser.html
%%DATADIR%%/html/del_mailinglist_confirm.html
%%DATADIR%%/html/del_user_confirm.html
-%%DATADIR%%/html/en
-%%DATADIR%%/html/es
%%DATADIR%%/html/footer.html
-%%DATADIR%%/html/fr
%%DATADIR%%/html/header.html
-%%DATADIR%%/html/hu
-%%DATADIR%%/html/it
-%%DATADIR%%/html/ja
%%DATADIR%%/html/main_menu.html
%%DATADIR%%/html/mod_autorespond.html
%%DATADIR%%/html/mod_dotqmail.html
%%DATADIR%%/html/mod_mailinglist-idx.html
%%DATADIR%%/html/mod_user.html
-%%DATADIR%%/html/nl
-%%DATADIR%%/html/no
-%%DATADIR%%/html/pt-BR
-%%DATADIR%%/html/pl
-%%DATADIR%%/html/ru
%%DATADIR%%/html/setremotecatchall.html
%%DATADIR%%/html/show_autorespond.html
%%DATADIR%%/html/show_digest_subscribers.html
@@ -43,10 +30,23 @@
%%DATADIR%%/html/show_moderators.html
%%DATADIR%%/html/show_subscribers.html
%%DATADIR%%/html/show_users.html
-%%DATADIR%%/html/sk
-%%DATADIR%%/html/sv
-%%DATADIR%%/html/tr
-%%DATADIR%%/html/xaa
+%%DATADIR%%/lang/bg
+%%DATADIR%%/lang/da
+%%DATADIR%%/lang/de
+%%DATADIR%%/lang/en
+%%DATADIR%%/lang/es
+%%DATADIR%%/lang/fr
+%%DATADIR%%/lang/hu
+%%DATADIR%%/lang/it
+%%DATADIR%%/lang/ja
+%%DATADIR%%/lang/nl
+%%DATADIR%%/lang/no
+%%DATADIR%%/lang/pl
+%%DATADIR%%/lang/pt-BR
+%%DATADIR%%/lang/ru
+%%DATADIR%%/lang/sk
+%%DATADIR%%/lang/sv
+%%DATADIR%%/lang/tr
%%CGIBINDIR%%/%%CGIBINSUBDIR%%/qmailadmin
%%WEBDATADIR%%/%%WEBDATASUBDIR%%/images/delete.png
%%WEBDATADIR%%/%%WEBDATASUBDIR%%/images/disabled.png
@@ -74,4 +74,5 @@
@unexec /bin/rmdir %D/%%CGIBINDIR%%/%%CGIBINSUBDIR%% 2> /dev/null || true
@unexec /bin/rmdir %D/%%CGIBINDIR%% 2> /dev/null || true
@dirrm %%DATADIR%%/html
+@dirrm %%DATADIR%%/lang
@dirrm %%DATADIR%%