aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarcus Alves Grando <mnag@FreeBSD.org>2006-03-11 18:40:23 +0000
committerMarcus Alves Grando <mnag@FreeBSD.org>2006-03-11 18:40:23 +0000
commit57486a5c26920bcf5801481e35faf37a23d10862 (patch)
tree8973d32b3e75d416bd8d2fe690fc16626121e83e
parentfb1023504ae54a92f5bde05c65d008f8c0754a1a (diff)
downloadports-57486a5c26920bcf5801481e35faf37a23d10862.tar.gz
ports-57486a5c26920bcf5801481e35faf37a23d10862.zip
- Reorganize Makefile and replace to right ${PERL}
Notified by: tobez Approved by: portmgr (marcus in past commit)
Notes
Notes: svn path=/head/; revision=157062
-rw-r--r--devel/cvs2cl/Makefile10
1 files changed, 6 insertions, 4 deletions
diff --git a/devel/cvs2cl/Makefile b/devel/cvs2cl/Makefile
index eba3305d9d1c..3f17e45f8359 100644
--- a/devel/cvs2cl/Makefile
+++ b/devel/cvs2cl/Makefile
@@ -18,19 +18,21 @@ COMMENT= CVS-log-message-to-ChangeLog conversion script
USE_PERL5= yes
NO_WRKSUBDIR= yes
+NO_BUILD= yes
MANCOMPRESSED= no
MAN1= ${PORTNAME}.1
PLIST_FILES= bin/${PORTNAME}
do-extract:
@${MKDIR} ${WRKSRC}
+ @${CP} ${DISTDIR}/${DIST_SUBDIR}/${DISTFILES} ${WRKSRC}/${PORTNAME}
-do-build:
- @${SED} -e "s^exec perl -w -x^exec /usr/local/bin/perl -w -x^; s^#!perl -w^#!/usr/local/bin/perl -w^ " \
- ${DISTDIR}/${DIST_SUBDIR}/${DISTFILES} > ${WRKSRC}/${PORTNAME}
- @pod2man ${WRKSRC}/${PORTNAME} > ${WRKSRC}/${PORTNAME}.1
+post-patch:
+ @${REINPLACE_CMD} -e "s|exec perl -w -x|exec ${PERL} -w -x|" \
+ -e "s|#!perl -w|#!${PERL} -w|" ${WRKSRC}/${PORTNAME}
do-install:
+ @pod2man ${WRKSRC}/${PORTNAME} > ${WRKSRC}/${PORTNAME}.1
${INSTALL_SCRIPT} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin/${PORTNAME}
${INSTALL_MAN} ${WRKSRC}/${PORTNAME}.1 ${MANPREFIX}/man/man1/