aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRenato Botelho <garga@FreeBSD.org>2008-09-16 12:11:43 +0000
committerRenato Botelho <garga@FreeBSD.org>2008-09-16 12:11:43 +0000
commitba9f2b1d24814b9883182bcc24fd670a010cca71 (patch)
treec377679f06088620e3429c6c764b1985e22eab80
parentb408caedbdcf97b1819fb262fc5e88945962de1d (diff)
downloadports-ba9f2b1d24814b9883182bcc24fd670a010cca71.tar.gz
ports-ba9f2b1d24814b9883182bcc24fd670a010cca71.zip
- UNBREAK: Fix build with clamav 0.94
- Bump PORTREVISION PR: ports/127421 Submitted by: maintainer Approved by: portmgr (pav)
Notes
Notes: svn path=/head/; revision=220404
-rw-r--r--security/klamav/Makefile3
-rw-r--r--security/klamav/files/patch-src_klammail_clamdmail.c11
2 files changed, 12 insertions, 2 deletions
diff --git a/security/klamav/Makefile b/security/klamav/Makefile
index 755ff025ad78..080a18ddecb9 100644
--- a/security/klamav/Makefile
+++ b/security/klamav/Makefile
@@ -7,6 +7,7 @@
PORTNAME= klamav
PORTVERSION= 0.44
+PORTREVISION= 1
CATEGORIES= security
MASTER_SITES= SF
DISTNAME= ${PORTNAME}-${PORTVERSION}-source
@@ -36,8 +37,6 @@ CONFIGURE_ARGS+=--with-qt-dir=${QT_PREFIX} \
USE_KDELIBS_VER= 3
-BROKEN= Doesn't build with clamav-0.94
-
.include <bsd.port.pre.mk>
pre-configure:
diff --git a/security/klamav/files/patch-src_klammail_clamdmail.c b/security/klamav/files/patch-src_klammail_clamdmail.c
new file mode 100644
index 000000000000..77a6257aa95b
--- /dev/null
+++ b/security/klamav/files/patch-src_klammail_clamdmail.c
@@ -0,0 +1,11 @@
+--- src/klammail/clamdmail.c.orig 2008-09-16 08:46:48.000000000 -0300
++++ src/klammail/clamdmail.c 2008-09-16 08:47:25.000000000 -0300
+@@ -160,7 +160,7 @@
+ if(fsync(fd) == -1) {
+ // cli_dbgmsg("fsync() failed for descriptor %d\n", fd);
+ close(fd);
+- return CL_EFSYNC;
++ return CL_EIO;
+ }
+
+ close(fd);