aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Thegler <lth@FreeBSD.org>2004-08-29 15:18:05 +0000
committerLars Thegler <lth@FreeBSD.org>2004-08-29 15:18:05 +0000
commit45bee6fe31734ad47eda4361a00792089b5f478b (patch)
tree557bb0b182ef0d94a2992e03ef631f21243619f5
parent41eb32a848d3f9b4f1aa82c4e52adce7ba45f144 (diff)
downloadports-45bee6fe31734ad47eda4361a00792089b5f478b.tar.gz
ports-45bee6fe31734ad47eda4361a00792089b5f478b.zip
Notes
-rw-r--r--mail/Makefile1
-rw-r--r--mail/p5-Email-MIME-ContentType/Makefile26
-rw-r--r--mail/p5-Email-MIME-ContentType/distinfo2
-rw-r--r--mail/p5-Email-MIME-ContentType/files/5.005_03-ContentType.pm17
-rw-r--r--mail/p5-Email-MIME-ContentType/files/5.005_03-Makefile.PL7
-rw-r--r--mail/p5-Email-MIME-ContentType/pkg-descr5
-rw-r--r--mail/p5-Email-MIME-ContentType/pkg-plist7
7 files changed, 65 insertions, 0 deletions
diff --git a/mail/Makefile b/mail/Makefile
index 30a004399a44..4acd4916758c 100644
--- a/mail/Makefile
+++ b/mail/Makefile
@@ -230,6 +230,7 @@
SUBDIR += p5-Email-FolderType
SUBDIR += p5-Email-LocalDelivery
SUBDIR += p5-Email-LocalDelivery-Ezmlm
+ SUBDIR += p5-Email-MIME-ContentType
SUBDIR += p5-Email-MIME-Encodings
SUBDIR += p5-Email-Simple
SUBDIR += p5-Email-Simple-Creator
diff --git a/mail/p5-Email-MIME-ContentType/Makefile b/mail/p5-Email-MIME-ContentType/Makefile
new file mode 100644
index 000000000000..23435bc30dff
--- /dev/null
+++ b/mail/p5-Email-MIME-ContentType/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: p5-Email-MIME-ContentType
+# Date created: 2004-08-29
+# Whom: Lars Thegler <lars@thegler.dk>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Email-MIME-ContentType
+PORTVERSION= 1.0
+CATEGORIES= mail perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Email
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= lth@FreeBSD.org
+COMMENT= Parse a MIME Content-Type Header
+
+PERL_CONFIGURE= yes
+
+MAN3= Email::MIME::ContentType.3
+
+.include <bsd.port.pre.mk>
+.if ${PERL_LEVEL} <= 500503
+EXTRA_PATCHES= ${PATCHDIR}/5.005_03-*
+.endif
+.include <bsd.port.post.mk>
diff --git a/mail/p5-Email-MIME-ContentType/distinfo b/mail/p5-Email-MIME-ContentType/distinfo
new file mode 100644
index 000000000000..c41db2895c1a
--- /dev/null
+++ b/mail/p5-Email-MIME-ContentType/distinfo
@@ -0,0 +1,2 @@
+MD5 (Email-MIME-ContentType-1.0.tar.gz) = 39633da4afe003204454e26e64f9fb5a
+SIZE (Email-MIME-ContentType-1.0.tar.gz) = 2957
diff --git a/mail/p5-Email-MIME-ContentType/files/5.005_03-ContentType.pm b/mail/p5-Email-MIME-ContentType/files/5.005_03-ContentType.pm
new file mode 100644
index 000000000000..328351ed0634
--- /dev/null
+++ b/mail/p5-Email-MIME-ContentType/files/5.005_03-ContentType.pm
@@ -0,0 +1,17 @@
+--- ContentType.pm.orig Sun Aug 29 15:11:25 2004
++++ ContentType.pm Sun Aug 29 15:11:51 2004
+@@ -1,11 +1,11 @@
+ package Email::MIME::ContentType;
+-require 5.006;
+ use base 'Exporter';
+-our @EXPORT = qw(parse_content_type);
++use vars qw(@EXPORT $VERSION);
++@EXPORT = qw(parse_content_type);
+ use strict;
+ use Carp;
+ use warnings;
+-our $VERSION = '1.0';
++$VERSION = '1.0';
+
+ my $tspecials = quotemeta '()<>@,;:\\"/[]?=';
+ my $ct_default = 'text/plain; charset=us-ascii';
diff --git a/mail/p5-Email-MIME-ContentType/files/5.005_03-Makefile.PL b/mail/p5-Email-MIME-ContentType/files/5.005_03-Makefile.PL
new file mode 100644
index 000000000000..b23bcb911c53
--- /dev/null
+++ b/mail/p5-Email-MIME-ContentType/files/5.005_03-Makefile.PL
@@ -0,0 +1,7 @@
+--- Makefile.PL.orig Wed Jan 7 18:05:03 2004
++++ Makefile.PL Sun Aug 29 15:10:58 2004
+@@ -1,4 +1,3 @@
+-use 5.006;
+ use ExtUtils::MakeMaker;
+ # See lib/ExtUtils/MakeMaker.pm for details of how to influence
+ # the contents of the Makefile that is written.
diff --git a/mail/p5-Email-MIME-ContentType/pkg-descr b/mail/p5-Email-MIME-ContentType/pkg-descr
new file mode 100644
index 000000000000..abe2d1864779
--- /dev/null
+++ b/mail/p5-Email-MIME-ContentType/pkg-descr
@@ -0,0 +1,5 @@
+This module is responsible for parsing email content type headers
+according to section 5.1 of RFC 2045. It returns a hash with entries
+for the discrete type, the composite type, and a hash of attributes.
+
+WWW: http://search.cpan.org/dist/Email-MIME-ContentType/
diff --git a/mail/p5-Email-MIME-ContentType/pkg-plist b/mail/p5-Email-MIME-ContentType/pkg-plist
new file mode 100644
index 000000000000..a8f45151952e
--- /dev/null
+++ b/mail/p5-Email-MIME-ContentType/pkg-plist
@@ -0,0 +1,7 @@
+%%SITE_PERL%%/Email/MIME/ContentType.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Email/MIME/ContentType/.packlist
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/Email/MIME/ContentType 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/Email/MIME 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/Email 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/Email/MIME 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/Email 2>/dev/null || true