aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2004-02-23 16:40:57 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2004-02-23 16:40:57 +0000
commit490282cb9d97cdfc4ce59a64623c3c82aab8496a (patch)
tree1a470b8b9700c47f1a0c0a5e9e2ed66f32cbabc4
parenta856d49c1901463ec2afbacd8f82f61d1ff00769 (diff)
downloadports-490282cb9d97cdfc4ce59a64623c3c82aab8496a.tar.gz
ports-490282cb9d97cdfc4ce59a64623c3c82aab8496a.zip
Notes
-rw-r--r--security/doscan/Makefile5
-rw-r--r--security/doscan/distinfo3
-rw-r--r--security/doscan/files/freebsd4.diff11
3 files changed, 15 insertions, 4 deletions
diff --git a/security/doscan/Makefile b/security/doscan/Makefile
index e5a3bbd2cbbc..d5c507228c13 100644
--- a/security/doscan/Makefile
+++ b/security/doscan/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= doscan
-PORTVERSION= 0.2.5
-PORTREVISION= 1
+PORTVERSION= 0.2.6
CATEGORIES= security net
MASTER_SITES= http://static.enyo.de/fw/releases/doscan/
@@ -25,7 +24,7 @@ MAN1= doscan.1
.include <bsd.port.pre.mk>
.if ${OSVERSION} < 500000
-BROKEN= "Does not compile"
+EXTRA_PATCHES= ${PATCHDIR}/freebsd4.diff
.endif
post-install:
diff --git a/security/doscan/distinfo b/security/doscan/distinfo
index 5a6e6930b9e8..e763625b7caa 100644
--- a/security/doscan/distinfo
+++ b/security/doscan/distinfo
@@ -1 +1,2 @@
-MD5 (doscan-0.2.5.tar.gz) = 57fcb9d260c8cea003ed484b3fe7bd70
+MD5 (doscan-0.2.6.tar.gz) = 3391cc5a8e84b9f6b89e2219b8eae477
+SIZE (doscan-0.2.6.tar.gz) = 224734
diff --git a/security/doscan/files/freebsd4.diff b/security/doscan/files/freebsd4.diff
new file mode 100644
index 000000000000..cc89721cc173
--- /dev/null
+++ b/security/doscan/files/freebsd4.diff
@@ -0,0 +1,11 @@
+--- src/results.cc.orig Mon Feb 23 15:15:59 2004
++++ src/results.cc Mon Feb 23 15:30:54 2004
+@@ -427,7 +427,7 @@
+ #ifdef GETHOSTBYADDR_ACCEPTS_CHAR
+ he = gethostbyaddr (reinterpret_cast<char*>(&in), sizeof (in), AF_INET);
+ #else
+-#error Type of first argument to gethostbyaddr() is not known.
++ he = gethostbyaddr ((const char*)(&in), sizeof (in), AF_INET);
+ #endif
+ #endif
+