aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2004-07-09 03:36:01 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2004-07-09 03:36:01 +0000
commit5c98e2233243d848299005cf730eb4e36394e91f (patch)
tree05b421118eab5a245a3ed8e66772622728c9338e
parent071328fb4f1be0c7e0926163aba98d5fdfdcc746 (diff)
downloadports-5c98e2233243d848299005cf730eb4e36394e91f.tar.gz
ports-5c98e2233243d848299005cf730eb4e36394e91f.zip
Notes
-rw-r--r--java/Makefile1
-rw-r--r--java/jgrapht/Makefile70
-rw-r--r--java/jgrapht/distinfo2
-rw-r--r--java/jgrapht/pkg-descr17
4 files changed, 90 insertions, 0 deletions
diff --git a/java/Makefile b/java/Makefile
index aa1e2461deeb..cbee77b5c0eb 100644
--- a/java/Makefile
+++ b/java/Makefile
@@ -81,6 +81,7 @@
SUBDIR += jfc
SUBDIR += jflex
SUBDIR += jfreechart
+ SUBDIR += jgrapht
SUBDIR += jikes
SUBDIR += jlex
SUBDIR += jlint
diff --git a/java/jgrapht/Makefile b/java/jgrapht/Makefile
new file mode 100644
index 000000000000..61e6814f6bf9
--- /dev/null
+++ b/java/jgrapht/Makefile
@@ -0,0 +1,70 @@
+# ex:ts=8
+# Ports collection makefile for: jgrapht
+# Date created: Jul 9, 2004
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= jgrapht
+PORTVERSION= 0.5.3
+CATEGORIES= java
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= A Java class provides mathematical graph-theory objects and algorithms
+
+USE_ZIP= yes
+USE_JAVA= yes
+JAVA_VERSION= 1.3+
+JAVA_RUN= yes
+
+.if !defined(WITHOUT_COMPILE) || !defined(NOPORTDOCS)
+BUILD_DEPENDS+= ${ANT_CMD}:${PORTSDIR}/devel/apache-ant
+ANT_CMD?= ${LOCALBASE}/bin/ant
+ANT= ${SETENV} JAVA_HOME=${JAVA_HOME} ${ANT_CMD}
+.endif
+
+.if !defined(WITHOUT_COMPILE)
+JAVA_BUILD= yes
+ANT_TARGETS= jar
+.endif
+
+.if !defined(NOPORTDOCS)
+ANT_TARGETS+= javadoc
+PORTDOCS= *
+.endif
+
+PLIST_FILES= %%JAVAJARDIR%%/${PORTNAME}.jar
+
+pre-fetch:
+ @${ECHO_MSG} ""
+ @${ECHO_MSG} "You may use the following build options:"
+ @${ECHO_MSG} ""
+ @${ECHO_MSG} " WITHOUT_COMPILE=yes Install the pre-compiled .jar file"
+ @${ECHO_MSG} ""
+
+do-build:
+.if !defined(WITHOUT_COMPILE) || !defined(NOPORTDOCS)
+ @cd ${WRKSRC} && ${ANT} ${ANT_TARGETS}
+ @${MV} -f ${WRKSRC}/${PORTNAME}-${PORTVERSION}-local.jar ${WRKSRC}/${PORTNAME}-${PORTVERSION}.jar
+.endif
+
+do-install: do-install-jar do-install-javadoc
+
+do-install-jar:
+ @${ECHO_CMD} -n ">> Installing .jar file..."
+ @${INSTALL_DATA} ${WRKSRC}/${PORTNAME}-${PORTVERSION}.jar ${JAVAJARDIR}/${PORTNAME}.jar
+ @${ECHO_CMD} " [DONE]"
+
+do-install-javadoc:
+.if !defined(NOPORTDOCS)
+ @${ECHO_CMD} -n ">> Installing documentation in ${DOCSDIR}..."
+ @${MKDIR} ${DOCSDIR}
+ @cd ${WRKSRC}/javadoc && ${FIND} . \
+ | ${CPIO} -pdmu -R ${SHAREOWN}:${SHAREGRP} ${DOCSDIR}
+ @${ECHO_CMD} " [DONE]"
+.endif
+
+.include <bsd.port.mk>
diff --git a/java/jgrapht/distinfo b/java/jgrapht/distinfo
new file mode 100644
index 000000000000..a7a8a5422c14
--- /dev/null
+++ b/java/jgrapht/distinfo
@@ -0,0 +1,2 @@
+MD5 (jgrapht-0.5.3.zip) = 24795c1d575eb21af724f712e906da26
+SIZE (jgrapht-0.5.3.zip) = 818759
diff --git a/java/jgrapht/pkg-descr b/java/jgrapht/pkg-descr
new file mode 100644
index 000000000000..c9150881f88d
--- /dev/null
+++ b/java/jgrapht/pkg-descr
@@ -0,0 +1,17 @@
+JGraphT is a free Java graph library that provides mathematical graph-theory
+objects and algorithms. JGraphT supports various types of graphs including:
+ * directed and undirected graphs.
+ * graphs with weighted / unweighted / labeled or any user-defined edges.
+ * various edge multiplicity options, including: simple-graphs, multigraphs,
+ pseudographs.
+ * unmodifiable graphs - allow modules to provide "read-only" access to
+ internal graphs.
+ * listenable graphs - allow external listeners to track modification events.
+ * subgraphs graphs that are auto-updating subgraph views on other graphs.
+ * all compositions of above graphs.
+
+Although powerful, JGraphT is designed to be simple. For example, graph vertices
+can be of any objects. You can create graphs based on: Strings, URLs, XML
+documents, etc; you can even create graphs of graphs!
+
+WWW: http://jgrapht.sourceforge.net/