aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Pentchev <roam@FreeBSD.org>2010-03-04 13:07:27 +0000
committerPeter Pentchev <roam@FreeBSD.org>2010-03-04 13:07:27 +0000
commit86137097bb5abde8e3232606fedb17e8d5c28bdf (patch)
tree812da82bf261897ae25cc2af429fa71ec4676cbf
parenta9328933fa3a4c523a8d84bcee1f9beaa0bbdfaa (diff)
downloadports-86137097bb5abde8e3232606fedb17e8d5c28bdf.tar.gz
ports-86137097bb5abde8e3232606fedb17e8d5c28bdf.zip
Update to curlpp-0.7.3, disabling the Boost interface.
Reflect the move to Google Code. Feature safe: yes
Notes
Notes: svn path=/head/; revision=250555
-rw-r--r--ftp/curlpp/Makefile8
-rw-r--r--ftp/curlpp/distinfo6
-rw-r--r--ftp/curlpp/pkg-descr4
-rw-r--r--ftp/curlpp/pkg-plist114
4 files changed, 74 insertions, 58 deletions
diff --git a/ftp/curlpp/Makefile b/ftp/curlpp/Makefile
index 8cece742f06f..535523a0d524 100644
--- a/ftp/curlpp/Makefile
+++ b/ftp/curlpp/Makefile
@@ -7,10 +7,10 @@
#
PORTNAME= curlpp
-PORTVERSION= 0.7.0
-PORTREVISION= 1
+PORTVERSION= 0.7.3
CATEGORIES= ftp
-MASTER_SITES= http://rrette.com/files/curlpp/curlpp-${PORTVERSION:R}/
+MASTER_SITES= ${MASTER_SITE_GOOGLE_CODE} \
+ http://rrette.com/files/curlpp/curlpp-${PORTVERSION:R}/
MAINTAINER= roam@FreeBSD.org
COMMENT= A C++ wrapper for libcurl
@@ -20,7 +20,7 @@ LIB_DEPENDS= curl.5:${PORTSDIR}/ftp/curl
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
-CONFIGURE_ARGS= --disable-ewarning
+CONFIGURE_ARGS= --disable-ewarning --without-boost
USE_LDCONFIG= yes
post-patch:
diff --git a/ftp/curlpp/distinfo b/ftp/curlpp/distinfo
index 31bd6178dc9b..628130339ddb 100644
--- a/ftp/curlpp/distinfo
+++ b/ftp/curlpp/distinfo
@@ -1,3 +1,3 @@
-MD5 (curlpp-0.7.0.tar.gz) = 34cd0c82795b9f245930335bb5e2e764
-SHA256 (curlpp-0.7.0.tar.gz) = c211937ff8c92ab371cf08cc256340bb62bb85167443730c27fac061fcb79bbe
-SIZE (curlpp-0.7.0.tar.gz) = 457303
+MD5 (curlpp-0.7.3.tar.gz) = ccc3d30d4b3b5d2cdbed635898c29485
+SHA256 (curlpp-0.7.3.tar.gz) = e3f9427b27c5bddf898d383d45c0d3d5397e2056ff935d9a5cdaef6a9a653bd5
+SIZE (curlpp-0.7.3.tar.gz) = 493966
diff --git a/ftp/curlpp/pkg-descr b/ftp/curlpp/pkg-descr
index 5b75c60abb3d..25edd02d8499 100644
--- a/ftp/curlpp/pkg-descr
+++ b/ftp/curlpp/pkg-descr
@@ -1 +1,5 @@
curlpp is a C++ wrapper for libcurl.
+
+Author: Jean-Philippe Barrette-LaPierre <jpbarrette@gmail.com>
+WWW: http://www.curlpp.org/
+ http://code.google.com/p/curlpp/
diff --git a/ftp/curlpp/pkg-plist b/ftp/curlpp/pkg-plist
index f63920a9921d..636577b1e056 100644
--- a/ftp/curlpp/pkg-plist
+++ b/ftp/curlpp/pkg-plist
@@ -1,6 +1,4 @@
bin/curlpp-config
-include/curlpp/CurlHandle.hpp
-include/curlpp/CurlHandle.inl
include/curlpp/Easy.hpp
include/curlpp/Easy.inl
include/curlpp/Exception.hpp
@@ -9,40 +7,27 @@ include/curlpp/Info.hpp
include/curlpp/Info.inl
include/curlpp/Infos.hpp
include/curlpp/Multi.hpp
-include/curlpp/NonCopyable.hpp
include/curlpp/Option.hpp
include/curlpp/Option.inl
include/curlpp/OptionBase.hpp
-include/curlpp/OptionContainer.hpp
-include/curlpp/OptionContainer.inl
-include/curlpp/OptionContainerType.hpp
-include/curlpp/OptionList.hpp
-include/curlpp/OptionSetter.hpp
-include/curlpp/OptionSetter.inl
include/curlpp/Options.hpp
-include/curlpp/SList.hpp
-include/curlpp/StorageOptions.hpp
-include/curlpp/StorageOptions.inl
-include/curlpp/TypeTrait.hpp
include/curlpp/Types.hpp
include/curlpp/cURLpp.hpp
-include/curlpp/dllfct.h
-include/curlpp/utilspp/singleton/CreationStatic.hpp
-include/curlpp/utilspp/singleton/CreationStatic.inl
-include/curlpp/utilspp/singleton/CreationUsingNew.hpp
-include/curlpp/utilspp/singleton/CreationUsingNew.inl
-include/curlpp/utilspp/singleton/LifetimeDefault.hpp
-include/curlpp/utilspp/singleton/LifetimeDefault.inl
-include/curlpp/utilspp/singleton/LifetimeLibrary.hpp
-include/curlpp/utilspp/singleton/LifetimeLibrary.inl
-include/curlpp/utilspp/singleton/LifetimeWithLongevity.hpp
-include/curlpp/utilspp/singleton/LifetimeWithLongevity.inl
-include/curlpp/utilspp/singleton/PrivateMembers.hpp
-include/curlpp/utilspp/singleton/PrivateMembers.inl
-include/curlpp/utilspp/singleton/SingletonHolder.hpp
-include/curlpp/utilspp/singleton/SingletonHolder.inl
-@dirrm include/curlpp/utilspp/singleton
-@dirrm include/curlpp/utilspp
+include/curlpp/config.h.in
+include/curlpp/config.h.sample
+include/curlpp/config.win32.h
+include/curlpp/internal/CurlHandle.hpp
+include/curlpp/internal/CurlHandle.inl
+include/curlpp/internal/OptionContainer.hpp
+include/curlpp/internal/OptionContainer.inl
+include/curlpp/internal/OptionContainerType.hpp
+include/curlpp/internal/OptionList.hpp
+include/curlpp/internal/OptionSetter.hpp
+include/curlpp/internal/OptionSetter.inl
+include/curlpp/internal/SList.hpp
+include/curlpp/internal/buildconfig.h
+include/curlpp/internal/global.h
+@dirrm include/curlpp/internal
@dirrm include/curlpp
include/utilspp/EmptyType.hpp
include/utilspp/Functors.hpp
@@ -55,37 +40,64 @@ include/utilspp/ThreadingFactoryMutex.inl
include/utilspp/ThreadingSingle.hpp
include/utilspp/ThreadingSingle.inl
include/utilspp/TypeList.hpp
+include/utilspp/TypeTrait.hpp
+include/utilspp/clone_ptr.hpp
include/utilspp/functor/Binder.hpp
-include/utilspp/functor/Binder.inl
-include/utilspp/functor/FunctorHandler.hpp
include/utilspp/functor/Functor.hpp
+include/utilspp/functor/FunctorHandler.hpp
include/utilspp/functor/FunctorImpl.hpp
-include/utilspp/functor/Functor.inl
include/utilspp/functor/MemFunHandler.hpp
+include/utilspp/singleton/CreationStatic.hpp
+include/utilspp/singleton/CreationStatic.inl
+include/utilspp/singleton/CreationUsingNew.hpp
+include/utilspp/singleton/CreationUsingNew.inl
+include/utilspp/singleton/LifetimeDefault.hpp
+include/utilspp/singleton/LifetimeDefault.inl
+include/utilspp/singleton/LifetimeLibrary.hpp
+include/utilspp/singleton/LifetimeLibrary.inl
+include/utilspp/singleton/LifetimeWithLongevity.hpp
+include/utilspp/singleton/LifetimeWithLongevity.inl
+include/utilspp/singleton/PrivateMembers.hpp
+include/utilspp/singleton/PrivateMembers.inl
+include/utilspp/singleton/SingletonHolder.hpp
+include/utilspp/singleton/SingletonHolder.inl
@dirrm include/utilspp/functor
+@dirrm include/utilspp/singleton
@dirrm include/utilspp
lib/libcurlpp.a
lib/libcurlpp.la
lib/libcurlpp.so
lib/libcurlpp.so.0
+lib/libutilspp.a
+lib/libutilspp.la
+lib/libutilspp.so
+lib/libutilspp.so.0
libdata/pkgconfig/curlpp.pc
%%PORTDOCS%%%%DOCSDIR%%/guide.pdf
-%%PORTDOCS%%%%EXAMPLESDIR%%/README
-%%PORTDOCS%%%%EXAMPLESDIR%%/example01.cpp
-%%PORTDOCS%%%%EXAMPLESDIR%%/example02.cpp
-%%PORTDOCS%%%%EXAMPLESDIR%%/example03.cpp
-%%PORTDOCS%%%%EXAMPLESDIR%%/example04.cpp
-%%PORTDOCS%%%%EXAMPLESDIR%%/example05.cpp
-%%PORTDOCS%%%%EXAMPLESDIR%%/example06.cpp
-%%PORTDOCS%%%%EXAMPLESDIR%%/example07.cpp
-%%PORTDOCS%%%%EXAMPLESDIR%%/example08.cpp
-%%PORTDOCS%%%%EXAMPLESDIR%%/example09.cpp
-%%PORTDOCS%%%%EXAMPLESDIR%%/example10.cpp
-%%PORTDOCS%%%%EXAMPLESDIR%%/example11.cpp
-%%PORTDOCS%%%%EXAMPLESDIR%%/example12.cpp
-%%PORTDOCS%%%%EXAMPLESDIR%%/example13.cpp
-%%PORTDOCS%%%%EXAMPLESDIR%%/example14.cpp
-%%PORTDOCS%%%%EXAMPLESDIR%%/example15.cpp
-%%PORTDOCS%%%%EXAMPLESDIR%%/example16.cpp
%%PORTDOCS%%@dirrm %%DOCSDIR%%
-%%PORTDOCS%%@dirrm %%EXAMPLESDIR%%
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/README
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/example01.cpp
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/example02.cpp
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/example03.cpp
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/example04.cpp
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/example05.cpp
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/example06.cpp
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/example07.cpp
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/example08.cpp
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/example09.cpp
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/example10.cpp
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/example11.cpp
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/example12.cpp
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/example13.cpp
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/example14.cpp
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/example15.cpp
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/example16.cpp
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/example17.cpp
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/example18.cpp
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/example19.cpp
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/example20.cpp
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/example21.cpp
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/example22.cpp
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/example23.cpp
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/example24.cpp
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%